Couleur conditionnelle dans un nuage de point

Le
heartbreaker
Bonjour à tous,

Après une infructueuse recherche dans les questions similaires je vous
soumet mon problème.

J'ai un nuage de point 30 au maximum.
Plusieurs points peuvent avoir la même légende.
Le problème vient du fait que mes points changent régulierement et que je ne
peux donc pas mettre une couleur unique à chaque série.

Comment pourrais-je donc réussir ce formidable tour de force ? via une macro
VBA ou tout autre solution

Merci pour votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Misange
Le #5099831
Bonjour

Quel problème (le problème vient de ...)
quel tour de force ?
Variation de couleur par point ne te convient pas ?
Ce serait bien de dire ce que tu veux exactement avant de demander le
code VBA pour faire ça ! ;-) on est pas dans ton classeur ...

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Bonjour à tous,

Après une infructueuse recherche dans les questions similaires je vous
soumet mon problème.

J'ai un nuage de point 30 au maximum.
Plusieurs points peuvent avoir la même légende.
Le problème vient du fait que mes points changent régulierement et que je ne
peux donc pas mettre une couleur unique à chaque série.

Comment pourrais-je donc réussir ce formidable tour de force ? via une macro
VBA ou tout autre solution...

Merci pour votre aide.


heartbreaker
Le #5099781
Excuse mon manque de clarté.

J'ai un nuage de point sur une feuille.
Mes données sources sont sur une autre feuille (ici "sélection"), y
correspondent la légende (correct, incorrect, pasable, mauvais, excellent...)
dans la feuille "base".
Dans la feuille base on retrouve également les donnèes qui me servent pour
la sélection.
Je voudrais que mes données sélectionnées soit d'une couleur prédéfini(sur
le nuage de point) en fonction de la légende auquel elles appartiennent.

Merci pour l'aide apportée.





Bonjour

Quel problème (le problème vient de ...)
quel tour de force ?
Variation de couleur par point ne te convient pas ?
Ce serait bien de dire ce que tu veux exactement avant de demander le
code VBA pour faire ça ! ;-) on est pas dans ton classeur ...

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Bonjour à tous,

Après une infructueuse recherche dans les questions similaires je vous
soumet mon problème.

J'ai un nuage de point 30 au maximum.
Plusieurs points peuvent avoir la même légende.
Le problème vient du fait que mes points changent régulierement et que je ne
peux donc pas mettre une couleur unique à chaque série.

Comment pourrais-je donc réussir ce formidable tour de force ? via une macro
VBA ou tout autre solution...

Merci pour votre aide.





Misange
Le #5097381
Bonjour
Regarde déjà de ce côté :
http://www.excelabo.net/excel/graphcondition.php#couleursgraphcondition
ainsi que sur les sites de référence en matière de graphiques : ceux de
Jon Peltier et Prodomosua.

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Excuse mon manque de clarté.

J'ai un nuage de point sur une feuille.
Mes données sources sont sur une autre feuille (ici "sélection"), y
correspondent la légende (correct, incorrect, pasable, mauvais, excellent...)
dans la feuille "base".
Dans la feuille base on retrouve également les donnèes qui me servent pour
la sélection.
Je voudrais que mes données sélectionnées soit d'une couleur prédéfini(sur
le nuage de point) en fonction de la légende auquel elles appartiennent.

Merci pour l'aide apportée.





Bonjour

Quel problème (le problème vient de ...)
quel tour de force ?
Variation de couleur par point ne te convient pas ?
Ce serait bien de dire ce que tu veux exactement avant de demander le
code VBA pour faire ça ! ;-) on est pas dans ton classeur ...

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Bonjour à tous,

Après une infructueuse recherche dans les questions similaires je vous
soumet mon problème.

J'ai un nuage de point 30 au maximum.
Plusieurs points peuvent avoir la même légende.
Le problème vient du fait que mes points changent régulierement et que je ne
peux donc pas mettre une couleur unique à chaque série.

Comment pourrais-je donc réussir ce formidable tour de force ? via une macro
VBA ou tout autre solution...

Merci pour votre aide.






heartbreaker
Le #5097321
Désolé rien trouvé.
Dans mon cas ce n'est pas en fonction de la valeur dans le graphique mais en
fonction de sa légende...


Bonjour
Regarde déjà de ce côté :
http://www.excelabo.net/excel/graphcondition.php#couleursgraphcondition
ainsi que sur les sites de référence en matière de graphiques : ceux de
Jon Peltier et Prodomosua.

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Excuse mon manque de clarté.

J'ai un nuage de point sur une feuille.
Mes données sources sont sur une autre feuille (ici "sélection"), y
correspondent la légende (correct, incorrect, pasable, mauvais, excellent...)
dans la feuille "base".
Dans la feuille base on retrouve également les donnèes qui me servent pour
la sélection.
Je voudrais que mes données sélectionnées soit d'une couleur prédéfini(sur
le nuage de point) en fonction de la légende auquel elles appartiennent.

Merci pour l'aide apportée.





Bonjour

Quel problème (le problème vient de ...)
quel tour de force ?
Variation de couleur par point ne te convient pas ?
Ce serait bien de dire ce que tu veux exactement avant de demander le
code VBA pour faire ça ! ;-) on est pas dans ton classeur ...

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Bonjour à tous,

Après une infructueuse recherche dans les questions similaires je vous
soumet mon problème.

J'ai un nuage de point 30 au maximum.
Plusieurs points peuvent avoir la même légende.
Le problème vient du fait que mes points changent régulierement et que je ne
peux donc pas mettre une couleur unique à chaque série.

Comment pourrais-je donc réussir ce formidable tour de force ? via une macro
VBA ou tout autre solution...

Merci pour votre aide.









Francois L
Le #5097151
Désolé rien trouvé.
Dans mon cas ce n'est pas en fonction de la valeur dans le graphique mais en
fonction de sa légende...



Bonjour, bonsoir casseur de coeur qui ne semble pas sensible à ce type
de formule....

... et si tu nous disais ce qui détermine la légende bon, pas , etc.

--
François L



Bonjour
Regarde déjà de ce côté :
http://www.excelabo.net/excel/graphcondition.php#couleursgraphcondition
ainsi que sur les sites de référence en matière de graphiques : ceux de
Jon Peltier et Prodomosua.

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Excuse mon manque de clarté.

J'ai un nuage de point sur une feuille.
Mes données sources sont sur une autre feuille (ici "sélection"), y
correspondent la légende (correct, incorrect, pasable, mauvais, excellent...)
dans la feuille "base".
Dans la feuille base on retrouve également les donnèes qui me servent pour
la sélection.
Je voudrais que mes données sélectionnées soit d'une couleur prédéfini(sur
le nuage de point) en fonction de la légende auquel elles appartiennent.

Merci pour l'aide apportée.





Bonjour

Quel problème (le problème vient de ...)
quel tour de force ?
Variation de couleur par point ne te convient pas ?
Ce serait bien de dire ce que tu veux exactement avant de demander le
code VBA pour faire ça ! ;-) on est pas dans ton classeur ...

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Bonjour à tous,

Après une infructueuse recherche dans les questions similaires je vous
soumet mon problème.

J'ai un nuage de point 30 au maximum.
Plusieurs points peuvent avoir la même légende.
Le problème vient du fait que mes points changent régulierement et que je ne
peux donc pas mettre une couleur unique à chaque série.

Comment pourrais-je donc réussir ce formidable tour de force ? via une macro
VBA ou tout autre solution...

Merci pour votre aide.










heartbreaker
Le #5096781
Bonjour,
j'ai une base de nom sous cette forme
A B C D
Pierre Lille 12 7
Paul Paris 13 9
Jean Nice 5 6
Arnaud Nice 6 5
Luc Lille 4 7
Sylvie Rouen 22 3
Julie Amiens 7 12
Marie Lille 7 16
Annie Strasbourg 12 5
Sophie 9 13

Pour faire mon nuage de point je selectionne des personnes de la colonne A
(pas tous) sur une autre feuille (selection). Mes abscisses et ordonnées sont
en colonnes C et D (recopié dans selection).
Je voudrais que les gens de Paris soit par exemple en vert, ceux de Lille en
rouge, ceux de Nice en bleu et ainsi de suite.

Existe t il une solution pour réussir?

Merci de votre aide





Désolé rien trouvé.
Dans mon cas ce n'est pas en fonction de la valeur dans le graphique mais en
fonction de sa légende...



Bonjour, bonsoir casseur de coeur qui ne semble pas sensible à ce type
de formule....

.... et si tu nous disais ce qui détermine la légende bon, pas , etc.

--
François L



Bonjour
Regarde déjà de ce côté :
http://www.excelabo.net/excel/graphcondition.php#couleursgraphcondition
ainsi que sur les sites de référence en matière de graphiques : ceux de
Jon Peltier et Prodomosua.

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Excuse mon manque de clarté.

J'ai un nuage de point sur une feuille.
Mes données sources sont sur une autre feuille (ici "sélection"), y
correspondent la légende (correct, incorrect, pasable, mauvais, excellent...)
dans la feuille "base".
Dans la feuille base on retrouve également les donnèes qui me servent pour
la sélection.
Je voudrais que mes données sélectionnées soit d'une couleur prédéfini(sur
le nuage de point) en fonction de la légende auquel elles appartiennent.

Merci pour l'aide apportée.





Bonjour

Quel problème (le problème vient de ...)
quel tour de force ?
Variation de couleur par point ne te convient pas ?
Ce serait bien de dire ce que tu veux exactement avant de demander le
code VBA pour faire ça ! ;-) on est pas dans ton classeur ...

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Bonjour à tous,

Après une infructueuse recherche dans les questions similaires je vous
soumet mon problème.

J'ai un nuage de point 30 au maximum.
Plusieurs points peuvent avoir la même légende.
Le problème vient du fait que mes points changent régulierement et que je ne
peux donc pas mettre une couleur unique à chaque série.

Comment pourrais-je donc réussir ce formidable tour de force ? via une macro
VBA ou tout autre solution...

Merci pour votre aide.













Trirème
Le #5096611
Bonjour heartbreaker,
Le mieux serait de préparer des données "bidons" comme ceci...
Dans ta feuille 'sélection' tu peux copier les colonnes A B Cet D de ta base.
Dans les colonnes suivantes - autant qu'il y a de ville dans ta base - tu
copies vers le bas les formules :
=SI($B1="Lille";$D1;NA()) en colonne E
=SI($B1="Paris";$D1;NA()) en colonne F
etc ...
Tu fais ensuite un nuage de points avec les données de la colonne C à la
dernière colonne, chaque série aura sa propre couleur et aura la colonne C en
abscisse.
Tu supprimes la série faisant référence à la colonne D puisque les données
sont "distribuées" sur les autres colonnes.

Le mieux serait de mettre un entête pour tes données. Pour les données de
'Lille' tu mets Lille (en E1), puis Paris (en F1), etc... (j'espère que tu
n'as pas des milliers de villes à gérer!)
et les formules pourraient être :
=SI($B2=E$1;$D1;NA()) en E2
=SI($B2=F$1;$D1;NA()) en colonne F
etc ...
Avec les dollars bien placés, tu écris la formule en E2 et tu la recopies
vers le bas puis vers la droite.

Cordialement,
Trirème


Bonjour,
j'ai une base de nom sous cette forme
A B C D
Pierre Lille 12 7
Paul Paris 13 9
Jean Nice 5 6
Arnaud Nice 6 5
Luc Lille 4 7
Sylvie Rouen 22 3
Julie Amiens 7 12
Marie Lille 7 16
Annie Strasbourg 12 5
Sophie 9 13

Pour faire mon nuage de point je selectionne des personnes de la colonne A
(pas tous) sur une autre feuille (selection). Mes abscisses et ordonnées sont
en colonnes C et D (recopié dans selection).
Je voudrais que les gens de Paris soit par exemple en vert, ceux de Lille en
rouge, ceux de Nice en bleu et ainsi de suite.

Existe t il une solution pour réussir?

Merci de votre aide





heartbreaker
Le #5096481
Bonjour et merci pour ta solution.

Un autre problème va je crois se poser. Quand je vais changer mes donnèes
(remplacement de pierre par paul par exemple). Paul aura t'il directement sa
bonne couleur de légende dans le nuage de point ?

Merci


Bonjour heartbreaker,
Le mieux serait de préparer des données "bidons" comme ceci...
Dans ta feuille 'sélection' tu peux copier les colonnes A B Cet D de ta base.
Dans les colonnes suivantes - autant qu'il y a de ville dans ta base - tu
copies vers le bas les formules :
=SI($B1="Lille";$D1;NA()) en colonne E
=SI($B1="Paris";$D1;NA()) en colonne F
etc ...
Tu fais ensuite un nuage de points avec les données de la colonne C à la
dernière colonne, chaque série aura sa propre couleur et aura la colonne C en
abscisse.
Tu supprimes la série faisant référence à la colonne D puisque les données
sont "distribuées" sur les autres colonnes.

Le mieux serait de mettre un entête pour tes données. Pour les données de
'Lille' tu mets Lille (en E1), puis Paris (en F1), etc... (j'espère que tu
n'as pas des milliers de villes à gérer!)
et les formules pourraient être :
=SI($B2=E$1;$D1;NA()) en E2
=SI($B2=F$1;$D1;NA()) en colonne F
etc ...
Avec les dollars bien placés, tu écris la formule en E2 et tu la recopies
vers le bas puis vers la droite.

Cordialement,
Trirème


Bonjour,
j'ai une base de nom sous cette forme
A B C D
Pierre Lille 12 7
Paul Paris 13 9
Jean Nice 5 6
Arnaud Nice 6 5
Luc Lille 4 7
Sylvie Rouen 22 3
Julie Amiens 7 12
Marie Lille 7 16
Annie Strasbourg 12 5
Sophie 9 13

Pour faire mon nuage de point je selectionne des personnes de la colonne A
(pas tous) sur une autre feuille (selection). Mes abscisses et ordonnées sont
en colonnes C et D (recopié dans selection).
Je voudrais que les gens de Paris soit par exemple en vert, ceux de Lille en
rouge, ceux de Nice en bleu et ainsi de suite.

Existe t il une solution pour réussir?

Merci de votre aide







Trirème
Le #5094381
Je crois n'avoir pas répondu au début de ta question
Pour faire mon nuage de point je selectionne des personnes de la colonne A
(pas tous) sur une autre feuille (selection).
Je t'ai suggéré de copier toutes tes données au lieu des lignes qui

t'intéressent.
Il faut continuer ainsi mais les formules que je t'indiquais devraient
prendre en compte le critère de sélection que tu t'imposes :
=SI(ET(Prénom répond au critère ; $B2=E$1);$D1;NA()) en E2
Avec 'Prénom répond au critère' qui pourrait être un flag dans une colonne
supplémentaire (entre la A et la B) que tu mets à jour selon le besoin, ou
encore pourrait être le résultat d'une RECHERCHEV() dans un petite table que
tu prépares pour la circonstance, pour un bilan hebdo ou mensuel j'imagine.



Bonjour et merci pour ta solution.

Un autre problème va je crois se poser. Quand je vais changer mes donnèes
(remplacement de pierre par paul par exemple). Paul aura t'il directement sa
bonne couleur de légende dans le nuage de point ?
Si tu remplaces 'Pierre' par 'Paul' tu remplaceras aussi 'Lille' par 'Paris'

(selon ton exemple) je suppose ?

Merci


Bonjour heartbreaker,
Le mieux serait de préparer des données "bidons" comme ceci...
Dans ta feuille 'sélection' tu peux copier les colonnes A B Cet D de ta base.
Dans les colonnes suivantes - autant qu'il y a de ville dans ta base - tu
copies vers le bas les formules :
=SI($B1="Lille";$D1;NA()) en colonne E
=SI($B1="Paris";$D1;NA()) en colonne F
etc ...
Tu fais ensuite un nuage de points avec les données de la colonne C à la
dernière colonne, chaque série aura sa propre couleur et aura la colonne C en
abscisse.
Tu supprimes la série faisant référence à la colonne D puisque les données
sont "distribuées" sur les autres colonnes.

Le mieux serait de mettre un entête pour tes données. Pour les données de
'Lille' tu mets Lille (en E1), puis Paris (en F1), etc... (j'espère que tu
n'as pas des milliers de villes à gérer!)
et les formules pourraient être :
=SI($B2=E$1;$D1;NA()) en E2
=SI($B2=F$1;$D1;NA()) en colonne F
etc ...
Avec les dollars bien placés, tu écris la formule en E2 et tu la recopies
vers le bas puis vers la droite.

Cordialement,
Trirème


Bonjour,
j'ai une base de nom sous cette forme
A B C D
Pierre Lille 12 7
Paul Paris 13 9
Jean Nice 5 6
Arnaud Nice 6 5
Luc Lille 4 7
Sylvie Rouen 22 3
Julie Amiens 7 12
Marie Lille 7 16
Annie Strasbourg 12 5
Sophie 9 13

Pour faire mon nuage de point je selectionne des personnes de la colonne A
(pas tous) sur une autre feuille (selection). Mes abscisses et ordonnées sont
en colonnes C et D (recopié dans selection).
Je voudrais que les gens de Paris soit par exemple en vert, ceux de Lille en
rouge, ceux de Nice en bleu et ainsi de suite.

Existe t il une solution pour réussir?

Merci de votre aide









heartbreaker
Le #5094331
Merci beaucoup !!

ca marche nickel ...


Je crois n'avoir pas répondu au début de ta question
Pour faire mon nuage de point je selectionne des personnes de la colonne A
(pas tous) sur une autre feuille (selection).
Je t'ai suggéré de copier toutes tes données au lieu des lignes qui

t'intéressent.
Il faut continuer ainsi mais les formules que je t'indiquais devraient
prendre en compte le critère de sélection que tu t'imposes :
=SI(ET(Prénom répond au critère ; $B2=E$1);$D1;NA()) en E2
Avec 'Prénom répond au critère' qui pourrait être un flag dans une colonne
supplémentaire (entre la A et la B) que tu mets à jour selon le besoin, ou
encore pourrait être le résultat d'une RECHERCHEV() dans un petite table que
tu prépares pour la circonstance, pour un bilan hebdo ou mensuel j'imagine.



Bonjour et merci pour ta solution.

Un autre problème va je crois se poser. Quand je vais changer mes donnèes
(remplacement de pierre par paul par exemple). Paul aura t'il directement sa
bonne couleur de légende dans le nuage de point ?
Si tu remplaces 'Pierre' par 'Paul' tu remplaceras aussi 'Lille' par 'Paris'

(selon ton exemple) je suppose ?

Merci


Bonjour heartbreaker,
Le mieux serait de préparer des données "bidons" comme ceci...
Dans ta feuille 'sélection' tu peux copier les colonnes A B Cet D de ta base.
Dans les colonnes suivantes - autant qu'il y a de ville dans ta base - tu
copies vers le bas les formules :
=SI($B1="Lille";$D1;NA()) en colonne E
=SI($B1="Paris";$D1;NA()) en colonne F
etc ...
Tu fais ensuite un nuage de points avec les données de la colonne C à la
dernière colonne, chaque série aura sa propre couleur et aura la colonne C en
abscisse.
Tu supprimes la série faisant référence à la colonne D puisque les données
sont "distribuées" sur les autres colonnes.

Le mieux serait de mettre un entête pour tes données. Pour les données de
'Lille' tu mets Lille (en E1), puis Paris (en F1), etc... (j'espère que tu
n'as pas des milliers de villes à gérer!)
et les formules pourraient être :
=SI($B2=E$1;$D1;NA()) en E2
=SI($B2=F$1;$D1;NA()) en colonne F
etc ...
Avec les dollars bien placés, tu écris la formule en E2 et tu la recopies
vers le bas puis vers la droite.

Cordialement,
Trirème


Bonjour,
j'ai une base de nom sous cette forme
A B C D
Pierre Lille 12 7
Paul Paris 13 9
Jean Nice 5 6
Arnaud Nice 6 5
Luc Lille 4 7
Sylvie Rouen 22 3
Julie Amiens 7 12
Marie Lille 7 16
Annie Strasbourg 12 5
Sophie 9 13

Pour faire mon nuage de point je selectionne des personnes de la colonne A
(pas tous) sur une autre feuille (selection). Mes abscisses et ordonnées sont
en colonnes C et D (recopié dans selection).
Je voudrais que les gens de Paris soit par exemple en vert, ceux de Lille en
rouge, ceux de Nice en bleu et ainsi de suite.

Existe t il une solution pour réussir?

Merci de votre aide











Publicité
Poster une réponse
Anonyme