Un coup de main pour survivre dans du Windows svp

Le
benoit.sansspam
Bonjour,


Je suis en mission dans une société qui n'a que des serveurs
Windows & Co. J'ai réussi à configurer pas mal de trucs (je sais sortir
sur le web car j'ai bien configurer le proxy). Par contre j'ai un gros
soucis de connexions internes.

Les serveurs ont des adresses ultra courtes comme un
« http://serveurwin/web », ou le serveur exchange (cuvée 2007) a comme
adresse « serveurmail ». Évidemment mes requêtes n'aboutissent pas. Je
suis en DHCP et j'ai donc les routeurs et serveurs DNS pré-renseignés
mais si je tape « http://serveurwin/web » j'ai une erreur. Idem pour
Mail qui n'arrive pas à se connecter. Ils ont comme nom de domaine
interne « societe.loc ou societe.local » ce qui veut dire que
« http://serveurwin/web » est « http://serveurwin.societe.loc/web ». Si
je le prérempli à la main je n'arrive pas à me connecter. Par contre si
je tape le 192.168.12.34 j'ai bien la machine (heureusement).

Avant que je vienne vers vous pour mettre en place du VPN et
accéder de l'extérieur (si la techno qu'ils ont choisie est compatible),
quelqu'un peut me dire comment je dois paramétrer mon réseau et mon Mail
pour y arriver ? J'ai bien « *.local, 169.254/16, intranet, *.loc »
comme zones à ignorer dans le proxy.

Quelles sont donc les infos à récupérer pour que ça tourne ? Un
nom Netbios, des adresses WINS ou autres ? Ma première étape est de
réussir à relever mes mails en interne et à ma connecter sur le serveur
web en intranet car si j'arrive à le faire à la main avec un
192.168.x.y, les liens pointes vers des http://serveur2/ et là je suis
paumé.

D'avance merci pour votre aide qui me permettra a utiliser mon
MacBook chéri et à configurer le MB Air du patron qui aimerait aussi
pouvoir s'en servir à la place du DELL ;)



PS je ne suis pas sur site avant lundi et je ne pourrai donner
les résultats de vos suggestions que tard le soir ou via Google si
j'arrive à m'en servir correctement.

--
Benoît http://picasaweb.google.com/leraillez/

Avec des fumeurs c'est difficile de s'arrêter. Avec des branleurs,
là, par contre, c'est difficile de continuer.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 4
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
yapu
Le #20939541
Benoit
Par contre j'ai un gros
soucis de connexions internes.



au boulot, j'ai un peu le meme problème.

les serveurs physiques ont des partages SMB variés dont chacun a un nom
court.
J'ai été amené à attaquer par la recherche réseau standard, me connecter
sur les serveurs, et ensuite faire un alias de chaque partage pour m'y
connecter facilement.
ceci dit, quand on me donne un lien pour aller chercher un fichier, une
fois que mon alias m'a mis sur le bon repertoire, je dois le suivre à la
main...

je ne sais pas si ça répond à tes soucis...

--
Philippe Manet
en fait, c'est manet avant @
benoit.sansspam
Le #20940501
Philippe Manet
les serveurs physiques ont des partages SMB variés dont chacun a un nom
court.
J'ai été amené à attaquer par la recherche réseau standard, me connecter
sur les serveurs, et ensuite faire un alias de chaque partage pour m'y
connecter facilement.
ceci dit, quand on me donne un lien pour aller chercher un fichier, une
fois que mon alias m'a mis sur le bon repertoire, je dois le suivre à la
main...

je ne sais pas si ça répond à tes soucis...



Je note ton idée d'alias mais cela ne va pas résoudre mes deux
problèmes actuels :

1. si je sais atteindre une page web en remplaçant le nom du
serveur par son adresse IP, je ne sais pas cliquer sur un lien qui
pointe sur le même serveur. Les serveurs web n'ont pas de nom de
domaine : http://www/lien.html

Je pense que Safari fait une requête de DNS sur « www » et ne
sais pas ajouter un nom de domaine (faire une requête sur
www.societe.loc, .local ou .fr par exemple). Il doit bien y avoir un
endroit où on peut demander de compléter automatiquement ça.

2. Tous mes essais pour me connecter au serveur Exchange
n'aboutissent pas. Il doit donc me manquer des infos dans ma config
Exchange sur le compte Mail que j'ai créé. Genre le chemin de serveur.
Quid ? J'ai un serveur interne qui se nomme ExchangeInt.societe.loc (nom
donné par le service info) et je n'arrive pas à me connecter dessus avec
pourtant la bonne config :

adresse =
nom complet = Benoît Leraillez
login = benoit
password = xxxxxxxxx
serveur interne = ExchangeInt.societe.loc

dans les avancées j'ai serveur interne = SWB/Exchange.asmx
port = 80 qui sont en standard sur mail.



D'avance merci (et je sais que les capitales et bas de casse
sont à respecter dans les configs Windows)

--
Benoît http://picasaweb.google.com/leraillez/

Avec des fumeurs c'est difficile de s'arrêter. Avec des branleurs,
là, par contre, c'est difficile de continuer.
Olivier Miakinen
Le #20947381
Bonjour,

Le 08/01/2010 22:23, Benoit a écrit :

Je suis en mission dans une société qui n'a que des serveurs
Windows & Co. J'ai réussi à configurer pas mal de trucs (je sais sortir
sur le web car j'ai bien configurer le proxy). Par contre j'ai un gros
soucis de connexions internes.

Les serveurs ont des adresses ultra courtes comme un
« http://serveurwin/web », ou le serveur exchange (cuvée 2007) a comme
adresse « serveurmail ». Évidemment mes requêtes n'aboutissent pas. Je
suis en DHCP et j'ai donc les routeurs et serveurs DNS pré-renseignés
mais si je tape « http://serveurwin/web » j'ai une erreur.



Quelle erreur ? Il n'arrive pas à résoudre le nom, c'est la connexion
vers l'adresse IP qui échoue, autre ?

As-tu essayé « ping serveurwin » dans une fenêtre de commande ?

Idem pour
Mail qui n'arrive pas à se connecter. Ils ont comme nom de domaine
interne « societe.loc ou societe.local » ce qui veut dire que
« http://serveurwin/web » est « http://serveurwin.societe.loc/web ».



Ah. Et « ping serveurwin.societe.loc » fonctionne ?

Si
je le prérempli à la main je n'arrive pas à me connecter. Par contre si
je tape le 192.168.12.34 j'ai bien la machine (heureusement).



Ok. Sauf erreur, il doit exister sur Windows l'équivalent du /etc/hosts
d'Unix. Ah oui, c'est bien le cas :
http://www.google.fr/search?q=hosts+windows
http://forums.cnetfrance.fr/index.php?showtopic`93

Essaye d'y ajouter :
192.168.12.34 serveurwin


Avant que je vienne vers vous pour mettre en place du VPN et
accéder de l'extérieur (si la techno qu'ils ont choisie est compatible),
quelqu'un peut me dire comment je dois paramétrer mon réseau et mon Mail
pour y arriver ? J'ai bien « *.local, 169.254/16, intranet, *.loc »
comme zones à ignorer dans le proxy.



Et pas 192.168 ?

[...]



Cordialement,
--
Olivier Miakinen
benoit.sansspam
Le #20952911
Olivier Miakinen
Bonjour,

Le 08/01/2010 22:23, Benoit a écrit :
>
> Je suis en mission dans une société qui n'a que des serveurs
> Windows & Co. J'ai réussi à configurer pas mal de trucs (je sais sortir
> sur le web car j'ai bien configurer le proxy). Par contre j'ai un gros
> soucis de connexions internes.
>
> Les serveurs ont des adresses ultra courtes comme un
> « http://serveurwin/web », ou le serveur exchange (cuvée 2007) a comme
> adresse « serveurmail ». Évidemment mes requêtes n'aboutissent pas. Je
> suis en DHCP et j'ai donc les routeurs et serveurs DNS pré-renseignés
> mais si je tape « http://serveurwin/web » j'ai une erreur.

Quelle erreur ? Il n'arrive pas à résoudre le nom, c'est la connexion
vers l'adresse IP qui échoue, autre ?



Je n'étais pas sur le site aujourd'hui, mais j'y serai demain.
Je note donc toutes tes questions pour y répondre demain soir (ou via
Google puisque seul le 80 et le 8080 ne peuvent sortir)

As-tu essayé « ping serveurwin » dans une fenêtre de commande ?



Je crois que oui et cela ne donnait rien. Je relance demain
matin.

> Idem pour
> Mail qui n'arrive pas à se connecter. Ils ont comme nom de domaine
> interne « societe.loc ou societe.local » ce qui veut dire que
> « http://serveurwin/web » est « http://serveurwin.societe.loc/web ».

Ah. Et « ping serveurwin.societe.loc » fonctionne ?



Je n'ai pas essayé non plus (je prends un paquet de cours sur
site et sur IP ces jours-ci ;)

> Si
> je le prérempli à la main je n'arrive pas à me connecter. Par contre si
> je tape le 192.168.12.34 j'ai bien la machine (heureusement).

Ok. Sauf erreur, il doit exister sur Windows l'équivalent du /etc/hosts
d'Unix. Ah oui, c'est bien le cas :
http://www.google.fr/search?q=hosts+windows
http://forums.cnetfrance.fr/index.php?showtopic`93

Essaye d'y ajouter :
192.168.12.34 serveurwin



Ok, je vais passer par là. Le seul pb est que s'ils modifient
les adresses IP des serveurs...

>
> Avant que je vienne vers vous pour mettre en place du VPN et
> accéder de l'extérieur (si la techno qu'ils ont choisie est compatible),
> quelqu'un peut me dire comment je dois paramétrer mon réseau et mon Mail
> pour y arriver ? J'ai bien « *.local, 169.254/16, intranet, *.loc »
> comme zones à ignorer dans le proxy.

Et pas 192.168 ?



Non, je vais donc ajouter 192.168.* et voir ce que cela donne.

Cordialement,



C'est moi qui te cordiale, vrai.



PS j'ai gardé pas mal de notre discussion dans la réponse car je
préfère avoir un document unique à relire quand je vais mettre les mains
dans le moteur

--
Benoît http://picasaweb.google.com/leraillez/

Avec des fumeurs c'est difficile de s'arrêter. Avec des branleurs,
là, par contre, c'est difficile de continuer.
laurent.pertois
Le #20953531
Benoit
Les serveurs ont des adresses ultra courtes comme un
« http://serveurwin/web », ou le serveur exchange (cuvée 2007) a comme
adresse « serveurmail ». Évidemment mes requêtes n'aboutissent pas. Je
suis en DHCP et j'ai donc les routeurs et serveurs DNS pré-renseignés
mais si je tape « http://serveurwin/web » j'ai une erreur. Idem pour
Mail qui n'arrive pas à se connecter. Ils ont comme nom de domaine
interne « societe.loc ou societe.local » ce qui veut dire que
« http://serveurwin/web » est « http://serveurwin.societe.loc/web ». Si
je le prérempli à la main je n'arrive pas à me connecter. Par contre si
je tape le 192.168.12.34 j'ai bien la machine (heureusement).



Vérifie que tu utilises bien les bons DNS internes et éventuellement,
mais normalement ce n'est plus nécessaire, ajoute le domaine dans le
champs de domaine de recherche par défaut s'il n'y est pas déjà.

--
Politically Correct Unix - UTILITIES
The "touch" command has been removed from the standard distribution due
to its inappropriate use by high-level managers.
Olivier Miakinen
Le #20953781
Le 11/01/2010 22:05, Benoit m'a répondu :

Ok. Sauf erreur, il doit exister sur Windows l'équivalent du /etc/hosts
d'Unix. Ah oui, c'est bien le cas :
http://www.google.fr/search?q=hosts+windows
http://forums.cnetfrance.fr/index.php?showtopic`93

Essaye d'y ajouter :
192.168.12.34 serveurwin



Ok, je vais passer par là. Le seul pb est que s'ils modifient
les adresses IP des serveurs...



Ben... c'est à eux d'avoir un serveur DNS qui serve l'adresse serveurwin
et non pas serveurwin.societe.loc, si c'est celui-là qu'ils utilisent
plutôt que celui-ci !

Mais au fait... peut-être en ont ils un, et que ce qui manque est
justement la config de *ce* serveur DNS sur la machine ?

--
Olivier Miakinen
laurent.pertois
Le #20954001
Olivier Miakinen
Mais au fait... peut-être en ont ils un, et que ce qui manque est
justement la config de *ce* serveur DNS sur la machine ?



Vu que Benoît parle d'Exchange il doit y avoir un Active Directory donc
il doit y avoir un DNS, cqfd.

--
Politically Correct Unix - UTILITIES
The "touch" command has been removed from the standard distribution due
to its inappropriate use by high-level managers.
Benoit
Le #20956141
On 11 jan, 23:08, (Laurent Pertois)
wrote:

Vérifie que tu utilises bien les bons DNS internes et éventuellement,
mais normalement ce n'est plus nécessaire, ajoute le domaine dans le
champs de domaine de recherche par défaut s'il n'y est pas déjà.




Les domaines de recherche par défaut étaient faux car il y a plusieurs
domaines du style societe1.loc et societe2.loc, et je n'avais que
societe1.loc ce qui explique que les liens de l'intranet
fonctionnaient à moitié.

La connexion se passe parfaitement maintenant : sortir (http only, ou
plutôt port 80 only) et web intranet

Il ne me reste plus qu'à réussir la connexion Mail, pour arrêter le
webmail.
laurent.pertois
Le #20957041
Benoit
La connexion se passe parfaitement maintenant : sortir (http only, ou
plutôt port 80 only) et web intranet



Cool.

Il ne me reste plus qu'à réussir la connexion Mail, pour arrêter le
webmail.



Ah ça... sur le serveur interne ?

--
Politically Correct Unix - UTILITIES
The "touch" command has been removed from the standard distribution due
to its inappropriate use by high-level managers.
benoit.sansspam
Le #20959331
Laurent Pertois
> Il ne me reste plus qu'à réussir la connexion Mail, pour arrêter le
> webmail.

Ah ça... sur le serveur interne ?



Oui. Le serveur n'est pas disponible de l'extérieur. Tu es soit
dans l'entreprise soit en Orange Buziness Machin Brozouf soit rien
d'autre.

--
Benoît http://picasaweb.google.com/leraillez/

Avec des fumeurs c'est difficile de s'arrêter. Avec des branleurs,
là, par contre, c'est difficile de continuer.
Publicité
Poster une réponse
Anonyme