Creer une colonne comptant le nombre d'occurrences?

Le
Fredy
Bonjour,

Afin de faciliter la description de mon problème, j'ai inclu mon fichier
excel pour exemple à cette adresse :
http://cjoint.com/?duncBdiony

Je souhaite créer de façon automatique la colonne C "nb occurrence".
Je pense que je pourrais utiliser une fonction SI mais j'ai en fait
plusieurs centaines de noms et de fruits differents!

Merci d'avance pour votre aide, ;)
Fred
ps: si vous connaissez une solution plus simple/rapide sous Access j'accepte
avec plaisir. ;)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel
Le #4322401
Bonjour.
Je ne comprends pas comment tu calcules le nombre d'occurences.
Cordialement.
Daniel
"Fredy" 45ffcee5$0$27178$
Bonjour,

Afin de faciliter la description de mon problème, j'ai inclu mon fichier
excel pour exemple à cette adresse :
http://cjoint.com/?duncBdiony

Je souhaite créer de façon automatique la colonne C "nb occurrence".
Je pense que je pourrais utiliser une fonction SI mais j'ai en fait
plusieurs centaines de noms et de fruits differents!

Merci d'avance pour votre aide, ;)
Fred
ps: si vous connaissez une solution plus simple/rapide sous Access
j'accepte avec plaisir. ;)


Fredy
Le #4322371
Bonjour,

Je ne comprends pas comment tu calcules le nombre d'occurences.
Cordialement.


Pardon. Toutes mes excuses! En effet je me suis trompé dans l'énnoncé!
Voici le fichier corrigé :
http://cjoint.com/?dustbweE8q

Il y a 2 personnes avec le même fruit : Pomme, pareil pour Fraise et une
seule personne avec des Cerises.

Merci d'avance,
Fred

Daniel
Le #4322281
En C2 :
=NB.SI($B$2:$B$6;B2)
à recopier vers le bas,
ou peut-il y avoir deux fois la ligne Albert pomme, par exemple ?
Daniel
"Fredy" 46001809$0$5881$
Bonjour,

Je ne comprends pas comment tu calcules le nombre d'occurences.
Cordialement.


Pardon. Toutes mes excuses! En effet je me suis trompé dans l'énnoncé!
Voici le fichier corrigé :
http://cjoint.com/?dustbweE8q

Il y a 2 personnes avec le même fruit : Pomme, pareil pour Fraise et une
seule personne avec des Cerises.

Merci d'avance,
Fred




Fredy
Le #4322211
Bonsoir Daniel,

En C2 :
=NB.SI($B$2:$B$6;B2)
à recopier vers le bas,
ou peut-il y avoir deux fois la ligne Albert pomme, par exemple ?


Whaou! Génial Merci! ;)
Puis je abuser en vous demandant si il existe une façon facile de délimiter
la plage $B$2:$B$6 ?
En fait seul $B$6 changera en fonction du nombre de lignes totales.

Si c'est trop complexe ne vous embettez pas!

Encore merci et bonne soirée. ;)
Fred

cousinhub
Le #4322191
Bonsoir, Daniel
J'ai suivi le fil, et moi, ce qui m'intéresserait, c'est d'avoir le
nombre d'occurrence unique du client (2 ou 3 ou plus d'Albert qui achète
des pommes....). Je cherche, je cherche mais ....
T'as compris, je souhaite le nombre de clients différents de chaque produit!
Merci

En C2 :
=NB.SI($B$2:$B$6;B2)
à recopier vers le bas,
ou peut-il y avoir deux fois la ligne Albert pomme, par exemple ?
Daniel
"Fredy" 46001809$0$5881$
Bonjour,

Je ne comprends pas comment tu calcules le nombre d'occurences.
Cordialement.
Pardon. Toutes mes excuses! En effet je me suis trompé dans l'énnoncé!

Voici le fichier corrigé :
http://cjoint.com/?dustbweE8q

Il y a 2 personnes avec le même fruit : Pomme, pareil pour Fraise et une
seule personne avec des Cerises.

Merci d'avance,
Fred








Daniel
Le #4322121
Je ne sais pas si j'ai bien compris tu peux définir un nom de la façon
suivante :
Insertion / Nom / Définir
nom : plage (par exemple)
"fait référence à" :
ÞCALER(Feuil1!$A$2;;;NBVAL(Feuil1!$A:$A)-1)
La plage sélectionne toutes les valeurs à partir de A2, quel que soit leur
nombre.
Dans la formule :
=NB.SI(plage;B2)
Daniel
"Fredy" 4600368b$0$6454$
Bonsoir Daniel,

En C2 :
=NB.SI($B$2:$B$6;B2)
à recopier vers le bas,
ou peut-il y avoir deux fois la ligne Albert pomme, par exemple ?


Whaou! Génial Merci! ;)
Puis je abuser en vous demandant si il existe une façon facile de
délimiter la plage $B$2:$B$6 ?
En fait seul $B$6 changera en fonction du nombre de lignes totales.

Si c'est trop complexe ne vous embettez pas!

Encore merci et bonne soirée. ;)
Fred



cousinhub
Le #4322091
Bonsoir,
désolé d'avoir un peu piqué ton fil, mais une autre solution serait de
passer par un Tableau Croisé Dynamique (TCD) qui donnerait exactement le
même résultat.
Ci joint quelques exemples :
http://cjoint.com/?duvu7KsVY7


reviens si tu as des questions
Bonne lecture

Bonsoir Daniel,

En C2 :
=NB.SI($B$2:$B$6;B2)
à recopier vers le bas,
ou peut-il y avoir deux fois la ligne Albert pomme, par exemple ?


Whaou! Génial Merci! ;)
Puis je abuser en vous demandant si il existe une façon facile de
délimiter la plage $B$2:$B$6 ?
En fait seul $B$6 changera en fonction du nombre de lignes totales.

Si c'est trop complexe ne vous embettez pas!

Encore merci et bonne soirée. ;)
Fred



Daniel
Le #4322071
Bonsoir.
Un TCD ?
Je sèche également...
Cordialement.
"cousinhub"
Bonsoir, Daniel
J'ai suivi le fil, et moi, ce qui m'intéresserait, c'est d'avoir le nombre
d'occurrence unique du client (2 ou 3 ou plus d'Albert qui achète des
pommes....). Je cherche, je cherche mais ....
T'as compris, je souhaite le nombre de clients différents de chaque
produit!
Merci

En C2 :
=NB.SI($B$2:$B$6;B2)
à recopier vers le bas,
ou peut-il y avoir deux fois la ligne Albert pomme, par exemple ?
Daniel
"Fredy" 46001809$0$5881$
Bonjour,

Je ne comprends pas comment tu calcules le nombre d'occurences.
Cordialement.
Pardon. Toutes mes excuses! En effet je me suis trompé dans l'énnoncé!

Voici le fichier corrigé :
http://cjoint.com/?dustbweE8q

Il y a 2 personnes avec le même fruit : Pomme, pareil pour Fraise et une
seule personne avec des Cerises.

Merci d'avance,
Fred









cousinhub
Le #4322061
Bonsoir,
j'y avais pensé, mais avec ta 2ème proposition, je m'étais dit que cela
devait bien exister.
D'ailleurs le TCD, je le lui ai proposé, ne voyant pas d'autres
alternatives....
Bonne soirée ;-)

Bonsoir.
Un TCD ?
Je sèche également...
Cordialement.
"cousinhub"
Bonsoir, Daniel
J'ai suivi le fil, et moi, ce qui m'intéresserait, c'est d'avoir le nombre
d'occurrence unique du client (2 ou 3 ou plus d'Albert qui achète des
pommes....). Je cherche, je cherche mais ....
T'as compris, je souhaite le nombre de clients différents de chaque
produit!
Merci




AV
Le #4321891
..........., je souhaite le nombre de clients différents de chaque produit!


Avec un TCD en ajoutant un champ ou avec formules matricielles :

http://cjoint.com/?dvgQl11SMp

AV

Publicité
Poster une réponse
Anonyme