Creer un sommaire avec deux conditions dont une avec intervales de

Le
Pstrophe
Bonjour.

je veux me créer un sommaire avec deux conditions dont une avec intervales
de dates.

Dans E1:E100 sont les données a additionner et dans la colonne B1:B100 sont
mes dates variant de 2007-01-01 à 2010-05-20. aussi dans la colonne F1:F100
on retouvre ma 2 ieme conditions, chois entre materiel ou entretien.

je veux être capable de faire un sommaire ou on additionne la colonne E
selon trois intervales, ( la premiere a titre d,exemple serait le 2007-01-04
au 2008-03-31. ) et selon la colonne F ( matériel ou entretien)

J'ai fais plusieurs essaies avec Somme si et Sommeprod, mais en vain.

merci de vos conseils.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #22151961
Bonjour,

Essaie quelque chose comme :

=Sommeprod((b1:B100>="2007-01-04"*1)*(b1:B100<="2008-03-31"*1)*(E1:E100))



"Pstrophe" groupe de discussion :
Bonjour.

je veux me créer un sommaire avec deux conditions dont une avec intervales
de dates.

Dans E1:E100 sont les données a additionner et dans la colonne B1:B100
sont
mes dates variant de 2007-01-01 à 2010-05-20. aussi dans la colonne
F1:F100
on retouvre ma 2 ieme conditions, chois entre materiel ou entretien.

je veux être capable de faire un sommaire ou on additionne la colonne E
selon trois intervales, ( la premiere a titre d,exemple serait le
2007-01-04
au 2008-03-31. ) et selon la colonne F ( matériel ou entretien)



=Sommeprod((b1:B100>="2007-01-04"*1)*(b1:B100<="2008-03-31"*1)*(E1:E100))
michdenis
Le #22152261
J'ai omis un critère...

=Sommeprod((b1:B100>="2007-01-04"*1)*(b1:B100<="2008-03-31"*1)*(F1:F100="entretien");E1:E100)
Pstrophe
Le #22167161
Bonjour,

Voici donc ce que j'ai transcrit :
=SOMMEPROD((Données!B1:B100>="2007-01-04"*1)*(Données!B1:B100<="2008-03-31"*1)*(Données!F1:F100="Matériel")*(Données!E1:E100))

Par contre j'ai quand meme un message de erreur de valeur, dans la case
réponse j'ai #valeur!

Merci encore pour votre soutien!

"michdenis" a écrit :

J'ai omis un critère...

=Sommeprod((b1:B100>="2007-01-04"*1)*(b1:B100<="2008-03-31"*1)*(F1:F100="entretien");E1:E100)




.

michdenis
Le #22167341
probablement dans ta plage E1:E100
tu as un ou des cellules au format texte.

Si tu as du texte en E1:E100, avec
la syntaxe que je t'ai donnée, tu aurais quand même
eu un résultat (mois la valeur des cellules "texte" ou au "format texte")

Je n'ai pas d'autres formules à te proposer!





"Pstrophe" discussion :
Bonjour,

Voici donc ce que j'ai transcrit :
=SOMMEPROD((Données!B1:B100>="2007-01-04"*1)*(Données!B1:B100<="2008-03-31"*1)*(Données!F1:F100="Matériel")*(Données!E1:E100))

Par contre j'ai quand meme un message de erreur de valeur, dans la case
réponse j'ai #valeur!

Merci encore pour votre soutien!

"michdenis" a écrit :

J'ai omis un critère...

=Sommeprod((b1:B100>="2007-01-04"*1)*(b1:B100<="2008-03-31"*1)*(F1:F100="entretien");E1:E100)




.

Pstrophe
Le #22167601
Merci ce fut exactement celà.
"michdenis" a écrit :

probablement dans ta plage E1:E100
tu as un ou des cellules au format texte.

Si tu as du texte en E1:E100, avec
la syntaxe que je t'ai donnée, tu aurais quand même
eu un résultat (mois la valeur des cellules "texte" ou au "format texte")

Je n'ai pas d'autres formules à te proposer!





"Pstrophe" discussion :
Bonjour,

Voici donc ce que j'ai transcrit :
=SOMMEPROD((Données!B1:B100>="2007-01-04"*1)*(Données!B1:B100<="2008-03-31"*1)*(Données!F1:F100="Matériel")*(Données!E1:E100))

Par contre j'ai quand meme un message de erreur de valeur, dans la case
réponse j'ai #valeur!

Merci encore pour votre soutien!

"michdenis" a écrit :

> J'ai omis un critère...
>
> =Sommeprod((b1:B100>="2007-01-04"*1)*(b1:B100<="2008-03-31"*1)*(F1:F100="entretien");E1:E100)
>
>
>
>
> .
>
Publicité
Poster une réponse
Anonyme