Critère pour une Formule dans une Requête

Le
richard86 Hors ligne
Bonjour à tous,
Je suis actuellement en train de travailler sur une base de données visant à vérifier que je n'ai pas été surfacturé sur certains produits. Pour ce faire, dans une table, je rentre chaque article avec le prix facturé. Dans une requête, je crée un regroupement par code produit et, dans un champ, je fais apparaitre le minimum facturé pour cet article et, dans un autre champ, le maximum facturé. Dans un troisième champ enfin, je calcule l'écart avec une formule (Max-Min)/Min. Ce champ est exprimé en %. Jusque là, tout fonctionne à merveille. Malheureusement, quand je rajoute un critère pour ce dernier champ, à savoir je ne veux que les positions où l'écart est supérieur à 10%, il n'y a plus rien qui apparait alors que j'ai des lignes test avec 25% voire même 31% de différence.
Est-ce que quelqu'un aurait la solution à ce problème?
Je ne suis pas un pro d'Accès et je me suis peut-être mal exprimé alors n'hésitez pas à me demander des informations complémentaires ou me proposer une solution alternative qui me permettrait d'arriver au même résultat.
Merci d'avance pour votre aide!
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Albert
Le #24548191
Bonjour

Il s'agit de faire un deuxième requête sur les résultats de la première
requête.

Albert




"richard86" message de news:
Bonjour à tous,
Je suis actuellement en train de travailler sur une base de données visant
à
vérifier que je n'ai pas été surfacturé sur certains produits. Pour ce
faire,
dans une table, je rentre chaque article avec le prix facturé. Dans une
requête,
je crée un regroupement par code produit et, dans un champ, je fais
apparaitre
le minimum facturé pour cet article et, dans un autre champ, le maximum
facturé.
Dans un troisième champ enfin, je calcule l'écart avec une formule
(Max-Min)/Min. Ce champ est exprimé en %. Jusque là, tout fonctionne à
merveille. Malheureusement, quand je rajoute un critère pour ce dernier
champ, à
savoir je ne veux que les positions où l'écart est supérieur à 10%, il n'y
a
plus rien qui apparait alors que j'ai des lignes test avec 25% voire même
31% de
différence.
Est-ce que quelqu'un aurait la solution à ce problème?
Je ne suis pas un pro d'Accès et je me suis peut-être mal exprimé alors
n'hésitez pas à me demander des informations complémentaires ou me
proposer une
solution alternative qui me permettrait d'arriver au même résultat.
Merci d'avance pour votre aide!
Gloops
Le #24548251
richard86 a écrit, le 10/06/2012 12:57 :
Bonjour à tous,
Je suis actuellement en train de travailler sur une base de données v isant à
vérifier que je n'ai pas été surfacturé sur certains produits. Pour ce faire,
dans une table, je rentre chaque article avec le prix facturé. Dans u ne requête,
je crée un regroupement par code produit et, dans un champ, je fais a pparaitre
le minimum facturé pour cet article et, dans un autre champ, le maxim um facturé.
Dans un troisième champ enfin, je calcule l'écart avec une formule
(Max-Min)/Min. Ce champ est exprimé en %. Jusque là, tout fonctionn e à
merveille. Malheureusement, quand je rajoute un critère pour ce derni er champ, à
savoir je ne veux que les positions où l'écart est supérieur à 10%, il n'y a
plus rien qui apparait alors que j'ai des lignes test avec 25% voire mê me 31% de
différence.
Est-ce que quelqu'un aurait la solution à ce problème?
Je ne suis pas un pro d'Accès et je me suis peut-être mal exprimé alors
n'hésitez pas à me demander des informations complémentaires ou m e proposer une
solution alternative qui me permettrait d'arriver au même résultat.
Merci d'avance pour votre aide!



Ben ... Fais voir ta formule.
Comment veux-tu qu'on te dise si elle est fausse, sinon ?
richard86 Hors ligne
Le #24548271
Le dimanche 10 Juin 2012 à 12:57 par richard86 :
Bonjour à tous,
Je suis actuellement en train de travailler sur une base de données
visant à vérifier que je n'ai pas été
surfacturé sur certains produits. Pour ce faire, dans une table, je
rentre chaque article avec le prix facturé. Dans une requête, je
crée un regroupement par code produit et, dans un champ, je fais
apparaitre le minimum facturé pour cet article et, dans un autre champ,
le maximum facturé. Dans un troisième champ enfin, je calcule
l'écart avec une formule (Max-Min)/Min. Ce champ est exprimé en
%. Jusque là, tout fonctionne à merveille. Malheureusement, quand
je rajoute un critère pour ce dernier champ, à savoir je ne veux
que les positions où l'écart est supérieur à 10%,
il n'y a plus rien qui apparait alors que j'ai des lignes test avec 25% voire
même 31% de différence.
Est-ce que quelqu'un aurait la solution à ce problème?
Je ne suis pas un pro d'Accès et je me suis peut-être mal
exprimé alors n'hésitez pas à me demander des informations
complémentaires ou me proposer une solution alternative qui me
permettrait d'arriver au même résultat.
Merci d'avance pour votre aide!


Mais c'est bien sûr!!!!!!!
Je m'en veux de ne pas y avoir pensé moi-même!!!
Un très grand MERCI pour cette réponse très rapide et pour votre solution qui me retire une véritable épine du pied!!!!!
richard86 Hors ligne
Le #24548281
Le dimanche 10 Juin 2012 à 12:57 par richard86 :
Bonjour à tous,
Je suis actuellement en train de travailler sur une base de données
visant à vérifier que je n'ai pas été
surfacturé sur certains produits. Pour ce faire, dans une table, je
rentre chaque article avec le prix facturé. Dans une requête, je
crée un regroupement par code produit et, dans un champ, je fais
apparaitre le minimum facturé pour cet article et, dans un autre champ,
le maximum facturé. Dans un troisième champ enfin, je calcule
l'écart avec une formule (Max-Min)/Min. Ce champ est exprimé en
%. Jusque là, tout fonctionne à merveille. Malheureusement, quand
je rajoute un critère pour ce dernier champ, à savoir je ne veux
que les positions où l'écart est supérieur à 10%,
il n'y a plus rien qui apparait alors que j'ai des lignes test avec 25% voire
même 31% de différence.
Est-ce que quelqu'un aurait la solution à ce problème?
Je ne suis pas un pro d'Accès et je me suis peut-être mal
exprimé alors n'hésitez pas à me demander des informations
complémentaires ou me proposer une solution alternative qui me
permettrait d'arriver au même résultat.
Merci d'avance pour votre aide!


Merci beaucoup Gloops mais la solution d'Albert est parfaite.
Elle est simple et ELLE MARCHE!!! Je m'en veux d'ailleurs de ne pas y avoir pensé moi-même.
Un grand merci à tous les deux pour votre aide!
Publicité
Poster une réponse
Anonyme