critères

Le
Christophe
Bonsoir,

Sur une feuille, j'ai un tableau récapitulatif de valeurs issues d'un
tableau situé sur une autre feuille.

Feuille A: A1=mois E1=année
Feuille B:
A B C
2006 2007
janvier 2 3
février 1 2
mars 3 2


quand je mets sur feuille A A1=février et E1= 2006, je veux obtenir
la valeur 3 (2 pour janvier et 1 pour février)
quand je mets sur feuille A A1=mars et E1= 2006, je veux obtenir la
valeur 6 (2 pour janvier et 1 pour février et 3 pour mars)

pouvez-vous m'aider.

Merci d'avance.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JièL
Le #4320221
Bonjoir(c) Christophe

un coup d'index equiv et hop
=INDEX('Feuille B'!B2:C4;EQUIV('Feuille A'!A1;'Feuille
B'!A2:A4);EQUIV('Feuille A'!E1;'Feuille B'!B1:C1))

Rappel : EQUIV donne la position de l'élément recherché, INDEX renvoi
l'élément qui est à la position XY

--
JièL / Jean-Louis GOUBERT
Là bas mieux qu'en face ;-) http://forums.offices.free.fr/
La nouvelle FAQ Outlook est là : http://faq.outlook.free.fr/index.php
Les stats de CDO : http://faq.outlook.free.fr/cdo/

Le 24/03/2007 23:28 vous avez écrit ceci :
Bonsoir,

Sur une feuille, j'ai un tableau récapitulatif de valeurs issues d'un
tableau situé sur une autre feuille.

Feuille A: A1=mois E1=année
Feuille B:
A B C
2006 2007
janvier 2 3
février 1 2
mars 3 2
...

quand je mets sur feuille A A1=février et E1= 2006, je veux
obtenir la valeur 3 (2 pour janvier et 1 pour février)
quand je mets sur feuille A A1=mars et E1= 2006, je veux obtenir
la valeur 6 (2 pour janvier et 1 pour février et 3 pour mars)

pouvez-vous m'aider.

Merci d'avance.



JB
Le #4320201
Bonjour,

Somme cumulée pour un mois et une année:

=SOMME(DECALER(données;;EQUIV(E1;an;0)-1;EQUIV(A1;Mois;0);1))

an ='Feuille B'!$B$1:$C$1
données ='Feuille B'!$B$2:$C$13
Mois ='Feuille B'!$A$2:$A$13

http://cjoint.com/?dzimADITX3

JB

On 25 mar, 00:28, "Christophe"
Bonsoir,

Sur une feuille, j'ai un tableau récapitulatif de valeurs issues d'un
tableau situé sur une autre feuille.

Feuille A: A1=mois E1=année
Feuille B:
A B C
2006 2007
janvier 2 3
février 1 2
mars 3 2
...

quand je mets sur feuille A A1=février et E1= 2006, je veux obtenir
la valeur 3 (2 pour janvier et 1 pour février)
quand je mets sur feuille A A1=mars et E1= 2006, je veux obten ir la
valeur 6 (2 pour janvier et 1 pour février et 3 pour mars)

pouvez-vous m'aider.

Merci d'avance.


LSteph
Le #4320111
Bonjour,

mois:þuilleB!$a$2:$a$13
an:þuilleB!$b$1:$c$1
données:þuilleB!$b$2:$c$13

=SOMMEPROD((LIGNE(mois)-2<EQUIV($A$1;mois;0))*(an=$E$1)*données)

Cordialement.

lSteph

Bonsoir,

Sur une feuille, j'ai un tableau récapitulatif de valeurs issues d'un
tableau situé sur une autre feuille.

Feuille A: A1=mois E1=année
Feuille B:
A B C
2006 2007
janvier 2 3
février 1 2
mars 3 2
...

quand je mets sur feuille A A1=février et E1= 2006, je veux
obtenir la valeur 3 (2 pour janvier et 1 pour février)
quand je mets sur feuille A A1=mars et E1= 2006, je veux obtenir
la valeur 6 (2 pour janvier et 1 pour février et 3 pour mars)

pouvez-vous m'aider.

Merci d'avance.



JièL
Le #4319991
Bonjoir(c) LSteph et JB

ah ok, j'avais pas compris la règle du jeux : faire le plus compliqué
possible en utilisant le plus possible de fonctions inutiles ou complexes,
c'est ça ? ;-))))))

bon, alors j'ai essayé, mais je sais pas si j'arrive à vos niveaux :-))))

=INDIRECT("'Feuille B'!"&MAJUSCULE(CAR(EQUIV(INDIRECT("'Feuille
A'!E1");INDIRECT("B1:C1");0)*ARRONDI(MAX(650/10;65);0)+1))&EQUIV(INDIRECT("'Feuille
A'!A1");INDIRECT(CAR(65)&2*1&":"&CAR(65)&CODE(CAR(4+48)));0)+1)

le con_cours(long plutôt) reste ouvert ;-)))))))))

NB : ça fonctionne pareil, mais c'est juste plus long à écrire et
impossible à lire ou à maintenir ;-))))))

JièL con_cul_rang ;-)))))

Le 25/03/2007 11:14 vous avez écrit ceci :
Bonjour,

mois:þuilleB!$a$2:$a$13
an:þuilleB!$b$1:$c$1
données:þuilleB!$b$2:$c$13

=SOMMEPROD((LIGNE(mois)-2<EQUIV($A$1;mois;0))*(an=$E$1)*données)

Cordialement.

lSteph

Bonsoir,

Sur une feuille, j'ai un tableau récapitulatif de valeurs issues d'un
tableau situé sur une autre feuille.

Feuille A: A1=mois E1=année
Feuille B:
A B C
2006 2007
janvier 2 3
février 1 2
mars 3 2
...

quand je mets sur feuille A A1=février et E1= 2006, je veux
obtenir la valeur 3 (2 pour janvier et 1 pour février)
quand je mets sur feuille A A1=mars et E1= 2006, je veux
obtenir la valeur 6 (2 pour janvier et 1 pour février et 3 pour mars)

pouvez-vous m'aider.

Merci d'avance.





JB
Le #4319951
Bonjour,

C'est la somme CUMULEE (janvier+février+....) qui est demandée et non
pas le nombre à l'INTERSECTION du mois et de l'année.

JB


On 25 mar, 14:11, JièL
Bonjoir(c) LSteph et JB

ah ok, j'avais pas compris la règle du jeux : faire le plus compliqué
possible en utilisant le plus possible de fonctions inutiles ou complexes,
c'est ça ? ;-))))))

bon, alors j'ai essayé, mais je sais pas si j'arrive à vos niveaux :- ))))

=INDIRECT("'Feuille B'!"&MAJUSCULE(CAR(EQUIV(INDIRECT("'Feuille
A'!E1");INDIRECT("B1:C1");0)*ARRONDI(MAX(650/10;65);0)+1))&EQUIV(INDIRECT ("­'Feuille
A'!A1");INDIRECT(CAR(65)&2*1&":"&CAR(65)&CODE(CAR(4+48)));0)+1)

le con_cours(long plutôt) reste ouvert ;-)))))))))

NB : ça fonctionne pareil, mais c'est juste plus long à écrire et
impossible à lire ou à maintenir ;-))))))

JièL con_cul_rang ;-)))))

Le 25/03/2007 11:14 vous avez écrit ceci :



Bonjour,

mois:þuilleB!$a$2:$a$13
an:þuilleB!$b$1:$c$1
données:þuilleB!$b$2:$c$13

=SOMMEPROD((LIGNE(mois)-2<EQUIV($A$1;mois;0))*(an=$E$1)*données)

Cordialement.

lSteph

Bonsoir,

Sur une feuille, j'ai un tableau récapitulatif de valeurs issues d'un
tableau situé sur une autre feuille.

Feuille A: A1=mois E1=année
Feuille B:
A B C
2006 2007
janvier 2 3
février 1 2
mars 3 2
...

quand je mets sur feuille A A1=février et E1= 2006, je ve ux
obtenir la valeur 3 (2 pour janvier et 1 pour février)
quand je mets sur feuille A A1=mars et E1= 2006, je veux
obtenir la valeur 6 (2 pour janvier et 1 pour février et 3 pour mars)

pouvez-vous m'aider.

Merci d'avance.- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -




JB
Le #4319921
Formule simplifiée si les années se suivent sans discontinuité:

=SOMME(DECALER(données;;E1-2006;EQUIV(A1;Mois;0);1))

http://cjoint.com/?dzqIeyVIKN

JB

On 25 mar, 00:28, "Christophe"
Bonsoir,

Sur une feuille, j'ai un tableau récapitulatif de valeurs issues d'un
tableau situé sur une autre feuille.

Feuille A: A1=mois E1=année
Feuille B:
A B C
2006 2007
janvier 2 3
février 1 2
mars 3 2
...

quand je mets sur feuille A A1=février et E1= 2006, je veux obtenir
la valeur 3 (2 pour janvier et 1 pour février)
quand je mets sur feuille A A1=mars et E1= 2006, je veux obten ir la
valeur 6 (2 pour janvier et 1 pour février et 3 pour mars)

pouvez-vous m'aider.

Merci d'avance.


LSteph
Le #4319911
Bonjour,

Non le Monsieur ne voulait pas ce qui par position
se pouvait résoudre selon l'index equiv que tu avais uindiqué,
mais un total cumulé et le sommeprod me semble convenir.

Salutations.

lSteph

Bonjoir(c) LSteph et JB

ah ok, j'avais pas compris la règle du jeux : faire le plus compliqué
possible en utilisant le plus possible de fonctions inutiles ou
complexes, c'est ça ? ;-))))))

bon, alors j'ai essayé, mais je sais pas si j'arrive à vos niveaux :-))))

=INDIRECT("'Feuille B'!"&MAJUSCULE(CAR(EQUIV(INDIRECT("'Feuille
A'!E1");INDIRECT("B1:C1");0)*ARRONDI(MAX(650/10;65);0)+1))&EQUIV(INDIRECT("'Feuille
A'!A1");INDIRECT(CAR(65)&2*1&":"&CAR(65)&CODE(CAR(4+48)));0)+1)

le con_cours(long plutôt) reste ouvert ;-)))))))))

NB : ça fonctionne pareil, mais c'est juste plus long à écrire et
impossible à lire ou à maintenir ;-))))))

JièL con_cul_rang ;-)))))

Le 25/03/2007 11:14 vous avez écrit ceci :
Bonjour,

mois:þuilleB!$a$2:$a$13
an:þuilleB!$b$1:$c$1
données:þuilleB!$b$2:$c$13

=SOMMEPROD((LIGNE(mois)-2<EQUIV($A$1;mois;0))*(an=$E$1)*données)

Cordialement.

lSteph

Bonsoir,

Sur une feuille, j'ai un tableau récapitulatif de valeurs issues d'un
tableau situé sur une autre feuille.

Feuille A: A1=mois E1=année
Feuille B:
A B C
2006 2007
janvier 2 3
février 1 2
mars 3 2
...

quand je mets sur feuille A A1=février et E1= 2006, je veux
obtenir la valeur 3 (2 pour janvier et 1 pour février)
quand je mets sur feuille A A1=mars et E1= 2006, je veux
obtenir la valeur 6 (2 pour janvier et 1 pour février et 3 pour mars)

pouvez-vous m'aider.

Merci d'avance.







JièL
Le #4319881
Le 25/03/2007 14:11 vous avez écrit ceci :
Bonjoir(c) LSteph et JB

ah ok, j'avais pas compris la règle du jeux : faire le plus compliqué
possible en utilisant le plus possible de fonctions inutiles ou
complexes, c'est ça ? ;-))))))


au temps pour moi, mais j'ai trouvé ça bien amusant à faire quand même
;-)))))))

--
JièL / Jean-Louis GOUBERT
Là bas mieux qu'en face ;-) http://forums.offices.free.fr/
La nouvelle FAQ Outlook est là : http://faq.outlook.free.fr/index.php
Les stats de CDO : http://faq.outlook.free.fr/cdo/

JièL
Le #4319871
Allez, pour le fun
=SOMME(INDIRECT("L2C"&EQUIV('Feuille A'!E1;B1:C1;0)+1&":L"&EQUIV('Feuille
A'!A1;A2:A4;0)+1&"C"&EQUIV('Feuille A'!E1;B1:C1;0)+1;0))

mdr
C'est génial les forums, on se marre tout seul ;-))))))

--
JièL / Jean-Louis GOUBERT
Là bas mieux qu'en face ;-) http://forums.offices.free.fr/
La nouvelle FAQ Outlook est là : http://faq.outlook.free.fr/index.php
Les stats de CDO : http://faq.outlook.free.fr/cdo/

Le 25/03/2007 14:11 vous avez écrit ceci :
Bonjoir(c) LSteph et JB

ah ok, j'avais pas compris la règle du jeux : faire le plus compliqué
possible en utilisant le plus possible de fonctions inutiles ou
complexes, c'est ça ? ;-))))))

bon, alors j'ai essayé, mais je sais pas si j'arrive à vos niveaux :-))))

=INDIRECT("'Feuille B'!"&MAJUSCULE(CAR(EQUIV(INDIRECT("'Feuille
A'!E1");INDIRECT("B1:C1");0)*ARRONDI(MAX(650/10;65);0)+1))&EQUIV(INDIRECT("'Feuille
A'!A1");INDIRECT(CAR(65)&2*1&":"&CAR(65)&CODE(CAR(4+48)));0)+1)

le con_cours(long plutôt) reste ouvert ;-)))))))))

NB : ça fonctionne pareil, mais c'est juste plus long à écrire et
impossible à lire ou à maintenir ;-))))))

JièL con_cul_rang ;-)))))

Le 25/03/2007 11:14 vous avez écrit ceci :
Bonjour,

mois:þuilleB!$a$2:$a$13
an:þuilleB!$b$1:$c$1
données:þuilleB!$b$2:$c$13

=SOMMEPROD((LIGNE(mois)-2<EQUIV($A$1;mois;0))*(an=$E$1)*données)

Cordialement.

lSteph

Bonsoir,

Sur une feuille, j'ai un tableau récapitulatif de valeurs issues d'un
tableau situé sur une autre feuille.

Feuille A: A1=mois E1=année
Feuille B:
A B C
2006 2007
janvier 2 3
février 1 2
mars 3 2
...

quand je mets sur feuille A A1=février et E1= 2006, je veux
obtenir la valeur 3 (2 pour janvier et 1 pour février)
quand je mets sur feuille A A1=mars et E1= 2006, je veux
obtenir la valeur 6 (2 pour janvier et 1 pour février et 3 pour mars)

pouvez-vous m'aider.

Merci d'avance.







LSteph
Le #4319791
:o))))

Allez, pour le fun
=SOMME(INDIRECT("L2C"&EQUIV('Feuille
A'!E1;B1:C1;0)+1&":L"&EQUIV('Feuille A'!A1;A2:A4;0)+1&"C"&EQUIV('Feuille
A'!E1;B1:C1;0)+1;0))

mdr
C'est génial les forums, on se marre tout seul ;-))))))



Publicité
Poster une réponse
Anonyme