Critéres multiples de validation

Le
Michel
Bonjour a toutes et a tous,

j'ai un critère de validation dans une cellules qui affiche une liste
déroulante qui propose X ou N si les conditions sont remplis, et rien

si une des condition et non rempli, (X signifie "Réinscription" et N "nouvel
adhérant")


=SI(ET(A3<>"";B3<>"";C3<>"";D3<>"";E3<>"";F3<>"";G3<>"";H3<>"";K3<>"";M3<>"";N3<>"");Inscrit)

Cela fonctionne très.

toutefois l'utilisateur a la faculté de choisir "N" même si il s'agit d'une
réinscription et vice versa, ce qui bien sur n'est pas souhaité.


J'ai donc fait 2 autres source de listes "Inscrit_1"pour (X) et
"Inscrit_2"pour (N).
La table posséde une colonne "V" qui contient le N° d'adhérant pour les
anciens


Je souhaiterais donc a présent que si la colonne "V" contient un N° (V<>"")
la liste soit "X" et "N" si pas de N°
Et bien sur rien, ni possibilité de saisi quelconque, si l'un des autres
champs est vide.

J'ai essayé beaucoup de combinaison en vain.

Un coup de main sera le bienvenu

D'avance merci

Michel
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Michel
Le #20179231
Voila,

J'ai progressé, la formule suivante fonctionne

=SI(ET(A2<>"";B2<>"";C2<>"";D2<>"";E2<>"";F2<>"";G2<>"";H2<>"";K2<>"";M2<>"";N2<>"";V2="");Inscrit_2;SI(ET(A2<>"";B2<>"";C2<>"";D2<>"";E2<>"";F2<>"";G2<>"";H2<>"";K2<>"";M2<>"";N2<>"";V2<>"");Inscrit_1))

Par recopie jusqu'a la ligne 999
=SI(ET(A999<>"";B999<>"";C999<>"";D999<>"";E999<>"";F999<>"";G999<>"";H999<>"";K999<>"";M999<>"";N999<>"";V999="");Inscrit_2;SI(ET(A999<>"";B999<>"";C999<>"";D999<>"";E999<>"";F999<>"";G999<>"";H999<>"";K999<>"";M999<>"";N999<>"";V999<>"");Inscrit_1))

Au dela elle et tronqué et deviens
=ET(A1000<>"";B1000<>"";C1000<>"";D1000<>"";E1000<>"";F1000<>"";G1000<>"";H1000<>"";K1000<>"";M1000<>"";N1000<>"";V1000="")?Inscrit_2
A1000<>"" B1000<>"" C1000<>"" D1000<>"" E1000<>"" F1000<>"" G1000<>""
H1000<>"" K1000<>"" M1000<>""

Je suppose qu'il y une limitation du nombre de caractères permis


Quelqu'un sait il comment obtenir la mème chose en plus court

D'avance Merci
Michel




"Michel" 4ab47ec6$0$17478$
Bonjour a toutes et a tous,

j'ai un critère de validation dans une cellules qui affiche une liste
déroulante qui propose X ou N si les conditions sont remplis, et rien

si une des condition et non rempli, (X signifie "Réinscription" et N
"nouvel adhérant")


=SI(ET(A3<>"";B3<>"";C3<>"";D3<>"";E3<>"";F3<>"";G3<>"";H3<>"";K3<>"";M3<>"";N3<>"");Inscrit)

Cela fonctionne très.

toutefois l'utilisateur a la faculté de choisir "N" même si il s'agit
d'une réinscription et vice versa, ce qui bien sur n'est pas souhaité.


J'ai donc fait 2 autres source de listes "Inscrit_1"pour (X) et
"Inscrit_2"pour (N).
La table posséde une colonne "V" qui contient le N° d'adhérant pour les
anciens


Je souhaiterais donc a présent que si la colonne "V" contient un N°
(V<>"") la liste soit "X" et "N" si pas de N°
Et bien sur rien, ni possibilité de saisi quelconque, si l'un des autres
champs est vide.

J'ai essayé beaucoup de combinaison en vain.

Un coup de main sera le bienvenu

D'avance merci

Michel



Daniel.C
Le #20179701
Bonjour.
Essaie :
=SI(ET(NBVAL(A2:H2;K2;M2;N:N2);N2<>"";V2="");Inscrit_2;SI(ET(NBVAL(A2:H2;K2;M2;N:N2);V2<>"");Inscrit_1))
Cordialement.
Daniel

Voila,

J'ai progressé, la formule suivante fonctionne

=SI(ET(A2<>"";B2<>"";C2<>"";D2<>"";E2<>"";F2<>"";G2<>"";H2<>"";K2<>"";M2<>"";N2<>"";V2="");Inscrit_2;SI(ET(A2<>"";B2<>"";C2<>"";D2<>"";E2<>"";F2<>"";G2<>"";H2<>"";K2<>"";M2<>"";N2<>"";V2<>"");Inscrit_1))

Par recopie jusqu'a la ligne 999
=SI(ET(A999<>"";B999<>"";C999<>"";D999<>"";E999<>"";F999<>"";G999<>"";H999<>"";K999<>"";M999<>"";N999<>"";V999="");Inscrit_2;SI(ET(A999<>"";B999<>"";C999<>"";D999<>"";E999<>"";F999<>"";G999<>"";H999<>"";K999<>"";M999<>"";N999<>"";V999<>"");Inscrit_1))

Au dela elle et tronqué et deviens
=ET(A1000<>"";B1000<>"";C1000<>"";D1000<>"";E1000<>"";F1000<>"";G1000<>"";H1000<>"";K1000<>"";M1000<>"";N1000<>"";V1000="")?Inscrit_2
A1000<>"" B1000<>"" C1000<>"" D1000<>"" E1000<>"" F1000<>"" G1000<>""
H1000<>"" K1000<>"" M1000<>""

Je suppose qu'il y une limitation du nombre de caractères permis


Quelqu'un sait il comment obtenir la mème chose en plus court

D'avance Merci
Michel




"Michel" 4ab47ec6$0$17478$
Bonjour a toutes et a tous,

j'ai un critère de validation dans une cellules qui affiche une liste
déroulante qui propose X ou N si les conditions sont remplis, et rien

si une des condition et non rempli, (X signifie "Réinscription" et N
"nouvel adhérant")


=SI(ET(A3<>"";B3<>"";C3<>"";D3<>"";E3<>"";F3<>"";G3<>"";H3<>"";K3<>"";M3<>"";N3<>"");Inscrit)

Cela fonctionne très.

toutefois l'utilisateur a la faculté de choisir "N" même si il s'agit d'une
réinscription et vice versa, ce qui bien sur n'est pas souhaité.


J'ai donc fait 2 autres source de listes "Inscrit_1"pour (X) et
"Inscrit_2"pour (N).
La table posséde une colonne "V" qui contient le N° d'adhérant pour les
anciens


Je souhaiterais donc a présent que si la colonne "V" contient un N° (V<>"")
la liste soit "X" et "N" si pas de N°
Et bien sur rien, ni possibilité de saisi quelconque, si l'un des autres
champs est vide.

J'ai essayé beaucoup de combinaison en vain.

Un coup de main sera le bienvenu

D'avance merci

Michel





Michel
Le #20179851
Ca y est, cela fonctione avec :

=SI(ET(A2:H2<>"";K2<>"";M2<>"";N2<>"";V2="");Inscrit_2;SI(ET(A2:H2<>"";K2<>"";M2<>"";N2<>"";V2<>"");Inscrit_1))

Désolé de vous avoir dérangé

Michel



"Michel" 4ab47ec6$0$17478$
Bonjour a toutes et a tous,

j'ai un critère de validation dans une cellules qui affiche une liste
déroulante qui propose X ou N si les conditions sont remplis, et rien

si une des condition et non rempli, (X signifie "Réinscription" et N
"nouvel adhérant")


=SI(ET(A3<>"";B3<>"";C3<>"";D3<>"";E3<>"";F3<>"";G3<>"";H3<>"";K3<>"";M3<>"";N3<>"");Inscrit)

Cela fonctionne très.

toutefois l'utilisateur a la faculté de choisir "N" même si il s'agit
d'une réinscription et vice versa, ce qui bien sur n'est pas souhaité.


J'ai donc fait 2 autres source de listes "Inscrit_1"pour (X) et
"Inscrit_2"pour (N).
La table posséde une colonne "V" qui contient le N° d'adhérant pour les
anciens


Je souhaiterais donc a présent que si la colonne "V" contient un N°
(V<>"") la liste soit "X" et "N" si pas de N°
Et bien sur rien, ni possibilité de saisi quelconque, si l'un des autres
champs est vide.

J'ai essayé beaucoup de combinaison en vain.

Un coup de main sera le bienvenu

D'avance merci

Michel



Daniel.C
Le #20179831
Oups :
=SI(ET(NBVAL(A2:H2;K2;M2:N2);N2<>"";V2="");Inscrit_2;SI(ET(NBVAL(A2:H2;K2;M2:N2);V2<>"");Inscrit_1))

Bonjour.
Essaie :
=SI(ET(NBVAL(A2:H2;K2;M2;N:N2);N2<>"";V2="");Inscrit_2;SI(ET(NBVAL(A2:H2;K2;M2;N:N2);V2<>"");Inscrit_1))
Cordialement.
Daniel

Voila,

J'ai progressé, la formule suivante fonctionne

=SI(ET(A2<>"";B2<>"";C2<>"";D2<>"";E2<>"";F2<>"";G2<>"";H2<>"";K2<>"";M2<>"";N2<>"";V2="");Inscrit_2;SI(ET(A2<>"";B2<>"";C2<>"";D2<>"";E2<>"";F2<>"";G2<>"";H2<>"";K2<>"";M2<>"";N2<>"";V2<>"");Inscrit_1))

Par recopie jusqu'a la ligne 999
=SI(ET(A999<>"";B999<>"";C999<>"";D999<>"";E999<>"";F999<>"";G999<>"";H999<>"";K999<>"";M999<>"";N999<>"";V999="");Inscrit_2;SI(ET(A999<>"";B999<>"";C999<>"";D999<>"";E999<>"";F999<>"";G999<>"";H999<>"";K999<>"";M999<>"";N999<>"";V999<>"");Inscrit_1))

Au dela elle et tronqué et deviens
=ET(A1000<>"";B1000<>"";C1000<>"";D1000<>"";E1000<>"";F1000<>"";G1000<>"";H1000<>"";K1000<>"";M1000<>"";N1000<>"";V1000="")?Inscrit_2
A1000<>"" B1000<>"" C1000<>"" D1000<>"" E1000<>"" F1000<>"" G1000<>""
H1000<>"" K1000<>"" M1000<>""

Je suppose qu'il y une limitation du nombre de caractères permis


Quelqu'un sait il comment obtenir la mème chose en plus court

D'avance Merci
Michel




"Michel" 4ab47ec6$0$17478$
Bonjour a toutes et a tous,

j'ai un critère de validation dans une cellules qui affiche une liste
déroulante qui propose X ou N si les conditions sont remplis, et rien

si une des condition et non rempli, (X signifie "Réinscription" et N
"nouvel adhérant")


=SI(ET(A3<>"";B3<>"";C3<>"";D3<>"";E3<>"";F3<>"";G3<>"";H3<>"";K3<>"";M3<>"";N3<>"");Inscrit)

Cela fonctionne très.

toutefois l'utilisateur a la faculté de choisir "N" même si il s'agit
d'une réinscription et vice versa, ce qui bien sur n'est pas souhaité.


J'ai donc fait 2 autres source de listes "Inscrit_1"pour (X) et
"Inscrit_2"pour (N).
La table posséde une colonne "V" qui contient le N° d'adhérant pour les
anciens


Je souhaiterais donc a présent que si la colonne "V" contient un N°
(V<>"") la liste soit "X" et "N" si pas de N°
Et bien sur rien, ni possibilité de saisi quelconque, si l'un des autres
champs est vide.

J'ai essayé beaucoup de combinaison en vain.

Un coup de main sera le bienvenu

D'avance merci

Michel






Publicité
Poster une réponse
Anonyme