Crystal Reports et Windev

Le
Serge
Bonjour,


Je devine un peu la réponse, mais à tout hasard, quelqu'un a-t-il pu piloter
Crystal avec Windev ?

Merci
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
J.B.
Le #14476901
Le Thu, 15 Nov 2007 13:19:26 +0100, Serge a écrit:

Bonjour,


Je devine un peu la réponse, mais à tout hasard, quelqu'un a-t-il pu
piloter
Crystal avec Windev ?

Merci




Oui.


--
J.Bratières
Serge
Le #14476891
oui ? c est à dire ?

Merci


"J.B."
Le Thu, 15 Nov 2007 13:19:26 +0100, Serge a écrit:

Bonjour,


Je devine un peu la réponse, mais à tout hasard, quelqu'un a-t-il pu
piloter
Crystal avec Windev ?

Merci




Oui.


--
J.Bratières


J.B.
Le #14476881
Le Thu, 15 Nov 2007 16:57:51 +0100, Serge a écrit:

oui ? c est à dire ?

Merci


"J.B."
Le Thu, 15 Nov 2007 13:19:26 +0100, Serge
a écrit:

Bonjour,


Je devine un peu la réponse, mais à tout hasard, quelqu'un a-t-il pu
piloter
Crystal avec Windev ?

Merci




Oui.


--
J.Bratières






Oui , nous avons pu utiliser Crystal depuis une appli WD.
Une autre question ?


--
J.Bratières
youpi
Le #14476871
ca a déjà circulé sur ce forum.
si tu as les archives.
sinon ca doit etre aussi sur windevasso non ?


"J.B."
Le Thu, 15 Nov 2007 16:57:51 +0100, Serge a écrit:

oui ? c est à dire ?

Merci


"J.B."
Le Thu, 15 Nov 2007 13:19:26 +0100, Serge
a écrit:

Bonjour,


Je devine un peu la réponse, mais à tout hasard, quelqu'un a-t-il pu
piloter
Crystal avec Windev ?

Merci




Oui.


--
J.Bratières






Oui , nous avons pu utiliser Crystal depuis une appli WD.
Une autre question ?


--
J.Bratières


Serge
Le #14476851
Ma question est de savoir comment imprimer un état fait sur Crystal Report
avec une appli Windev.

Merci


"J.B."
Le Thu, 15 Nov 2007 16:57:51 +0100, Serge a écrit:

oui ? c est à dire ?

Merci


"J.B."
Le Thu, 15 Nov 2007 13:19:26 +0100, Serge
a écrit:

Bonjour,


Je devine un peu la réponse, mais à tout hasard, quelqu'un a-t-il pu
piloter
Crystal avec Windev ?

Merci




Oui.


--
J.Bratières






Oui , nous avons pu utiliser Crystal depuis une appli WD.
Une autre question ?


--
J.Bratières


J.B.
Le #14476841
Le Fri, 16 Nov 2007 10:33:40 +0100, Serge a écrit:

Ma question est de savoir comment imprimer un état fait sur Crystal
Report
avec une appli Windev.

Merci



[...]

--
J.Bratières






Merci de répondre en dessous.

Utiliser l'ActiveX Crystal report Control

Un bout de code ici: (WD9!!)

ACTIVEX1>>SQLquery=ORDSQL() //007 deplacé en tete
//pour saisie des parametre
SI connexion = 0 ALORS //007
ACTIVEX1>>Connect="DSN="+ORADSN+";UID="+ORAUSER+";PWD="+ORAPWD //connection
oracle
FIN
Sablier(Vrai) //010
ACTIVEX1>>ReportFilename=pathrpt+SansEspace(ED.EDRPT) //nom du .rpt
SI crysimp <> 0 ALORS //005
ACTIVEX1>>PrinterSelect()
FIN

SI direct <> 0 ALORS //013
ACTIVEX1>>destination=1 //013 imprimante
SINON //013
ACTIVEX1>>destination=0 //013 fenetre
FIN //013

SI crysmax <>0 ALORS //005
ACTIVEX1>>WindowState=2 //005
FIN
SI crysarb <>0 ALORS //005
ACTIVEX1>>WindowShowGroupTree=1 //005
ELSE
ACTIVEX1>>WindowShowGroupTree=0 //005
FIN
// ce qui est ci-dessous ne fonctionne pas car pas trouvé (ni WD) comment
utiliser
// les occurences
//activex1>>ParameterFields (0,"TITRE;'"+seqedi+...;TRUE") //004 si un
jour ca marche
//activex1>>Formulas (0,"DATE=4")
//activex1>>ParameterFields="0,TITRE;chn;TRUE"
//activex1>>ParameterFields(0)="TITRE;chn;TRUE"
//activex1>>ParameterFields[0]="TITRE;chn;TRUE"

ACTIVEX1>>ReportTitle=Titre(nometab,seqedi,devise) //007 008 013
SI vue~="IMPCOUT" ALORS
ACTIVEX1>>SelectionFormula="{IMPCOUT.COUT}<>0" //filtrer les couts =0
ACTIVEX1>>action=1
Sablier(Faux) //010
Info("Edition terminée")



--
J.Bratières
Serge
Le #14476811
Merci, je m'y penche.

Serge


"J.B."
Le Fri, 16 Nov 2007 10:33:40 +0100, Serge a écrit:

Ma question est de savoir comment imprimer un état fait sur Crystal
Report
avec une appli Windev.

Merci



[...]

--
J.Bratières






Merci de répondre en dessous.

Utiliser l'ActiveX Crystal report Control

Un bout de code ici: (WD9!!)

ACTIVEX1>>SQLquery=ORDSQL() //007 deplacé en tete
//pour saisie des parametre
SI connexion = 0 ALORS //007
ACTIVEX1>>Connect="DSN="+ORADSN+";UID="+ORAUSER+";PWD="+ORAPWD
//connection oracle
FIN Sablier(Vrai) //010
ACTIVEX1>>ReportFilename=pathrpt+SansEspace(ED.EDRPT) //nom du .rpt
SI crysimp <> 0 ALORS //005
ACTIVEX1>>PrinterSelect()
FIN

SI direct <> 0 ALORS //013
ACTIVEX1>>destination=1 //013 imprimante
SINON //013
ACTIVEX1>>destination=0 //013 fenetre
FIN //013

SI crysmax <>0 ALORS //005
ACTIVEX1>>WindowState=2 //005
FIN
SI crysarb <>0 ALORS //005
ACTIVEX1>>WindowShowGroupTree=1 //005
ELSE
ACTIVEX1>>WindowShowGroupTree=0 //005 FIN
// ce qui est ci-dessous ne fonctionne pas car pas trouvé (ni WD) comment
utiliser
// les occurences
//activex1>>ParameterFields (0,"TITRE;'"+seqedi+...;TRUE") //004 si un
jour ca marche
//activex1>>Formulas (0,"DATE=4")
//activex1>>ParameterFields="0,TITRE;chn;TRUE"
//activex1>>ParameterFields(0)="TITRE;chn;TRUE"
//activex1>>ParameterFields[0]="TITRE;chn;TRUE"

ACTIVEX1>>ReportTitle=Titre(nometab,seqedi,devise) //007 008 013
SI vue~="IMPCOUT" ALORS ACTIVEX1>>SelectionFormula="{IMPCOUT.COUT}<>0"
//filtrer les couts =0
ACTIVEX1>>action=1
Sablier(Faux) //010
Info("Edition terminée")



--
J.Bratières


Publicité
Poster une réponse
Anonyme