css-mode

Le
Maxime Chupin
Bonjour,

Je cherche à utiliser le css-mode trouvé ici :
http://www.emacswiki.org/cgi-bin/wiki/css-mode.el

Je l'ai donc téléchargé et mis ici :

~/emacsel/

Puis dans mon .emacs j'ai mis ces quelques lignes :

(setq load-path (cons "~/emacsel/" load-path))
;; css mode
(autoload 'css-mode' "css-mode")
(setq auto-mode-alist
(append '(("\.css$" . css-mode))
auto-mode-alist))

Et lorsque j'ouvre une fichier .css, pas de mode css et si je fais M-x
css-mode il y a un [no-match] qui s'inscrit

Qu'ai-je fais de mal?

Merci.



--
Maxime Chupin
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Paul Gaborit
Le #21774701
À (at) 05 Oct 2008 11:09:31 GMT,
Maxime Chupin
Je cherche à utiliser le css-mode trouvé ici :
http://www.emacswiki.org/cgi-bin/wiki/css-mode.el

Je l'ai donc téléchargé et mis ici :

~/emacsel/



Ok.

Puis dans mon .emacs j'ai mis ces quelques lignes :

(setq load-path (cons "~/emacsel/" load-path))



Et si vous utilisiez plutôt :

(setq load-path (cons (expand-file-name "~/emacsel") load-path))

;; css mode
(autoload 'css-mode' "css-mode")
(setq auto-mode-alist
(append '(("\.css$" . css-mode))
auto-mode-alist))

Et lorsque j'ouvre une fichier .css, pas de mode css et si je fais M-x
css-mode il y a un [no-match] qui s'inscrit...

Qu'ai-je fais de mal?



À part ma remarque ci-dessus, je ne vois rien...

--
Paul Gaborit -
Maxime Chupin
Le #21774691
Le Mon, 06 Oct 2008 13:43:55 +0200, Paul Gaborit a écrit :
Et si vous utilisiez plutôt :

(setq load-path (cons (expand-file-name "~/emacsel") load-path))



Malheureusement cela ne fonctionne pas :-(




--
Maxime Chupin
Vincent Belaïche
Le #21774681
Maxime Chupin a écrit :
;; css mode
(autoload 'css-mode' "css-mode")



Il n'y aurait pas un ' de trop, ça ne serait pas plutôt

(autoload 'css-mode "css-mode")

qu'il faudrait.
Maxime Chupin
Le #21774661
Le Wed, 08 Oct 2008 07:12:04 +0200, Vincent Belaïche a écrit :
Il n'y aurait pas un ' de trop, ça ne serait pas plutôt

(autoload 'css-mode "css-mode")

qu'il faudrait.



J'ai modifié, en vain...

Merci de votre aide en tout cas :-)




--
Maxime Chupin
Asgeir
Le #21774651
Project-Id-Version: Claws-Mail-3.3.1cvs57 (3.4.0)
Report-Msgid-Bugs-To:
POT-Creation-Date: 2008-06-27 15:06+0100
PO-Revision-Date: 2008-06-23 11:53+0100
Last-Translator: Tristan Chabredier (wwp) Language-Team: MIME-Version: 1.0
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit
Plural-Forms: nplurals=2; plural=n>1;

Le .emacs.el est-il bien situé dans ~ ?

--
Asgeir
Maxime Chupin
Le #21774641
Le Wed, 08 Oct 2008 17:40:41 +0200, Asgeir a écrit :
Le .emacs.el est-il bien situé dans ~ ?



Je n'ai pas de .emacs.el...




--
Maxime Chupin
jj.retorre
Le #21774631
Maxime Chupin
Le Wed, 08 Oct 2008 07:12:04 +0200, Vincent Belaïche a écrit :
Il n'y aurait pas un ' de trop, ça ne serait pas plutôt

(autoload 'css-mode "css-mode")

qu'il faudrait.



J'ai modifié, en vain...

Merci de votre aide en tout cas :-)



J'ai ça dans mon .emacs ( C-x C-f .emacs )

8<------------------------------------------
;; ----- css-mode ----

(autoload 'css-mode "css-mode" "Mode for editing CSS files" t)

(setq auto-mode-alist
(append '(("\.css$" . css-mode))
auto-mode-alist))
;; ---------------------
8<------------------------------------------

et j'ai sauvé le fichier css-mode.el dans l'un des répertoires décrit
par la variable load-path (chez moi, c'est .emacs.d/lisp), mais ça n'a
pas grande importance.

C-h C-v load-path liste les endroits ou l'on
peut sauvegarder css-mode.el

Si on doit en créer un dans son espace personnel, la commande c'est

8<------------------------------------------
;; ajoute le répertoire ~/.emacs.d/lisp dans le load-path
;; -------------------------------------------------------
(setq load-path (cons (expand-file-name "~/.emacs.d/lisp") load-path))
8<------------------------------------------


Si ça ne marche pas chez toi, c'est un autre problème, il faut
regarder les messages.

--
JJR.
Maxime Chupin
Le #21774621
Le Wed, 08 Oct 2008 18:54:06 +0200, JJ. Rétorré a écrit :

J'ai ça dans mon .emacs ( C-x C-f .emacs )

8<------------------------------------------ ;; ----- css-mode ----

(autoload 'css-mode "css-mode" "Mode for editing CSS files" t)



Il me manquait le t... Maintenant ça marche !!!


Merci !

--
Maxime Chupin
Asgeir
Le #21774591
Project-Id-Version: Claws-Mail-3.3.1cvs57 (3.4.0)
Report-Msgid-Bugs-To:
POT-Creation-Date: 2008-06-27 15:06+0100
PO-Revision-Date: 2008-06-23 11:53+0100
Last-Translator: Tristan Chabredier (wwp) Language-Team: MIME-Version: 1.0
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit
Plural-Forms: nplurals=2; plural=n>1;

.emacs.el c'est juste le nom du fichier .emacs avec son extension...
=> C'était la phase propagande lipsienne.

--
Asgeir
Publicité
Poster une réponse
Anonyme