cumuler des temps en fonction ...

Le
Greg
Bonjour,

Voici le classeur qui vous permettra de mieux comprendre mon attente:
http://cjoint.com/?kntRGUT7eZ

Je cherche à cumuler des temps en fonction du contenu de la cellule voisine.
Je m'explique:

D E F G

1 0:30 maths 0:50 sciences

2 0:25 Français 0:25 Français

3 0:30 sciences 0:30 maths

Comment créer une formule qui cumulerait dans une cellule tous les temps
de francais, de maths etc

petite précision: les temps indiqués ici sont calculés à partir d'une
formule, reprenant d'autres cellules.

Merci pour vos lumières.

Greg
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
FS
Le #20345971
Bonsoir,

Par exemple, en M4 pour le Français :

=SOMME.SI($C$3:$C$15;"Français";$B$3:$B$15)+SOMME.SI($E$3:$E$15;"Français";$D$3:$D$15)+SOMME.SI($G$3:$G$15;"Français";$F$3:$F$15)+SOMME.SI($I$3:$I$15;"Français";$H$3:$H$15)
ou, un poil plus bref
=SOMMEPROD((B3:B15)*(C3:C15="Français")+(D3:D15)*(E3:E15="Français")+(F3:F15)*(G3:G15="Français")+(H3:H15)*(I3:I15="Français"))

Si ta liste des matières en K4:K15 reprenait exactement ceux de l'emploi
du temps (ce qui n'est pas le cas), ça pourrait se simplifier un peu.

FS
--
Frédéric SIGONNEAU
Modules et modèles pour Excel :
http://frederic.sigonneau.free.fr/

Greg a écrit :
Bonjour,

Voici le classeur qui vous permettra de mieux comprendre mon attente:
http://cjoint.com/?kntRGUT7eZ

Je cherche à cumuler des temps en fonction du contenu de la cellule
voisine. Je m'explique:

D E F G

1 0:30 maths 0:50 sciences

2 0:25 Français 0:25 Français

3 0:30 sciences 0:30 maths

Comment créer une formule qui cumulerait dans une cellule tous les
temps de francais, de maths ...etc

petite précision: les temps indiqués ici sont calculés à partir d'une
formule, reprenant d'autres cellules.

Merci pour vos lumières.

Greg




Greg
Le #20346241
Bonsoir Frédéric,

Génial! Ca marche impec! Pour régler le problème dont tu m'as parlé, je créé
des listes déroulantes. Ainsi, pas de problème possible dans l'écriture.

Merci beaucoup!!!

Greg

"FS" news:%
Bonsoir,

Par exemple, en M4 pour le Français :

=SOMME.SI($C$3:$C$15;"Français";$B$3:$B$15)+SOMME.SI($E$3:$E$15;"Français";$D$3:$D$15)+SOMME.SI($G$3:$G$15;"Français";$F$3:$F$15)+SOMME.SI($I$3:$I$15;"Français";$H$3:$H$15)
ou, un poil plus bref
=SOMMEPROD((B3:B15)*(C3:C15="Français")+(D3:D15)*(E3:E15="Français")+(F3:F15)*(G3:G15="Français")+(H3:H15)*(I3:I15="Français"))

Si ta liste des matières en K4:K15 reprenait exactement ceux de l'emploi
du temps (ce qui n'est pas le cas), ça pourrait se simplifier un peu.

FS
--
Frédéric SIGONNEAU
Modules et modèles pour Excel :
http://frederic.sigonneau.free.fr/

Greg a écrit :
Bonjour,

Voici le classeur qui vous permettra de mieux comprendre mon attente:
http://cjoint.com/?kntRGUT7eZ

Je cherche à cumuler des temps en fonction du contenu de la cellule
voisine. Je m'explique:

D E F G

1 0:30 maths 0:50 sciences

2 0:25 Français 0:25 Français

3 0:30 sciences 0:30 maths

Comment créer une formule qui cumulerait dans une cellule tous les
temps de francais, de maths ...etc

petite précision: les temps indiqués ici sont calculés à partir d'une
formule, reprenant d'autres cellules.

Merci pour vos lumières.

Greg





Publicité
Poster une réponse
Anonyme