[CUPS] certains postes n'arrivent plus à imprimer en réseau

Le
Samy Mezani
Bonjour,

Je dispose d'un petit réseau local constitué d'un serveur d'impression
CUPS sous wheezy et de 5 ordinateurs.

Depuis aujourd'hui 2 postes sous Windows XP et 7 ne peuvent plus
imprimer. Je n'ai pourtant changé aucune IP ni utilisateur. Un poste
sous Windows XP y arrive encore très bien, et les 2 postes sous Linux
n'ont aucun souci.

Dans les logs de CUPS j'ai le message récurrent :
Returning IPP client-error-not-authorized for Create-Job
(ipp://192.168.0.X:631/printers/HP_Officejet_6500) from 192.168.0.Y

Je ne comprends pas pourquoi puisque les utilisateurs autorisés sont
bien spécifiés depuis longtemps dans /etc/cups/printers.conf avec
'AllowUser <utilisateur>'

J'ai ajouté dans /etc/cups/cupsd.conf les lignes suivantes inspirées du
fichier de conf par défaut :
<Limit Create-Job Print-Job Print-URI Validate-Job>
Require user @OWNER @SYSTEM
Order deny,allow
</Limit>

Toujours aucune impression, mais je n'ai plus de message d'erreur :
192.168.0.Y - - [12/Dec/2014:14:26:31 +0100] "POST
/printers/HP_Officejet_6500 HTTP/1.1" 426 16054 Print-Job successful-ok

Mais pas de message avec
Validate-Job successful-ok
Create-Job successful-ok
Send-Document successful-ok

Je n'y comprend plus rien. Je tourne en rond depuis environ 4h
Une petite idée ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: https://lists.debian.org/548AF1B2.7080903@wanadoo.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Michel OLTRA
Le #26328726
Bonjour,


Le vendredi 12 décembre 2014, Samy Mezani a écrit...


Depuis aujourd'hui 2 postes sous Windows XP et 7 ne peuvent plus imprimer.
Je n'ai pourtant changé aucune IP ni utilisateur. Un poste sous Windows XP y
arrive encore très bien, et les 2 postes sous Linux n'ont aucun souci.

Je n'y comprend plus rien. Je tourne en rond depuis environ 4h...
Une petite idée ?



Problème d'adressage ip de ces 2 postes, avec 2 ip identiques ?

--
jm

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Samy Mezani
Le #26328730
Le 12/12/2014 17:57, Jean-Michel OLTRA a écrit :
Problème d'adressage ip de ces 2 postes, avec 2 ip identiques ?



Non ils ont bien 2 IP différentes, qui sont d'ailleurs fixes.

J'ai démarré l'un d'eux sur une clé avec Debian Wheezy, rebelotte, ça ne
veut pas imprimer malgré la bonne détection de l'imprimante sur le poste...

J'ai été obligé de réinstaller (pour d'autres raisons) Win 7 sur cet
ordinateur (quelle galère... je suis revenu 20 ans en arrière...), et
surprise l'installation de l'imprimante via
http://192.168.0.X:631/printers/imprimante s'est déroulé nickel (comme
d'habitude) et j'ai pu imprimer normalement.

Il y a peut-être un souci au niveau des IP, je vais essayer de changer.
Merci.

Samy

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
baal.fr
Le #26328741
xp se fait vieux et ne beneficie plus de mise à jour
il vaut mieux migrer à seven
sinon autent mettre tout le parc sous linux ....
Le 12/12/2014 18:09, Samy Mezani a écrit :
Le 12/12/2014 17:57, Jean-Michel OLTRA a écrit :
Problème d'adressage ip de ces 2 postes, avec 2 ip identiques ?



Non ils ont bien 2 IP différentes, qui sont d'ailleurs fixes.

J'ai démarré l'un d'eux sur une clé avec Debian Wheezy, rebelotte, ça
ne veut pas imprimer malgré la bonne détection de l'imprimante sur le
poste...

J'ai été obligé de réinstaller (pour d'autres raisons) Win 7 sur cet
ordinateur (quelle galère... je suis revenu 20 ans en arrière...), et
surprise l'installation de l'imprimante via
http://192.168.0.X:631/printers/imprimante s'est déroulé nickel (comme
d'habitude) et j'ai pu imprimer normalement.

Il y a peut-être un souci au niveau des IP, je vais essayer de
changer. Merci.

Samy




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
maderios
Le #26328767
On 12/12/2014 02:46 PM, Samy Mezani wrote:
Bonjour,

Je dispose d'un petit réseau local constitué d'un serveur d'impression
CUPS sous wheezy et de 5 ordinateurs.

Depuis aujourd'hui 2 postes sous Windows XP et 7 ne peuvent plus
imprimer. Je n'ai pourtant changé aucune IP ni utilisateur. Un poste
sous Windows XP y arrive encore très bien, et les 2 postes sous Linux
n'ont aucun souci.


Bonjour
Donc c'est un problème windows et non Debian. Donc rien à dire sur ce HS
de chez HS sinon que c'est, dans l'absolu, une occasion unique de jeter
windows et de le remplacer par Debian qui fonctionne très bien.
--
Maderios


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Samy Mezani
Le #26329356
Le 12/12/2014 18:11, baal.fr a écrit :
xp se fait vieux et ne beneficie plus de mise à jour
il vaut mieux migrer à seven
sinon autent mettre tout le parc sous linux ....
Le 12/12/2014 18:09, Samy Mezani a écrit :
Le 12/12/2014 17:57, Jean-Michel OLTRA a écrit :
Problème d'adressage ip de ces 2 postes, avec 2 ip identiques ?



Non ils ont bien 2 IP différentes, qui sont d'ailleurs fixes.

J'ai démarré l'un d'eux sur une clé avec Debian Wheezy, rebelotte, ça
ne veut pas imprimer malgré la bonne détection de l'imprimante sur le
poste...

J'ai été obligé de réinstaller (pour d'autres raisons) Win 7 sur cet
ordinateur (quelle galère... je suis revenu 20 ans en arrière...), et
surprise l'installation de l'imprimante via
http://192.168.0.X:631/printers/imprimante s'est déroulé nickel (comme
d'habitude) et j'ai pu imprimer normalement.

Il y a peut-être un souci au niveau des IP, je vais essayer de
changer. Merci.

Samy







Bonjour,

Finalement le problème se situait bien au niveau du serveur cups où /var
avait pris tellement d'embonpoint que la partition / n'avait plus assez
de place pour stocker les fichiers temporaires d'impression (df -h
indiquait 250Mo de libre)
D'où la réussite de mes essais sur Linux (fichiers texte légers) par
rapport aux autres postes (pdf plus lourds).

Je sais, j'aurais dû séparer /var de / mais bon...
Mais le souci est quand même que le message d'erreur de cups ne
correspondait pas vraiment au fond du problème.

Depuis l'obtention d'une place suffisante pour /, plus aucun souci.


Samy

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Sylvain L. Sauvage
Le #26329373
Le mardi 16 décembre 2014, 10:43:56 Samy Mezani a écrit :
[… plus de place …]
Mais le souci est quand même que le message d'erreur de cups
ne correspondait pas vraiment au fond du problème.



Personne ne vérifie jamais s’il y a de la place avant de créer
ou de remplir un fichier. (Déjà, peu vérifient que le fi chier
est seulement au moins créé.) Ça fait que les programmes
plantent plus loin, pour des raisons bizarres…

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Publicité
Poster une réponse
Anonyme