date anglais-français

Le
Michel Samoey
Bonjour, je copie des dates depuis le web d'origine américaine

31 Jan
1 Feb

en les collant dans excel2003, Excel reconnaît 31 Jan et le considère comme
une date, par contre 1 Feb est considéré comme du texte.
Y a t'il une astuce pour que tout soit considéré comme une date ?

Cordialement
Michel
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #5289621
bonjour Michel,

il faut transformer les mois anglais en mois francais Feb <=> Fev

par exemple avec une liste anglais {"Jan";"Feb"; etc...} fait avec Insertion, nom.
et une formule DATE(ANNÉE;MOIS;JOUR)

ÚTE(2007;INDEX(MoisAnglais;EQUIV(GAUCHE(A1;3);0));DROITE(A1;NB.CAR(A1-4)))

isabelle

Bonjour, je copie des dates depuis le web d'origine américaine

31 Jan
1 Feb

en les collant dans excel2003, Excel reconnaît 31 Jan et le considère comme
une date, par contre 1 Feb est considéré comme du texte.
Y a t'il une astuce pour que tout soit considéré comme une date ?

Cordialement
Michel




isabelle
Le #5289611
oups,
j'ai confondu la droite et la gauche,

ÚTE(2007;INDEX(MoisAnglais;EQUIV(DROITE(A1;3);0));GAUCHE(A1;NB.CAR(A1-4)))

isabelle

bonjour Michel,

il faut transformer les mois anglais en mois francais Feb <=> Fev

par exemple avec une liste anglais {"Jan";"Feb"; etc...} fait avec
Insertion, nom.
et une formule DATE(ANNÉE;MOIS;JOUR)

ÚTE(2007;INDEX(MoisAnglais;EQUIV(GAUCHE(A1;3);0));DROITE(A1;NB.CAR(A1-4)))


isabelle

Bonjour, je copie des dates depuis le web d'origine américaine

31 Jan
1 Feb

en les collant dans excel2003, Excel reconnaît 31 Jan et le considère
comme une date, par contre 1 Feb est considéré comme du texte.
Y a t'il une astuce pour que tout soit considéré comme une date ?

Cordialement
Michel





Fredo P.
Le #5289531
Bonsoir Michel
Sur Xl97, il y a la possibilité d'ajouter une liste; outils >options>Liste
pers.
La méthode la + simple: inscrire la liste sur cellules> sélectionner la
plage>importer>Ajouter.
Pour Xl2007 la fonction "liste" a été remplacé par "Tableau" (c'est ce que
mentionne l'aide)j'ai fini par abandonné la recherche de la méthode pour
obtenir la même chose qu'Xl97.

"Michel Samoey" 47965347$0$892$
Bonjour, je copie des dates depuis le web d'origine américaine

31 Jan
1 Feb

en les collant dans excel2003, Excel reconnaît 31 Jan et le considère
comme une date, par contre 1 Feb est considéré comme du texte.
Y a t'il une astuce pour que tout soit considéré comme une date ?

Cordialement
Michel



Michel Samoey
Le #5289141
Bonjour et merci
finalement je suis arrivé à cette formule
=SI(ESTNUM(A22);A22;CNUM(GAUCHE(A22;CHERCHE("
";A22;1)-1)&"/"&EQUIV(DROITE(A22;NBCAR(A22)-CHERCHE("
";A22;1));MoisAnglais;0)))

car il fallait
- faire la différence entre une date (vue par Excel) et du texte
- trouver la zone "jour" et zone "mois anglais" du texte en question

Cordialement
Michel
Publicité
Poster une réponse
Anonyme