Date et mise en forme conditionnelle

Le
AA
Bonjour à toutes et tous

Excel 2007

Soit un tableau de x colonnes et y lignesJe voudrais via la mise en
forme conditionnelle colorier en rouge par exemple une ligne si et
seulement si une cellule de cette ligne contient une dateMerci
d'avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #21000731
Bonjour,

Tu copies cette fonction personnalisée dans un module standard
de ton classeur :
'-------------------------------------------
Function EstDate(rg As Range) As Boolean
Dim C As Range
For Each C In rg
If IsDate(C.Value) Then
EstDate = True
Exit Function
End If
Next
End Function
'-------------------------------------------

Et pour ta mise en forme conditionnelle, tu inscris la formule:
Tu sélectionnes la plage de cellules
=EstDate(A1:G1)
A1 étant la première cellule de la plage et G1 la dernière cellule
appartenant à la première ligne
Reste à choisir le format de ton choix


"AA"
Bonjour à toutes et tous

Excel 2007

Soit un tableau de x colonnes et y lignes...Je voudrais via la mise en
forme conditionnelle colorier en rouge par exemple une ligne si et
seulement si une cellule de cette ligne contient une date...Merci
d'avance
FdeCourt
Le #21000821
Salut,

Une date sous Excel n'est qu'un chiffre avec une mise en forme
spécifique.
Si tu veux tester qu'une date est une date, je vois trois solutions :
Tester si on peux extraire l'année à partir du contenu de la cellule :
=ESTERREUR(ANNEE(A3))

Tester si la valeur de la cellule est supérieur à une date (par
exemple 31/12/2009) :
¡>40178

Ou en VBA avec une fonction personnalisée :
Function estDate(x As Range) As Boolean
Application.Volatile
On Error GoTo err_handler
If x.Rows.Count > 1 Or x.Columns.Count > 1 Then GoTo err_handler
estDate = IsDate(x)
On Error GoTo 0
Exit Function
err_handler:
estDate = False
End Function

Cordialement,

F.
Mehdi HAMMADI
Le #21005571
Bonjour,

Permettez moi de vous proposer une autre altérnative.

Celle-ci se base non pas sur le contenu de la cellule mais plutôt sur
le format appliqué à celle-ci en utilisant la fonction "CELLULE"

Basez votre mise en forme conditionnelle sur la formule suivante:

=SI(GAUCHE(CELLULE("format";A1);1)="D";1;0)=1

(où A1 représente la première cellule de votre plage)

Cordialement
MehdiH

http://officeusers.blogspot.com/

---------------------------------------------------------------------

Le Mon, 18 Jan 2010 06:10:28 -0800 (PST), AA :

Bonjour à toutes et tous

Excel 2007

Soit un tableau de x colonnes et y lignes...Je voudrais via la mise en
forme conditionnelle colorier en rouge par exemple une ligne si et
seulement si une cellule de cette ligne contient une date...Merci
d'avance


Publicité
Poster une réponse
Anonyme