date de naissance

Le
Monnerie
Bonjour,
dans un lycée on me demande de trouver les élèves qui vont avoir 16 ans dans
le trimestre
j'ai trouvé des façons détournées (cacul avec datedif, année etc)
mais je me demande si quelqu'un aurait une formule pour le faire
"automatiquement"
merci d'avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #18428721
Bonjour.
Datedif, c'est bien :
=SI(ET(DATEDIF(date de naissance;date début
trimestre;"y")<16);DATEDIF(date de naissance;date fin
trimestre;"y"));"joyeux anniversaire";"")
Cordialement.
Daniel

Bonjour,
dans un lycée on me demande de trouver les élèves qui vont avoir 16 ans dans
le trimestre
j'ai trouvé des façons détournées (cacul avec datedif, année etc...)
mais je me demande si quelqu'un aurait une formule pour le faire
"automatiquement"
merci d'avance


Monnerie
Le #18428701
merci
"Daniel.C"
Bonjour.
Datedif, c'est bien :
=SI(ET(DATEDIF(date de naissance;date début
trimestre;"y")<16);DATEDIF(date de naissance;date fin
trimestre;"y"));"joyeux anniversaire";"")
Cordialement.
Daniel

Bonjour,
dans un lycée on me demande de trouver les élèves qui vont avoir 16 ans
dans le trimestre
j'ai trouvé des façons détournées (cacul avec datedif, année etc...)
mais je me demande si quelqu'un aurait une formule pour le faire
"automatiquement"
merci d'avance






Sam
Le #18428681
Bonjour,

en A2 l'année de naissance soit 1993 (2009-16)
en B2 le trimestre souhaité
en colonne D les dates de naissance
en colonne E en mettant la formule ci-dessous on obtient des 1 si la date de
naissance correspond au trimestre et à l'année
=(ANNEE(D1)=$B$1)*(ENT((MOIS(D1)+2)/3)=$B$2)
Cordialement
Michel dit "Sam"

"Monnerie" %
Bonjour,
dans un lycée on me demande de trouver les élèves qui vont avoir 16 ans
dans le trimestre
j'ai trouvé des façons détournées (cacul avec datedif, année etc...)
mais je me demande si quelqu'un aurait une formule pour le faire
"automatiquement"
merci d'avance



ChristianM
Le #18428831
Bonsoir,
Si la date de naissance est en A5, résultat fonction de la date
d'aujourd'hui et de l'appartenance au même trimestre civil
=SI(ET((ENT((MOIS(A5)+2)/3)=ENT((MOIS(AUJOURDHUI())+2)/3));ANNEE(A5)+16=ANNEE(AUJOURDHUI()));"ok";"")

A contrôler : j'ai fait des tests, mais ce serait bien de retester sur qq
dates.

--
ChristianM


"Monnerie" %
Bonjour,
dans un lycée on me demande de trouver les élèves qui vont avoir 16 ans
dans le trimestre
j'ai trouvé des façons détournées (cacul avec datedif, année etc...)
mais je me demande si quelqu'un aurait une formule pour le faire
"automatiquement"
merci d'avance



Monnerie
Le #18429181
merci
j'ai testé la fonction avec datedif elle marche je testerai la votre
"Sam" 4974b303$0$9419$

Bonjour,

en A2 l'année de naissance soit 1993 (2009-16)
en B2 le trimestre souhaité
en colonne D les dates de naissance
en colonne E en mettant la formule ci-dessous on obtient des 1 si la date
de naissance correspond au trimestre et à l'année
=(ANNEE(D1)=$B$1)*(ENT((MOIS(D1)+2)/3)=$B$2)
Cordialement
Michel dit "Sam"

"Monnerie" news: %
Bonjour,
dans un lycée on me demande de trouver les élèves qui vont avoir 16 ans
dans le trimestre
j'ai trouvé des façons détournées (cacul avec datedif, année etc...)
mais je me demande si quelqu'un aurait une formule pour le faire
"automatiquement"
merci d'avance







Monnerie
Le #18445201
merci
j'ai testé la fonction avec datedif elle marche je testerai la votre
"ChristianM" a écrit dans le message de news:
Oa$
Bonsoir,
Si la date de naissance est en A5, résultat fonction de la date
d'aujourd'hui et de l'appartenance au même trimestre civil
=SI(ET((ENT((MOIS(A5)+2)/3)=ENT((MOIS(AUJOURDHUI())+2)/3));ANNEE(A5)+16=ANNEE(AUJOURDHUI()));"ok";"")

A contrôler : j'ai fait des tests, mais ce serait bien de retester sur qq
dates.

--
ChristianM


"Monnerie" news: %
Bonjour,
dans un lycée on me demande de trouver les élèves qui vont avoir 16 ans
dans le trimestre
j'ai trouvé des façons détournées (cacul avec datedif, année etc...)
mais je me demande si quelqu'un aurait une formule pour le faire
"automatiquement"
merci d'avance







JLuc
Le #18430541
Monnerie a écrit :
Bonjour,
dans un lycée on me demande de trouver les élèves qui vont avoir 16 ans dans
le trimestre
j'ai trouvé des façons détournées (cacul avec datedif, année etc...)
mais je me demande si quelqu'un aurait une formule pour le faire
"automatiquement"
merci d'avance



Celle ci est plus simple :D
=ET(MOIS(A1)<5;ANNEE(A1)93)
JLuc
Le #18430531
JLuc a écrit :
Monnerie a écrit :
Bonjour,
dans un lycée on me demande de trouver les élèves qui vont avoir 16 ans
dans le trimestre
j'ai trouvé des façons détournées (cacul avec datedif, année etc...)
mais je me demande si quelqu'un aurait une formule pour le faire
"automatiquement"
merci d'avance



Celle ci est plus simple :D
=ET(MOIS(A1)<5;ANNEE(A1)93)



Pardon, parti trop vite
En colonne A les date de naissance, en B1 la formule à recopier vers le
bas. Donne vrai ou faut
garnote
Le #18430751
Ne serait-ce pas plutôt :
=ET(MOIS(A1)<4;ANNEE(A1)93)

Celle-ci est plus simple :
=ET(MOIS(A1)<5;ANNEE(A1)93)



Serge
JLuc
Le #18432921
garnote a écrit :
Ne serait-ce pas plutôt :
=ET(MOIS(A1)<4;ANNEE(A1)93)

Celle-ci est plus simple :
=ET(MOIS(A1)<5;ANNEE(A1)93)



Serge



Ben non, un trimestre c'est 4 mois ...
:oÞ
Publicité
Poster une réponse
Anonyme