[Debian] Erreur de signature de paquets

Le
Rémi Moyen
Bonjour,

Depuis quelques temps, j'ai régulièrement une erreur de signature de
paquets quand je fais un 'aptitude update' sur ma Debian testing.
L'erreur vient d'Opera et est la suivante :

W: A error occurred during the signature verification. The repository is
not updated and the previous index files will be used. GPG error:
http://deb.opera.com testing Release: The following signatures couldn't
be verified because the public key is not available: NO_PUBKEY
A2019EA84E7532C8

Bon, les première fois j'ai cherché, maintenant je connais la solution
(et la raison), je fais :

wget -O - http://deb.opera.com/archive.key | apt-key add -

Et le problème est réglé.

Ce qui me gène, c'est que j'ai régulièrement besoin de refaire cette
manip, comme si la clé d'Opera était perdue. Aujourd'hui par exemple,
j'ai fait cette manip, puis 'apt-key list' qui m'a dit :

[une demi-douzaine de clé Debian officielles, puis: ]
pub 1024D/4E7532C8 2011-01-11 [expire: 2012-01-11]
uid Opera Software Archive Automatic Signing Key 2011
<packager@opera.com>
sub 4096g/BAC0E9D1 2011-01-11 [expire: 2012-01-11]

J'ai alors refait mon 'aptitude update' et 'aptitude full-upgrade' et
après, 'apt-key list' me donne la même liste qu'avant moins la clé
d'Opera !

En un sens, ça confirme mes soupçons : si la clé est enlevée par
(quelque chose ?), c'est normal que j'ai souvenir de l'avoir installée
plusieurs fois

Mais je n'arrive pas à savoir pourquoi cette clé disparaît. J'ai
remarqué dans la mise à jour d'aujourd'hui qu'il y avait (entre autres)
apt et un message lié aux clés à ce moment :

Paramétrage de apt (0.8.10.3)
gpg: clé F42584E6: « Lenny Stable Release Key
<debian-release@lists.debian.org> » n'a pas changé
gpg: clé 55BE302B: « Debian Archive Automatic Signing Key (5.0/lenny)
<ftpmaster@debian.org> » n'a pas changé
gpg: clé 6D849617: « Debian-Volatile Archive Automatic Signing Key
(5.0/lenny) » n'a pas changé
gpg: clé B98321F9: « Squeeze Stable Release Key
<debian-release@lists.debian.org> » n'a pas changé
gpg: clé 473041FA: « Debian Archive Automatic Signing Key (6.0/squeeze)
<ftpmaster@debian.org> » n'a pas changé
gpg: Quantité totale traitée: 5
gpg: inchangée: 5

Je ne sais pas si c'est lié, peut-être que la liste est purgée lors de
cette mise à jour (et re-remplie avec les clés Debian uniquement) ?

Est-ce que quelqu'un sait comment faire pour que la clé que j'ai ajoutée
avec 'apt-key add' reste installée d'une fois sur l'autre ? Je n'ai rien
vu dans la page de man d'apt-key.

Merci !
--
Rémi Moyen
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sergio
Le #23093361
Le 06/02/2011 18:09, Rémi Moyen a écrit :
Bonjour,

Depuis quelques temps, j'ai régulièrement une erreur de signature de
paquets quand je fais un 'aptitude update' sur ma Debian testing.
L'erreur vient d'Opera et est la suivante :



J'ai le même problème avec Ubuntu si ça peut te rassurer...

AMHA, Opera n'a pas encore compris comment gérer les paquets et dépôts pour Debian et consort.

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Rémi Moyen
Le #23093541
Le 06/02/2011 18:40, Sergio a écrit :
Le 06/02/2011 18:09, Rémi Moyen a écrit :
Bonjour,

Depuis quelques temps, j'ai régulièrement une erreur de signature de
paquets quand je fais un 'aptitude update' sur ma Debian testing.
L'erreur vient d'Opera et est la suivante :



J'ai le même problème avec Ubuntu si ça peut te rassurer...

AMHA, Opera n'a pas encore compris comment gérer les paquets et dépôts
pour Debian et consort.



Clairement, j'ai un problème sur l'intégration Opera-Debian. Est-ce que
c'est lié à Opera qui ne fournit pas sa clé comme il le faudrait, à
Debian qui gère mal les clés qui ne viennent pas d'eux, ou à moi qui
installe mal la clé sur mon système, je n'en sais rien.

Mais c'est un peu agaçant de devoir ré-installer cette clé à chaque fois
que je fais un update (en fin de compte, j'ignore le message d'erreur
jusqu'au jour où Opera sort une nouvelle version, et là je corrige
l'erreur et installe la nouvelle version, sachant que quelques jours
après l'erreur reviendra...).
--
Rémi Moyen
Sergio
Le #23093751
Le 06/02/2011 19:53, Rémi Moyen a écrit :

Clairement, j'ai un problème sur l'intégration Opera-Debian. Est-ce que
c'est lié à Opera qui ne fournit pas sa clé comme il le faudrait, à
Debian qui gère mal les clés qui ne viennent pas d'eux, ou à moi qui
installe mal la clé sur mon système, je n'en sais rien.



Clairement, c'est la faute à Opera...
J'ai plusieurs dépôts "non officiels" sur mon Ubuntu dont les mises à jour fonctionnent très bien.

Mais c'est un peu agaçant de devoir ré-installer cette clé à chaque fois
que je fais un update (en fin de compte, j'ignore le message d'erreur
jusqu'au jour où Opera sort une nouvelle version, et là je corrige
l'erreur et installe la nouvelle version, sachant que quelques jours
après l'erreur reviendra...).



Perso, je suggère de désactiver les dépôts Opera. Opera ne me sert que comme référence, pour tester mes sites. Donc les failles de
sécurité d'Opera sont le dernier de mes soucis (je ne mets pas de piège dans mes propres sites !). Une MAJ à chaque version majeure
d'Opera suffit...

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Rémi Moyen
Le #23094021
Le 06/02/2011 19:23, Sergio a écrit :
Le 06/02/2011 19:53, Rémi Moyen a écrit :

Clairement, j'ai un problème sur l'intégration Opera-Debian. Est-ce que
c'est lié à Opera qui ne fournit pas sa clé comme il le faudrait, à
Debian qui gère mal les clés qui ne viennent pas d'eux, ou à moi qui
installe mal la clé sur mon système, je n'en sais rien.



Clairement, c'est la faute à Opera...



...ou la mienne ! :-)

Perso, je suggère de désactiver les dépôts Opera.



Mouais. Ignorer l'erreur revient au même (et m'évite d'aller éditer
sources.list).

Bon, si y'a pas mieux, tant pis. Merci quand même !
--
Rémi Moyen
rm
Le #23102931
Le dimanche 6 février 2011 à 18:09, Rémi Moyen a écrit :

Bonjour,



Salut,

Depuis quelques temps, j'ai régulièrement une erreur de signature de
paquets quand je fais un 'aptitude update' sur ma Debian testing.
L'erreur vient d'Opera et est la suivante :

W: A error occurred during the signature verification. The repository is
not updated and the previous index files will be used. GPG error:
http://deb.opera.com testing Release: The following signatures couldn't
be verified because the public key is not available: NO_PUBKEY
A2019EA84E7532C8



Voir http://my.opera.com/desktopteam/blog/show.dml/24995122#comment52871612

Question : When i refresh synaptic 0.63.1 and mintUpdate 4.2.0 i get this
warning:
W: GPG error: http://deb.opera.com stable Release: The following signatures
couldn't be verified because the public key is not available: NO_PUBKEY
F9A2F76A9D1A0061


Réponse : The deb server has not had its key updated yet because it has not
expired. Don't worry about this. We'll update it shortly.


@+
--
rm - http://opera-fr.com
Rémi Moyen
Le #23103681
Le 08/02/2011 18:38, rm a écrit :

Réponse : The deb server has not had its key updated yet because it has not
expired. Don't worry about this. We'll update it shortly.



Ah OK, j'avais pas trouvé cette page. Merci pour l'info, ça me confirme
que je fais bien ce qu'il faut et que le problème vient d'Opera, pas de
mes manips !
--
Rémi Moyen
Publicité
Poster une réponse
Anonyme