Debian etch : python2.3 ou 2.4 ?

Le
Steve
Bonjour,

En voulant installer freevo, je lis sur la console :

INFO: using old version '/usr/bin/python2.3'

(ce que je vois d'ailleurs pour pleins d'autres programmes)

Or après un peu de recherche, je vois qu'il existe un python2.4 et m=
ême 2.5.
Quelle version utiliser et pourquoi ?

Maintenant mettons que je voudrais que sur mon etch, je veuille que la vers=
ion
2.4 (et pas la 2.3) soit utilisée par défaut, comment faire ?

Merci de réduire mon ignorance.

--
steve
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Vincent Bernat
Le #9775121
OoO En cette fin de matinée radieuse du samedi 21 juillet 2007, vers
11:26, Steve
En voulant installer freevo, je lis sur la console :



INFO: using old version '/usr/bin/python2.3'



(ce que je vois d'ailleurs pour pleins d'autres programmes)



Or après un peu de recherche, je vois qu'il existe un python2.4 et même 2.5.
Quelle version utiliser et pourquoi ?



La version de Python officielle pour Etch est la 2.4. Tu peux utiliser
la 2.5, mais elle sera moins testée (pour la raison précédente). Il ne
faut donc l'utiliser que si tu as besoins des fonctionnalités de la
version 2.5.

Maintenant mettons que je voudrais que sur mon etch, je veuille que la version
2.4 (et pas la 2.3) soit utilisée par défaut, comment faire ?



Je ne sais pas s'il existe un programme pour le faire proprement, mais
tu peux simplement changer le lien symbolique /usr/bin/python pour
pointer sur python2.4. Tu peux faire de même pour pygettext et pdb.
--
BOFH excuse #258:
That's easy to fix, but I can't be bothered.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Steve
Le #9775111
Le samedi 21 juillet 2007 11:56, Vincent Bernat a écrit :
OoO En cette fin de matinée radieuse du samedi 21 juillet 2007, vers

11:26, Steve > En voulant installer freevo, je lis sur la console :
>
> INFO: using old version '/usr/bin/python2.3'
>
> (ce que je vois d'ailleurs pour pleins d'autres programmes)
>
> Or après un peu de recherche, je vois qu'il existe un python2.4 et m ême
> 2.5. Quelle version utiliser et pourquoi ?

La version de Python officielle pour Etch est la 2.4. Tu peux utiliser
la 2.5, mais elle sera moins testée (pour la raison précédente). Il ne
faut donc l'utiliser que si tu as besoins des fonctionnalités de la
version 2.5.



ok merci.


> Maintenant mettons que je voudrais que sur mon etch, je veuille que la
> version 2.4 (et pas la 2.3) soit utilisée par défaut, comment faire ?

Je ne sais pas s'il existe un programme pour le faire proprement, mais
tu peux simplement changer le lien symbolique /usr/bin/python pour
pointer sur python2.4. Tu peux faire de même pour pygettext et pdb.



ls -l /usr/bin/python
lrwxrwxrwx 1 root root 9 2006-12-25 20:36 /usr/bin/python -> python2.4

et pourtant
INFO: using old version '/usr/bin/python2.3'

Comment faire pour avoir la 2.4 par défaut ?

--
steve
Steve
Le #9775091
Le samedi 21 juillet 2007 13:19, Vincent Bernat a écrit :
OoO Pendant le temps de midi du samedi 21 juillet 2007, vers 12:57,

Steve > et pourtant
> INFO: using old version '/usr/bin/python2.3'

Ce package n'utiliserait-il pas python-central ou python-support ? Dans
ce cas, le paquet est compilé pour toutes les versions de Python que tu
as sur ta machine.




aptitude install freevo
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
Construction de la base de données des étiquettes... Fait
Les NOUVEAUX paquets suivants vont être automatiquement installés :
freevo-common libglade0 libxml1 python-alsaaudio python-beautifulsoup
python-crypto python-elementtree python-freevo python-glade-1.2
python-gtk-1.2 python-kaa-base
python-kaa-imlib2 python-kaa-metadata python-pam python-pyopenssl
python-serial python-twisted python-twisted-bin python-twisted-conch
python-twisted-core
python-twisted-lore python-twisted-mail python-twisted-names
python-twisted-news python-twisted-runner python-twisted-web
python-twisted-words python-zopeinterface
Les NOUVEAUX paquets suivants vont être installés :
freevo freevo-common libglade0 libxml1 python-alsaaudio python-beautifuls oup
python-crypto python-elementtree python-freevo python-glade-1.2
python-gtk-1.2
python-kaa-base python-kaa-imlib2 python-kaa-metadata python-pam
python-pyopenssl python-serial python-twisted python-twisted-bin
python-twisted-conch
python-twisted-core python-twisted-lore python-twisted-mail
python-twisted-names python-twisted-news python-twisted-runner
python-twisted-web python-twisted-words
python-zopeinterface


on dirait que non.

> Comment faire pour avoir la 2.4 par défaut ?

C'est déjà le cas.



le lien y est mais freevo ne l'utilise pas (ainsi que pleins d'autres
programmes) donc on ne peut pas dire que la 2.4 est la version par défaut . Ou
me ai-je raté quelque chose ?

--
panic("bad_user_access_length executed (not cool, dude)");
2.0.38 /usr/src/linux/kernel/panic.c



--
steve
Vincent Bernat
Le #9775071
OoO Pendant le temps de midi du samedi 21 juillet 2007, vers 12:57,
Steve
et pourtant
INFO: using old version '/usr/bin/python2.3'



Ce package n'utiliserait-il pas python-central ou python-support ? Dans
ce cas, le paquet est compilé pour toutes les versions de Python que tu
as sur ta machine.

Comment faire pour avoir la 2.4 par défaut ?



C'est déjà le cas.
--
panic("bad_user_access_length executed (not cool, dude)");
2.0.38 /usr/src/linux/kernel/panic.c


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Vincent Bernat
Le #9775061
OoO Peu avant le début de l'après-midi du samedi 21 juillet 2007, vers
13:25, Steve
Ce package n'utiliserait-il pas python-central ou python-support ? Dans
ce cas, le paquet est compilé pour toutes les versions de Python que tu
as sur ta machine.






aptitude install freevo
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
Construction de la base de données des étiquettes... Fait
Les NOUVEAUX paquets suivants vont être automatiquement installés :
freevo-common libglade0 libxml1 python-alsaaudio python-beautifulsoup
python-crypto python-elementtree python-freevo python-glade-1.2
python-gtk-1.2 python-kaa-base
python-kaa-imlib2 python-kaa-metadata python-pam python-pyopenssl
python-serial python-twisted python-twisted-bin python-twisted-conch
python-twisted-core
python-twisted-lore python-twisted-mail python-twisted-names
python-twisted-news python-twisted-runner python-twisted-web
python-twisted-words python-zopeinterface
Les NOUVEAUX paquets suivants vont être installés :
freevo freevo-common libglade0 libxml1 python-alsaaudio python-beautifulsoup
python-crypto python-elementtree python-freevo python-glade-1.2
python-gtk-1.2
python-kaa-base python-kaa-imlib2 python-kaa-metadata python-pam
python-pyopenssl python-serial python-twisted python-twisted-bin
python-twisted-conch
python-twisted-core python-twisted-lore python-twisted-mail
python-twisted-names python-twisted-news python-twisted-runner
python-twisted-web python-twisted-words
python-zopeinterface




on dirait que non.



S'il est déjà installé, il n'apparaît pas dans la liste. Utilise plutôt
aptitude show freevo.

> Comment faire pour avoir la 2.4 par défaut ?

C'est déjà le cas.





le lien y est mais freevo ne l'utilise pas (ainsi que pleins d'autres
programmes) donc on ne peut pas dire que la 2.4 est la version par défaut. Ou
me ai-je raté quelque chose ?



Plein de programmes utilisent python-support et python-central de façon
à générer les .pyc pour toutes les versions de Python présentes sur le
système.

--
# Basic IBM dingbats, some of which will never have a purpose clear
# to mankind
2.4.0 linux/drivers/char/cp437.uni


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
François Boisson
Le #9775051
Le Sat, 21 Jul 2007 11:56:52 +0200
Vincent Bernat
La version de Python officielle pour Etch est la 2.4. Tu peux utiliser
la 2.5, mais elle sera moins testée (pour la raison précédente). Il ne
faut donc l'utiliser que si tu as besoins des fonctionnalités de la
version 2.5.



Il peut y avoir des raisons de compatibilité. Par exemple, j'ai un programme
(simple) qui tourne parfaitement avec python2.1, n'a jamais pu fonctionner
avec le 2.3 et semble parfaitement tourner avec le 2.4...

François Boisson


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Steve
Le #9775011
Le samedi 21 juillet 2007 13:30, Vincent Bernat a écrit :
OoO Peu avant le début de l'après-midi du samedi 21 juillet 2007, v ers

13:25, Steve >> Ce package n'utiliserait-il pas python-central ou python-support ? Da ns
>> ce cas, le paquet est compilé pour toutes les versions de Python qu e tu
>> as sur ta machine.
>




S'il est déjà installé, il n'apparaît pas dans la liste. Utilise plutôt
aptitude show freevo.




aptitude show freevo
Paquet : freevo
Nouveau: oui
État: installé
Automatiquement installé: non
Version : 1.7.2-2
Priorité : optionnel
Section : graphics
Responsable : Georg W. Leonhardt Taille décompressée : 3260k
Dépend: python, python-central (>= 0.5.8), debconf (>= 0.5) | debconf -2.0,
python-freevo (>= 1.7.2-2), freevo-common (>= 1.7.2-2), mplayer-nogui |
mplayer | mplayer-386 |
player-586 | mplayer-686 | mplayer-k7, lsdvd, xmltv-util,
libxmltv-perl

il est là

>> > Comment faire pour avoir la 2.4 par défaut ?
>>
>> C'est déjà le cas.
>
> le lien y est mais freevo ne l'utilise pas (ainsi que pleins d'autres
> programmes) donc on ne peut pas dire que la 2.4 est la version par
> défaut. Ou me ai-je raté quelque chose ?

Plein de programmes utilisent python-support et python-central de façon
à générer les .pyc pour toutes les versions de Python présentes sur le
système.



ok, mais si je veux utiliser la 2.4 avec freevo et pas la 2.3 je fais
comment ?

(et si c'est déjà le cas comme tu le disais avant, pourquoi le message ...
using old 2.3 ?)

--
steve
Vincent Bernat
Le #9775001
OoO En ce début d'après-midi nuageux du samedi 21 juillet 2007, vers
14:34, Steve
S'il est déjà installé, il n'apparaît pas dans la liste. Utilise plutôt
aptitude show freevo.






aptitude show freevo
Paquet : freevo
Nouveau: oui
État: installé
Automatiquement installé: non
Version : 1.7.2-2
Priorité : optionnel
Section : graphics
Responsable : Georg W. Leonhardt Taille décompressée : 3260k
Dépend: python, python-central (>= 0.5.8), debconf (>= 0.5) | debconf-2.0,
python-freevo (>= 1.7.2-2), freevo-common (>= 1.7.2-2), mplayer-nogui |
mplayer | mplayer-386 |
player-586 | mplayer-686 | mplayer-k7, lsdvd, xmltv-util,
libxmltv-perl



A mon avis, python-freevo dépend de python-central ou python-support. :)

Plein de programmes utilisent python-support et python-central de façon
à générer les .pyc pour toutes les versions de Python présentes sur le
système.





ok, mais si je veux utiliser la 2.4 avec freevo et pas la 2.3 je fais
comment ?



À l'installation, python-freevo compile les .pyc pour Python 2.3 et pour
Python 2.4. Comme ça, tu peux l'utiliser avec les deux versions de
Python. Je suppose que par défaut, freevo utilise Python 2.4. Que donne
ps auxww | grep python une fois qu'il est lancé ?
--
HIGH EXPLOSIVES AND SCHOOL DON'T MIX
HIGH EXPLOSIVES AND SCHOOL DON'T MIX
HIGH EXPLOSIVES AND SCHOOL DON'T MIX
-+- Bart Simpson on chalkboard in episode 8F03


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Steve
Le #9774991
Le samedi 21 juillet 2007 15:06, Vincent Bernat a écrit :
OoO En ce début d'après-midi nuageux du samedi 21 juillet 2007, v ers

14:34, Steve >> S'il est déjà installé, il n'apparaît pas dans la liste. Util ise plutôt
>> aptitude show freevo.
>
> aptitude show freevo
> Paquet : freevo
> Nouveau: oui
> État: installé
> Automatiquement installé: non
> Version : 1.7.2-2
> Priorité : optionnel
> Section : graphics
> Responsable : Georg W. Leonhardt > Taille décompressée : 3260k
> Dépend: python, python-central (>= 0.5.8), debconf (>= 0.5) |
> debconf-2.0, python-freevo (>= 1.7.2-2), freevo-common (>= 1.7.2-2),
> mplayer-nogui | mplayer | mplayer-386 |
> player-586 | mplayer-686 | mplayer-k7, lsdvd, xmltv-util,
> libxmltv-perl

A mon avis, python-freevo dépend de python-central ou python-support. :)



oui c'est marqué au-dessus


>> Plein de programmes utilisent python-support et python-central de fa çon
>> à générer les .pyc pour toutes les versions de Python présen tes sur le
>> système.
>
> ok, mais si je veux utiliser la 2.4 avec freevo et pas la 2.3 je fais
> comment ?

À l'installation, python-freevo compile les .pyc pour Python 2.3 et pour
Python 2.4. Comme ça, tu peux l'utiliser avec les deux versions de
Python. Je suppose que par défaut, freevo utilise Python 2.4. Que donne
ps auxww | grep python une fois qu'il est lancé ?



user 18287 3.4 3.4 69104 36068 pts/3 Sl 15:05 0:04
python /usr/lib/python2.4/site-packages/freevo/main.py

bingo ! bon alors je ne comprends pas pourquoi à l'installation il me dit
qu'il utilise le 2.3 ..

bref.. je suis content.

Merci à toi Vincent et très bon après-midi

--
steve
Vincent Bernat
Le #9774971
OoO En ce début d'après-midi ensoleillé du samedi 21 juillet 2007, vers
15:12, Steve
user 18287 3.4 3.4 69104 36068 pts/3 Sl 15:05 0:04
python /usr/lib/python2.4/site-packages/freevo/main.py



bingo ! bon alors je ne comprends pas pourquoi à l'installation il me dit
qu'il utilise le 2.3 ..



Uniquement pour compiler les pyc. Mais il utilise aussi Python 2.4.

ls -l /usr/lib/python2.3/site-packages/freevo/main.pyc
ls -l /usr/lib/python2.4/site-packages/freevo/main.pyc
--
BOFH excuse #184:
loop found in loop in redundant loopback


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme