debian lenny et gtkam

Le
Professeur M
Salut à tous,

sur une machine debian Lenny seul root arrive à faire fonctionner gtkam
(détection et configuration de l'APN)

Sur le web (et autat que je me souvienne, c'est ce que j'avais fait pour
sarge et etch) il fallait ajouter l'utilisateur au groupe camera.

Or cette fois-ci :

# addgroup mephisto camera
addgroup: Le groupe « camera » n'existe pas.

pas glop.

Quelqu'un a une idée ?

Méphisto
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas George
Le #19718931
Professeur Méphisto
wrote in message
sur une machine debian Lenny seul root arrive à faire fonctionner gtkam
(détection et configuration de l'APN)

Sur le web (et autat que je me souvienne, c'est ce que j'avais fait pour
sarge et etch) il fallait ajouter l'utilisateur au groupe camera.



Regarde les droits sur les devices qui correspondent à ton appareil photo.
Professeur M
Le #19881381
Le Tue, 07 Jul 2009 21:18:45 +0000, Nicolas George a écrit :

Sur le web (et autat que je me souvienne, c'est ce que j'avais fait
pour sarge et etch) il fallait ajouter l'utilisateur au groupe camera.



Regarde les droits sur les devices qui correspondent à ton appareil
photo.



bon, de retour de vac' et après avoir remis la main sur ce foutu satané
APN je m'y recolle...

Je rebranche l'APN :

$ dmesg

[ 320.756031] usb 4-5: new high speed USB device using ehci_hcd and
address 4
[ 320.906573] usb 4-5: configuration #1 chosen from 1 choice
[ 320.911468] usb 4-5: New USB device found, idVendora9,
idProduct0ff
[ 320.911476] usb 4-5: New USB device strings: Mfr=1, Product=2,
SerialNumber=0
[ 320.911480] usb 4-5: Product: Canon Digital Camera
[ 320.911482] usb 4-5: Manufacturer: Canon Inc.


$ lsusb
Bus 004 Device 004: ID 04a9:30ff Canon, Inc. Digital IXUS 55 (PTP mode)/
PowerShot SD450 (PTP mode)

heuuu, il est où le device de mon appareil ? Tous les /dev/usbdev*
appartiennent à root/root

Méph'
Nicolas George
Le #19881541
Professeur Méphisto
wrote in message
Bus 004 Device 004: ID 04a9:30ff Canon, Inc. Digital IXUS 55 (PTP mode)/
PowerShot SD450 (PTP mode)



PTP mode, donc probablement accessible via un /dev/usbdev*.

heuuu, il est où le device de mon appareil ? Tous les /dev/usbdev*
appartiennent à root/root



C'est probablement précisément le problème.

Regarde :

- ce que dit :
/sbin/udevadm info --attribute-walk --path /sys/class/usb_endpoint/usbdev4.4_ep0
(ou peut-être autre chose, pour les nombres à la fin ; il faut que tu
voies le nom de ton appareil quelque part)

- le contenu de /etc/udev/rules.d/*gphoto*.rules

En particulier, j'ai remarqué hier pour un scanner, et ça a l'air la même
chose pour gphoto, j'ai ceci dans les règles de la distribution (Squeeze à
jour) :

SUBSYSTEM!="usb|usb_device", GOTO="libgphoto2_rules_end"

alors que le noyau dit « usb_endpoint ».
Publicité
Poster une réponse
Anonyme