[Debian Lenny] probleme de forwarding...

Le
Vinc teteve
--_e9ed77af-8801-4ea6-a745-7e084397e58a_
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

Bonjour à tous, =
=
Je m'en remets à vos esprits éclairés, le mien étant dans le désa=
rroi le plus profond =
Utilisateur de Linux "occasionnel" (non-expert), j'ai voulu me lancer dans =
la manip' suivante : =
=
Relier ma freebox (mode routeur désactivé) à une machine sous =
Debian/Lenny sur l'interface eth0 (82.240.*.*), et la deuxième carte =
réseau de cette machine eth1 à un switch D-Link pour y connecter mes =
autres PC dans un LAN privé (en 192.168.0.*/24). =
Mais je n'arrive pas à activer le forwarding sur cette passerelle sous De=
bian. =
De mon poste de travail j'arrive bien à pinger ma passerelle, de ma =
passerelle j'arrive à pinger mon poste de travail et des adresses sur =
le net. Mais pas moyen d'activer le NAT. =
J'ai bien mis dans le fichier /etc/sysctl.conf à la ligne net.ipv4.conf.d=
efaults.forwarding=1 =
J'ai mis un petit script dans le répertoire /etc/networking/if-pre-up.d/s=
tart : =
=
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE =
iptables -A FORWARD -p tcp --tcp-flags SYN,RST SYN -j TCPMSS-o eth0 --clamp=
-mss-to-pmtu =
=
puis un petit /etc/init.d/network restart =
Mais ça ne veut pô marcher Où est l'erreur ?? =
=
En vous remerciant d'avance =
TeteveConfiguration: Debian lennycontrolleur réseau intégré à la CM=
: eth0carte réseau 3COM : eth1
_________________________________________________________________
Besoin d'un e-mail ? Créez gratuitement un compte Windows Live Hotmail, p=
lus sûr, plus simple et plus complet !
http://www.windowslive.fr/hotmail/default.asp=

--_e9ed77af-8801-4ea6-a745-7e084397e58a_
Content-Type: text/html; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<html>
<head>
<style>
P
{
margin:0px;
padding:0px
}
body
{
FONT-SIZE: 10pt;
FONT-FAMILY:Tahoma
}
</style>
</head>
<body><div style="text-align: left;"><span class="Texte">Bonjour à to=
us, =
<br> =
<br>Je m'en remets à vos esprits éclairés, le mien étant dans le d=
ésarroi le plus profond =
<br>Utilisateur de Linux "occasionnel" (non-expert), j'ai voulu me lancer d=
ans la manip' suivante : =
<br> =
<br>Relier ma freebox (mode routeur désactivé) à une machine sous =
Debian/Lenny sur l'interface eth0 (82.240.*.*), et la deuxième carte =
réseau de cette machine eth1 à un switch D-Link pour y connecter mes =
autres PC dans un LAN privé (en 192.168.0.*/24). =
<br>Mais je n'arrive pas à activer le forwarding sur cette passerelle sou=
s Debian. =
<br>De mon poste de travail j'arrive bien à pinger ma passerelle, de ma=
=
passerelle j'arrive à pinger mon poste de travail et des adresses sur =
le net. Mais pas moyen d'activer le NAT. =
<br>J'ai bien mis dans le fichier /etc/sysctl.conf à la ligne net.ipv4.co=
nf.defaults.forwarding=1 =
<br>J'ai mis un petit script dans le répertoire /etc/networking/if-pre-up=
.d/start : =
<br> =
<br>iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE =
<br>iptables -A FORWARD -p tcp --tcp-flags SYN,RST SYN -j TCPMSS-o eth0 --c=
lamp-mss-to-pmtu =
<br> =
<br>puis un petit /etc/init.d/network restart =
<br>Mais ça ne veut pô marcher Où est l'erreur ?? =
<br> =
<br>En vous remerciant d'avance =
<br>Teteve<pre class="code"><b>Configuration: </b>Debian lenny<br>control=
leur réseau intégré à la CM : eth0<br>carte réseau 3COM : eth1</p=
re></span></div><br /><hr />Besoin d'un e-mail ? Créez gratuitement un co=
mpte Windows Live Hotmail et bénéficiez d'un filtre antivirus gratuit !=
<a href='http://www.windowslive.fr/hotmail/default.asp' target='_new'>=
Windows Live Hotmail</a></body>
</html>=

--_e9ed77af-8801-4ea6-a745-7e084397e58a_--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Serge Cavailles
Le #9587701
Le dimanche 12 août 2007 21:00, Vinc teteve a écrit :
Bonjour à tous,



Bonsoir,

Je m'en remets à vos esprits éclairés, le mien étant dans le dé sarroi le
plus profond... Utilisateur de Linux "occasionnel" (non-expert), j'ai
voulu me lancer dans la manip' suivante :

Relier ma freebox (mode routeur désactivé) à une machine sous
Debian/Lenny sur l'interface eth0 (82.240.*.*), et la deuxième carte
réseau de cette machine eth1 à un switch D-Link pour y connecter mes
autres PC dans un LAN privé (en 192.168.0.*/24).
Mais je n'arrive pas à activer le forwarding sur cette passerelle sous
Debian. De mon poste de travail j'arrive bien à pinger ma passerelle, de
ma passerelle j'arrive à pinger mon poste de travail et des adresses sur
le net. Mais pas moyen d'activer le NAT.
J'ai bien mis dans le fichier /etc/sysctl.conf à la ligne
net.ipv4.conf.defaults.forwarding=1 J'ai mis un petit script dans le
répertoire /etc/networking/if-pre-up.d/start :

iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE



iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

C'est sur la liaison ppp qu'il faut travailler. L'interface eth n'a même pas
besoin d'avoir une IP, il suffit qu'il soit up.

iptables -A FORWARD -p tcp --tcp-flags SYN,RST SYN -j TCPMSS-o eth0
--clamp-mss-to-pmtu



iptables -t mangle -A FORWARD -p tcp -m tcp --tcp-flags SYN,RST SYN
-j TCPMSS --clamp-mss-to-pmtu

voir fil "Problèmes persistants de MTU" du 05/08/07 pour plus de détails


puis un petit /etc/init.d/network restart...
Mais ça ne veut pô marcher... Où est l'erreur ??

En vous remerciant d'avance...



Si ça peut aider :)
--
Serge
fra-duf-no-spam
Le #9587671
Le 13737ième jour après Epoch,
Vinc teteve écrivait:

Bonjour à tous,

Je m'en remets à vos esprits éclairés, le mien étant dans le désarroi le plus profond...
Utilisateur de Linux "occasionnel" (non-expert), j'ai voulu me lancer dan s la manip' suivante :

Relier ma freebox (mode routeur désactivé) à une machine s ous
Debian/Lenny sur l'interface eth0 (82.240.*.*), et la deuxième carte



Tu peux dire 82.240.31.243, c'est marqué dans ton mail de toute faà §on ;)

Mais je n'arrive pas à activer le forwarding sur cette passerelle
sous Debian.
De mon poste de travail j'arrive bien à pinger ma passerelle, de ma
passerelle j'arrive à pinger mon poste de travail et des adresses sur
le net. Mais pas moyen d'activer le NAT.
J'ai bien mis dans le fichier /etc/sysctl.conf à la ligne net.ipv4.c onf.defaults.forwarding=1
J'ai mis un petit script dans le répertoire
/etc/networking/if-pre-up.d/start :



Tu as vérifié avec un "cat /proc/sys/net/ipv4/ip_forwarding" ?
Serge Cavailles
Le #9587661
Le dimanche 12 août 2007 23:47, François TOURDE a écrit  :
Le 13737ième jour après Epoch,

Serge Cavailles écrivait:
> Le dimanche 12 août 2007 21:00, Vinc teteve a écrit :

[...]

>> Relier ma freebox (mode routeur désactivé) à une machin e sous

[...]

> C'est sur la liaison ppp qu'il faut travailler. L'interface eth n'a
> même pas besoin d'avoir une IP, il suffit qu'il soit up.

Euh... Pas sur une freebox.



Je parle de l'interface de la passerelle (ici eth0)

> voir fil "Problèmes persistants de MTU" du 05/08/07 pour plus de
> détails

Ah ben rien à voir, là, mais bon.


La syntaxe pour la règle et des infos autour de la mise en oeuvre, mai s
bon...

il pleut chez vous? :D
--
Serge
fra-duf-no-spam
Le #9587641
Le 13737ième jour après Epoch,
Serge Cavailles écrivait:

Le dimanche 12 août 2007 21:00, Vinc teteve a écrit :


[...]
Relier ma freebox (mode routeur désactivé) à une machine sous




[...]
C'est sur la liaison ppp qu'il faut travailler. L'interface eth n'a mà ªme pas
besoin d'avoir une IP, il suffit qu'il soit up.



Euh... Pas sur une freebox.

voir fil "Problèmes persistants de MTU" du 05/08/07 pour plus de
détails



Ah ben rien à voir, là, mais bon.
fra-duf-no-spam
Le #9587621
Le 13737ième jour après Epoch,
Serge Cavailles écrivait:

Le dimanche 12 août 2007 23:47, François TOURDE a écrit  :
Le 13737ième jour après Epoch,

Serge Cavailles écrivait:
> Le dimanche 12 août 2007 21:00, Vinc teteve a écrit :

[...]

>> Relier ma freebox (mode routeur désactivé) à une machi ne sous

[...]

> C'est sur la liaison ppp qu'il faut travailler. L'interface eth n'a
> même pas besoin d'avoir une IP, il suffit qu'il soit up.

Euh... Pas sur une freebox.



Je parle de l'interface de la passerelle (ici eth0)



Oui, moi aussi... La freebox ne se connecte pas au pc en mode
ppp. C'est elle qui éventuellement fait une liaison ppp, mais quel que
soit son mode, elle est reliée en pur ethernet au PC.

> voir fil "Problèmes persistants de MTU" du 05/08/07 pour plus de
> détails

Ah ben rien à voir, là, mais bon.


La syntaxe pour la règle et des infos autour de la mise en oeuvre, m ais
bon...



Oui, si tu veux, mais lui n'a pas de problème de MTU, pour le moment
:)

il pleut chez vous? :D



Il eut plu, mais ça s'est calmé... J'ai failli pas pouvoir aller boire
l'apéro chez mes beaux parents... Mais l'averse s'est calmée, et le
'chateau Moulin De la Rivière' (un médoc sympa) permet à l'h umidité de
disparaître. (nb: Sur le bouchon du médoc en question, est marqu é
MDR. J'avais pas le choix ^^)
Franck Joncourt
Le #9587611
--z4+8/lEcDcG5Ke9S
Content-Type: text/plain; charset=utf-8
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Sun, Aug 12, 2007 at 11:40:04PM +0200, François TOURDE wrote:

Tu peux dire 82.240.31.243, c'est marqué dans ton mail de toute fa çon ;)



Voila pourquoi j'aime bien mon ip dynamique :p!


> Mais je n'arrive pas à activer le forwarding sur cette passerelle
> sous Debian.
> De mon poste de travail j'arrive bien à pinger ma passerelle, de ma
> passerelle j'arrive à pinger mon poste de travail et des adresses sur
> le net. Mais pas moyen d'activer le NAT.
> J'ai bien mis dans le fichier /etc/sysctl.conf à la ligne net.ipv4 .conf.defaults.forwarding=1
> J'ai mis un petit script dans le répertoire
> /etc/networking/if-pre-up.d/start :

Tu as vérifié avec un "cat /proc/sys/net/ipv4/ip_forwarding" ?




Pour activer le forwding en ipv4 avec sysctl :

sysctl net.ipv4.ip_forward=1

Autrement tu fais "sysctl -a | grep forward" pour voir ce qu'il en est

--
Franck Joncourt
http://www.debian.org - http://smhteam.info/wiki/
GPG server : pgpkeys.mit.edu
Fingerprint : C10E D1D0 EF70 0A2A CACF 9A3C C490 534E 75C0 89FE

--z4+8/lEcDcG5Ke9S
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFGv4VMxJBTTnXAif4RAvYGAKCQAuA3b9toBzf0zI3StE+VtQgQYQCgggUF
Q/PICj1AtHNmNmHXqQzGB9c =wQWZ
-----END PGP SIGNATURE-----

--z4+8/lEcDcG5Ke9S--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Pascal Hambourg
Le #9587601
Salut,

Vinc teteve a écrit :

Relier ma freebox (mode routeur désactivé) à une machine sous
Debian/Lenny sur l'interface eth0 (82.240.*.*), et la deuxième carte
réseau de cette machine eth1 à un switch D-Link pour y connecter mes
autres PC dans un LAN privé (en 192.168.0.*/24).



Archi-classique.

Mais je n'arrive pas à activer le forwarding sur cette passerelle sous
Debian.
De mon poste de travail j'arrive bien à pinger ma passerelle, de ma
passerelle j'arrive à pinger mon poste de travail et des adresses sur le
net. Mais pas moyen d'activer le NAT.
J'ai bien mis dans le fichier /etc/sysctl.conf à la ligne
net.ipv4.conf.defaults.forwarding=1



"net.ipv4.ip_forward" est plus classique.

J'ai mis un petit script dans le répertoire
/etc/networking/if-pre-up.d/start :

iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE



Ok.

iptables -A FORWARD -p tcp --tcp-flags SYN,RST SYN -j TCPMSS-o eth0
--clamp-mss-to-pmtu



Cette règle n'est a priori utile que pour contourner des problèmes de
MTU typiques de PPPoE, or que je sache la Freebox n'utilise pas PPPoE
est n'est pas sujette à ce genre de problème.

puis un petit /etc/init.d/network restart...



sysctl.conf doit être rechargé pour que la modification fasse effet,
donc il faut soit redémarrer la machine, soit relire le fichier (sysctl
-p) soit modifier directement le paramètre à la main (sysctl -w
net.ipv4.ip_forward=1).

Mais ça ne veut pô marcher... Où est l'erreur ??



Tu n'as rien de plus détaillé que "ça veut pô marcher", comme des
résultats de tests de réolution de nom, de ping et traceroute vers des
adresses IP et noms de machines ?

A part ça, il y a d'autres règles iptables actives (iptables-save) ?
Les PC du LAN ont bien l'adresse privée de cette machine comme
passerelle par défaut ? Les DNS qui vont bien ?


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme