Debian : pb de réseau

Le
Eul_Bofo
Bonjour.

J'ai toujours des soucis avec Debian (perso, je suis plutôt LFS). Bref.
Je viens d'acheter un portable sans OS, et j'essaye d'installer une Debian
(etch) dessus. Tout se passe bien, sauf le réseau.

En gros, je me connecte, pour le moment, avec le cable ethernet reliant
normalement ma linbox au winpc de ma femme. L'adresse du portable est
192.168.10.3, celui de l'interface de la linbox 192.168.10.1.

Je donne ces renseignements à l'installation, avec en plus les deux
serveurs DNS de free, plus l'adressee, une fois de plus, de ma linbox
puisque celle-ci fait office de DNS local.

Et bin je vous le donne Emile : ça marche pas :-( Je n'arrive pas à me
connecter au réseau.

Ce qui est d'autant plus bizarre, c'est que j'ai eu un peu accès pendant
un temps, lors d'une première install, après avoir bidouillé dans le
fichier /etc/network/interfaces. Et que j'ai pu me connecter normalement
avec une kubuntu (c'est d'ailleurs comme cela que j'ai appris que eth0 est
le port de l'interface ethernet, et eth1 et bin je sais pas trop.
L'interface wifi ? C'est possible que ça change d'un boot à l'autre ?

Bin, ben, bref, qu'est-ce que j'ai loupé ?

Je précise : ordinateur MSI M670, avec un chipset nvidia et un processeur
Sempron. Si vous avez une idée, je suis preneur !

bye

--

Nicolas FRANCOIS
http://nicolas.francois.free.fr
A TRUE Klingon programmer does NOT comment his code
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Fabien LE LEZ
Le #1882351
On Thu, 29 Mar 2007 04:31:07 +0200, Eul_Bofo

Et bin je vous le donne Emile : ça marche pas :-(

Je n'arrive pas à me connecter au réseau.


Ça veut dire quoi ?

Est-ce qu'un ping vers la passerelle donne quelque chose ?
Que donne un "traceroute 64.233.167.99" ?
Est-ce que ifconfig affiche quelque chose d'intéressant ?
À quoi ressemblent les fichiers
/etc/sysconfig/network-scripts/ifcfg-* ?

ygg
Le #1882350

Bin, ben, bref, qu'est-ce que j'ai loupé ?

pong


zoot
Le #1882348
On 29 mar, 04:31, Eul_Bofo
Bonjour.

J'ai toujours des soucis avec Debian (perso, je suis plutôt LFS). Bref.
Je viens d'acheter un portable sans OS, et j'essaye d'installer une Debian
(etch) dessus. Tout se passe bien, sauf le réseau.

En gros, je me connecte, pour le moment, avec le cable ethernet reliant
normalement ma linbox au winpc de ma femme. L'adresse du portable est
192.168.10.3, celui de l'interface de la linbox 192.168.10.1.

Je donne ces renseignements à l'installation, avec en plus les deux
serveurs DNS de free, plus l'adressee, une fois de plus, de ma linbox
puisque celle-ci fait office de DNS local.

Et bin je vous le donne Emile : ça marche pas :-( Je n'arrive pas à me
connecter au réseau.

Ce qui est d'autant plus bizarre, c'est que j'ai eu un peu accès pendant
un temps, lors d'une première install, après avoir bidouillé dans le
fichier /etc/network/interfaces. Et que j'ai pu me connecter normalement
avec une kubuntu (c'est d'ailleurs comme cela que j'ai appris que eth0 est
le port de l'interface ethernet, et eth1... et bin je sais pas trop.
L'interface wifi ? C'est possible que ça change d'un boot à l'autre ?

Bin, ben, bref, qu'est-ce que j'ai loupé ?

Je précise : ordinateur MSI M670, avec un chipset nvidia et un processe ur
Sempron. Si vous avez une idée, je suis preneur !

bye

--

Nicolas FRANCOIS
http://nicolas.francois.free.fr
A TRUE Klingon programmer does NOT comment his code


Je ne connait pas Debin, mais la plupart des problemes reseau peuvent
etre aborde par:

que donne ifconfig -a
netstat -r
est ce que ping en utilisant l'adresses IP fonctionne?
est ce que le cable ethernet est bon ( croise si directement entre
deux PC, normal si un HUB ou autre equipement de reseau ,est
intercalee
si ping ne fontionne pas en utilisant le nom machine ( ping
pc_ma_femme ) c'est peut etre un probleme DNS.
Si tu a un sevreur DNS local pourquoi definr le DNS externe, si ils ne
sont pas disponible pas de connection locale.
Tu peux configure ton serbveru DNS pour 'forwarder' les requetes vers
les seevreur exterieur si des requetes sont faite vers des sites
exterieurs..

A suivre ,,,
Zoot

Eul_Bofo
Le #1882347
Le Thu, 29 Mar 2007 05:18:04 +0200, Fabien LE LEZ a écrit :

On Thu, 29 Mar 2007 04:31:07 +0200, Eul_Bofo

Et bin je vous le donne Emile : ça marche pas :-(

Je n'arrive pas à me connecter au réseau.


Ça veut dire quoi ?

Est-ce qu'un ping vers la passerelle donne quelque chose ?
Que donne un "traceroute 64.233.167.99" ?
Est-ce que ifconfig affiche quelque chose d'intéressant ?
À quoi ressemblent les fichiers
/etc/sysconfig/network-scripts/ifcfg-* ?


À rien, vu que je n'ai pas accès à une console, ceci se passant pendant
l'installation.

En fait, j'ai trouvé le problème : l'interface eth0 n'est pas la bonne.
Bizarre parce que j'ai eu l'impression un moment que j'avais accès à mon
réseau local par cette interface.

J'ai configuré l'interface eth1, et maintenant, ça marche au poil.

Désolé pour le dérangement.

bye

--

Nicolas FRANCOIS
http://nicolas.francois.free.fr
A TRUE Klingon programmer does NOT comment his code


Fabien LE LEZ
Le #1882346
On Thu, 29 Mar 2007 15:49:14 +0200, Eul_Bofo

À rien, vu que je n'ai pas accès à une console, ceci se passant pendant
l'installation.


Si le réseau foire, prends une distrib "complète", pas une
distribution "network".
Ensuite, si tu ne peux pas accéder à une console pendant
l'installation, il te suffit de laisser l'installation se terminer
sans réseau, puis de rajouter la couche réseau après.

Nicolas George
Le #1882345
Eul_Bofo wrote in message
Bizarre parce que j'ai eu l'impression un moment que j'avais accès à mon
réseau local par cette interface.


Tu ne peux pas compter que l'ordre de détection des interfaces soit toujours
le même.

Eul_Bofo
Le #1882337
Le Thu, 29 Mar 2007 15:32:32 +0000, Nicolas George a écrit :

Eul_Bofo wrote in message
Bizarre parce que j'ai eu l'impression un moment que j'avais accès à mon
réseau local par cette interface.


Tu ne peux pas compter que l'ordre de détection des interfaces soit toujours
le même.


Comment fais-tu pour préciser ? Tu donnes des paramètres
supplémentaires à udev ?

bye

--

Nicolas FRANCOIS
http://nicolas.francois.free.fr
A TRUE Klingon programmer does NOT comment his code


Thierry Boudet
Le #1882331
On 2007-03-29, Fabien LE LEZ

À rien, vu que je n'ai pas accès à une console, ceci se passant pendant
l'installation.


Si le réseau foire, prends une distrib "complète", pas une
distribution "network".


C'est la logique Debian ?-)


--
Et d'où tiens tu cette source ?
DTC.

C'est quoi donc, peut tu m'éclairer de tes lumière !

-+- ptilou dans fcold.debats: mais il fait noir comme dans... -+-


Publicité
Poster une réponse
Anonyme