debian squeeze : microcode (firmware)

Le
Dominique MICOLLET
Bonjour,

Je suis en train d'essayer d'installer une Debian Squezze sur un Dell
VOSTRO 1720, avec la publication candidate N°1 de l'installateur réseau.

Il se produit une bizarrerie avec la carte réseau. L'installateur me
demande de fournir le microcode de la carte réseau (rtl8168d-1.fw).
Je n'y parviens pas : j'ai récupéré sur une autre machine le paquet
firmware-realtek qui contient ce fichier et l'ai placé sur une clef USB
formaté FAT, dans sa racine et aussi dans un répertoire firmware (dans
lequel sont les paquets fournis par l'archive firmware.tar.gz).
La clef est en apparence analysée par l'installateur qui m'informe
cependant qu'il ne trouve pas le microcode.
Je manque à l'évidence une étape ou ne la fait pas correctement.

Quelqu'un aurait-il la bonté d'éclairer ma lanterne, s'il a réussi cette
manipulation ?

Incidemment, je me suis rendu compte que la carte fonctionne malgré tout :
après avoir "renoncé" à installer le microcode, l'installateur m'a proposé
de configurer la carte et je peux accéder au réseau.
Le microcode se serait-il malgré tout installé ?

Cordialement.

--
Dominique MICOLLET
Adresse email : enlever deux francs
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Antoine Rouchet
Le #23059861
"Dominique MICOLLET" message news:4d4144c6$0$26374$
Bonjour,

Je suis en train d'essayer d'installer une Debian Squezze sur un Dell
VOSTRO 1720, avec la publication candidate N°1 de l'installateur réseau.

Il se produit une bizarrerie avec la carte réseau. L'installateur me
demande de fournir le microcode de la carte réseau (rtl8168d-1.fw).
Je n'y parviens pas : j'ai récupéré sur une autre machine le paquet
firmware-realtek qui contient ce fichier et l'ai placé sur une clef USB
formaté FAT, dans sa racine et aussi dans un répertoire firmware (dans
lequel sont les paquets fournis par l'archive firmware.tar.gz).
La clef est en apparence analysée par l'installateur qui m'informe
cependant qu'il ne trouve pas le microcode.
Je manque à l'évidence une étape ou ne la fait pas correctement.

Quelqu'un aurait-il la bonté d'éclairer ma lanterne, s'il a réussi cette
manipulation ?

Incidemment, je me suis rendu compte que la carte fonctionne malgré tout
:
après avoir "renoncé" à installer le microcode, l'installateur m'a proposé
de configurer la carte et je peux accéder au réseau.
Le microcode se serait-il malgré tout installé ?

Cordialement.



Bonsoir,

Normalement l'installeur devrait trouver le firmware copié sur la clé USB,
je l'ai fait il y a peu ayant été confronté au même problème. J'ai
simplement copié le fichier demandé sur la racine de la clé (qui était
formatée en ext2 par contre)

En fait les firmwares de la plupart des cartes réseaux n'étant pas libre,
ils ne sont plus disponible sur Debian que dans la section "non-free" des
dépôts de paquets, section qui n'est pas activé par défaut sur une Debien
fraichement installée.

Pour l'activer, il faut éditer le fichier /etc/apt/sources.list et ajouter
la section "non-free":

deb http://.../debian squeeze main contrib

devient:

deb http://.../debian squeeze main contrib non-free

Ensuite (compte root) apt-get update pour rafraichir la liste des paquets et
enfin l'installation du paquet qui contient le firmware de votre carte:

apt-get install firmware-realtek

Et il ne devrait plus se plaindre! :)

Antoine
Dominique MICOLLET
Le #23060171
Antoine Rouchet wrote:

J'ai
simplement copié le fichier demandé sur la racine de la clé (qui était
formatée en ext2 par contre)



Quel fichier avez-vous recopié : le microcode lui-même (extension .fw) ou le
paquet le contenant (extension .deb) ?



En fait les firmwares de la plupart des cartes réseaux n'étant pas libre,
ils ne sont plus disponible sur Debian que dans la section "non-free" des
dépôts de paquets, section qui n'est pas activé par défaut sur une Debien
fraichement installée.



C'est à dire que, en l'espèce, elle n'est même pas fraîchement installée,
puisque je suis en phase d'installation :-).

Pour l'activer, il faut éditer le fichier /etc/apt/sources.list et ajouter


la section "non-free":
.....
apt-get install firmware-realtek



J'ai vaguement l'impression que cette affaire est un serpent qui se mord la
queue : pour installer le firmware, il faut que la distribution soit
installée, et pour installer la distribution, il faut que le firmware soit
installé.

Ou alors, il faut une debian disponible sur une autre machine pour installer
le paquet et récupérer le fichier adhoc.

Ceci étant, ayant eu a refaire l'installation, j'ai carrement contourné la
phase installation du microcode, et la carte réseau a parfaitement
fonctionné. Je suppose qu'elle marche dans un mode dégradé. Je ne sais pas
encore si l'installation est ok, parce que je l'ai faite sur une clef USB
et j'ai un soucis de montage du système de fichier racine.

Merci pour les infos.

Cordialement.



--
Dominique MICOLLET
Adresse email : enlever deux francs
Pascal Hambourg
Le #23060801
Salut,

Dominique MICOLLET a écrit :

J'ai vaguement l'impression que cette affaire est un serpent qui se mord la
queue : pour installer le firmware, il faut que la distribution soit
installée, et pour installer la distribution, il faut que le firmware soit
installé.



C'est pour cela que Debian fournit des images d'installation non
officielles incluant les firmwares non libres. Je ne sais plus où.
Antoine Rouchet
Le #23062641
"Dominique MICOLLET" message news:4d42751e$0$789$
Antoine Rouchet wrote:

J'ai
simplement copié le fichier demandé sur la racine de la clé (qui était
formatée en ext2 par contre)



Quel fichier avez-vous recopié : le microcode lui-même (extension .fw) ou
le
paquet le contenant (extension .deb) ?




Uniquement le microcode lui-même. Dans le doute, vous pouvez y déposer les
deux :-)



En fait les firmwares de la plupart des cartes réseaux n'étant pas libre,
ils ne sont plus disponible sur Debian que dans la section "non-free" des
dépôts de paquets, section qui n'est pas activé par défaut sur une Debien
fraichement installée.



C'est à dire que, en l'espèce, elle n'est même pas fraîchement installée,
puisque je suis en phase d'installation :-).

Pour l'activer, il faut éditer le fichier /etc/apt/sources.list et ajouter


la section "non-free":
.....
apt-get install firmware-realtek



J'ai vaguement l'impression que cette affaire est un serpent qui se mord
la
queue : pour installer le firmware, il faut que la distribution soit
installée, et pour installer la distribution, il faut que le firmware soit
installé.

Ou alors, il faut une debian disponible sur une autre machine pour
installer
le paquet et récupérer le fichier adhoc.

Ceci étant, ayant eu a refaire l'installation, j'ai carrement contourné la
phase installation du microcode, et la carte réseau a parfaitement
fonctionné. Je suppose qu'elle marche dans un mode dégradé. Je ne sais pas
encore si l'installation est ok, parce que je l'ai faite sur une clef USB
et j'ai un soucis de montage du système de fichier racine.

Merci pour les infos.



De rien!

Cordialement.



De même :)




--
Dominique MICOLLET
Adresse email : enlever deux francs
squeeze
Le #23063431
Le 27/01/2011 11:11, Dominique MICOLLET a écrit :
Bonjour,

Je suis en train d'essayer d'installer une Debian Squezze sur un Dell
VOSTRO 1720, avec la publication candidate N°1 de l'installateur réseau.

Il se produit une bizarrerie avec la carte réseau. L'installateur me
demande de fournir le microcode de la carte réseau (rtl8168d-1.fw).
Je n'y parviens pas : j'ai récupéré sur une autre machine le paquet
firmware-realtek qui contient ce fichier et l'ai placé sur une clef USB
formaté FAT, dans sa racine et aussi dans un répertoire firmware (dans
lequel sont les paquets fournis par l'archive firmware.tar.gz).
La clef est en apparence analysée par l'installateur qui m'informe
cependant qu'il ne trouve pas le microcode.
Je manque à l'évidence une étape ou ne la fait pas correctement.

Quelqu'un aurait-il la bonté d'éclairer ma lanterne, s'il a réussi cette
manipulation ?

Incidemment, je me suis rendu compte que la carte fonctionne malgré tout :
après avoir "renoncé" à installer le microcode, l'installateur m'a proposé
de configurer la carte et je peux accéder au réseau.
Le microcode se serait-il malgré tout installé ?

Cordialement.




ai déja eu le souci avec toutes mes install récentes de debian ..
l'installeur se plaint mais ça marche quand même :-)
Publicité
Poster une réponse
Anonyme