Debian squeeze + driver Nvidia

Le
Luxpopuli Open source
--90e6ba6e88ea5929f004a2507686
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Bonjour,

J'ai un gros problme avec les drivers proprios Nvidia (problme que je
n'ai jamais eu auparavant, qui est survenu suite une mise jour - en=
fin
je crois - et que je n'arrive absolument pas rsoudre).

Avant d'avoir ce problme de driver Nvidia
(NVIDIA-Linux-x86_64-260.19.44.run ou autres) qui refuse de prendre en
compte mon IIYAMA 24" (impossible de dpasser prsent 1024x768 au l=
ieu de
1920x1200 habituellement avec ce driver) je l'installais comme ceci:

/etc/init.d/kdm /stop
Alt+Ctrl+F1
cd /usr/src/
./NVIDIA-Linux-x86_64-260.19.44.run

la compilation se faisait,
puis j'indiquais dans xorg.conf que le driver devenait nvidia et non =
pas
nv
puis je redmarrais le serveur X et hop j'avais mon serveur X qui tournai=
t
comme un charme (avec en plus compiz et ses effets).

Depuis dimanche soir, plus rien. Ce driver ne veut plus prendre en compte
les hautes rsolutions de mon cran.
Dans /var/log/Xorg.0.log il y a cette ligne: The EDID read for display
device CRT-1 is invalid:
C'est elle qui semble indiquer qu'il y a un problme.

A force de tripatouiller droite, gauche j'ai fini par casser ma Deb=
ian.
Donc j'ai tout rinstall: une lenny (via netinstall) puis upgrade vers
squeeze.

Mais j'ai toujours ce p.. de problme que je ne n'arrive pas rs=
oudre!

Pourquoi ma mthode qui a toujours march ne marche plus !

Du coup j'utilise le driver nouveau qui lui gre mon cran en 192=
0x1200
mais bon je n'ai plus aucun effet et la prise en charge de ma carte
graphique n'est pas aussi bonne qu'avec les drivers proprio (ce driver est
la seule entorse que je me permets vis vis des logiciels propritaire=
s).

Par ailleurs, dans /var/log/Xorg.0.log je vois cris:

(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Server Extension
(II) NVIDIA GLX Module 270.41.06 Mon Apr 18 15:10:15 PDT 2011
(II) Loading extension GLX

mais quand je tape:

~# glxinfo

j'obtiens:

*name of display: :0.0*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*Error: couldn't find RGB GLX visual or fbconfig*
*
*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*3 GLXFBConfigs:*
* visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav*
* id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat*
*-*
*Erreur de segmentation*

J'ai fait des recherches sur le net et j'ai mme essay cette technique=
:

http://blog.fakroun.net/debian/installer-les-drivers-nvidia-sur/

mais sans aucun rsultat: pas mieux que 1024x768

J'ai test ceci dans mon xorg.conf:

*Section "Monitor"*
* Identifier "Monitor0"*
* Option "ModeDebug" "TRUE"*
* # ON SUPPRIME "EDID" POUR EVITER LE MESSAGE The EDID read for
display device CRT-1 is invalid: DANS LE FICHIER DE LOG /var/log/Xorg.0.=
log
*
* Option "UseEdid" "FALSE"*
* Option "ModeLine" "1920x1200@55"*
*EndSection*

Le mode debug permet d'obtenir ~ 3000 lignes d'info dans /var/log/Xorg.0.lo=
g
!
Le rsultat des courses c'est que toutes les rsolutions testes au-d=
essus
de 1024x768 sont rejetes (hors frquence) !!!!!!!!!

Si quelqu'un a une ide pour me sortir de cette panade je suis trs pre=
neur
;-)

--90e6ba6e88ea5929f004a2507686
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Bonjour,<div><br></div><div>J&#39;ai un gros problme avec les drivers pr=
oprios Nvidia (problme que je n&#39;aijamaiseu auparavant, qui est=
survenu suite une mise jour - enfin je crois - et que je n&#39;=
arrive absolument pas rsoudre).</div>

<div><br></div><div>Avant d&#39;avoir ce problme de driver Nvidia (NVIDI=
A-Linux-x86_64-260.19.44.run ou autres) qui refuse de prendre en compte mon=
IIYAMA 24&quot; (impossible de dpasser prsent 1024x768 au lieu d=
e 1920x1200habituellement avec ce driver)je l&#39;installais comme ce=
ci:</div>

<div><br></div><div>/etc/init.d/kdm /stop</div><div>Alt+Ctrl+F1</div><div>c=
d /usr/src/</div><div>./NVIDIA-Linux-x86_64-260.19.44.run</div><div><br></d=
iv><div>la compilation se faisait,</div><div>puis j&#39;indiquais dans x=
org.conf que le driver devenait nvidia et non pas nv</div>

<div>puis je redmarrais le serveur X et hop j&#39;avais mon serveur X qu=
i tournait comme un charme (avec en plus compiz et ses effets).</div><div><=
br></div><div>Depuis dimanche soir, plus rien. Ce driver ne veut plus prend=
re en compte les hautes rsolutions de mon cran.</div>

<div>Dans/var/log/Xorg.0.log il y a cette ligne: The EDID read for di=
splay device CRT-1 is invalid:</div><div>C&#39;est elle qui semble in=
diquer qu&#39;il y a un problme.</div><div><br></div><div>A force de tri=
patouiller droite, gauche j&#39;ai fini par casser ma Debian. Donc =
j&#39;ai tout rinstall: une lenny (via netinstall) puis upgrade vers =
squeeze.</div>

<div><br></div><div>Mais j&#39;ai toujours ce p.. de problme que je n=
e n&#39;arrive pas rsoudre!</div><div><br></div><div>Pourquoi ma m=
thode qui a toujours march ne marche plus !</div><div><br></div><div>=
Du coup j&#39;utilise le driver nouveau qui lui gre mon cran en=
1920x1200 mais bon je n&#39;ai plus aucun effet et la prise en charge de m=
a carte graphique n&#39;est pas aussi bonne qu&#39;avec les drivers proprio=
(ce driver est la seule entorse que je me permets vis vis des logiciel=
s propritaires).</div>
<div><br></div><div>Par ailleurs, dans/var/log/Xorg.0.log je vois cri=
s:</div><div><br></div><meta http-equiv="content-type" content="text/ht=
ml; charset=utf-8"><div><div>(II) LoadModule: &quot;glx&quot;</div><div>(=
II) Loading /usr/lib/xorg/modules/extensions/libglx.so</div>
<div>(II) Module glx: vendor=&quot;NVIDIA Corporation&quot;</div><div>=
compiled for 4.0.2, module version = 1.0.0</div><div>=
Module class: X.Org Server Extension</div><div>(II) NVIDIA G=
LX Module 270.41.06 Mon Apr 18 15:10:15 PDT 2011</div>
<div>(II) Loading extension GLX</div></div><div><br></div><div>mais quand j=
e tape:</div><div><br></div><div>~# glxinfo</div><div><br></div><div>j&#39;=
obtiens:</div><div><br></div><div><div><i>name of display: :0.0</i></div>
<div><i>Xlib: extension &quot;GLX&quot; missing on display &quot;:0.0&qu=
ot;.</i></div><div><i>Xlib: extension &quot;GLX&quot; missing on display=
&quot;:0.0&quot;.</i></div><div><i>Xlib: extension &quot;GLX&quot; miss=
ing on display &quot;:0.0&quot;.</i></div>
<div><i>Xlib: extension &quot;GLX&quot; missing on display &quot;:0.0&qu=
ot;.</i></div><div><i>Xlib: extension &quot;GLX&quot; missing on display=
&quot;:0.0&quot;.</i></div><div><i>Error: couldn&#39;t find RGB GLX visual=
or fbconfig</i></div>
<div><i><br></i></div><div><i>Xlib: extension &quot;GLX&quot; missing on=
display &quot;:0.0&quot;.</i></div><div><i>Xlib: extension &quot;GLX&qu=
ot; missing on display &quot;:0.0&quot;.</i></div><div><i>Xlib: extensio=
n &quot;GLX&quot; missing on display &quot;:0.0&quot;.</i></div>
<div><i>Xlib: extension &quot;GLX&quot; missing on display &quot;:0.0&qu=
ot;.</i></div><div><i>Xlib: extension &quot;GLX&quot; missing on display=
&quot;:0.0&quot;.</i></div><div><i>Xlib: extension &quot;GLX&quot; miss=
ing on display &quot;:0.0&quot;.</i></div>
<div><i>Xlib: extension &quot;GLX&quot; missing on display &quot;:0.0&qu=
ot;.</i></div><div><i>3 GLXFBConfigs:</i></div><div><i> visual x =
bf lv rg d st colorbuffer ax dp st accumbuffer ms cav</i></div><di=
v><i>id dep cl sp sz l ci b ro r g b a bf th cl r g=
b a ns b eat</i></div>
<div><i>-=
</i></div><div><i>Erreur de segmentation</i></div></div><div><br></div><=
div>J&#39;ai fait des recherches sur le net et j&#39;ai mme essay cet=
te technique:</div>
<div><br></div><div><a href="http://blog.fakroun.net/debian/installer-les=
-drivers-nvidia-sur/">http://blog.fakroun.net/debian/installer-les-drivers-=
nvidia-sur/</a></div><div><br></div><div>mais sans aucun rsultat: pas mi=
eux que 1024x768</div>
<div><br></div><div>J&#39;ai test ceci dans mon xorg.conf:</div><div><br=
></div><div><div><i>Section &quot;Monitor&quot;</i></div><div><i> =
Identifier &quot;Monitor0&quot;</i></div><div><i> =
Option &quot;ModeDebug&quot; &quot;TRUE&quot;=
</i></div>
<div><i> # ON SUPPRIME &quot;EDID&quot; POUR EVITER LE MES=
SAGE The EDID read for display device CRT-1 is invalid: DANS LE FICHI=
ER DE LOG /var/log/Xorg.0.log</i></div><div><i> Option =
&quot;UseEdid&quot; &quot;FALSE&quot;</i></div>
<div><i> Option &quot;ModeLine&quot; &q=
uot;1920x1200@55&quot;</i></div><div><i>EndSection</i></div></div><div><br>=
</div><div>Le mode debug permet d&#39;obtenir ~ 3000 lignes d&#39;info dans=
/var/log/Xorg.0.log !</div>
<div>Le rsultat des courses c&#39;est que toutes les rsolutions test=
es au-dessus de 1024x768 sont rejetes (hors frquence) !!!!!!!!!</d=
iv><div><br></div><div>Si quelqu&#39;un a une ide pour me sortir de cett=
e panade je suis trs preneur ;-)</div>
<meta http-equiv="content-type" content="text/html; charset=utf-8">


--90e6ba6e88ea5929f004a2507686--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/BANLkTik96Eeo+9O63sDKEBNYGHpXzboxeg@mail.gmail.com
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bernard Schoenacker
Le #23329411
Le Mon, 2 May 2011 21:59:33 +0200,
Luxpopuli Open source
Bonjour,

J'ai un gros problème avec les drivers proprios Nvidia (problème que
je n'ai jamais eu auparavant, qui est survenu suite à une mise à jour
- enfin je crois... - et que je n'arrive absolument pas à résoudre).

Avant d'avoir ce problème de driver Nvidia
(NVIDIA-Linux-x86_64-260.19.44.run ou autres) qui refuse de prendre en
compte mon IIYAMA 24" (impossible de dépasser à présent 1024x768 au
lieu de 1920x1200 habituellement avec ce driver) je l'installais
comme ceci:

/etc/init.d/kdm /stop
Alt+Ctrl+F1
cd /usr/src/
./NVIDIA-Linux-x86_64-260.19.44.run

la compilation se faisait,
puis j'indiquais dans xorg.conf que le driver devenait «nvidia» et
non pas «nv»
puis je redémarrais le serveur X et hop j'avais mon serveur X qui
tournait comme un charme (avec en plus compiz et ses effets).

Depuis dimanche soir, plus rien. Ce driver ne veut plus prendre en
compte les hautes résolutions de mon écran.
Dans /var/log/Xorg.0.log il y a cette ligne: «The EDID read for
display device CRT-1 is invalid:»
C'est elle qui semble indiquer qu'il y a un problème.

A force de tripatouiller à droite, à gauche j'ai fini par casser ma
Debian. Donc j'ai tout réinstallé: une lenny (via netinstall) puis
upgrade vers squeeze.

Mais j'ai toujours ce p..... de problème que je ne n'arrive pas à
résoudre!

Pourquoi ma méthode qui a toujours marché ne marche plus !

Du coup j'utilise le driver «nouveau» qui lui gère mon écran en
1920x1200 mais bon je n'ai plus aucun effet et la prise en charge de
ma carte graphique n'est pas aussi bonne qu'avec les drivers proprio
(ce driver est la seule entorse que je me permets vis à vis des
logiciels propriétaires).

Par ailleurs, dans /var/log/Xorg.0.log je vois écris:

(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Server Extension
(II) NVIDIA GLX Module 270.41.06 Mon Apr 18 15:10:15 PDT 2011
(II) Loading extension GLX

mais quand je tape:

~# glxinfo

j'obtiens:

*name of display: :0.0*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*Error: couldn't find RGB GLX visual or fbconfig*
*
*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*Xlib: extension "GLX" missing on display ":0.0".*
*3 GLXFBConfigs:*
* visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms
cav*
* id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b
eat*
*----------------------------------------------------------------------*
*Erreur de segmentation*

J'ai fait des recherches sur le net et j'ai même essayé cette
technique:

http://blog.fakroun.net/debian/installer-les-drivers-nvidia-sur/

mais sans aucun résultat: pas mieux que 1024x768

J'ai testé ceci dans mon xorg.conf:

*Section "Monitor"*
* Identifier "Monitor0"*
* Option "ModeDebug" "TRUE"*
* # ON SUPPRIME "EDID" POUR EVITER LE MESSAGE «The EDID read
for display device CRT-1 is invalid:» DANS LE FICHIER DE
LOG /var/log/Xorg.0.log *
* Option "UseEdid" "FALSE"*
* Option "ModeLine" ""*
*EndSection*

Le mode debug permet d'obtenir ~ 3000 lignes d'info
dans /var/log/Xorg.0.log !
Le résultat des courses c'est que toutes les résolutions testées
au-dessus de 1024x768 sont rejetées (hors fréquence) !!!!!!!!!

Si quelqu'un a une idée pour me sortir de cette panade je suis très
preneur ;-)



bonjour,

je te conseille simplmeent de mettre en place :

grandr - gtk interface to xrandr

ensuite, tu désactive l'affichage au niveau de la détection ...

je sais que après tu te retrouve avec un écran tout noir, mais
il suffit de rebooter ...

slt
bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
giggzounet
Le #23330091
Le 02/05/2011 21:59, Luxpopuli Open source a écrit :
Bonjour,

J'ai un gros problème avec les drivers proprios Nvidia (problème que je
n'ai jamais eu auparavant, qui est survenu suite à une mise à jour -
enfin je crois... - et que je n'arrive absolument pas à résoudre).

Avant d'avoir ce problème de driver Nvidia
(NVIDIA-Linux-x86_64-260.19.44.run ou autres) qui refuse de prendre en
compte mon IIYAMA 24" (impossible de dépasser à présent 1024x768 au lieu
de 1920x1200 habituellement avec ce driver) je l'installais comme ceci:

/etc/init.d/kdm /stop
Alt+Ctrl+F1
cd /usr/src/
./NVIDIA-Linux-x86_64-260.19.44.run

la compilation se faisait,
puis j'indiquais dans xorg.conf que le driver devenait «nvidia» et non
pas «nv»
puis je redémarrais le serveur X et hop j'avais mon serveur X qui
tournait comme un charme (avec en plus compiz et ses effets).

Depuis dimanche soir, plus rien. Ce driver ne veut plus prendre en
compte les hautes résolutions de mon écran.
Dans /var/log/Xorg.0.log il y a cette ligne: «The EDID read for display
device CRT-1 is invalid:»
C'est elle qui semble indiquer qu'il y a un problème.

A force de tripatouiller à droite, à gauche j'ai fini par casser ma
Debian. Donc j'ai tout réinstallé: une lenny (via netinstall) puis
upgrade vers squeeze.

Mais j'ai toujours ce p..... de problème que je ne n'arrive pas à résoudre!

Pourquoi ma méthode qui a toujours marché ne marche plus !

Du coup j'utilise le driver «nouveau» qui lui gère mon écran en
1920x1200 mais bon je n'ai plus aucun effet et la prise en charge de ma
carte graphique n'est pas aussi bonne qu'avec les drivers proprio (ce
driver est la seule entorse que je me permets vis à vis des logiciels
propriétaires).

Par ailleurs, dans /var/log/Xorg.0.log je vois écris:

(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Server Extension
(II) NVIDIA GLX Module 270.41.06 Mon Apr 18 15:10:15 PDT 2011
(II) Loading extension GLX

mais quand je tape:

~# glxinfo

j'obtiens:

/name of display: :0.0/
/Xlib: extension "GLX" missing on display ":0.0"./
/Xlib: extension "GLX" missing on display ":0.0"./
/Xlib: extension "GLX" missing on display ":0.0"./
/Xlib: extension "GLX" missing on display ":0.0"./
/Xlib: extension "GLX" missing on display ":0.0"./
/Error: couldn't find RGB GLX visual or fbconfig/
/
/
/Xlib: extension "GLX" missing on display ":0.0"./
/Xlib: extension "GLX" missing on display ":0.0"./
/Xlib: extension "GLX" missing on display ":0.0"./
/Xlib: extension "GLX" missing on display ":0.0"./
/Xlib: extension "GLX" missing on display ":0.0"./
/Xlib: extension "GLX" missing on display ":0.0"./
/Xlib: extension "GLX" missing on display ":0.0"./
/3 GLXFBConfigs:/
/ visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav/
/ id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat/
/----------------------------------------------------------------------/
/Erreur de segmentation/

J'ai fait des recherches sur le net et j'ai même essayé cette technique:

http://blog.fakroun.net/debian/installer-les-drivers-nvidia-sur/

mais sans aucun résultat: pas mieux que 1024x768

J'ai testé ceci dans mon xorg.conf:

/Section "Monitor"/
/ Identifier "Monitor0"/
/ Option "ModeDebug" "TRUE"/
/ # ON SUPPRIME "EDID" POUR EVITER LE MESSAGE «The EDID read for
display device CRT-1 is invalid:» DANS LE FICHIER DE LOG
/var/log/Xorg.0.log/
/ Option "UseEdid" "FALSE"/
/ Option "ModeLine" ""/
/EndSection/

Le mode debug permet d'obtenir ~ 3000 lignes d'info
dans /var/log/Xorg.0.log !
Le résultat des courses c'est que toutes les résolutions testées
au-dessus de 1024x768 sont rejetées (hors fréquence) !!!!!!!!!

Si quelqu'un a une idée pour me sortir de cette panade je suis très
preneur ;-)



salut,

J'ai une configuration dans le même genre que la tienne: squeeze +
nvidia GTS 450 + LG 24 pouces.

Pour installer les drivers proprio je ne passe plus par le .run de
nvidia mais par les paquets nvidia qui sont dans debian. Tu désinstalles
correctement le .run (c'est important!). Ensuite tu installes les
headers qui correspondent au noyau (ça aussi c'est important). ensuite
tu installes le paquet nvidia-kernel-dkms avec le nvidia-glx. Tu peux
ensuite installer les fioritures nvidia-xconfig, nvidia-settings,
vdpau...tu rebootes! c'est important. car le module nvidia ne se charge
pas si nouveau est chargé. L'installation des paquets nvidia crée un
fichier qui blacklist nouveau au boot...

Si ta carte est récente et que tu n'es pas satisfait des paquets nvidia
de stable, pas de panique! tu fais comme moi, un peu de bidouille...tu
ajoutes sid dans ton source.list et c'est parti pour le pinning! tu
installes les même paquets nvidia cités plus haut mais cette fois-ci
venant d'instable! ça a résolu mes problèmes avec ma GTS 450.

je te laisse lire les avantages de dkms!
bye
GiGGz


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/ipo808$q84$
Publicité
Poster une réponse
Anonyme