debian wheezy ATI : pas de vidéo

Le
yann
Bonjour et bonne année à tous,

Après une mise à jour de testing je suis passé sous gnome3 mais pas
"complètement" : gnome-shell ne fonctionne pas avec mon environnement
d'utilisateur mais en gnome classique cela fonctionne.

Coté graphique j'ai une carte ATI Radeon HD 3200. J'ai installé les
paquets suivants :
ii fglrx-atieventsd 1:11-12-1
ii fglrx-control 1:11-12-1
ii fglrx-driver 1:11-12-1
ii fglrx-glx 1:11-12-1
ii fglrx-glx-ia32 1:11-12-1
ii fglrx-modules-dkms 1:11-12-1

Coté xorg après un aticonfig --initial :
Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:5:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Actuellement l'interface graphique fonctionne avec compiz et les
animations sur mon compte en "gnome classic"

Le programme des "paramètre système" donne pour la carte graphique :
Pilote VESA RS780
Exprérience Restreint

L'animation des fenêtres fonctionne bien.

Les jeux openGL comme bzflag, crack attack! ou foobillard fonctionnent
correctement.

par contre dès que je lance un lecteur de video (vlc, totem, xine,
etc..) sur une vidéo (flv, avi, dvd) le programme plante la session
qui revient à gdm.


Coté utilisateur de test, gnome-shell se lance. Par contre j'observe
différents comportements :
- des "brouillages" d'écran lors de la bascule sur les activités, il
s'agit d'une sorte de saute d'image avec apparition de gros carrés
alignée en colonne ;
- les fenêtres ouvertes affichent leur contenu avec une distorsion qui
pourrait ressembler à un effet de kaléidoscope dans la diagonale du
coin haut droit au coin bas gauche. suivant le cas elle peut se
rafficher correctement lors d'un retaillage ou pas


Enfin l'écran est un asus vk246h connecté en DVI.

Avez-vous quelques idées sur la source de ce problème ?

PS j'ai fait pas mal d'essais ces dernières semaines et notamment
l'installation des pilotes AMD

merci d'avance
--
Yann.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/a8009d74c495472848a86f9571dc438b@ianco.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Yves F. Barbier
Le #24121811
On Mon, 02 Jan 2012 19:02:35 +0100
wrote:

Le programme des "paramètre système" donne pour la carte graphi que :
Pilote VESA RS780
Exprérience Restreint



Donc tu n'utilises apparemment pas le driver fglrx mais le VESA.

Que rapporte: glxinfo | grep rend

Par ailleurs, le man du driver packagé radeon signale que la RS780
est prise en compte:
…
· Full support for 8, 15, 16 and 24 bit pixel depths;
· RandR 1.2 and RandR 1.3 support;
· TV-out support (only on R/RV/RS1xx, R/RV/RS2xx, R/RV/RS3xx. Experime ntal support on R/RV5xx, R/RV6xx, and R/RV7xx through the ATOMTvOut option);
· Full EXA 2D acceleration;
· Full XAA 2D acceleration (only on R/RV/RS1xx, R/RV/RS2xx, R/RV /RS3xx, R/RV/RS4xx, R/RV5xx, RS6xx. XAA Render acceleration supported only on R/RV100, R/RV/RS2xx and RS3xx);
· Textured XVideo acceleration including anti-tearing support (Bicubic filtering only available on R/RV3xx, R/RV/RS4xx, R/RV5xx, and RS6xx/RS740);
· Overlay XVideo acceleration (only on R/RV/RS1xx, R/RV/RS2xx, R/RV/RS 3xx, R/RV/RS4xx);
· 3D acceleration;
…
RV670 Radeon HD 3850/3870
RS780 Radeon HD 3100/3200/3300
RV710 Radeon HD 4350/4550
…

--
You look like a million dollars. All green and wrinkled.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernard Schoenacker
Le #24121801
Le Mon, 02 Jan 2012 19:02:35 +0100,
a écrit :

Bonjour et bonne année à tous,

Après une mise à jour de testing je suis passé sous gnome3 mais pas
"complètement" : gnome-shell ne fonctionne pas avec mon environnement
d'utilisateur mais en gnome classique cela fonctionne.

Coté graphique j'ai une carte ATI Radeon HD 3200. J'ai installé les
paquets suivants :
ii fglrx-atieventsd 1:11-12-1
ii fglrx-control 1:11-12-1
ii fglrx-driver 1:11-12-1
ii fglrx-glx 1:11-12-1
ii fglrx-glx-ia32 1:11-12-1
ii fglrx-modules-dkms 1:11-12-1

Coté xorg après un aticonfig --initial :
Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:5:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Actuellement l'interface graphique fonctionne avec compiz et les
animations sur mon compte en "gnome classic"

Le programme des "paramètre système" donne pour la carte graphique :
Pilote VESA RS780
Exprérience Restreint

L'animation des fenêtres fonctionne bien.

Les jeux openGL comme bzflag, crack attack! ou foobillard fonctionnent
correctement.

par contre dès que je lance un lecteur de video (vlc, totem, xine,
etc..) sur une vidéo (flv, avi, dvd) le programme plante la session
qui revient à gdm.


Coté utilisateur de test, gnome-shell se lance. Par contre j'observe
différents comportements :
- des "brouillages" d'écran lors de la bascule sur les activités, il
s'agit d'une sorte de saute d'image avec apparition de gros carrés
alignée en colonne ;
- les fenêtres ouvertes affichent leur contenu avec une distorsion qui
pourrait ressembler à un effet de kaléidoscope dans la diagonale du
coin haut droit au coin bas gauche. suivant le cas elle peut se
rafficher correctement lors d'un retaillage ou pas...


Enfin l'écran est un asus vk246h connecté en DVI.

Avez-vous quelques idées sur la source de ce problème ?

PS j'ai fait pas mal d'essais ces dernières semaines et notamment
l'installation des pilotes AMD...

merci d'avance
--
Yann.




bonjour,

serait il possible de vérifier :

dpkg -l | awk '/radeon/ {print $2" "$3}'

xrandr -q

ensuite pour xorg.conf ( actuel "radeon" ) :

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "SyncMaster" ## type d'écran
Option "DPMS" "true"
# HorizSync 30.0-96.0
# VertRefresh 50.0-160.0
# DisplaySize 324 244 ### ( dimensions H & V )
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Carte vidéo générique"
Monitor "SyncMaster"
DefaultDepth 24
SubSection "Display"
Depth 24
# Modes "1600x1200" ## attention à la résolution
EndSubSection

après il suffira de continuer à fournir le plus d'information
pécises ....
Merci de ne pas tourner autour du pot comme le fait si bien
un chat questionnant son rav, nous ne sommes pas dans une
école ( ישיבה ) ....


slt
bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Yann Cohen
Le #24123501
Le Mon, 2 Jan 2012 19:59:50 +0100,
"Jean-Yves F. Barbier"
On Mon, 02 Jan 2012 19:02:35 +0100
wrote:

> Le programme des "paramètre système" donne pour la carte grap hique :
> Pilote VESA RS780
> Exprérience Restreint

Donc tu n'utilises apparemment pas le driver fglrx mais le VESA.

Que rapporte: glxinfo | grep rend

Par ailleurs, le man du driver packagé radeon signale que la RS780
est prise en compte:
…
· Full support for 8, 15, 16 and 24 bit pixel depths;
· RandR 1.2 and RandR 1.3 support;
· TV-out support (only on R/RV/RS1xx, R/RV/RS2xx, R/RV/RS3xx.
Experimental support on R/RV5xx, R/RV6xx, and R/RV7xx through the
ATOMTvOut option); · Full EXA 2D acceleration; · Full XAA 2D
acceleration (only on R/RV/RS1xx, R/RV/RS2xx, R/RV/RS3xx,
R/RV/RS4xx, R/RV5xx, RS6xx. XAA Render acceleration supported only on
R/RV100, R/RV/RS2xx and RS3xx); · Textured XVideo acceleration
including anti-tearing support (Bicubic filtering only available on
R/RV3xx, R/RV/RS4xx, R/RV5xx, and RS6xx/RS740); · Overlay XVideo
acceleration (only on R/RV/RS1xx, R/RV/RS2xx, R/RV/RS3xx,
R/RV/RS4xx); · 3D acceleration; … RV670 Radeon HD 3850 /3870
RS780 Radeon HD 3100/3200/3300 RV710 Radeon HD 4350/4550 ⠀¦



Voici les résultats des commandes demandées.

:~$ glxinfo | grep rend
direct rendering: Yes
OpenGL renderer string: ATI Radeon HD 3200 Graphics
GL_NV_conditional_render, GL_NV_copy_depth_to_color,

:~$ xrandr -q
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 1920 x 1920
DFP1 connected 1920x1080+0+0 (normal left inverted right x axis y axis)
531mm x 299mm 1920x1080 60.0*+
1776x1000 60.0 +
1280x720 60.0 +
1600x1200 60.0
1680x1050 60.0
1400x1050 60.0
1280x1024 75.0 60.0
1440x900 59.9
1280x960 75.0 60.0
1280x800 75.0 60.0
1152x864 75.0 60.0
1280x768 74.9 59.9
1024x768 75.0 70.1 60.0
800x600 72.2 75.0 70.0 60.3 56.2
720x480 60.0
640x480 75.0 72.8 60.0
CRT1 disconnected (normal left inverted right x axis y axis)

:~$ sudo dpkg -l | awk '/radeon/ {print $2" "$3}'
libdrm-radeon1 2.4.29-1
xserver-xorg-video-radeon 1:6.14.3-2

merci.
--
Yann.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Yves F. Barbier
Le #24123571
On Tue, 3 Jan 2012 13:49:46 +0100
Yann Cohen
:~$ sudo dpkg -l | awk '/radeon/ {print $2" "$3}'
libdrm-radeon1 2.4.29-1
xserver-xorg-video-radeon 1:6.14.3-2



Ben t'as juste à changer le nom du driver dans xorg.conf: "radeon"

--
Hear about...
the absent minded sculptor who put his model to bed and
started chiseling on his wife?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Yann Cohen
Le #24144651
Le lundi 02 janvier 2012 à 19:02 +0100, a écrit :
Bonjour et bonne année à tous,

Après une mise à jour de testing je suis passé sous gnome3 mais pas
"complètement" : gnome-shell ne fonctionne pas avec mon environnement
d'utilisateur mais en gnome classique cela fonctionne.


[...]
merci d'avance
--
Yann.



Ben j'ai été un peu violent pour la résolution : ré installation de
debian wheezy, mais même comme cela je me suis retrouvé avec un PB =>
pas de firmware pour la carte avec le pilote radeon. C'est ce qui devait
manquer sur la précédente config.

Merci.

--
Yann Cohen ianco

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernard Schoenacker
Le #24144741
Le Mon, 09 Jan 2012 11:36:05 +0100,
Yann Cohen
Le lundi 02 janvier 2012 à 19:02 +0100, a écrit :
> Bonjour et bonne année à tous,
>
> Après une mise à jour de testing je suis passé sous gnome3 mais pas
> "complètement" : gnome-shell ne fonctionne pas avec mon
> environnement d'utilisateur mais en gnome classique cela fonctionne.
[...]
> merci d'avance
> --
> Yann.
>
Ben j'ai été un peu violent pour la résolution : ré installation de
debian wheezy, mais même comme cela je me suis retrouvé avec un PB =>
pas de firmware pour la carte avec le pilote radeon. C'est ce qui
devait manquer sur la précédente config.

Merci.




bonjour,


normalement, il n'y avait pas besoin de tout recommencer ....

il suffisait de rechercher (extrait):

apt-cache search radeon

xserver-xorg-video-radeon
firmware-linux-nonfree
libdrm-radeon1
radeontool
fglrx-modules-dkms
fglrx-driver

slt
bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Florent Charton
Le #24145191
Bonjour,

Le Mon, 09 Jan 2012 11:36:05 +0100,
Yann Cohen
Ben j'ai été un peu violent pour la résolution : ré i nstallation de
debian wheezy, mais même comme cela je me suis retrouvé avec un PB =>
pas de firmware pour la carte avec le pilote radeon. C'est ce qui
devait manquer sur la précédente config.


Les firmware pour le driver libre sont dans le package
firmware-linux-nonfree.
Je ne connais pas les rapports de performances entre fglrx (proprio) et
radeon (libre), mais avec la CG intégré à la carte mère de ma machine,
ça passe correctement (Radeon HD4200) pour compiz en 3200×1080.

Bon courage,
--
Florent Charton

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme