[Debutant] Installation logiciels

Le
doug713705
Bonjour à toutes, tous,

J'écris une application qui a besoin d'être portable et j'en suis à la phase
de test sous MacOSX 10.3.

Je ne connais pas du tout le monde Mac et ses astuces, ni même comment
installer un logiciel (je débute aujourd'hui) !!

Mon application utilise le paquet ImageMagick (
http://www.imagemagick.org ).
J'ai installer ce paquet sans trop de problème pourtant la commande convert
me renvoie l'erreur suivante lors de conversion de format :
Can't open library : /usr/lib/libbz2.1.0.dylib (no such file or directory)

Ce message est assez explicite, la bibliothèque libbz2 n'est pas trouvée et
effectivement elle n'est pas présente.

Ce qui me parait étrange c'est qu'il n'est bullement mentionné sur le site
d'ImageMagick que l'installation de la libbz2 soit nécessaire.

Notez que Stuffit Expander semble bien manipuler les fichiers bz2, j'imagine
qu'il utilise une libbz2 statique.

Mes questions sont les suivantes :
- Comment installer libbz2 sous MacOSX ? (Si c'est bien ce qu'il faut que je
fasses)
- J'ai cru comprendre qu'il était possible d'installer "port" qui semblerait
être l'outil qui me permettrait de télécharger et d'installer depuis les
sources différents programmes. Me trompe-je ? Si non, comment l'installer
(lien, doc) ?
-Existe t-il un "gestionnaire de paquets" sous MacOSX ou quelque chose qui
me permettrait de savoir _avec_précision_ ce qui est installé sur ma
machine ?

et surtout :
- Comment faire pour avoir | (pipe) avec ce #@~*! de "apple usb keyboard"
sur lequel manque la moitié des touches utiles ?

Merci pour toute l'aide que vous pourrez apporter à un pauvre linuxien
égaré.

Sinon, Mac hmm c'est beau :-)

--
[ Plus ou moins avec une chance de peut-être ]
- Pour me contacter, enlever nospam (2X) -
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 7
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nina Popravka
Le #2753931
On Mon, 08 Oct 2007 14:19:17 +0200, doug713705

Je ne connais pas du tout le monde Mac et ses astuces,
Moi encore moins, mais pas un seul gourou Mac se dévoue, je vais m'y

coller pour trois bricoles :-)))

Mes questions sont les suivantes :
- Comment installer libbz2 sous MacOSX ? (Si c'est bien ce qu'il faut que je
fasses)
Heu... Moi je vois dans /usr/lib un truc qui s'appelle libbz2.1.0, et

un autre du nom de libbz2.1.0.2, mais je suis sous 10.4.10...

- J'ai cru comprendre qu'il était possible d'installer "port" qui semblerait
être l'outil qui me permettrait de télécharger et d'installer depuis les
sources différents programmes. Me trompe-je ? Si non, comment l'installer
(lien, doc) ?
http://www.macports.org/

http://finkproject.org/
C'est là qu'on trouve des pingouineries et diablotineries pour MacOSX.

-Existe t-il un "gestionnaire de paquets" sous MacOSX ou quelque chose qui
me permettrait de savoir _avec_précision_ ce qui est installé sur ma
machine ?
Joker, mais je soupçonne que c'est plus complexe que ça.


et surtout :
- Comment faire pour avoir | (pipe) avec ce #@~*! de "apple usb keyboard"
sur lequel manque la moitié des touches utiles ?
Su rmon portable, majuscule flottante + alt (casserole avec la queue à

gauche) + l (comme lola)
Si ça n'est pas comme ça sur ton clavier, préférences système,
international, menu saisie, cocher "visualiseur de clavier", ça te
permettra de faire apparaître une palette représentant le clavier et
les symboles que ça donne en fonction des combinaisons de touches que
tu appuies.

Sinon, Mac... hmm... c'est beau :-)
Ah ouais, c'est l'interface graphique la plus élégante et cohérente, y

a pas photo. Quand on a l'habitude de KDE ou Gnome, ça doit faire une
choc ;->>>
--
Nina

doug713705
Le #2753881
Le lundi 8 octobre 2007 16:59, Nina Popravka s'est exprimé de la sorte sur
fr.comp.os.mac-os.x :

On Mon, 08 Oct 2007 14:19:17 +0200, doug713705

Je ne connais pas du tout le monde Mac et ses astuces,
Moi encore moins, mais pas un seul gourou Mac se dévoue, je vais m'y

coller pour trois bricoles :-)))



C'est marrant mais j'aurais parié que tu allais être la première à répondre.

Mes questions sont les suivantes :
- Comment installer libbz2 sous MacOSX ? (Si c'est bien ce qu'il faut que
je fasses)
Heu... Moi je vois dans /usr/lib un truc qui s'appelle libbz2.1.0, et

un autre du nom de libbz2.1.0.2, mais je suis sous 10.4.10...



Ah, me serais-je trompé de paquet ? 'y'avais le choix entre pour 10.3 et
pour 10.4. Une vérification s'impose.

Comment fait on pour désinstaller un paquet ? On supprime le répertoire et
hop ?

- J'ai cru comprendre qu'il était possible d'installer "port" qui
semblerait être l'outil qui me permettrait de télécharger et d'installer
depuis les sources différents programmes. Me trompe-je ? Si non, comment
l'installer (lien, doc) ?
http://www.macports.org/

http://finkproject.org/
C'est là qu'on trouve des pingouineries et diablotineries pour MacOSX.



AH, enfin quelque chose de plus sérieux que des cliquouilleries et autres
glissades/déposades ;-)

-Existe t-il un "gestionnaire de paquets" sous MacOSX ou quelque chose qui
me permettrait de savoir _avec_précision_ ce qui est installé sur ma
machine ?
Joker, mais je soupçonne que c'est plus complexe que ça.



et surtout :
- Comment faire pour avoir | (pipe) avec ce #@~*! de "apple usb keyboard"
sur lequel manque la moitié des touches utiles ?
Su rmon portable, majuscule flottante + alt (casserole avec la queue à

gauche) + l (comme lola)


Mac est plus convivial que Windows, on dépasse de loin le non moins célèbre
CTRL+Alt+Suppr. :-D

Si ça n'est pas comme ça sur ton clavier, préférences système,
international, menu saisie, cocher "visualiseur de clavier", ça te
permettra de faire apparaître une palette représentant le clavier et
les symboles que ça donne en fonction des combinaisons de touches que
tu appuies.


'M'en vais fouiller de ce coté.

Sinon, Mac... hmm... c'est beau :-)
Ah ouais, c'est l'interface graphique la plus élégante et cohérente,



Attention, j'ai dis beau, pas ergonomique ;-) Mais tout ça est très
subjectif.

y'a pas photo. Quand on a l'habitude de KDE ou Gnome, ça doit faire une
choc ;->>>


Les pingouins apprennent vite :
http://baghira.sourceforge.net/screenies.php

Merci de ton aide.
--
[ Plus ou moins avec une chance de peut-être ]
- Pour me contacter, enlever nospam (2X) -


Nina Popravka
Le #2753851
On Mon, 08 Oct 2007 17:39:47 +0200, doug713705

C'est marrant mais j'aurais parié que tu allais être la première à répondre.
Et t'es pas fauché, avec ça... :-)))))


Comment fait on pour désinstaller un paquet ? On supprime le répertoire et
hop ?
Y a pas de désinstallateur standard, en MacOSX. Ni de gestionnaire de

machin à la synaptics et autres, globalement.
Donc oui, on supprime le répertoire, et si on est consciencieux on va
voir auparavant ce qu'il a été foutre où, le pkg.
Avec Pacifist pour les feignasses à souris comme moi
:-)

Les pingouins apprennent vite :
http://baghira.sourceforge.net/screenies.php
Vi vi... Z'ont plus qu'à réaliser qu'une interface, c'est autre chose

que le look... (OOOpppppsss c'est vrai qu'on est déjà en train de
troller ailleurs)

Merci de ton aide.
Padkoi !!!!

--
Nina

kurtz le pirate
Le #2749501
In article doug713705
Ce qui me parait étrange c'est qu'il n'est bullement mentionné sur le site
d'ImageMagick que l'installation de la libbz2 soit nécessaire.


non mais sur la page de dowload, il y a :
ImageMagick-universal-apple-darwin8.10.1.tar.gz ----> Mac OS X (10.4.?)

donc à priori à partir de tiger non ?


--
klp

doug713705
Le #2749321
Le lundi 8 octobre 2007 20:05, kurtz le pirate s'est exprimé de la sorte sur
fr.comp.os.mac-os.x :

ImageMagick-universal-apple-darwin8.10.1.tar.gz ----> Mac OS X (10.4.?)

donc à priori à partir de tiger non ?


Ben, ce genre de notation (le ?) me laisse perplexe.
Est ce que ça veut dire fonctionne pour MacOSX > 10.4 ou fonctionne
peut-être sous 10.4 ?

Maintenant si dans le monde mac on note "> 10.4" "10.4 ?" alors d'accord.
Mais je doute quand même encore un peu ;-)
--
[ Plus ou moins avec une chance de peut-être ]
- Pour me contacter, enlever nospam (2X) -

Nina Popravka
Le #2749291
On Mon, 08 Oct 2007 21:37:30 +0200, doug713705

Maintenant si dans le monde mac on note "> 10.4" "10.4 ?" alors d'accord.
Mais je doute quand même encore un peu ;-)


Dans le monde Mac on n'est jamais sûr de rien, donc si tu ne vois pas
*explicitement* 10.3 et 10.4, c'est que ça marche pas sous les deux.
Et 10.4.? signifie à l'évidence "Tiger", merde koi... 10.4.*, si tu
veux.
--
Nina

blanc
Le #2749281
doug713705
- Comment faire pour avoir | (pipe) avec ce #@~*! de "apple usb keyboard"
sur lequel manque la moitié des touches utiles ?


Mais non, mais non, elles y sont. Une fois que tu sais où, plus de
problème. En attendant le visualiseur de clavier est ton ami :-)

Un autre ami que tu ne tarderas pas à réclamer, je présume, est cette
double page de raccourcis clavier :

Tu y trouveras d'ailleurs dans la deuxième page, sous le titre
"Caractères particuliers" les pipe, tilde, arobas et autres caractères
que tu cherches vainement depuis quelques temps... :-)
--
JiPaul.
/ /--/--//\ Jean-Paul Blanc
|/| L |\ quelquepart en (somewhere in)
/|| = |||\ FRANCE

doug713705
Le #2749271
Le lundi 8 octobre 2007 21:49, Nina Popravka s'est exprimé de la sorte sur
fr.comp.os.mac-os.x :

Dans le monde Mac on n'est jamais sûr de rien, donc si tu ne vois pas
*explicitement* 10.3 et 10.4, c'est que ça marche pas sous les deux.
Et 10.4.? signifie à l'évidence "Tiger", merde koi... 10.4.*, si tu
veux.


Aaaaaaah d'aaaaaccoooooord !

J'avais pas bien vu le . avant le ?

Pfiouu, dur, dur d'être un newbie !
On se ferait presque engueuler comme sur fcolc ! ;-)

--
[ Plus ou moins avec une chance de peut-être ]
- Pour me contacter, enlever nospam (2X) -

Nina Popravka
Le #2749261
On Mon, 08 Oct 2007 22:22:29 +0200, doug713705

Pfiouu, dur, dur d'être un newbie !
On se ferait presque engueuler comme sur fcolc ! ;-)


C'est de bonne guerre... :-)
D'autre part, je ne sais pas ce que tu développes, comment ça se
présente, etc, mais sur Mac il y a des trucs parfaitement
insupportables.
Par exemple la première fois que j'ai installé je sais plus quel port
de Wireshark, j'ai eu droit à droit à 2 heures de compil de toute la
tripaillerie gtk*, et la première fois que j'ai installé OOo, je me
suis battue pendant une heure pour installer X11 (non, il n'est pas
présent par défaut). Des trucs comme ça, pour un utilisateur de Mac,
c'est *totalement* rédhibitoire.
--
Nina

doug713705
Le #2703771
Le lundi 8 octobre 2007 22:43, Nina Popravka s'est exprimé de la sorte sur
fr.comp.os.mac-os.x :

C'est de bonne guerre... :-)


:-)

D'autre part, je ne sais pas ce que tu développes, comment ça se
présente, etc, mais sur Mac il y a des trucs parfaitement
insupportables.


Une bète appli en php,javascript, rien à voir avec l'OS en fait mais cet
appli est destiné à être installé sur toutes formes d'O.S, notamment
MacOSX.

J'essaie donc de vérifier que tout fonctionne bien et de rédiger une doc
d'installation complète pour l'utilisateur lambda qui ne sait ce qu'est un
démon http mais mes connaissances en Mac me limitent énormément.

Bon heureusement, 'y'a des gens biens qui ont déjà packagé MAMP.

Me reste plus qu'à interfacer ImageMagick par dessus tout ça.

Tout est tellement plus simple pour moi sous Linux ;-)

Bon, ne parlons pas de Windows, j'ai fait le choix suivant : "l'appli ne
fonctionnera jamais sous cet O.S. (sauf coup de bol)"

Par exemple la première fois que j'ai installé je sais plus quel port
de Wireshark, j'ai eu droit à droit à 2 heures de compil de toute la
tripaillerie gtk*, et la première fois que j'ai installé OOo, je me
suis battue pendant une heure pour installer X11 (non, il n'est pas
présent par défaut). Des trucs comme ça, pour un utilisateur de Mac,
c'est *totalement* rédhibitoire.


Ben, je ne suis pas allé si loin, l'installation d'ImgeMagick m'a presque
coupé l'envie de rendre mon bouzin installable sur MacOS !!

Macport m'a sorti des messages d'erreurs à refroidir l'ex-Slackwariste et
actuel Gentooiste que je suis !!!

Heureusement je ne suis pas du genre à lâcher l'affaire comme ça.
'M'en vais lui montrer moi a Steve Jobs comment je saurais franchir les
obstacles qu'il a mis sur ma route ;-)

Mais bon pour l'instant j'en suis arrivé à "J'vais m'installer un chti 10.4,
ça sera plus simple" :-D

Demain est un autre jour... Et je suis en vacances...
--
[ Plus ou moins avec une chance de peut-être ]
- Pour me contacter, enlever nospam (2X) -

Publicité
Poster une réponse
Anonyme