Déclaration d'impôts Debian amd64 SID

Le
Aurelien
Salut,

Quelqu'un a-t-il réussi à faire sa déclaration d'impôts avec Debian
AMD64 SID ?

J'ai tenté ce matin, j'utilise iceweasel

$> dpkg -l iceweasel
ii iceweasel 2.0.0.3-2


java runtime 5 (la 6 a un bogue concernant c->xlib.lock)

$> dpkg -l *java* (c'est un sacré bordel ; pourtant je n'ai installé que sun-java5-bin et sun-java5-jre)
un ia32-sun-java5-bin <néant>
un ia32-sun-java5-plugin <néant>
ii java-common 0.25
un java-gcj-compat <néant>
un java-gcj-compat-dev <néant>
un java-runtime <néant>
un java-virtual-machine <néant>
un java1-runtime <néant>
un java2-runtime <néant>
un lib-xt-java <néant>
un libbsf-java <néant>
ii libhsqldb-java 1.8.0.7-3
un libhsqldb-java-doc <néant>
ii libjaxp1.2-java 1.2.01-2
un libjaxp1.2-java-gcj <néant>
ii libjaxp1.3-java 1.3.03-5
un libjaxp1.3-java-gcj <néant>
ii libjline-java 0.9.5-2
un libjline-java-doc <néant>
un libmysql-java <néant>
un libpg-java <néant>
un libsapdbc-java <néant>
ii libservlet2.3-java 4.0-8
ii libservlet2.4-java 5.0.30-3
ii libxalan2-java 2.7.0-4
un libxalan2-java-doc <néant>
un libxalan2-java-gcj <néant>
ii libxerces2-java 2.8.1-2
un libxerces2-java-doc <néant>
un libxerces2-java-gcj <néant>
un libxsltc-java <néant>
ii libxt-java 0.20050823-2
un openoffice.org-java <néant>
ii openoffice.org-java-com 2.2.0-6
un openoffice.org2-java-co <néant>
ii sun-java5-bin 1.5.0-11-1
un sun-java5-fonts <néant>
ii sun-java5-jre 1.5.0-11-1
un sun-java5-plugin <néant>

et le bogue sur sun-java6-jre

$> apt-get install sun-java6-jre
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances Fait
Les paquets supplémentaires suivants seront installés :
sun-java6-bin
Paquets suggérés :
sun-java6-plugin ia32-sun-java6-plugin sun-java6-fonts ttf-baekmuk ttf-sazanami-gothic ttf-sazanami-mincho
ttf-arphic-bsmi00lp
Les NOUVEAUX paquets suivants seront installés :
sun-java6-bin sun-java6-jre
0 mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0o/29,7Mo dans les archives.
Après dépaquetage, 84,3Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ?
Lecture des champs des paquets Fait
Lecture de l'état des paquets Fait
Récupération des rapports de bogue Fait
Analyse des informations Trouvé/Corrigé Fait
Bogues de gravité grave sur sun-java6-jre (-> 6-00-2) <forwarded>
#414535 - sun-java6-jre: Java GUI programs don't work because "Assertion `c->xlib.lock' failed."
Résumé :
sun-java6-jre(1 bogue)
Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ? [Y/n/?/]


Déjà que ça me fait chier d'installer du non-libre sur ma machine

Merci d'avance, en tout cas.

PS : J'ai lu tout un tas de truc sur le fait qu'il fallait lancer
iceweasel en root, mais perso, j'ai pas eu besoin, et c'est tant mieux.
Je suis le seul ?

--

ORL (alias Yvette H.)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Julien Valroff
Le #9539151
Le mardi 08 mai 2007 à 10:57 +0200, Aurelien a écrit :
Salut,

Quelqu'un a-t-il réussi à faire sa déclaration d'impôts avec Debian
AMD64 SID ?


[...]
Bogues de gravité grave sur sun-java6-jre (-> 6-00-2) <forwarded>
#414535 - sun-java6-jre: Java GUI programs don't work because "Assertion `c->xlib.lock' failed."
Résumé :
sun-java6-jre(1 bogue)
Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ? [Y/n/?/...]



Ce bug n'affecte que libx11-6 >= 1.1.1, la version en sid est 1.0.3, il
n'y a donc pas de problème si tu utilises le paquet de sid.

@+
Julien



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Julien Valroff
Le #9539141
Le mardi 08 mai 2007 à 11:50 +0200, Gaëtan PERRIER a écrit :
Je suis en testing 32 bits et j'ai fais ma déclaration avec Firefox
mais lors de la phase de vérification il m'a dit que mon navigateur
n'était pas compatible. J'ai donc regardé l'aide qu'il m'a proposé à
ce moment et Firefox étant cité comme navigateur compatible, j'ai
continué quand même et tout c'est bien passé...
Avez-vous eu la même chose?


Oui, j'imagine que le renommage de firefox vers iceweasel dans Debian
nous fera ce genre de coups assez souvent.
Ma chaine UserAgent est :
Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.3) Gecko/20070310 Iceweasel/2.0.0.3 (Debian-2.0.0.3-2)

Je présume que Iceweasel se substitue à Firefox, qui est testé dans leur
application.
Par ailleurs, leur liste ne peut pas être exhaustive, il doit s'agir des
navigateurs certifiés (et donc testés).

@++
Julien



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Gaëtan PERRIER
Le #9539131
Je suis en testing 32 bits et j'ai fais ma déclaration avec Firefox mais lors de la phase de vérification il m'a dit que mon navigateur n'était pas compatible. J'ai donc regardé l'aide qu'il m'a proposé à ce moment et Firefox étant cité comme navigateur compatible, j'ai continué quand même et tout c'est bien passé...
Avez-vous eu la même chose?

Gaëtan


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Gaëtan PERRIER
Le #9539121
Le Tue, 08 May 2007 11:50:23 +0200
Gaëtan PERRIER
Je suis en testing 32 bits et j'ai fais ma déclaration avec Firefox
mais lors de la phase de vérification il m'a dit que mon navigateur
n'était pas compatible. J'ai donc regardé l'aide qu'il m'a proposé
à ce moment et Firefox étant cité comme navigateur compatible, j'ai
continué quand même et tout c'est bien passé... Avez-vous eu la
même chose?

Gaëtan



J'y pense totu un coup que sur Debian c'est Iceweasel, est-ce que ça pourrait venir de ça le problème de détection?

Gaëtan


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Aurelien
Le #9539111
On Tue, May 08, 2007 at 11:05:10AM +0200, Julien Valroff wrote :
Le mardi 08 mai 2007 à 10:57 +0200, Aurelien a écrit :
> Salut,
>
> Quelqu'un a-t-il réussi à faire sa déclaration d'impôts avec Debian
> AMD64 SID ?
[...]
> Bogues de gravité grave sur sun-java6-jre (-> 6-00-2) <forwarded>
> #414535 - sun-java6-jre: Java GUI programs don't work because "Assertion `c->xlib.lock' failed."
> Résumé :
> sun-java6-jre(1 bogue)
> Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ? [Y/n/?/...]

Ce bug n'affecte que libx11-6 >= 1.1.1, la version en sid est 1.0.3, il
n'y a donc pas de problème si tu utilises le paquet de sid.



Ah ? Tu m'apprends quelque chose, je croyais qu'apt-listbugs ne listait
que les bugs relatifs à la distribution installée sur le PC (en
utilisant le sources.list).
Merci.
Je vous tiens au courant pour la suite.

Note : je ne sais pas ce qu'il en est en 32 bits, mais en 64 bits, le
plugin JRE pour iceweasel n'existe pas ni dans l'archive debian, ni en
utilisant le gestionnaire de plugins d'iceweasel. Je ne sais pas si ça
pose problème, ou pas.


@+
Julien



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact





--
============================= ORL (alias Yvette H.)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Julien Valroff
Le #9539101
Le mardi 08 mai 2007 à 12:01 +0200, Aurelien a écrit :
On Tue, May 08, 2007 at 11:05:10AM +0200, Julien Valroff wrote :
> Le mardi 08 mai 2007 à 10:57 +0200, Aurelien a écrit :
> > Salut,
> >
> > Quelqu'un a-t-il réussi à faire sa déclaration d'impôts avec Debian
> > AMD64 SID ?
> [...]
> > Bogues de gravité grave sur sun-java6-jre (-> 6-00-2) <forwarded>
> > #414535 - sun-java6-jre: Java GUI programs don't work because "Assertion `c->xlib.lock' failed."
> > Résumé :
> > sun-java6-jre(1 bogue)
> > Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ? [Y/n/?/...]
>
> Ce bug n'affecte que libx11-6 >= 1.1.1, la version en sid est 1.0.3, il
> n'y a donc pas de problème si tu utilises le paquet de sid.

Ah ? Tu m'apprends quelque chose, je croyais qu'apt-listbugs ne listait
que les bugs relatifs à la distribution installée sur le PC (en
utilisant le sources.list).


Je ne vois pas comment il pourrait faire pour aller si loin dans le
détail. Il t'avertit, après, à toi de voir si les problèmes listés te
concernent ou non.

Merci.
Je vous tiens au courant pour la suite.

Note : je ne sais pas ce qu'il en est en 32 bits, mais en 64 bits, le
plugin JRE pour iceweasel n'existe pas ni dans l'archive debian, ni en
utilisant le gestionnaire de plugins d'iceweasel. Je ne sais pas si ça
pose problème, ou pas.


Je pense en effet que tu vas avoir un problème à ce niveau. SUN ne
distribue pas de plugin JRE pour 64 bits. Il y a peut-être une façon
d'utiliser le plugin 32bits avec un chroot, comme pour flash player ?
(je n'ai pas vérifié et je n'utilise pas debian 64).

Julien



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Gaëtan PERRIER
Le #9539091
Le Tue, 08 May 2007 11:57:28 +0200
Julien Valroff
Le mardi 08 mai 2007 à 11:50 +0200, Gaëtan PERRIER a écrit :
> Je suis en testing 32 bits et j'ai fais ma déclaration avec
> Firefox mais lors de la phase de vérification il m'a dit que mon
> navigateur n'était pas compatible. J'ai donc regardé l'aide qu'il
> m'a proposé à ce moment et Firefox étant cité comme navigateur
> compatible, j'ai continué quand même et tout c'est bien passé...
> Avez-vous eu la même chose?
Oui, j'imagine que le renommage de firefox vers iceweasel dans
Debian nous fera ce genre de coups assez souvent.
Ma chaine UserAgent est :
Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.3) Gecko/20070310
Iceweasel/2.0.0.3 (Debian-2.0.0.3-2)

Je présume que Iceweasel se substitue à Firefox, qui est testé dans
leur application.
Par ailleurs, leur liste ne peut pas être exhaustive, il doit
s'agir des navigateurs certifiés (et donc testés).




Encore heureux que le site ne bloque pas quand le navigateur n'est pas reconnu, comme certains autres sites.
Mais c'est quand même ennuyeux cette histoire, car le libre à réussi à imposer Firefox et à ce qu'il soit pris en compte par les webmaster mais si maintenant on leur explique qu'il aussi prendre en compte tous les forks ...

PS: pas la peine de troller sur iceweasel/Firefox ça déjà été fait longuement sur cette liste et ailleurs.

Gaëtan


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Aurelien
Le #9539081
On Tue, May 08, 2007 at 12:05:18PM +0200, Julien Valroff wrote :
Le mardi 08 mai 2007 à 12:01 +0200, Aurelien a écrit :
> On Tue, May 08, 2007 at 11:05:10AM +0200, Julien Valroff wrote :
> > Le mardi 08 mai 2007 à 10:57 +0200, Aurelien a écrit :
> > > Salut,
> > >
> > > Quelqu'un a-t-il réussi à faire sa déclaration d'impôts avec Debian
> > > AMD64 SID ?
> > [...]
> > > Bogues de gravité grave sur sun-java6-jre (-> 6-00-2) <forwarded>
> > > #414535 - sun-java6-jre: Java GUI programs don't work because "Assertion `c->xlib.lock' failed."
> > > Résumé :
> > > sun-java6-jre(1 bogue)
> > > Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ? [Y/n/?/...]
> >
> > Ce bug n'affecte que libx11-6 >= 1.1.1, la version en sid est 1.0.3, il
> > n'y a donc pas de problème si tu utilises le paquet de sid.
>
> Ah ? Tu m'apprends quelque chose, je croyais qu'apt-listbugs ne listait
> que les bugs relatifs à la distribution installée sur le PC (en
> utilisant le sources.list).
Je ne vois pas comment il pourrait faire pour aller si loin dans le
détail. Il t'avertit, après, à toi de voir si les problèmes listés te
concernent ou non.



OK, bah merci de l'info.


> Merci.
> Je vous tiens au courant pour la suite.
>
> Note : je ne sais pas ce qu'il en est en 32 bits, mais en 64 bits, le
> plugin JRE pour iceweasel n'existe pas ni dans l'archive debian, ni en
> utilisant le gestionnaire de plugins d'iceweasel. Je ne sais pas si ça
> pose problème, ou pas.
Je pense en effet que tu vas avoir un problème à ce niveau. SUN ne
distribue pas de plugin JRE pour 64 bits. Il y a peut-être une façon
d'utiliser le plugin 32bits avec un chroot, comme pour flash player ?
(je n'ai pas vérifié et je n'utilise pas debian 64).



Arf... Bon, ça me fait chier, j'ai pas voulu le faire pour flash, ça me
fait déjà chier d'installer du non libre. Je crois que je vais
redémarrer un windows, pour le coup, parce que là, c'est relou.....
Sinon, j'imagine que la solution nspluginswrapper (pas sûr de la syntaxe
exacte) fonctionnerait aussi.
Bref. Tant pis.



Julien



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact





--
============================= ORL (alias Yvette H.)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Aurelien
Le #9539071
On Tue, May 08, 2007 at 12:01:18PM +0200, Aurélien Roux wrote :
On Tue, May 08, 2007 at 11:05:10AM +0200, Julien Valroff wrote :
> Le mardi 08 mai 2007 à 10:57 +0200, Aurelien a écrit :
> > Salut,
> >
> > Quelqu'un a-t-il réussi à faire sa déclaration d'impôts avec Debian
> > AMD64 SID ?
> [...]
> > Bogues de gravité grave sur sun-java6-jre (-> 6-00-2) <forwarded>
> > #414535 - sun-java6-jre: Java GUI programs don't work because "Assertion `c->xlib.lock' failed."
> > Résumé :
> > sun-java6-jre(1 bogue)
> > Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ? [Y/n/?/...]
>
> Ce bug n'affecte que libx11-6 >= 1.1.1, la version en sid est 1.0.3, il
> n'y a donc pas de problème si tu utilises le paquet de sid.

Ah ? Tu m'apprends quelque chose, je croyais qu'apt-listbugs ne listait
que les bugs relatifs à la distribution installée sur le PC (en
utilisant le sources.list).
Merci.
Je vous tiens au courant pour la suite.



Bon, ça ne fonctionne toujours pas.
Le détecteur de configuration du site des impôts me dit qu'il me manque
une JVM.
D'autre part, lorsque la page de vérification de la configuration se
lance, iceweasel me met la petite barre "Missing plugins" et me propose
d'installer une JVM (plugin), mais finalement aucun candidat à
l'installation, et donc, non.

Voilà les paquets relatifs à java désormais installés (puisque j'ai
installé la v6) :

$> dpkg -l *java*
un ia32-sun-java5-bin <néant>
un ia32-sun-java5-plugin <néant>
un ia32-sun-java6-bin <néant>
un ia32-sun-java6-plugin <néant>
ii java-common 0.25
un java-gcj-compat <néant>
un java-gcj-compat-dev <néant>
un java-runtime <néant>
un java-virtual-machine <néant>
un java1-runtime <néant>
un java2-runtime <néant>
un lib-xt-java <néant>
un libbsf-java <néant>
ii libhsqldb-java 1.8.0.7-3
un libhsqldb-java-doc <néant>
ii libjaxp1.2-java 1.2.01-2
un libjaxp1.2-java-gcj <néant>
ii libjaxp1.3-java 1.3.03-5
un libjaxp1.3-java-gcj <néant>
ii libjline-java 0.9.5-2
un libjline-java-doc <néant>
un libmysql-java <néant>
un libpg-java <néant>
un libsapdbc-java <néant>
ii libservlet2.3-java 4.0-8
ii libservlet2.4-java 5.0.30-3
ii libxalan2-java 2.7.0-4
un libxalan2-java-doc <néant>
un libxalan2-java-gcj <néant>
ii libxerces2-java 2.8.1-2
un libxerces2-java-doc <néant>
un libxerces2-java-gcj <néant>
un libxsltc-java <néant>
ii libxt-java 0.20050823-2
un openoffice.org-java <néant>
ii openoffice.org-java-com 2.2.0-6
un openoffice.org2-java-co <néant>
ii sun-java5-bin 1.5.0-11-1
un sun-java5-fonts <néant>
ii sun-java5-jre 1.5.0-11-1
un sun-java5-plugin <néant>
ii sun-java6-bin 6-00-2
un sun-java6-fonts <néant>
ii sun-java6-jre 6-00-2
un sun-java6-plugin <néant>


Note : sur le site des impôts, ils disent de redémarrer le PC.
Evidemment, je ne l'ai pas fait ! ;)
--
============================= ORL (alias Yvette H.)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sylvain Sauvage
Le #9538581
Gaëtan PERRIER, mardi 8 mai 2007, 12:16:29 CEST
[...]
Encore heureux que le site ne bloque pas quand le navigateur n'est pas re connu, comme certains autres sites.
Mais c'est quand même ennuyeux cette histoire, car le libre à r éussi à imposer Firefox et à ce qu'il soit pris en compte pa r les webmaster mais si maintenant on leur explique qu'il aussi prendre en compte tous les forks ...



Il faudrait leur expliquer que :
– le mieux est de ne pas tester le client ;
– si on y est obligé, il faut tester sur le moteur (Gecko), pas
sur le nom ;
– mais le mieux est de ne pas tester le client.

--
Sylvain Sauvage
Publicité
Poster une réponse
Anonyme