déclaration impôts en ligne sous Lenny et Iceweasel 3.0.6

Le
Bernard
Bonjour à tous,

La bonne surprise, le piège, même, car c'est le dernier jour le
serveur me précise que je n'ai pas la configuration requise pour la
déclaration en ligne !

Pourtant, l'an dernier ainsi que l'année précédente, çà a fonctionné
sans problème !

Est-ce à dire que les impôts ont "modernisé" leur système de déclaration
et qu'aujourd'hui cela ne fonctionne plus qu'avec Microsoft Windows ?

Je dispose donc de Iceweasel 3.06 sous Debian Lenny. Y-a-t-il des
personnes qui ont réussi à faire leur déclaration avec ces outils ?
Sinon, que faut il utiliser ? Mon vieux certificat est bien reconnu,
mais un clic sur la "déclaration en ligne" mène sur un test qui dure
quelques dizaines de secondes, à la suite duquel j'ai ce qui suit :

"Problème de configuration

Système d'exploitation : la version de votre système d'exploitation ne
vous garantit pas de pouvoir déclarer vos revenus en ligne

Navigateur : Votre navigateur ne vous garantit pas de pouvoir déclarer
vos revenus en ligne

Cookies OK

Javascript OK

STOP: Logiciel JVM (Java Virtual Machine) : Attention, vous ne disposez
pas du logiciel JVM indispensable ou cette fonctionalité n'est pas
activée dans votre navigateur.

Des liens sont proposés pour l'affichage des configurations requises :
il n'est fait référence qu'à Microsoft Windows et MacIntosh !

Mon Iceweasel 3.06 a bien les fonctionalités Java activées (case JAVA
cochée). D'ailleurs, j'arrive sans problème à me connecter au site des
Archives Départementales des Yvelines, pour lequel JVM est indispensable.

Merci d'avance pour votre aide.

Bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/4C027A54.90402@teaser.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Grégory Bulot
Le #22189371
Bernard

Navigateur : Votre navigateur ne vous garantit pas de pouvoir
déclarer vos revenus en ligne...



ça c'est normal tu utlise Iceweasel, mais si c'est en fait du firefox à
98%, la chaine d'identification est .... iceweasel, il ne référen ce que
quelques navigateurs (pas les mieux, certes, mais pas tous !!).
D'un autre côté, ils ne disent pas "aller payer vos impôts en
suisse :-D"

Cela m'a aidé (auto-promo inside):
http://joomla.bulot-fr.com/gregory/index.php/tips-linux/118-les-impots-et-j ava-sous-lenny

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Michel OLTRA
Le #22189411
Bonjour,


Le dimanche 30 mai 2010, Bernard a écrit...


Je dispose donc de Iceweasel 3.06 sous Debian Lenny. Y-a-t-il des
personnes qui ont réussi à faire leur déclaration avec ces outils ?
Sinon, que faut il utiliser ? Mon vieux certificat est bien reconnu,
mais un clic sur la "déclaration en ligne" mène sur un test qui dure
quelques dizaines de secondes, à la suite duquel j'ai ce qui suit :



Aucun souci avec la version Squeeze FF 3.5, mais pas en utilisant le
certificat, par authentification simple num télédéclarant et autres.

Tu pourrais éventuellement installer l'extension User Agent Switcher
pour tenter de tromper le site des impôts…?

--
jm

A.E.L. Sarl (R.C.S CASTRES 490843240)
http://www.spidboutic.fr



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Frederic MASSOT
Le #22189461
Bernard

Navigateur : Votre navigateur ne vous garantit pas de pouvoir
déclarer vos revenus en ligne...




J'ai pu déclarer mes impôts sans problème avec la version Squeeze
d'Iceweasel et le certificat.

Le message sur le navigateur est lié à l'User Agent, tu peux utiliser
l'extension User Agent Switcher pour en changer, mais ce n'est pas le
point bloquant.

Ton problème vient du JRE que tu utilises ou n'utilise pas, que donne
chez toi la commande : dpkg -l "*jre*"


--
============================================= | FRÉDÉRIC MASSOT |
| http://www.juliana-multimedia.com |
| mailto: |
==========================Þbian=GNU/Linux==
--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernard
Le #22189641
Frederic MASSOT wrote:
Bernard

Navigateur : Votre navigateur ne vous garantit pas de pouvoir
déclarer vos revenus en ligne...




J'ai pu déclarer mes impôts sans problème avec la version Squeeze
d'Iceweasel et le certificat.

Le message sur le navigateur est lié à l'User Agent, tu peux utiliser
l'extension User Agent Switcher pour en changer, mais ce n'est pas le
point bloquant.

Ton problème vient du JRE que tu utilises ou n'utilise pas, que donne
chez toi la commande : dpkg -l "*jre*"




çà donne ce qui suit :

:~$ dpkg -l "*jre*"
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
|
État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/H=à garder/besoin Réinstallation/X=les deux (État,Err:
majuscule=mauvais)
||/ Nom Version Description
+++-==============-==============-=========================================== un cacao-oj6-jre <néant> (aucune description n'est disponible)
un default-jre <néant> (aucune description n'est disponible)
un default-jre-he <néant> (aucune description n'est disponible)
ii openjdk-6-jre 6b11-9.1+lenny OpenJDK Java runtime, using Hotspot JIT
ii openjdk-6-jre- 6b11-9.1+lenny OpenJDK Java runtime, using Hotspot
JIT (hea
ii openjdk-6-jre- 6b11-9.1+lenny OpenJDK Java runtime (architecture
independe
ii sun-java5-jre 1.5.0-17-0.1 Sun Java(TM) Runtime Environment (JRE)
5.0 (
un sun-java6-jre <néant> (aucune description n'est disponible)
:~$

Donc j'ai à la fois OpenJDK et Sun Java 5

J'installe Sun Java 6 et je refais le test :

:~$ dpkg -l "*jre*"
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
|
État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/H=à garder/besoin Réinstallation/X=les deux (État,Err:
majuscule=mauvais)
||/ Nom Version Description
+++-==============-==============-=========================================== un cacao-oj6-jre <néant> (aucune description n'est disponible)
un default-jre <néant> (aucune description n'est disponible)
un default-jre-he <néant> (aucune description n'est disponible)
ii openjdk-6-jre 6b11-9.1+lenny OpenJDK Java runtime, using Hotspot JIT
ii openjdk-6-jre- 6b11-9.1+lenny OpenJDK Java runtime, using Hotspot
JIT (hea
ii openjdk-6-jre- 6b11-9.1+lenny OpenJDK Java runtime (architecture
independe
ii sun-java5-jre 1.5.0-17-0.1 Sun Java(TM) Runtime Environment (JRE)
5.0 (
ii sun-java6-jre 6-12-1 Sun Java(TM) Runtime Environment (JRE)
6 (ar
:~$

Avec Sun Java6, çà ne fonctionne toujours pas avec les impôts (=:

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
J
Le #22189651
Le dimanche 30 mai 2010 à 16:46 +0200, Bernard a écrit :
Je dispose donc de Iceweasel 3.06 sous Debian Lenny. Y-a-t-il des
personnes qui ont réussi à faire leur déclaration avec ces outils ?



Utiliser openjdk-6-jre + icedtea6-plugin
ou bien sun-java6-jre + sun-java6-plugin
mais pas gcj

Pour changer de version de java quand on en a plusieurs, en root :
update-alternatives --config java

pour vérifier dans iceweasel, regarde dans les addons, onglet plugins.


--
Jérôme -

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Sylvain Sauvage
Le #22190231
Jérôme, dimanche 30 mai 2010, 18:03:13 CEST
[…]
Pour changer de version de java quand on en a plusieurs, en root :
update-alternatives --config java

pour vérifier dans iceweasel, regarde dans les addons, onglet plugin s.



Et de ce fait l’alternative mozilla-javaplugin.so (ou
pluginappletviewer ?).

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Stephane Bortzmeyer
Le #22190921
On Sun, May 30, 2010 at 04:46:44PM +0200,
Bernard a message of 53 lines which said:

La bonne surprise, le piège, même, car c'est le dernier jour...



Euh, ce n'est pas ce que je vois sur la doc'. Elle dit que la date
limite est du 10 au 24 juin, selon le département.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Frederic MASSOT
Le #22191151
Le 30/05/2010 18:03, Jérôme a écrit :
Le dimanche 30 mai 2010 à 16:46 +0200, Bernard a écrit :
Je dispose donc de Iceweasel 3.06 sous Debian Lenny. Y-a-t-il des
personnes qui ont réussi à faire leur déclaration avec ces outils ?



Utiliser openjdk-6-jre + icedtea6-plugin
ou bien sun-java6-jre + sun-java6-plugin
mais pas gcj

Pour changer de version de java quand on en a plusieurs, en root :
update-alternatives --config java

pour vérifier dans iceweasel, regarde dans les addons, onglet plugins.



Tu peux aussi regarder du coté du paquet "default-jre".

--
============================================= | FRÉDÉRIC MASSOT |
| http://www.juliana-multimedia.com |
| mailto: |
==========================Þbian=GNU/Linux==
--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernard
Le #22191541
Stephane Bortzmeyer wrote:
On Sun, May 30, 2010 at 04:46:44PM +0200,
Bernard a message of 53 lines which said:


La bonne surprise, le piège, même, car c'est le dernier jour...




Euh, ce n'est pas ce que je vois sur la doc'. Elle dit que la date
limite est du 10 au 24 juin, selon le département.




Certes, ce que j'ai voulu dire, c'est qu'au cas où je n'arriverais pas à
déboguer la situation avec ma tentative de déclaration via Internet,
demain était le dernier jour pour faire une déclaration papier classique.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
deb
Le #22192151
On 05/30/2010 06:03 PM, Jérôme wrote:
Le dimanche 30 mai 2010 à 16:46 +0200, Bernard a écrit :
Je dispose donc de Iceweasel 3.06 sous Debian Lenny. Y-a-t-il des
personnes qui ont réussi à faire leur déclaration avec ces outils ?



Utiliser openjdk-6-jre + icedtea6-plugin
ou bien sun-java6-jre + sun-java6-plugin
mais pas gcj


De mon côté, j'ai dû mettre à jour sun-java6-plugin. Mais comme je suis
sous unstable, ça ne t'avancera pas bcp :-(


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme