Déclaration des revenus. Plugin Java 1.6.0_07-b06

Le
Dominique
Bonsoir,

Linux 2.6, Firefox 3.0.10

Je n'arrive pas à signer ma déclaration de revenus. J'ai manifestement
un problème de plugin Java.

Je recherche le plugin 1.6.0_07-b06 que je trouve en plusieurs endroits.
Je le vire de partout.

Je n'ai plus, dans $HOME/mozilla/plugins que :

-rwxr-xr-x 1 normal normal 8115888 2009-04-08 20:06 libflashplayer.so
lrwxrwxrwx 1 normal normal 45 2009-04-22 10:26 libnpsoplugin.so ->
/opt/openoffice.org3/program/libnpsoplugin.so

Dans /usr/var/lib/mozilla/plugins, je n'ai plus rien.

Et bien about:plugins me trouve toujours le Plugin Java 1.6.0_07-b06

Pourtant :
normal@normal-laptop:~$ locate libjavaplugin_oji
/home/normal/messcripts/jre1.6.0_13/plugin/i386/ns7/libjavaplugin_oji.so
/home/normal/messcripts/jre1.6.0_13/plugin/i386/ns7-gcc29/libjavaplugin_oji.so
/usr/lib/jvm/java-6-sun-1.6.0.07/jre/plugin/i386/ns7/libjavaplugin_oji.so
/usr/lib/jvm/java-6-sun-1.6.0.07/jre/plugin/i386/ns7-gcc29/libjavaplugin_oji.so

m'indique bien que je n'ai plus de lien symbolique vers le plugin !

Et si je crée un lien symbolique avec la version 1.6.0_13 que j'ai
chargée, about:plugins persiste à ne me trouver que la version
précédente, information confirmée par Java

En détaillant un peu plus :

/usr/lib/iceweasel/plugins/libjavaplugin.so
/usr/lib/jvm/java-6-sun-1.6.0.07/jre/lib/i386/libjavaplugin_jni.so
/usr/lib/jvm/java-6-sun-1.6.0.07/jre/lib/i386/libjavaplugin_nscp.so
/usr/lib/jvm/java-6-sun-1.6.0.07/jre/lib/i386/libjavaplugin_nscp_gcc29.so
/usr/lib/jvm/java-6-sun-1.6.0.07/jre/plugin/i386/ns7/libjavaplugin_oji.so
/usr/lib/jvm/java-6-sun-1.6.0.07/jre/plugin/i386/ns7-gcc29/libjavaplugin_oji.so
/usr/lib/midbrowser/plugins/libjavaplugin.so
/usr/lib/mozilla/plugins/libjavaplugin_oji.so
/usr/lib/xulrunner/plugins/libjavaplugin.so
/usr/lib/xulrunner-addons/plugins/libjavaplugin.so

En cherchant vers xulrunner, j'ai ça :

normal@normal-laptop:/usr/lib/xulrunner/plugins$ ls -l
total 0
lrwxrwxrwx 1 root root 41 2009-04-05 18:30 libjavaplugin.so ->
/etc/alternatives/xulrunner-javaplugin.so

En fait, les 4 dernières lignes /usr/lib pointent cette version «
alternative »

Est-ce ici que se trouverait une version frelatée de Java ? si oui,
comment réparer ça ?

Sinon, j'ai une panne d'inspiration : où peut bien se cacher ce lien
vers l'ancienne version de jre ?

Merci pour votre aide et bonne soirée,
--
Dominique
Esto quod es
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Dominique
Le #19439581
Bonjour,

J'ai trouvé : il me fallait virer le plugin java installé par apt-get...

J'ai pu pointer mon plugin libjavaplugin_oji.so vers la version 1.6.0_13
de JRE.

Ma déclaration est signée mais le site des impôts trébuche sur une ou
plusieurs extensions. Lesquelles ? Mystère !

Alors, j'ai fait simple. j'ai créé un profil Firefox (firefox -P)
vierge, j'ai importé mes certificats et j'ai signé ma déclaration.

C'est la première année où je rencontre de telles difficultés.

Bonne journée à tous,

--
Dominique
Esto quod es
Publicité
Poster une réponse
Anonyme