Démarrage auto du WLAN

Le
Debellez
Bonjour,

Je suis sous Xubuntu 7.04i386

J'ai paramétré mon wlan avec succès :

voici mon fichier /etc/network/interfaces

*************************************************************************
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo eth0 eth1
iface lo inet loopback

iface eth1 inet dhcp
wpa-driver wext
wpa-key-mgmt WPA-PSK
wpa-ssid XXXXXXXXXX
wpa-psk YYYYYYYYYY

iface eth0 inet dhcp
# address 192.168.1.111
# netmask 255.255.255.0
# gateway 192.168.1.254
**************************************************************************

Après chaque démarrage de l'ordi, je suis obligé de faire :

$sudo ifup eth1

pour lancer la connexion.

Comment établir la connexion automatiquement ?

Merci d'avance.
Debellez
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
didier
Le #1900840
Le Wed, 12 Sep 2007 12:17:13 +0000, Debellez a écrit:

Bonjour,

Je suis sous Xubuntu 7.04i386

J'ai paramétré mon wlan avec succès :

voici mon fichier /etc/network/interfaces

*************************************************************************
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo eth0 eth1
iface lo inet loopback

iface eth1 inet dhcp
wpa-driver wext
wpa-key-mgmt WPA-PSK
wpa-ssid XXXXXXXXXX
wpa-psk YYYYYYYYYY

iface eth0 inet dhcp
# address 192.168.1.111
# netmask 255.255.255.0
# gateway 192.168.1.254
**************************************************************************

Après chaque démarrage de l'ordi, je suis obligé de faire :

$sudo ifup eth1

pour lancer la connexion.

Comment établir la connexion automatiquement ?

Merci d'avance.
Debellez


écrire « ifup eth1 » dans /etc/rc.local ?
chez moi ça marche presque toujours,
sans que je sache pourquoi ça ne marche pas
de temps en temps...

Didier.

Mihamina (R12y) Rakotomandimby
Le #1900838
didier wrote:

écrire « ifup eth1 » dans /etc/rc.local ?


Ca peut etre plus interessant de savoir pourquoi ça marche "de temps en
temps"...

didier
Le #1900834
Le Wed, 12 Sep 2007 19:21:00 +0200, Mihamina (R12y) Rakotomandimby a
écrit:

didier wrote:

écrire « ifup eth1 » dans /etc/rc.local ?


Ca peut etre plus interessant de savoir pourquoi ça marche "de temps en
temps"...


Je pensais que c'était dans /etc/rc.local qu'il fallait mettre
les commandes à lancer au démarrage avec les privilèges de root.
Aurais-je mal compris ?

Didier.


Nicolas George
Le #1900831
didier wrote in message
Je pensais que c'était dans /etc/rc.local qu'il fallait mettre
les commandes à lancer au démarrage avec les privilèges de root.
Aurais-je mal compris ?


Tu te trompes sur deux points.

D'une part, rc.local, c'est un foutoir où mettre des commandes en vrac. Pour
exécuter quelque chose proprement, il vaut mieux l'intégrer au démarrage
SysV standard. Bon, c'est mineur.

D'autre part, et c'est là qu'est ton erreur : l'activation du réseau est
normalement déjà appelée pendant le processus de boot. Si elle ne se fait
pas, c'est qu'il y a un problème quelque part. Rajouter la commande à un
autre endroit, ça peut cacher le problème, mais ça ne le résout pas. Ce
n'est pas fiable, ça peut se mettre à échouer sans prévenir.

Debellez
Le #1900826
Nicolas George $:

Si elle ne se fait
pas, c'est qu'il y a un problŠme quelque part.


Merci pour vos réponses.


Une piste pour déceler à quel moment il y a un dsfonctionnement ?

Cordialement.

Mihamina (R12y) Rakotomandimby
Le #1900825
Debellez wrote:
Une piste pour déceler à quel moment il y a un dsfonctionnement ?


/var/log/messages

Moi aussi ce que je fais, c'est que pour tester, je fais un script qui
décharge le module, le charge et "up" l'interface dans la foulée. Ca
reproduit de loin ce qui se passe au boot (ou tout s'enchaine et tout...).
C'est grace à cette méthode, dans un lointain passé, quand j'avais
encore les vieux modems USB speedtouch que j'ai su qu'il falait vraiment
introduire une temporisation entre le chargemant des modules et
l'utilisation des ports USB par le modem (chargement firmware, etc...).
Je n'avais pas forcément l'explication technique, mais je savais qu'il
fallait temporiser. Ce que le la sequence de boot ne fais pas.

D'ailleurs, rc.local est executé à la fin de la sequence de boot,...
largement suffisant si besoin de temporiser. Mais c'est quand meme mieux
de spécifier ça ailleurs dans le cas présent.

Publicité
Poster une réponse
Anonyme