La dépendance ne peut-être satisfaite...

Le
Une Bévue
je souhaite installer "instantreality" par
"InstantReality-Ubuntu-12.04-x64-2.2.0.24102.deb" la logithèque ubuntu
me dit :

La dépendance ne peut-être satisfaite libboost-date-time1.46.1 (>=1.46.1)

Mais, justement, je viens d'installer "libboost-date-time1.50.0".

c'est quoi le pb dans ce cas ?
--
L'homme est imparfait, mais ce n'est pas étonnant
quand on pense à l'époque où il a été créé.
— Alphonse Allais
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jacques_guezenec
Le #25026392
Le 05/12/2012 10:00, Une Bévue a écrit :
je souhaite installer "instantreality" par
"InstantReality-Ubuntu-12.04-x64-2.2.0.24102.deb" la logithèque ubuntu
me dit :

La dépendance ne peut-être satisfaite libboost-date-time1.46.1 (>=1.46.1)

Mais, justement, je viens d'installer "libboost-date-time1.50.0".

c'est quoi le pb dans ce cas ?
--
L'homme est imparfait, mais ce n'est pas étonnant
quand on pense à l'époque où il a été créé.
— Alphonse Allais


C'est clair pourtant : tu dois installer la 1.46 et non la 1.50. :)
Nicolas George
Le #25026452
jacques_guezenec , dans le message
La dépendance ne peut-être satisfaite libboost-date-time1.46.1 (>=1.46.1)



C'est clair pourtant : tu dois installer la 1.46 et non la 1.50. :)



Ce n'est pas ça qui est marqué, non.
Une Bévue
Le #25026602
Le 05/12/12 22:25, jacques_guezenec a écrit :
C'est clair pourtant : tu dois installer la 1.46 et non la 1.50. :)


ben non, pas du tout, pour moi ">=1.46.1" veut dire *plus grand* ou
égal, non ?

--
L'homme est imparfait, mais ce n'est pas étonnant
quand on pense à l'époque où il a été créé.
— Alphonse Allais
Francois Lafont
Le #25026772
Bonsoir,

Le 05/12/2012 10:00, Une Bévue a écrit :
je souhaite installer "instantreality" par
"InstantReality-Ubuntu-12.04-x64-2.2.0.24102.deb" la logithèque ubuntu
me dit :

La dépendance ne peut-être satisfaite libboost-date-time1.46.1 (>=1.46.1)

Mais, justement, je viens d'installer "libboost-date-time1.50.0".



Je crois qu'il y a toute les raisons de te faire confiance mais bon,
juste au cas où, que te donne ceci ?

dpkg -l | grep libboost

--
François Lafont
Une Bévue
Le #25026842
Le 06/12/2012 01:36, Francois Lafont a écrit :
dpkg -l | grep libboost



ça me donne :

ii libboost-date-time1.50.0 1.50.0-1
amd64 set of date-time
libraries based on generic programming concepts
ii libboost-program-options1.49.0
1.49.0-3.1ubuntu1.1 amd64 program options
library for C++
ii libboost-python1.49.0
1.49.0-3.1ubuntu1.1 amd64 Boost.Python Library
ii libboost-regex1.49.0
1.49.0-3.1ubuntu1.1 amd64 regular
expression library for C++
ii libboost-signals1.49.0
1.49.0-3.1ubuntu1.1 amd64 managed signals
and slots library for C++
ii libboost-system1.49.0
1.49.0-3.1ubuntu1.1 amd64 Operating system
(e.g. diagnostics support) library
ii libboost-thread1.49.0
1.49.0-3.1ubuntu1.1 amd64 portable C++
multi-threading

sans doute un bug dans le package alors ?
--
L'homme est imparfait, mais ce n'est pas étonnant
quand on pense à l'époque où il a été créé.
— Alphonse Allais
Jules ALIX.
Le #25026992
Le 05/12/2012 10:00, Une Bévue a écrit :
je souhaite installer "instantreality" par
"InstantReality-Ubuntu-12.04-x64-2.2.0.24102.deb" la logithèque ubuntu
me dit :

La dépendance ne peut-être satisfaite libboost-date-time1.46.1 (>=1.46.1)

Mais, justement, je viens d'installer "libboost-date-time1.50.0".

c'est quoi le pb dans ce cas ?
--
L'homme est imparfait, mais ce n'est pas étonnant
quand on pense à l'époque où il a été créé.
— Alphonse Allais



créez un raccourci "link" dont son nom de fichier est celui
dont tu as besoin, et bien sur il doit pointer vers ta version
de lib. sinon, copier coller, de la tienne que tu renommes.

au moins t'as pas une série de chmod 7777 à faire...c'est déjà
ça.

--

Sincèrement,

Jules ALIX

"La terre finira par nous rire au nez, bandes de Charognards !"

--- news://freenews.netfront.net/ - complaints: ---
Pascal Hambourg
Le #25027082
Salut,

Une Bévue a écrit :

La dépendance ne peut-être satisfaite libboost-date-time1.46.1 (>=1.46.1)

Mais, justement, je viens d'installer "libboost-date-time1.50.0".

c'est quoi le pb dans ce cas ?



Pas le même nom, donc ce sont deux paquets différents et non deux
versions différentes du même paquet.
Une Bévue
Le #25027212
Le 06/12/2012 09:29, Pascal Hambourg a écrit :
Pas le même nom, donc ce sont deux paquets différents et non deux
versions différentes du même paquet.



euh, là, je suis largué, je ne vois pas en quoi le nom de
"libboost-date-time1.46.1" diffère de "libboost-date-time1.50.0" mis à
part la version... ???

d'autant que le "(>=1.46.1)" m'indique bien une version non ?

--
L'homme est imparfait, mais ce n'est pas étonnant
quand on pense à l'époque où il a été créé.
— Alphonse Allais
Une Bévue
Le #25027202
Le 06/12/2012 08:25, Jules ALIX. a écrit :
créez un raccourci "link" dont son nom de fichier est celui
dont tu as besoin, et bien sur il doit pointer vers ta version
de lib. sinon, copier coller, de la tienne que tu renommes.



très bonne idée mais est-ce raisonnable vu que Pascal Hambourg m'indique
que "libboost-date-time1.46.1" et "libboost-date-time1.50.0" sont deux
paquets différents.

euh, ce matin, je n'ai pas bu de calva ;-)

--
L'homme est imparfait, mais ce n'est pas étonnant
quand on pense à l'époque où il a été créé.
— Alphonse Allais
yamo'
Le #25027292
Salut,

Une Bévue a tapoté, le 06/12/2012 10:11:
Le 06/12/2012 08:25, Jules ALIX. a écrit :
créez un raccourci "link" dont son nom de fichier est celui




très bonne idée mais est-ce raisonnable vu que Pascal Hambourg m'indique
que "libboost-date-time1.46.1" et "libboost-date-time1.50.0" sont deux
paquets différents.

euh, ce matin, je n'ai pas bu de calva ;-)



Ou alors, tu peux installer à la main ce fichu paquet :



--
Stéphane BOFH excuse #214:

Fluorescent lights are generating negative ions. If turning them off
doesn't work, take them out and put tin foil on the ends.
Publicité
Poster une réponse
Anonyme