depuis mon changement de Livebox Sagem>Inventel, FTP passif

Le
METIS
Bonjour,
depuis que l'on m'a changé la Livebox Sagem pour une
Inventel, je ne peux plus télécharger en FTP qu'en mode
passif vers mes différents hébergeurs.
Il doit y avoir une histoire de port ou de permission ché
pas quoi
Je ne suis pas bon du tout en réseaux et autre code,
pouvez-vous m'expliquer simplement.
Merci d'avance pour les aides à venir.

--
<|[;o)) METIS
http://www.graphM.com
Pour m'écrire en privé, mettez-moi des oranges
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
METIS
Le #16342101
METIS wrote:
Bonjour,
depuis que l'on m'a changé la Livebox Sagem pour une
Inventel, je ne peux plus télécharger en FTP qu'en mode
passif vers mes différents hébergeurs.
Il doit y avoir une histoire de port ou de permission ché
pas quoi...
Je ne suis pas bon du tout en réseaux et autre code,
pouvez-vous m'expliquer simplement.
Merci d'avance pour les aides à venir.



==>Bon, j'ai trouvé, c'est particulier sur la Livebox
Inventel, ça marche pas tout seul comme avec la Sagem.
Explications ici.
http://www.bichofeo.com/22.htm
Maintenant, ça marche !
Merci le Net(;o)))))))

--
<|[;o)) METIS
http://www.graphM.com
Pour m'écrire en privé, mettez-moi des oranges...
METIS
Le #16342111
METIS wrote:
Bonjour,
depuis que l'on m'a changé la Livebox Sagem pour une
Inventel, je ne peux plus télécharger en FTP qu'en mode
passif vers mes différents hébergeurs.
Il doit y avoir une histoire de port ou de permission ché
pas quoi...
Je ne suis pas bon du tout en réseaux et autre code,
pouvez-vous m'expliquer simplement.
Merci d'avance pour les aides à venir.



==>Bon, j'ai trouvé, c'est particulier sur la Livebox
Inventel, ça marche pas tout seul comme avec la Sagem.
Explications ici.
http://www.bichofeo.com/22.htm
Maintenant, ça marche !
Merci le Net(;o)))))))

--
<|[;o)) METIS
http://www.graphM.com
Pour m'écrire en privé, mettez-moi des oranges...
Pascal Hambourg
Le #16343171
Salut,

METIS a écrit :
depuis que l'on m'a changé la Livebox Sagem pour une
Inventel, je ne peux plus télécharger en FTP qu'en mode
passif vers mes différents hébergeurs.



==>Bon, j'ai trouvé, c'est particulier sur la Livebox
Inventel, ça marche pas tout seul comme avec la Sagem.
Explications ici.
http://www.bichofeo.com/22.htm



Euh, ce réglage est nécessaire pour un serveur FTP derrière une Livebox
(et quel que soit son modèle), pas pour un client. Là tu ouvres l'accès
depuis l'extérieur au port 21 de ton PC. Je n'ai pas besoin de ce
réglage sur ma Livebox Inventel pour faire du FTP en mode actif.
METIS
Le #16343531
Pascal Hambourg wrote:
Salut,

METIS a écrit :
==>Bon, j'ai trouvé, c'est particulier sur la Livebox
Inventel, ça marche pas tout seul comme avec la Sagem.
Explications ici.
http://www.bichofeo.com/22.htm



Euh, ce réglage est nécessaire pour un serveur FTP
derrière une Livebox (et quel que soit son modèle), pas
pour un client. Là tu ouvres l'accès depuis l'extérieur
au port 21 de ton PC. Je n'ai pas besoin de ce réglage
sur ma Livebox Inventel pour faire du FTP en mode actif.



==>Oui, c'est vrai, je viens de refaire un essai, ça fait
juste semblant de marcher.
Ca envoie quelque chose, il y a bien des fichiers transférés
sur le serveur distant, mais ils ne fonctionnent pas...

Bon, comment j'ouvre le prot 21...?
Scuze, chui nul en réseau et codage.

--
<|[;o)) METIS
http://www.graphM.com
Pour m'écrire en privé, mettez-moi des oranges...
Pascal Hambourg
Le #16351071
METIS a écrit :

Oui, c'est vrai, je viens de refaire un essai, ça fait
juste semblant de marcher.
Ca envoie quelque chose, il y a bien des fichiers transférés
sur le serveur distant, mais ils ne fonctionnent pas...



Mais encore ? Que contiennent-ils ? Pas d'erreur signalée ?

Bon, comment j'ouvre le port 21...?



Si le FTP en mode passif fonctionne, il n'y a rien à toucher au port 21.
Quel logiciel client FTP utilises-tu ? Avais-tu fait des réglages
particuliers pour le mode actif (ports, adresse) ?

Que donnent les transferts :
- en mode actif depuis le serveur
- en mode actif vers le serveur
- en mode passif depuis le serveur
- en mode passif vers le serveur ?
METIS
Le #16354001
Pascal Hambourg wrote:
METIS a écrit :

Oui, c'est vrai, je viens de refaire un essai, ça fait
juste semblant de marcher.
Ca envoie quelque chose, il y a bien des fichiers
transférés sur le serveur distant, mais ils ne
fonctionnent pas...



Mais encore ? Que contiennent-ils ? Pas d'erreur signalée?



Ils sont présent sur le serveur mais avec un poids 10x
inférieur.
Pas d'erreur signalée...

Bon, comment j'ouvre le port 21...?



Si le FTP en mode passif fonctionne, il n'y a rien à
toucher au port 21. Quel logiciel client FTP utilises-tu
? Avais-tu fait des réglages particuliers pour le mode
actif (ports, adresse) ?



==> Le problème, c'est que chez l'un de mes hébergeurs
(serveur sous loué à un pote), il ne peut pas (?) accepter
le mode passif...

Que donnent les transferts :
- en mode actif depuis le serveur



Très rapide...

- en mode actif vers le serveur



Très lent ou foireux...

- en mode passif depuis le serveur



Pas permis...

- en mode passif vers le serveur ?



Pas permis...

--
<|[;o)) METIS
http://www.graphM.com
Pour m'écrire en privé, mettez-moi des oranges...
Pascal Hambourg
Le #16358901
METIS a écrit :
Ca envoie quelque chose, il y a bien des fichiers
transférés sur le serveur distant, mais ils ne
fonctionnent pas...


Mais encore ? Que contiennent-ils ? Pas d'erreur signalée?



Ils sont présent sur le serveur mais avec un poids 10x
inférieur.



Vraiment 10% quelle que soit la taille d'origine ?
Que contiennent-ils ? Le début du fichier d'origine, un octet sur 10,
n'immporte quoi... ?

==> Le problème, c'est que chez l'un de mes hébergeurs
(serveur sous loué à un pote), il ne peut pas (?) accepter
le mode passif...

Que donnent les transferts :
- en mode actif depuis le serveur



Très rapide...



Et le fichier récupéré est bon ?

- en mode actif vers le serveur



Très lent ou foireux...



On dirait un problème de MTU/MSS.

- en mode passif depuis le serveur



Pas permis...

- en mode passif vers le serveur ?



Pas permis...



Alors comment sais-tu que le mode passif marche ? Il y a bien un serveur
dans le lot qui l'accepte ? Que donnent les tests avec ce serveur ?
METIS
Le #16361351
Pascal Hambourg wrote:
Alors comment sais-tu que le mode passif marche ? Il y a
bien un serveur dans le lot qui l'accepte ? Que donnent
les tests avec ce serveur ?



J'ai pas dis que le mode passif marche, sur ce serveur, les
réglages sont tels que ce n'est pas permis.

Mais depuis que j'ai ouvert les ports 20 et 21 dans la
Livebox Inventel, ça remarche normalement (en non passif).

Si tu veux on peut continuer les investigations ?
Merci en tout cas pour l'aide.

--
<|[;o)) METIS
http://www.graphM.com
Pour m'écrire en privé, mettez-moi des oranges...
Pascal Hambourg
Le #16362501
METIS a écrit :
Pascal Hambourg wrote:
Alors comment sais-tu que le mode passif marche ? Il y a
bien un serveur dans le lot qui l'accepte ? Que donnent
les tests avec ce serveur ?



J'ai pas dis que le mode passif marche, sur ce serveur, les
réglages sont tels que ce n'est pas permis.



Tu as écrit dans ton premier message "je ne peux plus télécharger en FTP
qu'en mode passif vers mes différents hébergeurs." Donc il y a bien au
moins un des hébergeurs avec lesquels le mode passif est possible et
fonctionne, non ?

Mais depuis que j'ai ouvert les ports 20 et 21 dans la
Livebox Inventel, ça remarche normalement (en non passif).



Ouverts comment ? Redirigés vers l'adresse du poste client ?
Ce n'est pas logique du tout. Les ports 20 et 21 sont côté serveur, pas
client. D'autre part l'établissement d'une connexion de données en mode
actif, les ports utilisés... sont strictement identiques que ce soit
pour un upload ou un download. Or tu as écrit que ça marche en download
mais pas en upload. Tout ça n'est pas logique du tout...
METIS
Le #16364941
Pascal Hambourg wrote:
METIS a écrit :
Pascal Hambourg wrote:
Alors comment sais-tu que le mode passif marche ? Il y a
bien un serveur dans le lot qui l'accepte ? Que donnent
les tests avec ce serveur ?



J'ai pas dis que le mode passif marche, sur ce serveur,
les réglages sont tels que ce n'est pas permis.



Tu as écrit dans ton premier message "je ne peux plus
télécharger en FTP qu'en mode passif vers mes différents
hébergeurs." Donc il y a bien au moins un des hébergeurs
avec lesquels le mode passif est possible et fonctionne,
non ?



==> Oui, j'ai des sites sur Nuxit et OVH, là ça marchait en
passif.

Mais depuis que j'ai ouvert les ports 20 et 21 dans la
Livebox Inventel, ça remarche normalement (en non
passif).



Ouverts comment ? Redirigés vers l'adresse du poste
client ? Ce n'est pas logique du tout. Les ports 20 et 21
sont
côté serveur, pas client. D'autre part l'établissement
d'une connexion de données en mode actif, les ports
utilisés... sont strictement identiques que ce soit pour
un upload ou un download. Or tu as écrit que ça marche en
download mais pas en upload. Tout ça n'est pas logique du
tout...



==>Certes, mais je suis venu ici demander de l'aide car je
ne connais pas grand chose en réseau...
De ce fait, je ne contrôle pas tout ce que je fais.

J'ai fait ça :
Donc Livebox Inventel
Configuration>Avancée>Routeur
Service FTP
Protocole TCP
Port externe 20
Port interne 21
Adresse IP du serveur 192.168.1.120

Voilà...

--
<|[;o)) METIS
http://www.graphM.com
Pour m'écrire en privé, mettez-moi des oranges...
Publicité
Poster une réponse
Anonyme