désactiver une carte vidéo

Le
François Patte
Bonjour,

J'ai un ordinateur portable muni de 2 cartes vidéo dont une intégrée:

VGA compatible controller: Intel Corporation Haswell Integrated Graphics
Controller (rev 06)
VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Mars
[Radeon HD 8790M]

Je voudrais configurer la deuxième (ATI) et charger le pilote fglrx associé.

Le pilote propriétaire se compile et peut se charger (presque) sans
problème, mais il est imossible de s'en servir, le fichier Xorg.0.log
montre une erreur fatale:

(EE) fglrx(0): Unspported by intel driver! vendor id 0×8086, device id
0×416

Je soupçonne que la carte intel est à l'origine du problème; je ne peux
pas la désactiver dans le bios (du moins je n'ai pas trouvé comment).

Comment peut-on désactiver cette carte (intégrée) au démarrage de la
machine, pour voir si ça marche sans elle?


Merci.
--
François Patte
Université Paris Descartes
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
François Patte
Le #26249732
Le 05/07/2014 23:12, François Patte a écrit :
Bonjour,

J'ai un ordinateur portable muni de 2 cartes vidéo dont une intégrée:

VGA compatible controller: Intel Corporation Haswell Integrated Graphics
Controller (rev 06)
VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Mars
[Radeon HD 8790M]

Je voudrais configurer la deuxième (ATI) et charger le pilote fglrx associé.

Le pilote propriétaire se compile et peut se charger (presque) sans
problème, mais il est imossible de s'en servir, le fichier Xorg.0.log
montre une erreur fatale:

(EE) fglrx(0): Unspported by intel driver! vendor id 0×8086, device id
0×416

Je soupçonne que la carte intel est à l'origine du problème; je ne peux
pas la désactiver dans le bios (du moins je n'ai pas trouvé comment...).

Comment peut-on désactiver cette carte (intégrée) au démarrage de la
machine, pour voir si ça marche sans elle?



On ajoute une règle udev:

ACTION=="add", KERNEL=="0000:00:02.0", SUBSYSTEM=="pci", RUN+="/bin/sh
-c 'echo 1 > /sys/bus/pci/devices/0000:00:02.0/remove'"

Et le bus 00:02.0 disparait....

Résultat: ça va mieux, le module intel n'est plus chargé par Xorg et je
n'ai plus erreur fatale mais... ça ne marche toujours pas! Le serveur X
ne démarre pas.

Où puis-je trouvé des experts en log de Xorg?

Merci



--
François Patte
Université Paris Descartes
JKB
Le #26250072
Le Sun, 06 Jul 2014 18:29:48 +0200,
François Patte
Le 05/07/2014 23:12, François Patte a écrit :
Bonjour,

J'ai un ordinateur portable muni de 2 cartes vidéo dont une intégrée:

VGA compatible controller: Intel Corporation Haswell Integrated Graphics
Controller (rev 06)
VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Mars
[Radeon HD 8790M]

Je voudrais configurer la deuxième (ATI) et charger le pilote fglrx associé.

Le pilote propriétaire se compile et peut se charger (presque) sans
problème, mais il est imossible de s'en servir, le fichier Xorg.0.log
montre une erreur fatale:

(EE) fglrx(0): Unspported by intel driver! vendor id 0×8086, device id
0×416

Je soupçonne que la carte intel est à l'origine du problème; je ne peux
pas la désactiver dans le bios (du moins je n'ai pas trouvé comment...).

Comment peut-on désactiver cette carte (intégrée) au démarrage de la
machine, pour voir si ça marche sans elle?



On ajoute une règle udev:

ACTION=="add", KERNEL=="0000:00:02.0", SUBSYSTEM=="pci", RUN+="/bin/sh
-c 'echo 1 > /sys/bus/pci/devices/0000:00:02.0/remove'"

Et le bus 00:02.0 disparait....

Résultat: ça va mieux, le module intel n'est plus chargé par Xorg et je
n'ai plus erreur fatale mais... ça ne marche toujours pas! Le serveur X
ne démarre pas.

Où puis-je trouvé des experts en log de Xorg?



Je ne sais pas. Mais si tu commençais par poster ici les lignes
commençant par EE et WW des logs de Xorg, ça pourrait nous donner
quelques idées...

JKB

--
Si votre demande me parvient sur carte perforée, je titiouaillerai très
volontiers une réponse...
=> http://grincheux.de-charybde-en-scylla.fr
=> http://loubardes.de-charybde-en-scylla.fr
François Patte
Le #26250762
Le 06/07/2014 20:02, JKB a écrit :
Le Sun, 06 Jul 2014 18:29:48 +0200,
François Patte
Le 05/07/2014 23:12, François Patte a écrit :
Bonjour,

J'ai un ordinateur portable muni de 2 cartes vidéo dont une intégrée:

VGA compatible controller: Intel Corporation Haswell Integrated Graphics
Controller (rev 06)
VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Mars
[Radeon HD 8790M]

Je voudrais configurer la deuxième (ATI) et charger le pilote fglrx associé.

Le pilote propriétaire se compile et peut se charger (presque) sans
problème, mais il est imossible de s'en servir, le fichier Xorg.0.log
montre une erreur fatale:

(EE) fglrx(0): Unspported by intel driver! vendor id 0×8086, device id
0×416

Je soupçonne que la carte intel est à l'origine du problème; je ne peux
pas la désactiver dans le bios (du moins je n'ai pas trouvé comment...).

Comment peut-on désactiver cette carte (intégrée) au démarrage de la
machine, pour voir si ça marche sans elle?



On ajoute une règle udev:

ACTION=="add", KERNEL=="0000:00:02.0", SUBSYSTEM=="pci", RUN+="/bin/sh
-c 'echo 1 > /sys/bus/pci/devices/0000:00:02.0/remove'"

Et le bus 00:02.0 disparait....

Résultat: ça va mieux, le module intel n'est plus chargé par Xorg et je
n'ai plus erreur fatale mais... ça ne marche toujours pas! Le serveur X
ne démarre pas.

Où puis-je trouvé des experts en log de Xorg?



Je ne sais pas. Mais si tu commençais par poster ici les lignes
commençant par EE et WW des logs de Xorg, ça pourrait nous donner
quelques idées...



Je veux bien, mais il y en a fort peu...

EE y en a point.

WW très peu:
[ 12.204] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not
exist.
[ 12.243] (WW) The directory
"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[ 12.244] (WW) "intel_drv" will not be loaded unless you've specified
it to be loaded elsewhere.
[ 12.673] (WW) Falling back to old probe method for fglrx
[ 20.853] (WW) fglrx(0): board is an unknown third party board,
chipset is supported
[ 20.992] (WW) fglrx(0): Option "VendorName" is not used
[ 20.992] (WW) fglrx(0): Option "ModelName" is not used

Ça me paraît anecdotique, sauf peut-être:

(WW) fglrx(0): board is an unknown third party board, chipset is supported

Mais qui semble dire que la carte est acceptée.

J'hésite à poster tout le fichier qui fait 737 lignes....


--
François Patte
Université Paris Descartes
Lucas Levrel
Le #26255162
Le 6 juillet 2014, François Patte a écrit :

Résultat: ça va mieux, le module intel n'est plus chargé par Xorg et je
n'ai plus erreur fatale mais... ça ne marche toujours pas! Le serveur X
ne démarre pas.







Sans fichier de config, est-ce que ça démarre ? (Tu sembles dire que tu le
forces à charger fglrx qu'il ne chargerait pas de lui-même.)

J'hésite à poster tout le fichier qui fait 737 lignes....



Pourquoi pas. Et si tu coupes la liste des modes supportés par l'écran
et/ou la carte, ça sera déjà plus court !

--
LL
Ἕν οἶδα ὅτι οὐδὲν οἶδα (Σωκράτης)
C'est mieux avé les accents (F. Patte)
Publicité
Poster une réponse
Anonyme