Désactiver champs d'un sous formulaire

Le
Benoit1024
bonjour,

j'ai un formulaire qui contient un sous-formulaire dans lequel on trouve un
seul champs.
j'ai une liste déroulante où le sélectionne la donnée que je veux afficher.
quand le formulaire s'ouvre, il est en "lecture seule" toutes les données
sont grisées sauf la liste déroulante du formulaire.
tout s'active quand je sélectionne une donnée dans la liste.

le seul problème et que je ne parviens pas à désactiver le champs du
sous-formulaire.
j'ai essayé :
F_Num_Interne_SF_Utilisateur.Enabled = False
ou
Forms!F_Num_Interne_SF_Utilisateur!UTIL_Utilisateur.Enabled = false

mais rien ne fonctionne, comment faut-il faire ?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Thierry (ze Titi)
Le #6330311
Bonjour Benoit1024 !

Tout est décrit ici:
http://www.mvps.org/accessfr/forms/frm0031.htm

Dans ton cas, tu auras quelque chose comme:
Me!F_Num_Interne_SF_Utilisateur.Form!Util_Utilisateur.Enabledúlse


Message du mercredi 07/11/2007

bonjour,

j'ai un formulaire qui contient un sous-formulaire dans lequel on trouve un
seul champs.
j'ai une liste déroulante où le sélectionne la donnée que je veux afficher.
quand le formulaire s'ouvre, il est en "lecture seule" toutes les données
sont grisées sauf la liste déroulante du formulaire.
tout s'active quand je sélectionne une donnée dans la liste.

le seul problème et que je ne parviens pas à désactiver le champs du
sous-formulaire.
j'ai essayé :
F_Num_Interne_SF_Utilisateur.Enabled = False
ou
Forms!F_Num_Interne_SF_Utilisateur!UTIL_Utilisateur.Enabled = false

mais rien ne fonctionne, comment faut-il faire ?


--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info

Benoit1024
Le #6330271
Bonjour,

Merci de ta réponse, mais cela ne fonctionne pas :(
la fenêtre de débogage s'ouvre et sélectionne la ligne
Me!F_Num_Interne_SF_Utilisateur.Form!UTIL_Utilisateur.Enabled = False


Bonjour Benoit1024 !

Tout est décrit ici:
http://www.mvps.org/accessfr/forms/frm0031.htm

Dans ton cas, tu auras quelque chose comme:
Me!F_Num_Interne_SF_Utilisateur.Form!Util_Utilisateur.Enabledúlse


Message du mercredi 07/11/2007

bonjour,

j'ai un formulaire qui contient un sous-formulaire dans lequel on trouve un
seul champs.
j'ai une liste déroulante où le sélectionne la donnée que je veux afficher.
quand le formulaire s'ouvre, il est en "lecture seule" toutes les données
sont grisées sauf la liste déroulante du formulaire.
tout s'active quand je sélectionne une donnée dans la liste.

le seul problème et que je ne parviens pas à désactiver le champs du
sous-formulaire.
j'ai essayé :
F_Num_Interne_SF_Utilisateur.Enabled = False
ou
Forms!F_Num_Interne_SF_Utilisateur!UTIL_Utilisateur.Enabled = false

mais rien ne fonctionne, comment faut-il faire ?


--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info






Thierry (ze Titi)
Le #6330251
Merci de ta réponse, mais cela ne fonctionne pas :(
Il faudrait chercher un peu, ça ne m'aide pas beaucoup ce que tu me

dis!
La formule est du type:

Me!LeSousFormulaire.Form!LeContrôle.Enabledúlse

A adapter.

--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info

Benoit1024
Le #6330221
c'est bien ça
je suis dans le formulaire "F_Num_Interne", j'ai un sous formulaire
"F_Num_Interne_SF_Utilisateur" avec le champs "UTIL_Utilisateur"

quand j'ouvre "F_Num_Interne" je désactive tout les éléments de ce
formualire et je soudrais faire pareil avec le champs du sous-formulaire.

j'ai essayé :
Me![F_Num_Interne_SF_Utilisateur].Form![UTIL_Utilisateur].Enabled = False

mais cela ne fonctionne pas...


Merci de ta réponse, mais cela ne fonctionne pas :(
Il faudrait chercher un peu, ça ne m'aide pas beaucoup ce que tu me

dis!
La formule est du type:

Me!LeSousFormulaire.Form!LeContrôle.Enabledúlse

A adapter.

--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info






Thierry (ze Titi)
Le #6330201
mais cela ne fonctionne pas...
Encore une fois, c'est vague ! Ca veut dire quoi ? Ca plante, tu as un

message d'erreur, il ne se passe rien ? Précise un peu, s'il te
plaît...
Tu ne serais pas en mode feuille de données par hasard ?

En ce jour mémorable du mercredi 07/11/2007, tu as émis l'idée
suivante:
c'est bien ça
je suis dans le formulaire "F_Num_Interne", j'ai un sous formulaire
"F_Num_Interne_SF_Utilisateur" avec le champs "UTIL_Utilisateur"

quand j'ouvre "F_Num_Interne" je désactive tout les éléments de ce
formualire et je soudrais faire pareil avec le champs du sous-formulaire.

j'ai essayé :
Me![F_Num_Interne_SF_Utilisateur].Form![UTIL_Utilisateur].Enabled = False

mais cela ne fonctionne pas...


Merci de ta réponse, mais cela ne fonctionne pas :(
Il faudrait chercher un peu, ça ne m'aide pas beaucoup ce que tu me

dis!
La formule est du type:

Me!LeSousFormulaire.Form!LeContrôle.Enabledúlse

A adapter.

--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info






--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info



Benoit1024
Le #6330191
merci de ta patience,
quand j'ouvre le formulaire "F_Num_Interne", une fenêtre de débogage s'ouvre
avec la ligne
"Me![F_Num_Interne_SF_Utilisateur].Form![UTIL_Utilisateur].Enabled = False"
sélectionné
si je supprime cette ligne le formulaire s'ouvre normalement, mais avec le
champs actif.


mais cela ne fonctionne pas...
Encore une fois, c'est vague ! Ca veut dire quoi ? Ca plante, tu as un

message d'erreur, il ne se passe rien ? Précise un peu, s'il te
plaît...
Tu ne serais pas en mode feuille de données par hasard ?

En ce jour mémorable du mercredi 07/11/2007, tu as émis l'idée
suivante:
c'est bien ça
je suis dans le formulaire "F_Num_Interne", j'ai un sous formulaire
"F_Num_Interne_SF_Utilisateur" avec le champs "UTIL_Utilisateur"

quand j'ouvre "F_Num_Interne" je désactive tout les éléments de ce
formualire et je soudrais faire pareil avec le champs du sous-formulaire.

j'ai essayé :
Me![F_Num_Interne_SF_Utilisateur].Form![UTIL_Utilisateur].Enabled = False

mais cela ne fonctionne pas...


Merci de ta réponse, mais cela ne fonctionne pas :(
Il faudrait chercher un peu, ça ne m'aide pas beaucoup ce que tu me

dis!
La formule est du type:

Me!LeSousFormulaire.Form!LeContrôle.Enabledúlse

A adapter.

--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info






--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info








Thierry (ze Titi)
Le #6330001
Hello Benoit1024 !

Mets ta base allégée sur
http://cjoint.com
et donne-nous le lien.

En ce jour mémorable du mercredi 07/11/2007, tu as émis l'idée
suivante:
merci de ta patience,
quand j'ouvre le formulaire "F_Num_Interne", une fenêtre de débogage s'ouvre
avec la ligne
"Me![F_Num_Interne_SF_Utilisateur].Form![UTIL_Utilisateur].Enabled = False"
sélectionné
si je supprime cette ligne le formulaire s'ouvre normalement, mais avec le
champs actif.


mais cela ne fonctionne pas...
Encore une fois, c'est vague ! Ca veut dire quoi ? Ca plante, tu as un

message d'erreur, il ne se passe rien ? Précise un peu, s'il te
plaît...
Tu ne serais pas en mode feuille de données par hasard ?

En ce jour mémorable du mercredi 07/11/2007, tu as émis l'idée
suivante:
c'est bien ça
je suis dans le formulaire "F_Num_Interne", j'ai un sous formulaire
"F_Num_Interne_SF_Utilisateur" avec le champs "UTIL_Utilisateur"

quand j'ouvre "F_Num_Interne" je désactive tout les éléments de ce
formualire et je soudrais faire pareil avec le champs du sous-formulaire.

j'ai essayé :
Me![F_Num_Interne_SF_Utilisateur].Form![UTIL_Utilisateur].Enabled = False

mais cela ne fonctionne pas...


Merci de ta réponse, mais cela ne fonctionne pas :(
Il faudrait chercher un peu, ça ne m'aide pas beaucoup ce que tu me

dis!
La formule est du type:

Me!LeSousFormulaire.Form!LeContrôle.Enabledúlse

A adapter.

--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info






--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info






--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info





Benoit1024
Le #6329701
bonjour à tous,
voici le lien http://cjoint.com/?lijSErsn58
je me suis battu avec les droits, car je l'avais protégé pour être le seule
à pouvoir la modifier. j'espère que ce sera bon et que vous y aurait bien,
accès.
il y a un fichier avec la base et un 2ème avec les données. vous ne devriez
pas avoir de problèmes pour vous y retrouver. certain formulaire sont en
cours, ils ne fonctionne pas encore très bien ;)

le formulaire qui me pose problème est F_Num_Interne. je voudrais qu'à
l'ouverture le sous-formulaire soit aussi désactiver.

merci de votre aide.


Hello Benoit1024 !

Mets ta base allégée sur
http://cjoint.com
et donne-nous le lien.

En ce jour mémorable du mercredi 07/11/2007, tu as émis l'idée
suivante:
merci de ta patience,
quand j'ouvre le formulaire "F_Num_Interne", une fenêtre de débogage s'ouvre
avec la ligne
"Me![F_Num_Interne_SF_Utilisateur].Form![UTIL_Utilisateur].Enabled = False"
sélectionné
si je supprime cette ligne le formulaire s'ouvre normalement, mais avec le
champs actif.


mais cela ne fonctionne pas...
Encore une fois, c'est vague ! Ca veut dire quoi ? Ca plante, tu as un

message d'erreur, il ne se passe rien ? Précise un peu, s'il te
plaît...
Tu ne serais pas en mode feuille de données par hasard ?

En ce jour mémorable du mercredi 07/11/2007, tu as émis l'idée
suivante:
c'est bien ça
je suis dans le formulaire "F_Num_Interne", j'ai un sous formulaire
"F_Num_Interne_SF_Utilisateur" avec le champs "UTIL_Utilisateur"

quand j'ouvre "F_Num_Interne" je désactive tout les éléments de ce
formualire et je soudrais faire pareil avec le champs du sous-formulaire.

j'ai essayé :
Me![F_Num_Interne_SF_Utilisateur].Form![UTIL_Utilisateur].Enabled = False

mais cela ne fonctionne pas...


Merci de ta réponse, mais cela ne fonctionne pas :(
Il faudrait chercher un peu, ça ne m'aide pas beaucoup ce que tu me

dis!
La formule est du type:

Me!LeSousFormulaire.Form!LeContrôle.Enabledúlse

A adapter.

--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info






--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info






--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info










Thierry (ze Titi)
Le #6329691
Bonjour Benoit1024 !

je me suis battu avec les droits, car je l'avais protégé pour être le seule
à pouvoir la modifier. j'espère que ce sera bon et que vous y aurait bien,
accès.
Nan, c'est pas bon... ;-)


le formulaire qui me pose problème est F_Num_Interne. je voudrais qu'à
l'ouverture le sous-formulaire soit aussi désactiver.
Tu m'aurais dit tout de suite (comme je te l'ai demandé 2 fois) que le

message d'erreur était "Impossible de désactiver le contrôle actif, ça
nous aurait fait gagner énormément de temps !

Maintenant, comme je n'ai pas les droits pour faire des modifs, il va
m'être très compliqué de faire des tests... Mais je te suggère de
tenter de donner le focus à un autre contrôle avant de désactiver le
sous-formulaire ou le contrôle voulu.

--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info

Benoit1024
Le #6329671
je ne vois pas ce message d'erreur. où le vois-tu ?
je crois avoir réussi à modifier les droits, ça devrait être bon maintenant
http://cjoint.com/?likJXjJKLr


Bonjour Benoit1024 !

je me suis battu avec les droits, car je l'avais protégé pour être le seule
à pouvoir la modifier. j'espère que ce sera bon et que vous y aurait bien,
accès.
Nan, c'est pas bon... ;-)


le formulaire qui me pose problème est F_Num_Interne. je voudrais qu'à
l'ouverture le sous-formulaire soit aussi désactiver.
Tu m'aurais dit tout de suite (comme je te l'ai demandé 2 fois) que le

message d'erreur était "Impossible de désactiver le contrôle actif, ça
nous aurait fait gagner énormément de temps !

Maintenant, comme je n'ai pas les droits pour faire des modifs, il va
m'être très compliqué de faire des tests... Mais je te suggère de
tenter de donner le focus à un autre contrôle avant de désactiver le
sous-formulaire ou le contrôle voulu.

--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info






Publicité
Poster une réponse
Anonyme