détails de formule...

Le
Mike
Bonjour à tous !!!!

J'ai 2 petites questions sur la syntaxe de 2 formules afin de
comprendre parfaitement leurs utilités, merci d'avance de vos réponses
:)

1 ère formule qui compare 2 plages de valeurs (formule matricielle)
que signifie le *1 et le =0 ?

=SOMME((A1:A11<>C1:C11)*1)=0

2ème formule qui recherche des doublons dans la validation
que signifie le =1 ?

=NB.SI(A:A;A1)=1

Une très bonne journée

Mike
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel
Le #4513711
Bonjour.
Dans les deux cas, si la condition est remplie (=0 ou =1), la formule
renvoie "VRAI" et "FAUX" dans le cas contraire.
Cordialement.
Daniel
"Mike"
Bonjour à tous !!!!

J'ai 2 petites questions sur la syntaxe de 2 formules afin de comprendre
parfaitement leurs utilités, merci d'avance de vos réponses :)

1 ère formule qui compare 2 plages de valeurs (formule matricielle)
que signifie le *1 et le =0 ?

=SOMME((A1:A11<>C1:C11)*1)=0

2ème formule qui recherche des doublons dans la validation
que signifie le =1 ?

=NB.SI(A:A;A1)=1

Une très bonne journée

Mike




Mike
Le #4513701
Bonjour,

J'ai parfaitement compris l'utilité je les ai testée !!!

ce que je désire c'est le détail !!
pourquoi =0 pourquoi =1 pourquoi *1
je dois expliqué....!

comment excel interprete tous ces (codes) chiffres ????

Merci
Mike


Bonjour.
Dans les deux cas, si la condition est remplie (=0 ou =1), la formule renvoie
"VRAI" et "FAUX" dans le cas contraire.
Cordialement.
Daniel
"Mike"
Bonjour à tous !!!!

J'ai 2 petites questions sur la syntaxe de 2 formules afin de comprendre
parfaitement leurs utilités, merci d'avance de vos réponses :)






1 ère formule qui compare 2 plages de valeurs (formule matricielle)
que signifie le *1 et le =0 ?

=SOMME((A1:A11<>C1:C11)*1)=0

2ème formule qui recherche des doublons dans la validation
que signifie le =1 ?

=NB.SI(A:A;A1)=1

Une très bonne journée

Mike






cousinhub
Le #4513671
Bonjour,
pour la première formule, tu compares tes deux zones, et le fait de la
rentrer en matriciel, et de multiplier par *1, te permet, en cas
d'erreur de saisie (le nombre est entré sous format texte, suite à une
importation, par exemple), de calculer quand même, les nombres étant
alors calculés sous le bon format.
Pour la deuxième, tu vérifies que le nombre inscrit dans la cellule
"critère" est bien unique, donc =1
bon dimanche

Bonjour à tous !!!!

J'ai 2 petites questions sur la syntaxe de 2 formules afin de comprendre
parfaitement leurs utilités, merci d'avance de vos réponses :)

1 ère formule qui compare 2 plages de valeurs (formule matricielle)
que signifie le *1 et le =0 ?

=SOMME((A1:A11<>C1:C11)*1)=0

2ème formule qui recherche des doublons dans la validation
que signifie le =1 ?

=NB.SI(A:A;A1)=1

Une très bonne journée

Mike




Modeste
Le #4513661
Bonsour® Mike avec ferveur ;o))) vous nous disiez :

afin de comprendre parfaitement leurs utilités,

1 ère formule qui compare 2 plages de valeurs (formule matricielle)
que signifie le *1 et le =0 ?
=SOMME((A1:A11<>C1:C11)*1)=0
le test logique A1:A11<>C1:C11 renvoie en fait une matrice Booléene de

VRAI,FAUX,VRAI etc...
sachant que VRAI vaut 1 et FAUX vaut 0
multiplier cette matrice Booléene par *1 transforme celle-ci en matrice
Numérique de 1, 0, 1; etc...
si la somme de cette matrice numérique vaut alors 0
la formule alors renvoie VRAI

en résumé
si aucune correspondance entre A1:A11 et C1:C11 alors VRAI

2ème formule qui recherche des doublons dans la validation
que signifie le =1 ?

=NB.SI(A:A;A1)=1
si le resultat de la formule renvoie VRAI

cela signifie que A1 n'a ete trouvé qu'une seule dois dans la plage A:A
au cas ou NB.SI(A:A;A1) serait different de 1 alors la formule renverrai FAUX
ce qui signifierait : présence de doublon

Attention !!!! ce n'est pas le cas ici (car A1 appartient à A:A )
par exemple : =NB.SI(A:A;B1)=1
un retour FAUX (NB.SI(A:A;B1)=0 ) signifierait également doublons ce qui n'est
pas exact puisque cela serait une absence !!!
--
--
@+
;o)))

Daniel
Le #4513641
1. "A1:A11<>C1:C11" compare chaque cellule de la plage A1:A11 à la cellule
correspondante de la plage C1:C11. A1 avec C1, A2 avec C2 etc. Si A1<>C1, la
formule renvoie "VRAI" et "FAUX" dans le cas contraire etc. Le "*1"
convertit les "VRAI" en 1 et les "FAUX" en 0 afin que la somme puisse se
faire. Si chaque cellule de la plage A1:A11 est égale à la plage C1:C11, le
résultat de la somme est égal à 0 et la formule retourne "VRAI".
2. Si la colonne A ne contient qu'une valeur A1, NB.SI(A:A;A1) renvoie 1 et
=NB.SI(A:A;A1)=1 retourne "VRAI" et "FAUX" dans le cas contraire.
Daniel

"Mike"
Bonjour,

J'ai parfaitement compris l'utilité je les ai testée !!!

ce que je désire c'est le détail !!
pourquoi =0 pourquoi =1 pourquoi *1
je dois expliqué....!

comment excel interprete tous ces (codes) chiffres ????

Merci
Mike


Bonjour.
Dans les deux cas, si la condition est remplie (=0 ou =1), la formule
renvoie "VRAI" et "FAUX" dans le cas contraire.
Cordialement.
Daniel
"Mike"
Bonjour à tous !!!!

J'ai 2 petites questions sur la syntaxe de 2 formules afin de comprendre
parfaitement leurs utilités, merci d'avance de vos réponses :)






1 ère formule qui compare 2 plages de valeurs (formule matricielle)
que signifie le *1 et le =0 ?

=SOMME((A1:A11<>C1:C11)*1)=0

2ème formule qui recherche des doublons dans la validation
que signifie le =1 ?

=NB.SI(A:A;A1)=1

Une très bonne journée

Mike










Mike
Le #4513621
Magnifique !!!! parfait, merci de test explications claires!

Mike


1. "A1:A11<>C1:C11" compare chaque cellule de la plage A1:A11 à la cellule
correspondante de la plage C1:C11. A1 avec C1, A2 avec C2 etc. Si A1<>C1, la
formule renvoie "VRAI" et "FAUX" dans le cas contraire etc. Le "*1" convertit
les "VRAI" en 1 et les "FAUX" en 0 afin que la somme puisse se faire. Si
chaque cellule de la plage A1:A11 est égale à la plage C1:C11, le résultat de
la somme est égal à 0 et la formule retourne "VRAI".
2. Si la colonne A ne contient qu'une valeur A1, NB.SI(A:A;A1) renvoie 1 et
=NB.SI(A:A;A1)=1 retourne "VRAI" et "FAUX" dans le cas contraire.
Daniel

"Mike"
Bonjour,

J'ai parfaitement compris l'utilité je les ai testée !!!

ce que je désire c'est le détail !!
pourquoi =0 pourquoi =1 pourquoi *1
je dois expliqué....!

comment excel interprete tous ces (codes) chiffres ????

Merci
Mike


Bonjour.
Dans les deux cas, si la condition est remplie (=0 ou =1), la formule
renvoie "VRAI" et "FAUX" dans le cas contraire.
Cordialement.
Daniel
"Mike"
Bonjour à tous !!!!

J'ai 2 petites questions sur la syntaxe de 2 formules afin de comprendre
parfaitement leurs utilités, merci d'avance de vos réponses :)






1 ère formule qui compare 2 plages de valeurs (formule matricielle)
que signifie le *1 et le =0 ?

=SOMME((A1:A11<>C1:C11)*1)=0

2ème formule qui recherche des doublons dans la validation
que signifie le =1 ?

=NB.SI(A:A;A1)=1

Une très bonne journée

Mike












Mike
Le #4532411
bonjour,

merci de tes précisions

Mike
Bonsour® Mike avec ferveur ;o))) vous nous disiez :

afin de comprendre parfaitement leurs utilités,

1 ère formule qui compare 2 plages de valeurs (formule matricielle)
que signifie le *1 et le =0 ?
=SOMME((A1:A11<>C1:C11)*1)=0
le test logique A1:A11<>C1:C11 renvoie en fait une matrice Booléene de

VRAI,FAUX,VRAI etc...
sachant que VRAI vaut 1 et FAUX vaut 0
multiplier cette matrice Booléene par *1 transforme celle-ci en matrice
Numérique de 1, 0, 1; etc...
si la somme de cette matrice numérique vaut alors 0
la formule alors renvoie VRAI

en résumé




si aucune correspondance entre A1:A11 et C1:C11 alors VRAI

2ème formule qui recherche des doublons dans la validation
que signifie le =1 ?

=NB.SI(A:A;A1)=1
si le resultat de la formule renvoie VRAI

cela signifie que A1 n'a ete trouvé qu'une seule dois dans la plage A:A
au cas ou NB.SI(A:A;A1) serait different de 1 alors la formule renverrai FAUX
ce qui signifierait : présence de doublon

Attention !!!! ce n'est pas le cas ici (car A1 appartient à A:A )
par exemple : =NB.SI(A:A;B1)=1
un retour FAUX (NB.SI(A:A;B1)=0 ) signifierait également doublons ce qui
n'est pas exact puisque cela serait une absence !!!
--



Mike
Le #4532401
un grand merci également

Mike
Bonjour,
pour la première formule, tu compares tes deux zones, et le fait de la
rentrer en matriciel, et de multiplier par *1, te permet, en cas d'erreur de
saisie (le nombre est entré sous format texte, suite à une importation, par
exemple), de calculer quand même, les nombres étant alors calculés sous le
bon format.
Pour la deuxième, tu vérifies que le nombre inscrit dans la cellule "critère"
est bien unique, donc =1
bon dimanche

Bonjour à tous !!!!

J'ai 2 petites questions sur la syntaxe de 2 formules afin de comprendre
parfaitement leurs utilités, merci d'avance de vos réponses :)

1 ère formule qui compare 2 plages de valeurs (formule matricielle)
que signifie le *1 et le =0 ?

=SOMME((A1:A11<>C1:C11)*1)=0

2ème formule qui recherche des doublons dans la validation
que signifie le =1 ?

=NB.SI(A:A;A1)=1

Une très bonne journée

Mike






Publicité
Poster une réponse
Anonyme