détection aléatoire de périphérique et xorg.conf

Le
maderios
Bonjour à tous
Sur Lenny et noyau 2.6.23.9
J'ai une tablette graphique usb en /dev/input/event3 dans mon xorg.conf.
Le problème est que je dois changer de temps à autre le "event" en
"event2", "event1", "event4" etc, après un redémarrage si je veux que la
tablette soit reconnue.
En gros, j'ai affaire à une détection aléatoire de la tablette. Tout
ceci sans ajouter aucun autre périphérique usb, bien entendu.
Alors si quelqu'un a une idée, merci
M


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
thomas.harding
Le #9733481
On Sun, Dec 09, 2007 at 09:10:14PM +0100, maderios wrote:
Bonjour à tous
Sur Lenny et noyau 2.6.23.9
J'ai une tablette graphique usb en /dev/input/event3 dans mon xorg.conf.
Le problème est que je dois changer de temps à autre le "event" en
"event2", "event1", "event4" etc, après un redémarrage si je veux que la
tablette soit reconnue.
En gros, j'ai affaire à une détection aléatoire de la tablette. Tout
ceci sans ajouter aucun autre périphérique usb, bien entendu.
Alors si quelqu'un a une idée, merci



remplacer /dev/input/event3 dans le xorg.conf par /dev/input/wacom
ou le /dev/input/by-id correspondant.

Ca me fait penser que je dois /encore/ recompiler le driver pour
que ma tablette soit prise en compte.

--
Thomas Harding


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
maderios
Le #9733321
Thomas Harding a écrit :
On Sun, Dec 09, 2007 at 09:10:14PM +0100, maderios wrote:

Bonjour à tous
Sur Lenny et noyau 2.6.23.9
J'ai une tablette graphique usb en /dev/input/event3 dans mon xorg.conf.
Le problème est que je dois changer de temps à autre le "event" en
"event2", "event1", "event4" etc, après un redémarrage si je veux que la
tablette soit reconnue.
En gros, j'ai affaire à une détection aléatoire de la tablette. Tout
ceci sans ajouter aucun autre périphérique usb, bien entendu.
Alors si quelqu'un a une idée, merci






remplacer /dev/input/event3 dans le xorg.conf par /dev/input/wacom
ou le /dev/input/by-id correspondant.



Pour faire cela, encore faut il avoir /dev/input/wacom dans
l'arborescence.
Ce n'est pas le cas.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Philippe Merlin
Le #9733311
Salut,
Il semble que ton problème soit du à udev, regarde ce lien c'a t'aidera peut
être : http://jmtrivial.info/tutoriels/logiciel/tutoriel-wacom.php
A+
Philippe MERLIN


Le lundi 10 décembre 2007, maderios a écrit :
Thomas Harding a écrit :
> On Sun, Dec 09, 2007 at 09:10:14PM +0100, maderios wrote:
>> Bonjour à tous
>> Sur Lenny et noyau 2.6.23.9
>> J'ai une tablette graphique usb en /dev/input/event3 dans mon xorg.con f.
>> Le problème est que je dois changer de temps à autre le "event" en
>> "event2", "event1", "event4" etc, après un redémarrage si je veux que la
>> tablette soit reconnue.
>> En gros, j'ai affaire à une détection aléatoire de la tablette. Tout
>> ceci sans ajouter aucun autre périphérique usb, bien entendu.
>> Alors si quelqu'un a une idée, merci
>
> remplacer /dev/input/event3 dans le xorg.conf par /dev/input/wacom
> ou le /dev/input/by-id correspondant.

Pour faire cela, encore faut il avoir /dev/input/wacom dans
l'arborescence.
Ce n'est pas le cas.


maderios
Le #9731311
Philippe Merlin a écrit :
Salut,
Il semble que ton problème soit du à udev, regarde ce lien c'a t'aidera peut
être : http://jmtrivial.info/tutoriels/logiciel/tutoriel-wacom.php
A+
Philippe MERLIN


Le lundi 10 décembre 2007, maderios a écrit :

Thomas Harding a écrit :

On Sun, Dec 09, 2007 at 09:10:14PM +0100, maderios wrote:

Bonjour à tous
Sur Lenny et noyau 2.6.23.9
J'ai une tablette graphique usb en /dev/input/event3 dans mon xorg.conf.
Le problème est que je dois changer de temps à autre le "event" en
"event2", "event1", "event4" etc, après un redémarrage si je veux que la
tablette soit reconnue.
En gros, j'ai affaire à une détection aléatoire de la tablette. Tout
ceci sans ajouter aucun autre périphérique usb, bien entendu.
Alors si quelqu'un a une idée, merci



remplacer /dev/input/event3 dans le xorg.conf par /dev/input/wacom
ou le /dev/input/by-id correspondant.



Pour faire cela, encore faut il avoir /dev/input/wacom dans
l'arborescence.
Ce n'est pas le cas.





Cela vient de udev, ou bien des paquets debian pour ma tablette wacom.
Je suis revenu sur Etch (que je garde toujours au cas où) où la tablette
fonctionne bien avec le paquet source linuxwacom-0.7.8-3 compilé maison.
A moins que le noyau 2.6.23 soit la cause du problème. Ce qui est
bizarre, c'est le coté aléatoire du phénomène.
M


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Philippe Merlin
Le #9731301
Bonjour,
Tu parles de Debian et de Etch , je ne comprends pas très bien Etch est l e nom
d'une version de Debian actuellement considérée comme stable, que veux tu
dire alors par Debian ?
Autre chose si tu as lu le lien il est facile grâce à un petit paramé trage
d'un fichier des paramètres d'udev que quoi qu'il se passe ta tablette so it
controlée par /dev/input/wacom.
Enfin, on vérifie que le package wacom-tools a ajouté le
fichier /etc/udev/rules.d/10-wacom.rules qui contient la ligne suivante :

KERNEL="event[0-9]*", SYSFS{idVendor}="056a", NAME="input/%k",
SYMLINK="input/wacom%e"
pour moi comme tu n'as qu'une tablette je mettrai plutôt SYMLINK="input /wacom"
A+
Philippe MERLIN


Le mardi 11 décembre 2007, maderios a écrit :
Philippe Merlin a écrit :
> Salut,
> Il semble que ton problème soit du à udev, regarde ce lien c'a t'ai dera
> peut être : http://jmtrivial.info/tutoriels/logiciel/tutoriel-wacom.p hp
> A+
> Philippe MERLIN
>
> Le lundi 10 décembre 2007, maderios a écrit :
>> Thomas Harding a écrit :
>>> On Sun, Dec 09, 2007 at 09:10:14PM +0100, maderios wrote:
>>>> Bonjour à tous
>>>> Sur Lenny et noyau 2.6.23.9
>>>> J'ai une tablette graphique usb en /dev/input/event3 dans mon
>>>> xorg.conf. Le problème est que je dois changer de temps à autre le
>>>> "event" en "event2", "event1", "event4" etc, après un redémarrag e si
>>>> je veux que la tablette soit reconnue.
>>>> En gros, j'ai affaire à une détection aléatoire de la tablette . Tout
>>>> ceci sans ajouter aucun autre périphérique usb, bien entendu.
>>>> Alors si quelqu'un a une idée, merci
>>>
>>> remplacer /dev/input/event3 dans le xorg.conf par /dev/input/wacom
>>> ou le /dev/input/by-id correspondant.
>>
>> Pour faire cela, encore faut il avoir /dev/input/wacom dans
>> l'arborescence.
>> Ce n'est pas le cas.

Cela vient de udev, ou bien des paquets debian pour ma tablette wacom.
Je suis revenu sur Etch (que je garde toujours au cas où) où la table tte
fonctionne bien avec le paquet source linuxwacom-0.7.8-3 compilé maison.
A moins que le noyau 2.6.23 soit la cause du problème. Ce qui est
bizarre, c'est le coté aléatoire du phénomène.
M


maderios
Le #9731281
Philippe Merlin a écrit :
Bonjour,
Tu parles de Debian et de Etch , je ne comprends pas très bien Etch est le nom
d'une version de Debian actuellement considérée comme stable,



que veux tu
dire alors par Debian ?


/
/Paquets debian lenny, comme c'est annoncé au début du premier mail:

"Sur Lenny et noyau 2.6.23.9"

Récapitulatif :
Sur Lenny noyau 2.6.23.9
Problème détection aléatoire de périph wacom avec paquets debian
xserver-xorg-input-wacom et wacom-tools
Sur Etch noyau 2.6.22.10
Pas de problème avec wacom, en sachant que je n'utilise pas les paquets
debian pour wacom mais les sources compilées linuxwacom-0.7.8-3
disponibles là http://linuxwacom.sourceforge.net/
M

Cela vient de udev, ou bien des paquets debian pour ma tablette wacom





Autre chose si tu as lu le lien il est facile grâce à un petit paramétrage
d'un fichier des paramètres d'udev que quoi qu'il se passe ta tablette soit
controlée par /dev/input/wacom.
Enfin, on vérifie que le package wacom-tools a ajouté le
fichier /etc/udev/rules.d/10-wacom.rules qui contient la ligne suivante :

KERNEL="event[0-9]*", SYSFS{idVendor}="056a", NAME="input/%k",
SYMLINK="input/wacom%e"
pour moi comme tu n'as qu'une tablette je mettrai plutôt SYMLINK="input/wacom"
A+
Philippe MERLIN

Salut,
Il semble que ton problème soit du à udev, regarde ce lien c'a t'aidera
peut être : http://jmtrivial.info/tutoriels/logiciel/tutoriel-wacom.php
A+
Philippe MERLIN

Le lundi 10 décembre 2007, maderios a écrit :

Thomas Harding a écrit :

On Sun, Dec 09, 2007 at 09:10:14PM +0100, maderios wrote:

Bonjour à tous
Sur Lenny et noyau 2.6.23.9
J'ai une tablette graphique usb en /dev/input/event3 dans mon
xorg.conf. Le problème est que je dois changer de temps à autre le
"event" en "event2", "event1", "event4" etc, après un redémarrage si
je veux que la tablette soit reconnue.
En gros, j'ai affaire à une détection aléatoire de la tablette. Tout
ceci sans ajouter aucun autre périphérique usb, bien entendu.
Alors si quelqu'un a une idée, merci



remplacer /dev/input/event3 dans le xorg.conf par /dev/input/wacom
ou le /dev/input/by-id correspondant.



Pour faire cela, encore faut il avoir /dev/input/wacom dans
l'arborescence.
Ce n'est pas le cas.





Cela vient de udev, ou bien des paquets debian pour ma tablette wacom.
Je suis revenu sur Etch (que je garde toujours au cas où) où la tablette
fonctionne bien avec le paquet source linuxwacom-0.7.8-3 compilé maison.
A moins que le noyau 2.6.23 soit la cause du problème. Ce qui est
bizarre, c'est le coté aléatoire du phénomène.
M












--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Philippe Merlin
Le #9731271
Salut,
Tu ne réponds pas au sujet du paramétrage d'udev ??
A+
Philippe MERLIN

Le mardi 11 décembre 2007, maderios a écrit :
Philippe Merlin a écrit :
> Bonjour,
> Tu parles de Debian et de Etch , je ne comprends pas très bien Etch e st
> le nom d'une version de Debian actuellement considérée comme stable,
>
> que veux tu
> dire alors par Debian ?

/
/Paquets debian lenny, comme c'est annoncé au début du premier mail:

"Sur Lenny et noyau 2.6.23.9"

Récapitulatif :
Sur Lenny noyau 2.6.23.9
Problème détection aléatoire de périph wacom avec paquets debian
xserver-xorg-input-wacom et wacom-tools
Sur Etch noyau 2.6.22.10
Pas de problème avec wacom, en sachant que je n'utilise pas les paquets
debian pour wacom mais les sources compilées linuxwacom-0.7.8-3
disponibles là http://linuxwacom.sourceforge.net/
M

> Cela vient de udev, ou bien des paquets debian pour ma tablette wacom
>
>
>
> Autre chose si tu as lu le lien il est facile grâce à un petit
> paramétrage d'un fichier des paramètres d'udev que quoi qu'il se pa sse ta
> tablette soit controlée par /dev/input/wacom.
> Enfin, on vérifie que le package wacom-tools a ajouté le
> fichier /etc/udev/rules.d/10-wacom.rules qui contient la ligne suivante :
>
> KERNEL="event[0-9]*", SYSFS{idVendor}="056a", NAME="input/%k",
> SYMLINK="input/wacom%e"
> pour moi comme tu n'as qu'une tablette je mettrai plutôt
> SYMLINK="input/wacom" A+
> Philippe MERLIN
>
>>> Salut,
>>> Il semble que ton problème soit du à udev, regarde ce lien c'a t' aidera
>>> peut être : http://jmtrivial.info/tutoriels/logiciel/tutoriel-wacom .php
>>> A+
>>> Philippe MERLIN
>>>
>>> Le lundi 10 décembre 2007, maderios a écrit :
>>>> Thomas Harding a écrit :
>>>>> On Sun, Dec 09, 2007 at 09:10:14PM +0100, maderios wrote:
>>>>>> Bonjour à tous
>>>>>> Sur Lenny et noyau 2.6.23.9
>>>>>> J'ai une tablette graphique usb en /dev/input/event3 dans mon
>>>>>> xorg.conf. Le problème est que je dois changer de temps à autr e le
>>>>>> "event" en "event2", "event1", "event4" etc, après un redémarr age si
>>>>>> je veux que la tablette soit reconnue.
>>>>>> En gros, j'ai affaire à une détection aléatoire de la tablet te. Tout
>>>>>> ceci sans ajouter aucun autre périphérique usb, bien entendu.
>>>>>> Alors si quelqu'un a une idée, merci
>>>>>
>>>>> remplacer /dev/input/event3 dans le xorg.conf par /dev/input/wacom
>>>>> ou le /dev/input/by-id correspondant.
>>>>
>>>> Pour faire cela, encore faut il avoir /dev/input/wacom dans
>>>> l'arborescence.
>>>> Ce n'est pas le cas.
>>
>> Cela vient de udev, ou bien des paquets debian pour ma tablette waco m.
>> Je suis revenu sur Etch (que je garde toujours au cas où) où la ta blette
>> fonctionne bien avec le paquet source linuxwacom-0.7.8-3 compilé mai son.
>> A moins que le noyau 2.6.23 soit la cause du problème. Ce qui est
>> bizarre, c'est le coté aléatoire du phénomène.
>> M


maderios
Le #9636631
Philippe Merlin a écrit :
Salut,
Tu ne réponds pas au sujet du paramétrage d'udev ??



Normalement, je n'ai pas à paramétrer manuellement udev.
Sur Lenny. Je suis revenu au noyau 2.6.22.10, et j'ai maintenant la
tablette en /dev/input/wacom avec les paquets debian
xserver-xorg-input-wacom et wacom-tools.
Affaire à suivre sur un noyau plus récent.
M

A+
Philippe MERLIN

Le mardi 11 décembre 2007, maderios a écrit :

Philippe Merlin a écrit :

Bonjour,
Tu parles de Debian et de Etch , je ne comprends pas très bien Etch est
le nom d'une version de Debian actuellement considérée comme stable,

que veux tu
dire alors par Debian ?



/
/Paquets debian lenny, comme c'est annoncé au début du premier mail:

"Sur Lenny et noyau 2.6.23.9"

Récapitulatif :
Sur Lenny noyau 2.6.23.9
Problème détection aléatoire de périph wacom avec paquets debian
xserver-xorg-input-wacom et wacom-tools
Sur Etch noyau 2.6.22.10
Pas de problème avec wacom, en sachant que je n'utilise pas les paquets
debian pour wacom mais les sources compilées linuxwacom-0.7.8-3
disponibles là http://linuxwacom.sourceforge.net/
M


Cela vient de udev, ou bien des paquets debian pour ma tablette wacom



Autre chose si tu as lu le lien il est facile grâce à un petit
paramétrage d'un fichier des paramètres d'udev que quoi qu'il se passe ta
tablette soit controlée par /dev/input/wacom.
Enfin, on vérifie que le package wacom-tools a ajouté le
fichier /etc/udev/rules.d/10-wacom.rules qui contient la ligne suivante :

KERNEL="event[0-9]*", SYSFS{idVendor}="056a", NAME="input/%k",
SYMLINK="input/wacom%e"
pour moi comme tu n'as qu'une tablette je mettrai plutôt
SYMLINK="input/wacom" A+
Philippe MERLIN


Salut,
Il semble que ton problème soit du à udev, regarde ce lien c'a t'aidera
peut être : http://jmtrivial.info/tutoriels/logiciel/tutoriel-wacom.php
A+
Philippe MERLIN

Le lundi 10 décembre 2007, maderios a écrit :

Thomas Harding a écrit :

On Sun, Dec 09, 2007 at 09:10:14PM +0100, maderios wrote:

Bonjour à tous
Sur Lenny et noyau 2.6.23.9
J'ai une tablette graphique usb en /dev/input/event3 dans mon
xorg.conf. Le problème est que je dois changer de temps à autre le
"event" en "event2", "event1", "event4" etc, après un redémarrage si
je veux que la tablette soit reconnue.
En gros, j'ai affaire à une détection aléatoire de la tablette. Tout
ceci sans ajouter aucun autre périphérique usb, bien entendu.
Alors si quelqu'un a une idée, merci



remplacer /dev/input/event3 dans le xorg.conf par /dev/input/wacom
ou le /dev/input/by-id correspondant.



Pour faire cela, encore faut il avoir /dev/input/wacom dans
l'arborescence.
Ce n'est pas le cas.





Cela vient de udev, ou bien des paquets debian pour ma tablette wacom.
Je suis revenu sur Etch (que je garde toujours au cas où) où la tablette
fonctionne bien avec le paquet source linuxwacom-0.7.8-3 compilé maison.
A moins que le noyau 2.6.23 soit la cause du problème. Ce qui est
bizarre, c'est le coté aléatoire du phénomène.
M
















--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme