Détection de suppression

Le
Michel
Bonjour à tous,

Ma question se présente comme de mettre la charue en avant du boeuf

Y a t-il un moyen de détecter un enregistrement marqué pour suppression mais
qui ne se supprime pas à la base de donnée???

Lorsque ma base de donnée plante (je cherche toujours pourquoi elle plante
mais il faut avancé) il y a toujours dans une table une enregistrement (une
ligne) dont tous les champs l'information est remplacé par l'expression
"#Supprimé" à l'exception du champs de ma clé primaire qui elle est vide.

Manuellement je vais sur cette cette ligne et je la supprime, elle crée
alors un enregistrement vide avec une table d'erreur systtème, j'efface
cette ligne et ferme la base de données en la compctant Rouvre la base de
donnée, la table d'erreur a disparue et replace la clé primaire sur la table
fautive

Comment faire pour retrouver cet enregistrement sans faire planter la base
de donnée à nouveau

Merci beaucoup,

Michel
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
ze Titi
Le #6265121
Salut Michel !

Comme ça, au premier abord, je penserais bien à une corruption de ta
base. As-tu essayé d'ouvrir une base vierge et d'y importer tous les
objets de ta base existante ?

D'autre part, comment lances-tu la suppression de tes enregistrements ?
Code, requête ?

En ce jour exceptionnel du lundi 23/04/2007, tu nous as très
généreusement gratifié du message suivant:

Bonjour à tous,

Ma question se présente comme de mettre la charue en avant du boeuf...

Y a t-il un moyen de détecter un enregistrement marqué pour suppression mais
qui ne se supprime pas à la base de donnée???

Lorsque ma base de donnée plante (je cherche toujours pourquoi elle plante
mais il faut avancé) il y a toujours dans une table une enregistrement (une
ligne) dont tous les champs l'information est remplacé par l'expression
"#Supprimé" à l'exception du champs de ma clé primaire qui elle est vide.

Manuellement je vais sur cette cette ligne et je la supprime, elle crée alors
un enregistrement vide avec une table d'erreur systtème, j'efface cette ligne
et ferme la base de données en la compctant... Rouvre la base de donnée, la
table d'erreur a disparue et replace la clé primaire sur la table fautive...

Comment faire pour retrouver cet enregistrement sans faire planter la base de
donnée à nouveau

Merci beaucoup,

Michel


--
Cordialement,
Ze Titi

Tout pour réussir avec Access :
http://www.mpfa.info

Michel Lauzon
Le #6264951
Salut ze Titi,

Le problème arrive à répétition depuis quelques semaines (Application qui
roule depuis plus d'une année). Chaque fois je crée une nouvelle base de
donnée et importe les données dans la nouvelle. Pensant corrigé un problème
de corruption aussi.

Dans un premier lieu le phénomène se produisait lors de l'archivage des
données... Un formulaire présentait les données et celle-ci était transferré
(avec du code) dans une autre table et suprimé de celle active après
acceptation de ceux-ci. Suite au problème à répétition, j'active un champ
logique pour archivage ultérieur mais j'ai obtientenu le même résultat une
fois depuis.

Le problème semble se produire, plus souvent qu'autrement d'un poste
satelite sur un petit réseau local.

Le message d'erreur que j'obtiens en est un qui dit, au rafraichissement du
formulaire, que l'enregistrement de la table a été supprimé par un autre
utilisateur???

Merci à l'avance...

Michel

"ze Titi"
Salut Michel !

Comme ça, au premier abord, je penserais bien à une corruption de ta base.
As-tu essayé d'ouvrir une base vierge et d'y importer tous les objets de
ta base existante ?

D'autre part, comment lances-tu la suppression de tes enregistrements ?
Code, requête ?

En ce jour exceptionnel du lundi 23/04/2007, tu nous as très généreusement
gratifié du message suivant:

Bonjour à tous,

Ma question se présente comme de mettre la charue en avant du boeuf...

Y a t-il un moyen de détecter un enregistrement marqué pour suppression
mais qui ne se supprime pas à la base de donnée???

Lorsque ma base de donnée plante (je cherche toujours pourquoi elle
plante mais il faut avancé) il y a toujours dans une table une
enregistrement (une ligne) dont tous les champs l'information est
remplacé par l'expression "#Supprimé" à l'exception du champs de ma clé
primaire qui elle est vide.

Manuellement je vais sur cette cette ligne et je la supprime, elle crée
alors un enregistrement vide avec une table d'erreur systtème, j'efface
cette ligne et ferme la base de données en la compctant... Rouvre la base
de donnée, la table d'erreur a disparue et replace la clé primaire sur la
table fautive...

Comment faire pour retrouver cet enregistrement sans faire planter la
base de donnée à nouveau

Merci beaucoup,

Michel


--
Cordialement,
Ze Titi

Tout pour réussir avec Access :
http://www.mpfa.info





ze Titi
Le #6264931
Une gestion d'erreur avec un DoEvents avant le rafraichissement du
formulaire devrait résoudre ton problème mais ça demande confirmation.

En ce jour exceptionnel du lundi 23/04/2007, tu nous as très
généreusement gratifié du message suivant:

Salut ze Titi,

Le problème arrive à répétition depuis quelques semaines (Application qui
roule depuis plus d'une année). Chaque fois je crée une nouvelle base de
donnée et importe les données dans la nouvelle. Pensant corrigé un problème
de corruption aussi.

Dans un premier lieu le phénomène se produisait lors de l'archivage des
données... Un formulaire présentait les données et celle-ci était transferré
(avec du code) dans une autre table et suprimé de celle active après
acceptation de ceux-ci. Suite au problème à répétition, j'active un champ
logique pour archivage ultérieur mais j'ai obtientenu le même résultat une
fois depuis.

Le problème semble se produire, plus souvent qu'autrement d'un poste satelite
sur un petit réseau local.

Le message d'erreur que j'obtiens en est un qui dit, au rafraichissement du
formulaire, que l'enregistrement de la table a été supprimé par un autre
utilisateur???

Merci à l'avance...

Michel

"ze Titi"
Salut Michel !

Comme ça, au premier abord, je penserais bien à une corruption de ta base.
As-tu essayé d'ouvrir une base vierge et d'y importer tous les objets de ta
base existante ?

D'autre part, comment lances-tu la suppression de tes enregistrements ?
Code, requête ?

En ce jour exceptionnel du lundi 23/04/2007, tu nous as très généreusement
gratifié du message suivant:

Bonjour à tous,

Ma question se présente comme de mettre la charue en avant du boeuf...

Y a t-il un moyen de détecter un enregistrement marqué pour suppression
mais qui ne se supprime pas à la base de donnée???

Lorsque ma base de donnée plante (je cherche toujours pourquoi elle plante
mais il faut avancé) il y a toujours dans une table une enregistrement
(une ligne) dont tous les champs l'information est remplacé par
l'expression "#Supprimé" à l'exception du champs de ma clé primaire qui
elle est vide.

Manuellement je vais sur cette cette ligne et je la supprime, elle crée
alors un enregistrement vide avec une table d'erreur systtème, j'efface
cette ligne et ferme la base de données en la compctant... Rouvre la base
de donnée, la table d'erreur a disparue et replace la clé primaire sur la
table fautive...

Comment faire pour retrouver cet enregistrement sans faire planter la base
de donnée à nouveau

Merci beaucoup,

Michel


-- Cordialement,
Ze Titi

Tout pour réussir avec Access :
http://www.mpfa.info





--
Cordialement,
Ze Titi

Tout pour réussir avec Access :
http://www.mpfa.info



Michel Lauzon
Le #6264911
Merci,

Je vais essayer mais que le problème se reproduise même en ayant changer,
pour seulement, l'état d'un champ logique me sidère...

Le DoEvents n'est là que pour perdre du temps!!!


"ze Titi"
Une gestion d'erreur avec un DoEvents avant le rafraichissement du
formulaire devrait résoudre ton problème mais ça demande confirmation.

En ce jour exceptionnel du lundi 23/04/2007, tu nous as très généreusement
gratifié du message suivant:

Salut ze Titi,

Le problème arrive à répétition depuis quelques semaines (Application qui
roule depuis plus d'une année). Chaque fois je crée une nouvelle base de
donnée et importe les données dans la nouvelle. Pensant corrigé un
problème de corruption aussi.

Dans un premier lieu le phénomène se produisait lors de l'archivage des
données... Un formulaire présentait les données et celle-ci était
transferré (avec du code) dans une autre table et suprimé de celle active
après acceptation de ceux-ci. Suite au problème à répétition, j'active un
champ logique pour archivage ultérieur mais j'ai obtientenu le même
résultat une fois depuis.

Le problème semble se produire, plus souvent qu'autrement d'un poste
satelite sur un petit réseau local.

Le message d'erreur que j'obtiens en est un qui dit, au rafraichissement
du formulaire, que l'enregistrement de la table a été supprimé par un
autre utilisateur???

Merci à l'avance...

Michel

"ze Titi" news:
Salut Michel !

Comme ça, au premier abord, je penserais bien à une corruption de ta
base. As-tu essayé d'ouvrir une base vierge et d'y importer tous les
objets de ta base existante ?

D'autre part, comment lances-tu la suppression de tes enregistrements ?
Code, requête ?

En ce jour exceptionnel du lundi 23/04/2007, tu nous as très
généreusement gratifié du message suivant:

Bonjour à tous,

Ma question se présente comme de mettre la charue en avant du boeuf...

Y a t-il un moyen de détecter un enregistrement marqué pour suppression
mais qui ne se supprime pas à la base de donnée???

Lorsque ma base de donnée plante (je cherche toujours pourquoi elle
plante mais il faut avancé) il y a toujours dans une table une
enregistrement (une ligne) dont tous les champs l'information est
remplacé par l'expression "#Supprimé" à l'exception du champs de ma clé
primaire qui elle est vide.

Manuellement je vais sur cette cette ligne et je la supprime, elle crée
alors un enregistrement vide avec une table d'erreur systtème, j'efface
cette ligne et ferme la base de données en la compctant... Rouvre la
base de donnée, la table d'erreur a disparue et replace la clé primaire
sur la table fautive...

Comment faire pour retrouver cet enregistrement sans faire planter la
base de donnée à nouveau

Merci beaucoup,

Michel


-- Cordialement,
Ze Titi

Tout pour réussir avec Access :
http://www.mpfa.info





--
Cordialement,
Ze Titi

Tout pour réussir avec Access :
http://www.mpfa.info







ze Titi
Le #6264901
Le DoEvents n'est là que pour perdre du temps!!!


Je l'ai utilisé dans certaines situations (je ne me rappelle plus
lesquelles) et il m'avait bien dépanné...

En ce jour mémorable du lundi 23/04/2007, tu as entrepris la lourde
tâche de taper sur ton clavier :
Merci,

Je vais essayer mais que le problème se reproduise même en ayant changer,
pour seulement, l'état d'un champ logique me sidère...

Le DoEvents n'est là que pour perdre du temps!!!


"ze Titi"
Une gestion d'erreur avec un DoEvents avant le rafraichissement du
formulaire devrait résoudre ton problème mais ça demande confirmation.

En ce jour exceptionnel du lundi 23/04/2007, tu nous as très généreusement
gratifié du message suivant:

Salut ze Titi,

Le problème arrive à répétition depuis quelques semaines (Application qui
roule depuis plus d'une année). Chaque fois je crée une nouvelle base de
donnée et importe les données dans la nouvelle. Pensant corrigé un
problème de corruption aussi.

Dans un premier lieu le phénomène se produisait lors de l'archivage des
données... Un formulaire présentait les données et celle-ci était
transferré (avec du code) dans une autre table et suprimé de celle active
après acceptation de ceux-ci. Suite au problème à répétition, j'active un
champ logique pour archivage ultérieur mais j'ai obtientenu le même
résultat une fois depuis.

Le problème semble se produire, plus souvent qu'autrement d'un poste
satelite sur un petit réseau local.

Le message d'erreur que j'obtiens en est un qui dit, au rafraichissement
du formulaire, que l'enregistrement de la table a été supprimé par un
autre utilisateur???

Merci à l'avance...

Michel

"ze Titi" news:
Salut Michel !

Comme ça, au premier abord, je penserais bien à une corruption de ta
base. As-tu essayé d'ouvrir une base vierge et d'y importer tous les
objets de ta base existante ?

D'autre part, comment lances-tu la suppression de tes enregistrements ?
Code, requête ?

En ce jour exceptionnel du lundi 23/04/2007, tu nous as très
généreusement gratifié du message suivant:

Bonjour à tous,

Ma question se présente comme de mettre la charue en avant du boeuf...

Y a t-il un moyen de détecter un enregistrement marqué pour suppression
mais qui ne se supprime pas à la base de donnée???

Lorsque ma base de donnée plante (je cherche toujours pourquoi elle
plante mais il faut avancé) il y a toujours dans une table une
enregistrement (une ligne) dont tous les champs l'information est
remplacé par l'expression "#Supprimé" à l'exception du champs de ma clé
primaire qui elle est vide.

Manuellement je vais sur cette cette ligne et je la supprime, elle crée
alors un enregistrement vide avec une table d'erreur systtème, j'efface
cette ligne et ferme la base de données en la compctant... Rouvre la
base de donnée, la table d'erreur a disparue et replace la clé primaire
sur la table fautive...

Comment faire pour retrouver cet enregistrement sans faire planter la
base de donnée à nouveau

Merci beaucoup,

Michel


-- Cordialement,
Ze Titi

Tout pour réussir avec Access :
http://www.mpfa.info





-- Cordialement,
Ze Titi

Tout pour réussir avec Access :
http://www.mpfa.info





--
Cordialement,
Ze Titi

Tout pour réussir avec Access :
http://www.mpfa.info





3stone
Le #6264821
Salut,

"Michel Lauzon"
[...]
| Le DoEvents n'est là que pour perdre du temps!!!


Non !!!
Le DoEvents rend la main au système, ce qui est bien différent...
(le multitâche de Windows étant ce qu'il est... :o)

Ceci dit, sans prétendre que cela corrige ton problème ;-)

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Michel Lauzon
Le #6264721
OK alors,

Le DoEvents dans mon code, sur le formulaire, je l'ajoute avant le ReFresh
de mon formulaire...

Et dois-je en placer plusieurs???


"3stone"
Salut,

"Michel Lauzon"
[...]
| Le DoEvents n'est là que pour perdre du temps!!!


Non !!!
Le DoEvents rend la main au système, ce qui est bien différent...
(le multitâche de Windows étant ce qu'il est... :o)

Ceci dit, sans prétendre que cela corrige ton problème ;-)

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)



3stone
Le #6264671
re,

"Michel Lauzon"
| Le DoEvents dans mon code, sur le formulaire, je l'ajoute avant le ReFresh
| de mon formulaire...
|
| Et dois-je en placer plusieurs???


Dès que l'action n'est plus séquencielle, comme créer ou autre action
sur des fichiers, il est bon d'ajouter un, voir plusieurs DoEvents.

Access a de plus la particularité de s'attribuer un max de ressources
et de ne les lacher qu'en cas de demande. Le DoEvents facilite cela...

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Publicité
Poster une réponse
Anonyme