deux conditions dans formule Si et ET

Le
Alex
Bonjour à tous,

Sur mon onglet "FICHES", je désirais effectuer un contôle des fiches
saisies en fonction du NOM mis en colonne A et d'un numero de semaine
en colonne B (1 2 3 4 (valeur numérique représentant le N° de
semaine)). Mes formules de contrôle sont sur la même feuille mais à
partir AW1, et j'ai écrit ceci :

=SI(ET($A:$A="Toto";$B:$B=1);"OK";"pas ok")

'Toto = Nom et 1 = N° de la semaine

Je voulais que si Toto en colonne A et 1 en colonne B alors OK sinon
pas ok

J'avais entrer 52 fois la même formule en augmentant de 1 la valeur $B:
$B qui représente le numéro de semaine.

Ma formule ne semble pas fonctionner, pourtant je pensais qu'elle
était correcte, quelqu'un aurait il la solution à mon problème ?

Merci par avance de votre aide.
Alex
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
PierreB
Le #23047691
Le 24/01/2011 10:18, Alex a écrit :
Bonjour à tous,

Sur mon onglet "FICHES", je désirais effectuer un contôle des fiches
saisies en fonction du NOM mis en colonne A et d'un numero de semaine
en colonne B (1 2 3 4 (valeur numérique représentant le N° de
semaine)). Mes formules de contrôle sont sur la même feuille mais à
partir AW1, et j'ai écrit ceci :

=SI(ET($A:$A="Toto";$B:$B=1);"OK";"pas ok")

'Toto = Nom et 1 = N° de la semaine

Je voulais que si Toto en colonne A et 1 en colonne B alors OK sinon
pas ok

J'avais entrer 52 fois la même formule en augmentant de 1 la valeur $B:
$B qui représente le numéro de semaine.

Ma formule ne semble pas fonctionner, pourtant je pensais qu'elle
était correcte, quelqu'un aurait il la solution à mon problème ?

Merci par avance de votre aide.
Alex




Bonjour,

Si les noms sont en A1, A2, .... et que les N° de semaines sont en
B1,B2,...., et si on écrit:

=SI(ET(A1="TOTO";B1=1);"OK";"Pas OK"); puis recopier vers le bas jusqu'à
la ligne n: =SI(ET(An="TOTO";Bn=1);"OK";"Pas OK")

OK ne s'écriera que quand la double condition "TOTO" et 1 sera
satisfaite; dans tous les autres cas, soit ce n'est pas TOTO, soit c'est
un autre N° de semaine que la semaine 1, "Pas OK" s'écriera.

Est-ce bien ce que tu veux obtenir ? ca parait bizarre ..., je ne
comprends pas à quoi ca peut bien aboutir !

Pierre
Alex
Le #23047771
Bonjour Pierre,

Merci de ta réponse.

En fait, il faut bien que les deux conditions soient respectés (le nom
+ le numero de semaine) mais les données peuvent être n'importe où
dans la colonne A et la colonne B (Pas en A1 et A2) cela peut etre en
A545 et B545, c'est pour controler que la personne a bien saisie la
fiche de la semaine.
Merci par avance de ton aide.
Alex
Alex
Le #23047921
Complément d'information :
J'ai plusieurs nom à controler d'où ma verification par ce biais
(Environ 50 noms) ainsi avec ce moyen de controle je verrais
immédiatement qui n'a pas rempli sa fiche sans pointé.
Merci par avance de votre aide.
Alex
DanielCo
Le #23048511
Peut-être :
=EQUIV("toto";A:A;0)=EQUIV(1;B:B;0)
Daniel


Complément d'information :
J'ai plusieurs nom à controler d'où ma verification par ce biais
(Environ 50 noms) ainsi avec ce moyen de controle je verrais
immédiatement qui n'a pas rempli sa fiche sans pointé.
Merci par avance de votre aide.
Alex
michel ou sam
Le #23048491
Bonjour,
la condition semble être appliquée que pour les éléments des champs ayant le
même n° de la ligne où tu mets ta formule

Je te propose une formule du style
=SOMMEPROD(($A$1:$A$100="Toto")*($B$1:$B$100=1))
qui te donnera des 0 si la personne n'a pas pointé sa semaine.

En réalité je ferai un tableau, en ligne 1 de AX1 à ... avec les noms
En colonne AW, le numéro de semaine
et la formule de AX2 serait
=SOMMEPROD(($A$1:$A$100=AX$1)*($B$1:$B$100=$AW2))
qu'il suffira de tirer sur tout le tableau
Michel

"Alex"
Bonjour à tous,

Sur mon onglet "FICHES", je désirais effectuer un contôle des fiches
saisies en fonction du NOM mis en colonne A et d'un numero de semaine
en colonne B (1 2 3 4 (valeur numérique représentant le N° de
semaine)). Mes formules de contrôle sont sur la même feuille mais à
partir AW1, et j'ai écrit ceci :

=SI(ET($A:$A="Toto";$B:$B=1);"OK";"pas ok")

'Toto = Nom et 1 = N° de la semaine

Je voulais que si Toto en colonne A et 1 en colonne B alors OK sinon
pas ok

J'avais entrer 52 fois la même formule en augmentant de 1 la valeur $B:
$B qui représente le numéro de semaine.

Ma formule ne semble pas fonctionner, pourtant je pensais qu'elle
était correcte, quelqu'un aurait il la solution à mon problème ?

Merci par avance de votre aide.
Alex
Alex
Le #23049311
Merci pour ta réponse. C'est tout fait ca qu'il me fallait.
Alex
Publicité
Poster une réponse
Anonyme