Différence entre deux dates sauf mercredi et dimanche

Le
Ron
Bonjour !
j'aimerais pouvoir modifier ma fonction pour calculer la différence entre
deux dates sans tenir compte des mercredis et dimanches.
pouvez-vous m'aider svp ?

Celle-ci tient compte uniquement du dimanche (qui n'est pas retenu dans le
décompe) et des jours fériés.
je veux donc que le mercredi ne soit pas non plus retenu dans le décompte
merci d'avance

=(M33-K33)-ENT(((M33-K33)-SI(JOURSEM(K33)=1;0;8-JOURSEM(K33)))/7)-SOMMEPROD((Feuil2!A$2:A$17>=K33)*(Feuil2!A$2:A$17<=M33)*(JOURSEM(Feuil2!A$2:A$17)<>1))
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
AV
Le #4358301
....pour calculer la différence entre
deux dates sans tenir compte des mercredis et dimanches.


=SOMMEPROD((JOURSEM(LIGNE(INDIRECT(dateDébut&":"&dateFin)))<>1)*(JOURSEM(LIGNE(INDIRECT(dateDébut&":"&dateFin)))<>4))

AV

Ron
Le #4358181
J'obtiens le message d'erreur #ref! quand je rentre la formule :

=SOMMEPROD((JOURSEM(LIGNE(INDIRECT(K26&":"&M26)))<>1)*(JOURSEM(LIGNE(INDIRECT(K26&":"&M26)))<>4))


....pour calculer la différence entre
deux dates sans tenir compte des mercredis et dimanches.


=SOMMEPROD((JOURSEM(LIGNE(INDIRECT(dateDébut&":"&dateFin)))<>1)*(JOURSEM(LIGNE(INDIRECT(dateDébut&":"&dateFin)))<>4))

AV






AV
Le #4357901
J'obtiens le message d'erreur #ref! quand je rentre la formule :
=SOMMEPROD((JOURSEM(LIGNE(INDIRECT(K26&":"&M26)))<>1)*(JOURSEM(LIGNE(INDIRECT(K26&":"&M26)))<>4))


Si K26 et M26 sont bien des dates, il n'y aura pas de message d'erreur..

AV

JB
Le #4357621
Bonsoir,

=SOMMEPROD(ESTNA(EQUIV(JOURSEM(LIGNE(INDIRECT(A1&":"&B1)));{1;4};
0))*1)

http://cjoint.com/?dcvYrQuYKL

JB

On 2 mar, 14:11, Ron
Bonjour !
j'aimerais pouvoir modifier ma fonction pour calculer la différence ent re
deux dates sans tenir compte des mercredis et dimanches.
pouvez-vous m'aider svp ?

Celle-ci tient compte uniquement du dimanche (qui n'est pas retenu dans le
décompe) et des jours fériés.
je veux donc que le mercredi ne soit pas non plus retenu dans le décomp te
merci d'avance

=(M33-K33)-ENT(((M33-K33)-SI(JOURSEM(K33)=1;0;8-JOURSEM(K33)))/7)-SOM MEPROD­((Feuil2!A$2:A$17>=K33)*(Feuil2!A$2:A$17<=M33)*(JOURSEM(Feuil2 !A$2:A$17)<>1­))


AV
Le #4357411
En A1 date début et en B1 date fin
Matricielle (validation par ctrl+maj+entrée)

=SOMME(ENT((B1+1-JOURSEM(B1-{2;3;5;6;7})-A1+8)/7))

PS : En matière de formule, le plus court est rarement le moins abscons mais bon
...
AV
Ron
Le #4228941
merci beaucoup !
cette dernière fonctionne tout à fait, mais j'aimerais déduire les jours
fériés déclarés dans une autre colonne, de cette liste.
Pouvez-vous encore m'aider svp ?


En A1 date début et en B1 date fin
Matricielle (validation par ctrl+maj+entrée)

=SOMME(ENT((B1+1-JOURSEM(B1-{2;3;5;6;7})-A1+8)/7))

PS : En matière de formule, le plus court est rarement le moins abscons mais bon
....
AV





AV
Le #4226511
cette dernière fonctionne tout à fait, mais j'aimerais déduire les jours
fériés déclarés dans une autre colonne, de cette liste.


Plages nommées et validation matricielle :
=SOMME(ENT((Fin+1-JOURSEM(Fin-{2;3;5;6;7})-Début+8)/7))-SOMME((jrF>=Début)*(jrF<=Fin))

AV

Publicité
Poster une réponse
Anonyme