Différence entre linux-image-2.6.26-1-* et linux-image-2.6.26-2-*

Le
Emmanuel Kasper
Bonjour
Je viens de me rendre compte que pour chaque paquet linux-image, apt
propose un paquet 2.6.26-1 et un paquet 2.6.26-2

Par exemple
$ apt-cache search -n linux-image-2.6.26 xen amd64
linux-image-2.6.26-1-xen-amd64 - Linux 2.6.26 image on AMD64, oldstyle
Xen support
linux-image-2.6.26-2-xen-amd64 - Linux 2.6.26 image on AMD64, oldstyle
Xen support

et donc

$ apt-cache policy linux-image-2.6.26-1-xen-amd64
linux-image-2.6.26-1-xen-amd64:
Installed: (none)
Candidate: 2.6.26-13lenny2
Version table:
2.6.26-13lenny2 0
500 http://security.debian.org lenny/updates/main Packages

$ apt-cache policy linux-image-2.6.26-2-xen-amd64
linux-image-2.6.26-2-xen-amd64:
Installed: (none)
Candidate: 2.6.26-15lenny2
Version table:
2.6.26-15lenny2 0
500 http://security.debian.org lenny/updates/main Packages
2.6.26-15 0
500 http://ftp.at.debian.org lenny/main Packages

J'interprète ceci comme le packaging de deux versions différentes de
Linux, l'une 2.6.26-13, l'autre de 2.6.26-15.
Lequel de ces deux paquets est il préférable d'installer ? Pourquoi
trouve-t-on ce "doublon" dans l'archive debian ?

Manu

--

openForce Information Technology GesmbH
http://www.openforce.com/
It is a book about a Spanish guy called Manual. You should read it.
-- Dilbert

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Raphael Hertzog
Le #19414651
On Tue, 26 May 2009, Emmanuel Kasper wrote:
Je viens de me rendre compte que pour chaque paquet linux-image, apt
propose un paquet 2.6.26-1 et un paquet 2.6.26-2

J'interprète ceci comme le packaging de deux versions différentes de
Linux, l'une 2.6.26-13, l'autre de 2.6.26-15.
Lequel de ces deux paquets est il préférable d'installer ? Pourquoi
trouve-t-on ce "doublon" dans l'archive debian ?



C'est la dernière version qu'il vaut mieux installer, bien entendu, donc
2.6.26-2.

Le changement dans le nom du paquet est rendu nécessaire par certaines
modifications dans le noyau (qui cassent l'ABI). Cela permet d'éviter des
situations où le noyau courant ne peut pas charger les modules présents
sur le disque parce qu'ils ont été compilés avec une version incompatible du
noyau.

Le mieux est d'installer linux-image-686 (ou linux-image-686-bigmem) et
de laisser ce paquet auto-installer la dernière version du noyau (dont il
dépend).

Cordialement,
--
Raphaël Hertzog

Contribuez à Debian et gagnez un cahier de l'admin Debian Lenny :
http://www.ouaza.com/wp/2009/03/02/contribuer-a-debian-gagner-un-livre/

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Pascal Hambourg
Le #19414641
Salut,

Emmanuel Kasper a écrit :
Je viens de me rendre compte que pour chaque paquet linux-image, apt
propose un paquet 2.6.26-1 et un paquet 2.6.26-2


[...]
$ apt-cache policy linux-image-2.6.26-1-xen-amd64
linux-image-2.6.26-1-xen-amd64:
Installed: (none)
Candidate: 2.6.26-13lenny2
Version table:
2.6.26-13lenny2 0
500 http://security.debian.org lenny/updates/main Packages



C'est la version correspondant à l'avant-dernière (donc obsolète) mise à
jour de sécurité du noyau DSA-1749-1 du 20 mars 2009. Il ne faut
évidemment pas l'utiliser.

$ apt-cache policy linux-image-2.6.26-2-xen-amd64
linux-image-2.6.26-2-xen-amd64:
Installed: (none)
Candidate: 2.6.26-15lenny2
Version table:
2.6.26-15lenny2 0
500 http://security.debian.org lenny/updates/main Packages



C'est la version correspondant à la dernière (donc actuelle) mise à jour
de sécurité du noyau DSA-1800-1 du 15 mai 2009. C'est la version qu'il
faut utiliser.

2.6.26-15 0
500 http://ftp.at.debian.org lenny/main Packages



C'est la version correspondant à la dernière révision mineure 5.0r1 de
lenny publiée le 11 avril 2009. Le changement 2.6.26-13/2.6.26-1 vers
2.6.26-15/2.6.26-2 a eu lieu à cette occasion. Cette version est
vulnérable aux failles décrites dans l'annonce de sécurité DSA-1800-1.

J'interprète ceci comme le packaging de deux versions différentes de
Linux, l'une 2.6.26-13, l'autre de 2.6.26-15.



lenny 5.0r0 -> 2.6.26-13
lenny 5.0r1 -> 2.6.26-15

Lequel de ces deux paquets est il préférable d'installer ?



La plus récente, bien sûr.
Pour être sûr d'installer la dernière version, tu peux installer le
paquet linux-image-xen-amd64 ou linux-image-2.6-xen-amd64 qui en dépend.

Pourquoi trouve-t-on ce "doublon" dans l'archive debian ?



Parce que la vieille version 2.6.26-1/2.6.26-13lenny2 est encore dans
l'archive de sécurité pour un certain temps.

Lorsqu'un paquet fait l'objet d'une mise à jour de sécurité, la version
corrigée est ajoutée au dépôt de sécurité. A l'occasion de la révision
suivante de la distribution stable, elle est intégrée au dépôt
principal. Plus tard, elle est supprimée du dépôt de sécurité. Là il y a
eu en plus changement de nom et de version du paquet lors de la révision
r1, d'où la coexistance des deux dans les différents dépôts.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Emmanuel Kasper
Le #19415171
Pascal Hambourg schrieb:
Salut,

Emmanuel Kasper a écrit :
Je viens de me rendre compte que pour chaque paquet linux-image, apt
propose un paquet 2.6.26-1 et un paquet 2.6.26-2


[...]
$ apt-cache policy linux-image-2.6.26-1-xen-amd64
linux-image-2.6.26-1-xen-amd64:
Installed: (none)
Candidate: 2.6.26-13lenny2
Version table:
2.6.26-13lenny2 0
500 http://security.debian.org lenny/updates/main Packages



C'est la version correspondant à l'avant-dernière (donc obsolète) mise à
jour de sécurité du noyau DSA-1749-1 du 20 mars 2009. Il ne faut
évidemment pas l'utiliser.

$ apt-cache policy linux-image-2.6.26-2-xen-amd64
linux-image-2.6.26-2-xen-amd64:
Installed: (none)
Candidate: 2.6.26-15lenny2
Version table:
2.6.26-15lenny2 0
500 http://security.debian.org lenny/updates/main Packages



C'est la version correspondant à la dernière (donc actuelle) mise à jour
de sécurité du noyau DSA-1800-1 du 15 mai 2009. C'est la version qu'il
faut utiliser.

2.6.26-15 0
500 http://ftp.at.debian.org lenny/main Packages



C'est la version correspondant à la dernière révision mineure 5.0r1 de
lenny publiée le 11 avril 2009. Le changement 2.6.26-13/2.6.26-1 vers
2.6.26-15/2.6.26-2 a eu lieu à cette occasion. Cette version est
vulnérable aux failles décrites dans l'annonce de sécurité DSA-1800-1.

J'interprète ceci comme le packaging de deux versions différentes de
Linux, l'une 2.6.26-13, l'autre de 2.6.26-15.



lenny 5.0r0 -> 2.6.26-13
lenny 5.0r1 -> 2.6.26-15

Lequel de ces deux paquets est il préférable d'installer ?



La plus récente, bien sûr.
Pour être sûr d'installer la dernière version, tu peux installer le
paquet linux-image-xen-amd64 ou linux-image-2.6-xen-amd64 qui en dépend.




ok merci pour cette explication bien détaillée. La raison pour laquelle
je n'avais pas installé les paquets virtuels linux-image-xen-amd64 ou
linux-image-2.6-xen-amd64 est que viens d'effectuer la mise à jour 4.0
-> 5.0

Comme je mets à jour séparément userland et kernel pour minimiser les
complications, je n'utilise pas les paquets virtuels qui forcent la mise
à jour du noyau ( ok je pourrais utiliser les flags hold de dpkg aussi )


--

openForce Information Technology GesmbH
http://www.openforce.com/
It is a book about a Spanish guy called Manual. You should read it.
-- Dilbert

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme