Difficulté matricielle

Le
Tatanka
Bonjour, Bonjour,

Contexte :
La plage B2:B5 se nomme « montant »
La plage H4:H7 se nomme « un »
La plage H4:K4 se nomme « deux »
et toutes ces plages contiennent des valeurs numériques.

Je sélectionne alors D2:D5, j'entre la formule :
=SI(C2>0;montant+deux;montant-TRANSPOSE(un))
et je valide pat Ctrl+Maj+Entrée.
Mais sur chaque ligne de D2:D5, j'ai toujours C2.
Comment faire pour obtenir C2, C3, C4 et C5 dans
ce calcul matriciel ?

Un gros marci,
Serge
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DanielCo
Le #22921271
Bonjour.
Peut-être :
=SI(C2:C5>0;Montant+deux;Montant-TRANSPOSE(un))
Cordialement.
Daniel


Bonjour, Bonjour,

Contexte :
La plage B2:B5 se nomme « montant »
La plage H4:H7 se nomme « un »
La plage H4:K4 se nomme « deux »
et toutes ces plages contiennent des valeurs numériques.

Je sélectionne alors D2:D5, j'entre la formule :
=SI(C2>0;montant+deux;montant-TRANSPOSE(un))
et je valide pat Ctrl+Maj+Entrée.
Mais sur chaque ligne de D2:D5, j'ai toujours C2.
Comment faire pour obtenir C2, C3, C4 et C5 dans
ce calcul matriciel ?

Un gros marci,
Serge
Tatanka
Le #22922251
Ave Daniel,

Pourquoi n'y ai-je pas pensé !
Les matricielles de même dimension s'amusent entre elles :-)

Merci
Serge

"DanielCo"
Bonjour.
Peut-être :
=SI(C2:C5>0;Montant+deux;Montant-TRANSPOSE(un))
Cordialement.
Daniel


Bonjour, Bonjour,

Contexte :
La plage B2:B5 se nomme « montant »
La plage H4:H7 se nomme « un »
La plage H4:K4 se nomme « deux »
et toutes ces plages contiennent des valeurs numériques.

Je sélectionne alors D2:D5, j'entre la formule :
=SI(C2>0;montant+deux;montant-TRANSPOSE(un))
et je valide pat Ctrl+Maj+Entrée.
Mais sur chaque ligne de D2:D5, j'ai toujours C2.
Comment faire pour obtenir C2, C3, C4 et C5 dans
ce calcul matriciel ?

Un gros marci,
Serge




Tatanka
Le #22922241
...les matrices...

Bonne fin de soirée

"Tatanka"
Ave Daniel,

Pourquoi n'y ai-je pas pensé !
Les matricielles de même dimension s'amusent entre elles :-)

Merci
Serge

"DanielCo"
Bonjour.
Peut-être :
=SI(C2:C5>0;Montant+deux;Montant-TRANSPOSE(un))
Cordialement.
Daniel
stormtroopertk1230 Hors ligne
Le #22935501
Tatanka a écrit le 13/12/2010 à 17h44 :
Bonjour, Bonjour,

Contexte :
La plage B2:B5 se nomme « montant »
La plage H4:H7 se nomme « un »
La plage H4:K4 se nomme « deux »
et toutes ces plages contiennent des valeurs numériques.

Je sélectionne alors D2:D5, j'entre la formule :
=SI(C2>0;montant+deux;montant-TRANSPOSE(un))
et je valide pat Ctrl+Maj+Entrée.
Mais sur chaque ligne de D2:D5, j'ai toujours C2.
Comment faire pour obtenir C2, C3, C4 et C5 dans
ce calcul matriciel ?

Un gros marci,
Serge


Formule matricielle :

={somme(nom de feuille!$A$2:$A$2000*(nom de feuille!$D$2:$D$2000= 1 valeur de la colonne D))} -> donne montant de la valeur choisie de la colonne D ( D ayant plusieurs valeurs)

Colonne A = Montants

Les grandes accolades -> contrôle, shift + entrée ( sinon formule matricielle renvoie 0)

plages de A et D doivent toujours être identique ( 2 à 2000 dans cet exemple)
Publicité
Poster une réponse
Anonyme