Disque(s) physique(s) non reconnu(s) suite à une modification du partitionnement

Le
pxg
Bonjour

A ma gauche une carte mère gigabyte ga-h55m-usb3+i5-750 équipée de deux
contrôleurs sata (un x3400 d'intel avec 5 ports ainsi qu'un gigabyte 2
ports) et à ma droite un maxtor DiamondMax 23 de 250 Gb les deux contrôleurs
sont règlés en AHCI le disque est connecté sur le port 0 du contrôleur
intel.

Un système multiboot comportant au minimum Seven et Xp pro (ce dernier
installé avec difficulté en insérant le pilote par le truchement d'une
disquette). Cette configuration reproduite sur 15 machines identtiques
fonctionne plutôt pas mal..

Dans certains cas, lorsqu'on modifie le partitionnement, le disque n'est
plus reconnu au démarrage suivant : blocage de la machine à la détection du
disque (code erreur 23) :

Si l'on connecte le disque sur un port du contrôleur gigabyte le disque est
détecté et Seven démarre (moins évident avec Xp car changement de contrôleur
disque). Si l'on remet le disque à la configuration initiale le problème se
renouvelle
Si l'on efface le mbr du disque - sur une autre machine ou à l'aide de
l'autre contrôleur - on peut reconnecter le disque à sa position initiale et
l'utiliser à nouveau.

En effaçant la mémoire cmos il peut arriver que le disque soit à nouveau
détecté et que tout reparte jusqu'au prochain blocage parfois sans
modification supplémentaire.

J'ai également remarqué en lançant testdisk que les partitions ne sont pas
en correspondance avec le mappage chs détecté. Les pilotes du contrôleur
x3400 sont différents pour xp et pour seven cela pourrait-il avoir une
influence sur les frontières des partitions créées et leur mauvais
alignement ? En quoi cela aurait-il une influence sur la détection du disque
?

Soupçonnant un problème entre les modes gpt/mbr évoqué il y a peu ici
(juste un soupçon car je n'ai pas encore les idées claires à ce sujet) j'ai
tenté un alignement des partitions après avoir branché le disque sur le
contrôleur gigabyte. L'outil Paragon Alignement Tools me signalait la
partition XP comme mal alignée. Après action j'avais toujours la détection
bloquée sur le contrôleur intel et en plus la partition Xp était perdue.

Ce problème s'est présenté sur quelques unes des quinze machines. Comme ce
sont des machines de tp il n'y a pas de problème de perte d'informations
mais je ne sais pas envisager à quel moment et dans quelles circonstances
cet incident peut survenir afin de l'éviter. Du fait de l'usage spécifiques
des machines les modifications du partitionnement sont fréquentes et
nécessaires.

En l'absence d'un bios corrigeant une erreur de cet ordre, j'ai adressé une
requête au support de gigabyte mais je n'ai pas de solutions pour le moment.

Ce que je n'ai pas encore essayé faute de temps et surtout d'une machine
disponible :
désactiver le mode ahci pour le contrôleur intel
remplacer le disque maxtor par un disque wd

Auriez vous une piste à part celle de me priver du contrôleur intel ?

Merci d'avance

pxg
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
georges j-m
Le #22322371
Le 02/07/2010 15:29, pxg a écrit :
Bonjour

A ma gauche une carte mère gigabyte ga-h55m-usb3+i5-750 équipée de deux
contrôleurs sata (un x3400 d'intel avec 5 ports ainsi qu'un gigabyte 2
ports) et à ma droite un maxtor DiamondMax 23 de 250 Gb les deux contrôleurs
sont règlés en AHCI le disque est connecté sur le port 0 du contrôleur
intel.




Sur mes ordinateurs j'ai mis les disques SATA en mode IDE, j'avais des
ennuis semblables aux tiens avec XP.
--
Georges
pxg
Le #22336921
georges j-m wrote:
Le 02/07/2010 15:29, pxg a écrit :
Bonjour



Sur mes ordinateurs j'ai mis les disques SATA en mode IDE, j'avais des
ennuis semblables aux tiens avec XP.



d'accord pour la solution de contournement, même si elle ne me satisfait
pas.
Je "voudrais" que ça marche car je me "prive" de fonctionnalités utiles en
l'occurrence :
* le branchement à chaud par exemple
* et je crois car je n'ai pas eu le temps de vérifier l'utilisation des
ports e-sata de la carte mère.
* l'éventualité d'utiliser le raid

* Le point performance n'est pas avancé car nous n'avons pas le temps de
vérifier si le NCQ améliore les performance lors de l'utilisation de
plusieurs machines virtuelles simultanément, ce qui est notre quotidien.

Merci beaucoup pour ta réponse.

Cordialement

pxg
Publicité
Poster une réponse
Anonyme