Disques durs et fstab

Le
Paul Pygeon
Salut à tous

J'ai installé deux nouveaux disques durs dans ma OpenSuse 13.2. L:e
problème c'est que fstab refuse de les monter et la distribution tombe en
mode recovery.

Voici mon fstab actuel:

"/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part1 / btrfs
defaults 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-1.0-part3 /Atlantis btrfs
defaults 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part1
/boot/grub2/i386-pc btrfs subvol=boot/grub2/i386-pc 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part1
/boot/grub2/x86_64-efi btrfs subvol=boot/grub2/x86_64-efi 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part1 /opt btrfs
subvol=opt 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part1 /srv btrfs
subvol=srv 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part1 /tmp btrfs
subvol=tmp 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part1 /usr/local
btrfs subvol=usr/local 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part1 /var/crash
btrfs subvol=var/crash 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part1
/var/lib/mailman btrfs subvol=var/lib/mailman 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part1
/var/lib/named btrfs subvol=var/lib/named 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part1
/var/lib/pgsql btrfs subvol=var/lib/pgsql 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part1 /var/log
btrfs subvol=var/log 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part1 /var/opt
btrfs subvol=var/opt 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part1 /var/spool
btrfs subvol=var/spool 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part1 /var/tmp
btrfs subvol=var/tmp 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part5 /home btrfs
defaults 0 0
UUIDöb5f4b5-85e5-4765-88a3-b8d50273cd55 swap swap defaults 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part6 /Andromeda
ext4 defaults 1 2
/dev/disk/by-path/pci-0000:00:09.0-ata-4.0-part1 /Univers
ext4 defaults 1 2
UUIDgc4e03e-a839-4dcd-930d-3989603dccf0 /home3 ext4 defaults 1 2
/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part1 /.snapshots
btrfs subvol=.snapshots 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-1.0-part2 /home2 ext4
defaults 1 2
/dev/disk/by-path/pci-0000:00:09.0-ata-1.0-part1 /mint ext4
defaults 1 2
#//192.168.0.102/ /mnt/Clemence cifs,auto username=flipper,password=maxime 0
0
/dev/disk/by-path/pci-0000:00:09.0-ata-1.0-part4 swap swap
defaults 0 0"

Qu'est-ce qui pourrait clocher selon vous et comment monter toutes mes
partitions?

Merci pour vos lumières
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas George
Le #26414568
Paul Pygeon , dans le message
Qu'est-ce qui pourrait clocher

L'administrateur qui ne lit pas les messages d'erreur.
Paul Pygeon
Le #26414573
Nicolas George wrote:
Paul Pygeon , dans le message
Qu'est-ce qui pourrait clocher

L'administrateur qui ne lit pas les messages d'erreur.

D'abord je ne suis pas un administrateur mais un UTILISATEUR moyen et
ensuite toujours aussi désagréable à ce que je vois. Si tu n'as aucune
solution à donner, tu la fermes. Ça va?
Crynux
Le #26414574
Le Sat, 29 Oct 2016 10:42:12 -0400
Paul Pygeon
Nicolas George wrote:
Paul Pygeon , dans le message
Qu'est-ce qui pourrait clocher

L'administrateur qui ne lit pas les messages d'erreur.

D'abord je ne suis pas un administrateur mais un UTILISATEUR moyen et
ensuite toujours aussi désagréable à ce que je vois. Si tu n'as aucune
solution à donner, tu la fermes. Ça va?

Pour avoir acces a fstab, il faut etre administrateur
--
Crynux
Sergio
Le #26414577
Le 29/10/2016 à 17:00, Crynux a écrit :
Paul Pygeon , dans le message
Qu'est-ce qui pourrait clocher

L'administrateur qui ne lit pas les messages d'erreur.

D'abord je ne suis pas un administrateur mais un UTILISATEUR moyen et
ensuite toujours aussi désagréable à ce que je vois. Si tu n'as aucune
solution à donner, tu la fermes. Ça va?


+1
Pour avoir acces a fstab, il faut etre administrateur

Ne pas confondre le compte "Administrateur" de Windows ("root" chez Unix), et le métier d'administrateur.
--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Nicolas George
Le #26414576
Paul Pygeon , dans le message
D'abord je ne suis pas un administrateur mais un UTILISATEUR moyen et

Si c'était le cas, tu ne serais pas en train de toucher à fstab, tu
serais en train d'UTILISER la machine, rendue fonctionnelle par son
administrateur.
Si tu touches à fstab, c'est que tu endosses le rôle d'administrateur,
et tu dois te comporter comme tel.
ensuite toujours aussi désagréable à ce que je vois.

Tu veux dire : aussi désagréable que venir poser une question sans
donner les informations pertinentes ?
Si tu n'as aucune
solution à donner,

J'en ai donné une. Et pas n'importe laquelle, la seule valable : lire
les messages d'erreur.
tu la fermes. Ça va?

Non, ça va pas. Tu viens demander de l'aide, tu ne peux pas te permettre
d'être grossier comme ça. Si tu n'es pas content de l'aide que tu
reçois, tu raques. Il y a plein de consultants qui seront prêts à te
facturer un bras pour corriger un problème trivial ; tu as même le nom
qui convient à la transaction.
Olivier Miakinen
Le #26414582
Bonjour,
Le 29/10/2016 17:06, Nicolas George répondait à Paul Pygeon :
[...] tu as même le nom qui convient à la transaction.

Tu ne crois pas que tu vas un peu trop loin, là ?
Que tu reproches à ceux qui demandent de l'aide de ne pas suffisamment
s'aider eux-mêmes (en cherchant les messages d'erreur avant de venir
ici), c'est une chose.
Mais te moquer de leur patronyme en est une autre.
--
Olivier Miakinen
Th.A.C
Le #26414584
Le 29/10/2016 à 15:00, Paul Pygeon a écrit :
Salut à tous
J'ai installé deux nouveaux disques durs dans ma OpenSuse 13.2. L:e
problème c'est que fstab refuse de les monter et la distribution tombe en
mode recovery.
Voici mon fstab actuel:
"/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part1 / btrfs
defaults 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-1.0-part3 /Atlantis btrfs
defaults 0 0
/dev/disk/by-path/pci-0000:00:09.0-ata-2.0-part1
/boot/grub2/i386-pc btrfs subvol=boot/grub2/i386-pc 0 0

Comme suggéré par Nicolas, tu devrais lire les logs.
A commencer par la commande 'dmesg' qui donne les messages d'erreur
depuis le boot (dès que le noyau est actif il me semble).
par exemple:
dmesg|more
pour afficher page par page.
A toi de chercher les messages qui concernent les disques et leurs
points de montage.
Je ne connais pas OpenSuse, mais je trouve assez bizarre et dangereux
ces '/dev/disk/by-path/pci-0000:00:09.0-ata-1.0-partxxx'.
Si je comprend leur fonctionnement, le simple fait de brancher un disque
sur un autre connecteur de la carte mère te fait perdre le montage
puisque la ligne dans fstab pointe sur un périphérique pci au lieu d'un
UUID.
L'UUID de chaque partition étant normalement unique, il permet de
désigner une partition sans se préoccuper de savoir sur quel disque elle
est, ni sur quel connecteur le disque est branché.
Pour t'aider à diagnostiquer, tu as des commandes comme:
- mount
pour connaitre les montages actuels effectifs
- fdisk -l
pour lister les disques avec leurs partitions
(je n'ai pas testé sur des disques au format GPT)
- blkid
pour lister les partitions avec leur UUID
et plein d'autres...
par exemple dans ton cas quand le système est en mode recovery, tu peux
utiliser la commande:
mount -a
qui tenteras de monter toutes les partitions déclarées dans fstab.
Tu verras les messages en directe s'il y en a.
Tu peux aussi ne brancher qu'un disque à la fois ce qui te permettra
peut-être d'isoler le disque coupable s'il n'y en a qu'un.
Quand à la réponse de Nicolas, même si elle est un peu moqueuse et
'courte', tu aurais pu lui demander ou se trouvent ces messages d'erreur
et comment les consulter.
Thierry
Nicolas George
Le #26414593
Olivier Miakinen , dans le message a écrit :
Tu ne crois pas que tu vas un peu trop loin, là ?

Dans mes souvenirs, c'est un pseudonyme choisi exprès. Si ce n'est pas
le cas, ce bout était effectivement complètement déplacé.
Paul Pygeon
Le #26414597
Crynux wrote:
Le Sat, 29 Oct 2016 10:42:12 -0400
Paul Pygeon
Nicolas George wrote:
Paul Pygeon , dans le message
Qu'est-ce qui pourrait clocher

L'administrateur qui ne lit pas les messages d'erreur.

D'abord je ne suis pas un administrateur mais un UTILISATEUR moyen et
ensuite toujours aussi désagréable à ce que je vois. Si tu n'as aucune
solution à donner, tu la fermes. Ça va?

Pour avoir acces a fstab, il faut etre administrateur

Entre être administrateur et connaître un mot de passe, il y a de la marge.
Olivier Miakinen
Le #26414601
Le 29/10/2016 18:54, Nicolas George m'a répondu :
Dans mes souvenirs, c'est un pseudonyme choisi exprès. Si ce n'est pas
le cas, ce bout était effectivement complètement déplacé.

Ok.
--
Olivier Miakinen
Publicité
Poster une réponse
Anonyme