Données validation

Le
Guy72
Bonjour à tous,
En colonne B, mes cellules contiennent la liste "Données validation" avec le
nom "=Liste!$A$2:$A$36"
En colonne C, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;2)))
En colonne D, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;3)))
En colonne E, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;4)))
Avant de mettre ces formules en colonne E, dès que j'avais un mot
spécifique, toute la ligne se colorisait, maintenant qu'il ya une formule le
mot apparaît bien mais ne colorise plus la ligne.
If [Target] = "Jardinage" Then
Range(Cells(Target.Row, 6), Cells(Target.Row,
1)).Interior.ColorIndex = 4
Range(Cells(Target.Row, 6), Cells(Target.Row, 1)).Font.ColorIndex =
1
Exit Sub
End If
Y a t-il un moyen de pouvoir quand même le faire ?
--
Cordialement
Guy
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #18127521
Bonjour,

Private Sub Worksheet_Calculate()
[champ].Interior.ColorIndex = xlNone
For Each c In [champ]
If UCase(c) = "JARDINAGE" Then
Range(Cells(c.Row, 6), Cells(c.Row, 1)).Interior.ColorIndex = 4
Range(Cells(c.Row, 6), Cells(c.Row, 1)).Font.ColorIndex = 1
End If
Next c
End Sub

http://cjoint.com/?mnnA5xvWYH

JB
http://boisgontierjacques.free.fr/


On 13 déc, 11:59, "Guy72"
Bonjour à tous,
En colonne B, mes cellules contiennent la liste "Données validation" av ec le
nom "=Liste!$A$2:$A$36"
En colonne C, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;2)))
En colonne D, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;3)))
En colonne E, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;4)))
Avant de mettre ces formules en colonne E, dès que j'avais un mot
spécifique, toute la ligne se colorisait, maintenant qu'il ya une formu le le
mot apparaît bien mais ne colorise plus la ligne.
If [Target] = "Jardinage" Then
        Range(Cells(Target.Row, 6), Cells(Target.Row,
1)).Interior.ColorIndex = 4
        Range(Cells(Target.Row, 6), Cells(Target.Row, 1)).Font.Co lorIndex =
1
        Exit Sub
    End If
Y a t-il un moyen de pouvoir quand même le faire ?
--
Cordialement
Guy


FFO
Le #18128271
Salut Guy

L'évènnement à utiliser pour des formules est :

Private Sub Worksheet_Calculate()

Est ce celui que tu utilises ????

Tu pourrais mettre un code comme celui-ci :

Private Sub Worksheet_Calculate()
On Error Resume Next
Trouvé = Cells.Find(What:="Jardinage", After:=Range("A1"), LookIn:=xlValues, _
LookAt:=xlWhole).Address
If Trouvé <> "" Then
Trouvésuivant = Trouvé
Range(Cells(Range(Trouvé).Row, 6), Cells(Range(Trouvé).Row,
1)).Interior.ColorIndex = 4
Range(Cells(Range(Trouvé).Row, 6), Cells(Range(Trouvé).Row,
1)).Font.ColorIndex = 1
For i = 1 To 65535
Trouvésuivant = Cells.FindNext(After:=Range(Trouvésuivant)).Address
If Trouvésuivant <> Trouvé Then
Range(Cells(Range(Trouvésuivant).Row, 6), Cells(Range(Trouvésuivant).Row,
1)).Interior.ColorIndex = 4
Range(Cells(Range(Trouvésuivant).Row, 6), Cells(Range(Trouvésuivant).Row,
1)).Font.ColorIndex = 1
Else
Exit For
End If
Next
End If
End Sub

Celà devrait faire

Fais des essais et dis moi !!!!
Guy72
Le #18129211
Bonjour,
Voici mon fichier, c'est plus simple à expliquer.
http://www.cijoint.fr/cjlink.php?file=cj200812/cijXqWiv0t.xls

--
Cordialement
Guy
"Guy72" %
Bonjour à tous,
En colonne B, mes cellules contiennent la liste "Données validation" avec
le nom "=Liste!$A$2:$A$36"
En colonne C, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;2)))
En colonne D, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;3)))
En colonne E, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;4)))
Avant de mettre ces formules en colonne E, dès que j'avais un mot
spécifique, toute la ligne se colorisait, maintenant qu'il ya une formule
le mot apparaît bien mais ne colorise plus la ligne.
If [Target] = "Jardinage" Then
Range(Cells(Target.Row, 6), Cells(Target.Row,
1)).Interior.ColorIndex = 4
Range(Cells(Target.Row, 6), Cells(Target.Row, 1)).Font.ColorIndex =
1
Exit Sub
End If
Y a t-il un moyen de pouvoir quand même le faire ?
--
Cordialement
Guy



Jacky
Le #18129311
Bonsoir,

Ignorer le dernier argument de RevhercheV n'est pas une bonne idée
En C3
=SI($B3="";"";(RECHERCHEV($B3;Liste!$A$2:$D$15;2;0)))
En D3
=SI($B3="";"";(RECHERCHEV($B3;Liste!$A$2:$D$15;3;0)))

--
Salutations
JJ


"Guy72" %
Bonjour à tous,
En colonne B, mes cellules contiennent la liste "Données validation" avec
le nom "=Liste!$A$2:$A$36"
En colonne C, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;2)))
En colonne D, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;3)))
En colonne E, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;4)))
Avant de mettre ces formules en colonne E, dès que j'avais un mot
spécifique, toute la ligne se colorisait, maintenant qu'il ya une formule
le mot apparaît bien mais ne colorise plus la ligne.
If [Target] = "Jardinage" Then
Range(Cells(Target.Row, 6), Cells(Target.Row,
1)).Interior.ColorIndex = 4
Range(Cells(Target.Row, 6), Cells(Target.Row, 1)).Font.ColorIndex =
1
Exit Sub
End If
Y a t-il un moyen de pouvoir quand même le faire ?
--
Cordialement
Guy



Jacky
Le #18129301
Re.
J'ai oublié la colonne E, mais tu as certainement corrigé.
;o)

--
Salutations
JJ


"Jacky"
Bonsoir,

Ignorer le dernier argument de RevhercheV n'est pas une bonne idée
En C3
=SI($B3="";"";(RECHERCHEV($B3;Liste!$A$2:$D$15;2;0)))
En D3
=SI($B3="";"";(RECHERCHEV($B3;Liste!$A$2:$D$15;3;0)))

--
Salutations
JJ


"Guy72" %
Bonjour à tous,
En colonne B, mes cellules contiennent la liste "Données validation" avec
le nom "=Liste!$A$2:$A$36"
En colonne C, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;2)))
En colonne D, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;3)))
En colonne E, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;4)))
Avant de mettre ces formules en colonne E, dès que j'avais un mot
spécifique, toute la ligne se colorisait, maintenant qu'il ya une formule
le mot apparaît bien mais ne colorise plus la ligne.
If [Target] = "Jardinage" Then
Range(Cells(Target.Row, 6), Cells(Target.Row,
1)).Interior.ColorIndex = 4
Range(Cells(Target.Row, 6), Cells(Target.Row, 1)).Font.ColorIndex
= 1
Exit Sub
End If
Y a t-il un moyen de pouvoir quand même le faire ?
--
Cordialement
Guy







Guy72
Le #18129401
Bonjour Jacky,
D'accord, mais ça ne mets toujours pas la ligne en couleur.
--
Cordialement
Guy
"Jacky" %
Re.
J'ai oublié la colonne E, mais tu as certainement corrigé.
;o)

--
Salutations
JJ


"Jacky"
Bonsoir,

Ignorer le dernier argument de RevhercheV n'est pas une bonne idée
En C3
=SI($B3="";"";(RECHERCHEV($B3;Liste!$A$2:$D$15;2;0)))
En D3
=SI($B3="";"";(RECHERCHEV($B3;Liste!$A$2:$D$15;3;0)))

--
Salutations
JJ


"Guy72" %
Bonjour à tous,
En colonne B, mes cellules contiennent la liste "Données validation"
avec le nom "=Liste!$A$2:$A$36"
En colonne C, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;2)))
En colonne D, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;3)))
En colonne E, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;4)))
Avant de mettre ces formules en colonne E, dès que j'avais un mot
spécifique, toute la ligne se colorisait, maintenant qu'il ya une
formule le mot apparaît bien mais ne colorise plus la ligne.
If [Target] = "Jardinage" Then
Range(Cells(Target.Row, 6), Cells(Target.Row,
1)).Interior.ColorIndex = 4
Range(Cells(Target.Row, 6), Cells(Target.Row, 1)).Font.ColorIndex
= 1
Exit Sub
End If
Y a t-il un moyen de pouvoir quand même le faire ?
--
Cordialement
Guy











Jacky
Le #18129551
Re...
D'accord,


C'et dejà bien ;o)
mais ça ne mets toujours pas la ligne en couleur.
J'ai pas vérifier cela , ce soir ...peut-être

--
Salutations
JJ


"Guy72" %23cCeM%
Bonjour Jacky,
D'accord, mais ça ne mets toujours pas la ligne en couleur.
--
Cordialement
Guy
"Jacky" %
Re.
J'ai oublié la colonne E, mais tu as certainement corrigé.
;o)

--
Salutations
JJ


"Jacky"
Bonsoir,

Ignorer le dernier argument de RevhercheV n'est pas une bonne idée
En C3
=SI($B3="";"";(RECHERCHEV($B3;Liste!$A$2:$D$15;2;0)))
En D3
=SI($B3="";"";(RECHERCHEV($B3;Liste!$A$2:$D$15;3;0)))

--
Salutations
JJ


"Guy72" %
Bonjour à tous,
En colonne B, mes cellules contiennent la liste "Données validation"
avec le nom "=Liste!$A$2:$A$36"
En colonne C, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;2)))
En colonne D, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;3)))
En colonne E, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;4)))
Avant de mettre ces formules en colonne E, dès que j'avais un mot
spécifique, toute la ligne se colorisait, maintenant qu'il ya une
formule le mot apparaît bien mais ne colorise plus la ligne.
If [Target] = "Jardinage" Then
Range(Cells(Target.Row, 6), Cells(Target.Row,
1)).Interior.ColorIndex = 4
Range(Cells(Target.Row, 6), Cells(Target.Row,
1)).Font.ColorIndex = 1
Exit Sub
End If
Y a t-il un moyen de pouvoir quand même le faire ?
--
Cordialement
Guy















Jacky
Le #18131181
RE..
Chose promise chose........
http://www.cijoint.fr/cjlink.php?file=cj200812/cijVddPBIg.xls
;o)
--
Salutations
JJ


"Jacky"
Re...
D'accord,


C'et dejà bien ;o)
mais ça ne mets toujours pas la ligne en couleur.
J'ai pas vérifier cela , ce soir ...peut-être

--
Salutations
JJ


"Guy72" %23cCeM%
Bonjour Jacky,
D'accord, mais ça ne mets toujours pas la ligne en couleur.
--
Cordialement
Guy
"Jacky" %
Re.
J'ai oublié la colonne E, mais tu as certainement corrigé.
;o)

--
Salutations
JJ


"Jacky"
Bonsoir,

Ignorer le dernier argument de RevhercheV n'est pas une bonne idée
En C3
=SI($B3="";"";(RECHERCHEV($B3;Liste!$A$2:$D$15;2;0)))
En D3
=SI($B3="";"";(RECHERCHEV($B3;Liste!$A$2:$D$15;3;0)))

--
Salutations
JJ


"Guy72" %
Bonjour à tous,
En colonne B, mes cellules contiennent la liste "Données validation"
avec le nom "=Liste!$A$2:$A$36"
En colonne C, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;2)))
En colonne D, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;3)))
En colonne E, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;4)))
Avant de mettre ces formules en colonne E, dès que j'avais un mot
spécifique, toute la ligne se colorisait, maintenant qu'il ya une
formule le mot apparaît bien mais ne colorise plus la ligne.
If [Target] = "Jardinage" Then
Range(Cells(Target.Row, 6), Cells(Target.Row,
1)).Interior.ColorIndex = 4
Range(Cells(Target.Row, 6), Cells(Target.Row,
1)).Font.ColorIndex = 1
Exit Sub
End If
Y a t-il un moyen de pouvoir quand même le faire ?
--
Cordialement
Guy



















Guy72
Le #18131281
Bonsoir Jacky
Ok ça fonctionne;
Merci pour la retraite, mais tu y vas un peu fort pour les impôts.
A+
--
Cordialement
Guy

"Jacky"
Bonsoir,

Ignorer le dernier argument de RevhercheV n'est pas une bonne idée
En C3
=SI($B3="";"";(RECHERCHEV($B3;Liste!$A$2:$D$15;2;0)))
En D3
=SI($B3="";"";(RECHERCHEV($B3;Liste!$A$2:$D$15;3;0)))

--
Salutations
JJ


"Guy72" %
Bonjour à tous,
En colonne B, mes cellules contiennent la liste "Données validation" avec
le nom "=Liste!$A$2:$A$36"
En colonne C, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;2)))
En colonne D, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;3)))
En colonne E, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;4)))
Avant de mettre ces formules en colonne E, dès que j'avais un mot
spécifique, toute la ligne se colorisait, maintenant qu'il ya une formule
le mot apparaît bien mais ne colorise plus la ligne.
If [Target] = "Jardinage" Then
Range(Cells(Target.Row, 6), Cells(Target.Row,
1)).Interior.ColorIndex = 4
Range(Cells(Target.Row, 6), Cells(Target.Row, 1)).Font.ColorIndex
= 1
Exit Sub
End If
Y a t-il un moyen de pouvoir quand même le faire ?
--
Cordialement
Guy







Guy72
Le #18134901
Bonjour Jacky,
Je n'arrive pas à comprendre, pourquoi quand j'ajoute un mot dans la liste
et que j'ajoute son code avec les autres, ça ne fonctionne pas ?
Les nouveaux textes en A et en E sont bien là, mais la couleur ne se fait
pas.
Exemple : ASF-->Prélèvement-->Autoroute-->La Mer (couleur bleu).
J'ai ajouter ça
If [Target] = "La Mer" Then
Range(Cells(Target.Row, 6), Cells(Target.Row,
1)).Interior.ColorIndex = 5
Range(Cells(Target.Row, 6), Cells(Target.Row, 1)).Font.ColorIndex =
2
Exit Sub
End If
--
Cordialement
Guy
"Jacky"
RE..
Chose promise chose........
http://www.cijoint.fr/cjlink.php?file=cj200812/cijVddPBIg.xls
;o)
--
Salutations
JJ


"Jacky"
Re...
D'accord,


C'et dejà bien ;o)
mais ça ne mets toujours pas la ligne en couleur.
J'ai pas vérifier cela , ce soir ...peut-être

--
Salutations
JJ


"Guy72" %23cCeM%
Bonjour Jacky,
D'accord, mais ça ne mets toujours pas la ligne en couleur.
--
Cordialement
Guy
"Jacky" %
Re.
J'ai oublié la colonne E, mais tu as certainement corrigé.
;o)

--
Salutations
JJ


"Jacky"
Bonsoir,

Ignorer le dernier argument de RevhercheV n'est pas une bonne idée
En C3
=SI($B3="";"";(RECHERCHEV($B3;Liste!$A$2:$D$15;2;0)))
En D3
=SI($B3="";"";(RECHERCHEV($B3;Liste!$A$2:$D$15;3;0)))

--
Salutations
JJ


"Guy72" %
Bonjour à tous,
En colonne B, mes cellules contiennent la liste "Données validation"
avec le nom "=Liste!$A$2:$A$36"
En colonne C, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;2)))
En colonne D, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;3)))
En colonne E, j'ai la formule suivante :
=SI(B3="";"";(RECHERCHEV($B3;Liste$A$2:$D$35;4)))
Avant de mettre ces formules en colonne E, dès que j'avais un mot
spécifique, toute la ligne se colorisait, maintenant qu'il ya une
formule le mot apparaît bien mais ne colorise plus la ligne.
If [Target] = "Jardinage" Then
Range(Cells(Target.Row, 6), Cells(Target.Row,
1)).Interior.ColorIndex = 4
Range(Cells(Target.Row, 6), Cells(Target.Row,
1)).Font.ColorIndex = 1
Exit Sub
End If
Y a t-il un moyen de pouvoir quand même le faire ?
--
Cordialement
Guy
























Publicité
Poster une réponse
Anonyme