Double condition SI dans une formule

Le
Paulo
Bonjour,

Je dois intégrer deux conditions pour parfaire un résultat.

Si la valeur A1 est égale ou inférieure à 1000, alors le résultat sera
toujours égal à 2.
Si la valeur A1 est comprise entre 1000 exclu et 2000 inclus, le résultat
doit être égal à 5.
Si la valeur A1 est strictement supérieure à 2000, alors le résultat doit
être le calcul de A1*0.25%

Voici ma formule refusée par excel :
=SI((L3<00);2;[si(1000<L3> 00);5;(L3*0,25%)])

Je ne m'y prends surement pas de la bonne façon ou alors on ne peut pas
mettre deux conditions dans la même formule ?

Merci de vos lumières.
Paulo.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
karine
Le #18089991
bonjour,

si c'est possible,

=SI(A1<00;2;SI(A1< 00;5;A1*0,25%))


"Paulo" a écrit :

Bonjour,

Je dois intégrer deux conditions pour parfaire un résultat.

Si la valeur A1 est égale ou inférieure à 1000, alors le résultat sera
toujours égal à 2.
Si la valeur A1 est comprise entre 1000 exclu et 2000 inclus, le résultat
doit être égal à 5.
Si la valeur A1 est strictement supérieure à 2000, alors le résultat doit
être le calcul de A1*0.25%

Voici ma formule refusée par excel :
=SI((L3<00);2;[si(1000<L3> 00);5;(L3*0,25%)])

Je ne m'y prends surement pas de la bonne façon ou alors on ne peut pas
mettre deux conditions dans la même formule ?

Merci de vos lumières.
Paulo.





ChristianM
Le #18089971
Bonjour,

=SI(A1<00;2;SI(A1< 00;5;A1*0.25/100))


--
ChristianM


"Paulo"
Bonjour,

Je dois intégrer deux conditions pour parfaire un résultat.

Si la valeur A1 est égale ou inférieure à 1000, alors le résultat sera
toujours égal à 2.
Si la valeur A1 est comprise entre 1000 exclu et 2000 inclus, le résultat
doit être égal à 5.
Si la valeur A1 est strictement supérieure à 2000, alors le résultat doit
être le calcul de A1*0.25%

Voici ma formule refusée par excel :
=SI((L3<00);2;[si(1000<L3> 00);5;(L3*0,25%)])

Je ne m'y prends surement pas de la bonne façon ou alors on ne peut pas
mettre deux conditions dans la même formule ?

Merci de vos lumières.
Paulo.



Paulo
Le #18089961
Re bonjour,

Merci beaucoup, cela fonctionne.
Finalement c'est encore plus simple que je ne croyais.

Paulo

"karine"
bonjour,

si c'est possible,

=SI(A1<00;2;SI(A1< 00;5;A1*0,25%))


"Paulo" a écrit :

Bonjour,

Je dois intégrer deux conditions pour parfaire un résultat.

Si la valeur A1 est égale ou inférieure à 1000, alors le résultat sera
toujours égal à 2.
Si la valeur A1 est comprise entre 1000 exclu et 2000 inclus, le résultat
doit être égal à 5.
Si la valeur A1 est strictement supérieure à 2000, alors le résultat doit
être le calcul de A1*0.25%

Voici ma formule refusée par excel :
=SI((L3<00);2;[si(1000<L3> 00);5;(L3*0,25%)])

Je ne m'y prends surement pas de la bonne façon ou alors on ne peut pas
mettre deux conditions dans la même formule ?

Merci de vos lumières.
Paulo.








gmlsteph
Le #18089951
Bonjour,

=SI(ET(A1<>"";ESTNUM(A1));SI(A1<00;2;SI(A1>2000;A1*0,25%;5));"")

--
lSteph

On 9 déc, 11:12, "Paulo"
Bonjour,

Je dois intégrer deux conditions pour parfaire un résultat.

Si la valeur A1 est égale ou inférieure à 1000, alors le résultat sera
toujours égal à 2.
Si la valeur A1 est comprise entre 1000 exclu et 2000 inclus, le résult at
doit être égal à 5.
Si la valeur A1 est strictement supérieure à 2000, alors le résulta t doit
être le calcul de  A1*0.25%

Voici ma formule refusée par excel :
=SI((L3<00);2;[si(1000<L3> 00);5;(L3*0,25%)])

Je ne m'y prends surement pas de la bonne façon ou alors on ne peut pas
mettre deux conditions dans la même formule ?

Merci de vos lumières.
Paulo.


Jean MARTIN
Le #18089941
=SI(L3<1001;"2";SI(L3<2001;"5";L3*0,25%))
ça semble marcher !
ean

"Paulo" news:
Bonjour,

Je dois intégrer deux conditions pour parfaire un résultat.

Si la valeur A1 est égale ou inférieure à 1000, alors le résultat sera
toujours égal à 2.
Si la valeur A1 est comprise entre 1000 exclu et 2000 inclus, le résultat
doit être égal à 5.
Si la valeur A1 est strictement supérieure à 2000, alors le résultat doit
être le calcul de A1*0.25%

Voici ma formule refusée par excel :
=SI((L3<00);2;[si(1000<L3> 00);5;(L3*0,25%)])

Je ne m'y prends surement pas de la bonne façon ou alors on ne peut pas
mettre deux conditions dans la même formule ?

Merci de vos lumières.
Paulo.



Paulo
Le #18090491
Merci à tous, Karine a été la plus rapide ;)


"Paulo"
Bonjour,

Je dois intégrer deux conditions pour parfaire un résultat.

Si la valeur A1 est égale ou inférieure à 1000, alors le résultat sera
toujours égal à 2.
Si la valeur A1 est comprise entre 1000 exclu et 2000 inclus, le résultat
doit être égal à 5.
Si la valeur A1 est strictement supérieure à 2000, alors le résultat doit
être le calcul de A1*0.25%

Voici ma formule refusée par excel :
=SI((L3<00);2;[si(1000<L3> 00);5;(L3*0,25%)])

Je ne m'y prends surement pas de la bonne façon ou alors on ne peut pas
mettre deux conditions dans la même formule ?

Merci de vos lumières.
Paulo.




Fredo P.
Le #18091501
=(A1>0)*(A1<1000)*2+(ET(A1>00;A1< 00)*5)+((A1>2000)*A1*0,25)

"Paulo" news:
Re bonjour,

Merci beaucoup, cela fonctionne.
Finalement c'est encore plus simple que je ne croyais.

Paulo

"karine"

news:

> bonjour,
>
> si c'est possible,
>
> =SI(A1<00;2;SI(A1< 00;5;A1*0,25%))
>
>
> "Paulo" a écrit :
>
>> Bonjour,
>>
>> Je dois intégrer deux conditions pour parfaire un résultat.
>>
>> Si la valeur A1 est égale ou inférieure à 1000, alors le résultat sera
>> toujours égal à 2.
>> Si la valeur A1 est comprise entre 1000 exclu et 2000 inclus, le


résultat
>> doit être égal à 5.
>> Si la valeur A1 est strictement supérieure à 2000, alors le résultat


doit
>> être le calcul de A1*0.25%
>>
>> Voici ma formule refusée par excel :
>> =SI((L3<00);2;[si(1000<L3> 00);5;(L3*0,25%)])
>>
>> Je ne m'y prends surement pas de la bonne façon ou alors on ne peut pas
>> mettre deux conditions dans la même formule ?
>>
>> Merci de vos lumières.
>> Paulo.
>>
>>
>>
>




LSteph
Le #18096111
;-)

C'est vrai mais toutes les formules ne sont pas les mêmes!

celle de JM ne va que si on entre un nombre entier.

celle de Christian est bien aussi mais ne va pas pour un pav num norme
fr car utilise le . et non la ,
mais pour ceux qui ont un petit portable c'est parfois plus pratique !

celle de Karine est amha celle qui irait le mieux mais gagnerait ainsi
SI(A1<00;2;SI(A1>2000;A1*0,25%;5))
car un > ira plus vite qu'un <
Sinon il m'a semblé que tester si vide ou non numérique cela prend à
peine plus pour que cela fonctionne dans un plus grand nombre de cas.


@+
--
lSteph
( vilain petit canard qui est content d'avoir pris un peu plus de temps
pour traverser la mare )

Paulo a écrit :
Merci à tous, Karine a été la plus rapide ;)



Paulo
Le #18100721
Bonjour,

Et avec toutes ces explications complémentaires, j'ai appris des choses.
Merci.


"LSteph" %
;-)

C'est vrai mais toutes les formules ne sont pas les mêmes!

celle de JM ne va que si on entre un nombre entier.

celle de Christian est bien aussi mais ne va pas pour un pav num norme fr
car utilise le . et non la ,
mais pour ceux qui ont un petit portable c'est parfois plus pratique !

celle de Karine est amha celle qui irait le mieux mais gagnerait ainsi
SI(A1<00;2;SI(A1>2000;A1*0,25%;5))
car un > ira plus vite qu'un < >
Sinon il m'a semblé que tester si vide ou non numérique cela prend à
peine plus pour que cela fonctionne dans un plus grand nombre de cas.


@+
--
lSteph
( vilain petit canard qui est content d'avoir pris un peu plus de temps
pour traverser la mare )

Paulo a écrit :
Merci à tous, Karine a été la plus rapide ;)






Publicité
Poster une réponse
Anonyme