dri imprevisible avec intel

Le
ph
Bonjour à tous

Configuration bien difficile sur un Toshiba Centrino duo avec Intel 945 ou
915 ? et Kubuntu 7.10.

Dans xorg.conf, j'ai bien load dri et glx, avec driver intel ou i810.

Quand je démarre, dri n'est pas chargé (glxinfo), mais si je redémarre X, ça
fonctionne parfois.

Si je tente de lancer un programme 3D lorsque dri n'est pas chargé, ça
plante la session -- et je ne vous raconte pas la lenteur des affichages.

drm et agp sont initialisés (dmesg)
[ 12.432000] Linux agpgart interface v0.102 (c) Dave Jones
[ 12.720000] agpgart: Detected an Intel 945GM Chipset.
[ 12.720000] agpgart: Detected 7932K stolen memory.
[ 12.736000] agpgart: AGP aperture is 256M @ 0xc0000000

[ 22.992000] [drm] Initialized drm 1.1.0 20060810
[ 23.004000] [drm] Initialized i915 1.6.0 20060119 on minor 0

le log de xorg n'est pas très contributif

(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
ABI class: XFree86 XInput driver, version 0.3
(II) Loading /usr/lib/xorg/modules/drivers//intel_drv.so
ABI class: X.Org XInput driver, version 0.7
(--) intel(0): Will try to allocate texture pool for old Mesa 3D driver.
drmOpenDevice: node name is /dev/dri/card0
(II) intel(0): [drm] loaded kernel module for "i915" driver
(II) intel(0): [drm] created "i915" driver at busid "pci:0000:00:02.0"
(II) intel(0): [dri] visual configs initialized
drmOpenDevice: node name is /dev/dri/card0
(WW) AIGLX: 3D driver claims to not support visual 0x23

->->->(WW) intel: No matching Device section for instance (BusID PCI:0:2:1)
found ->->Le problème ?
->->->(WW) intel(0): Bad V_BIOS checksum
(WW) AIGLX: 3D driver claims to not support visual 0x23
(WW) AIGLX: 3D driver claims to not support visual 0x24


Il n'y a pas d'erreur d'allocation de mémoire


export LIBGL_DEBUG=verbose ne change rien à l'affichage de glxinfo

j'ai mis

Section "DRI"
Mode 0666
EndSection

Je suis en DefaultDepth 24
Qu'est-ce qui peut empêcher dri de se charger parfois ?

Merci d'avance

GD
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
ph
Le #1917808
ph wrote:

Bonjour à tous

Configuration bien difficile sur un Toshiba Centrino duo avec Intel 945 ou
915 ? et Kubuntu 7.10.

J'ai désinstallé xserver-xgl


Merci à ceux qui ont réfléchi au problème.

GD

Publicité
Poster une réponse
Anonyme