Drupal6 et éditeur WISIWYG

Le
Patrice Karatchentzeff
Bonjour,

J'ai fait le choix comme CMS de drupal parce que, pour beaucoup,
c'était un des rares empaquetés et le paquet dh-make-drupal m'a
bien séduit.

Je m'en mors profondément les doigts.

Impossible d'installer un éditeur wysiwig sur drupal6 (squeeze)
avec enfin, pour être exact, j'ai réussi avec openwysiwig mais il
est tellement léger que ça ne sert à rien.

Mon objectif est d'installer au moins un équivalent de tinymce.

Drupal a choisi de faire un module générique pour installer un éditeu=
r
wysiwig : je n'aime pas trop car impose d'installer à la main les
modules qu'on veut ensuite.

Donc j'ai essayé d'installer directement tinymce.

dh-make-drupal et dpkg -i => OK.

Le module est bien installé et visible de l'interface de drupal. Je l'ai =
activé.

Il y a ensuite un problème car il ne trouve pas le .js. Le module
s'appelle drupal6-mod-tinymce et contient ce nom dans le répertoire à
la place de tinymce. J'ai fait un lien symbolique pour réparer (c'est
crade mais pour avancer !).

Ensuite, tout semble OK sauf que je n'ai jamais d'éditeurs dans les
pages ou les articles

Impossible de déboguer cela. Ça fait une semaine que je suis dessus.

Une âme charitable qui aurait réussi ?

Merci d'avance,

PK

--
      |      _,,,,,_       Patrice KARATCHENTZEFF
ZZZzz /,`.-'`'    -.  ;-;;,_   mailto:p.karatchentzeff@free.fr
     |,4-  ) )-,_. , (  `'-'  http://p.karatchentzeff.free.fr
    '''(_/--'  `-'_)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/AANLkTik-_rh-n6BPLu-1f0E16tw+0R-rCmhSkEWAp_vH@mail.gmail.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel Caillibaud
Le #22700721
Le 17/10/10 à 19:10, Patrice Karatchentzeff PK> J'ai fait le choix comme CMS de drupal parce que, pour beaucoup,
PK> c'était un des rares empaquetés... et le paquet dh-make-drupa l m'a
PK> bien séduit.

Je connais un peu drupal mais pas le paquet du même nom (en gén éral pour les applis web j'aime autant partir des sources
originales, surtout pour drupal où de toute façon on ajoute plein de modules).

../..
PK> Mon objectif est d'installer au moins un équivalent de tinymce.

Ben, installe tinyMCE ;-)

PK> Drupal a choisi de faire un module générique pour installer u n éditeur
PK> wysiwig : je n'aime pas trop car impose d'installer à la main les
PK> modules qu'on veut ensuite.

C'était déjà le cas avant, à cause de licences de redis tributions restrictives, sauf qu'avant il fallait télécharger le module
tinyMce + tinyMce, idem pour les autres, maintenant y'a un module unique av ec une lib à installer par éditeur, je trouve ça
nettement mieux (ça permet d'avoir différents éditeurs suiva nt les types de contenus, avec un seul module installé).

PK> Donc j'ai essayé d'installer directement tinymce.
PK>
PK> dh-make-drupal et dpkg -i => OK.
PK>
PK> Le module est bien installé et visible de l'interface de drupal. J e l'ai activé.
PK>
PK> Il y a ensuite un problème car il ne trouve pas le .js. Le module
PK> s'appelle drupal6-mod-tinymce et contient ce nom dans le répertoir e à
PK> la place de tinymce. J'ai fait un lien symbolique pour réparer (c' est
PK> crade mais pour avancer !).
PK>
PK> Ensuite, tout semble OK... sauf que je n'ai jamais d'éditeurs dans les
PK> pages ou les articles...
PK>
PK> Impossible de déboguer cela. Ça fait une semaine que je suis dessus.

Un pb de format d'entrée non ?

PK> Une âme charitable qui aurait réussi ?

Ben, oui, mais sans le paquet.

Installe (hors arbo web) le module drush, et ensuite tu utilise ses scripts pour installer / mettre à jour tous les modules en
une commande, activer/désactiver thèmes et modules, etc.
Il ne restera plus que les mise à jour du core à faire à la main, mais c'est pas très compliqué (cf
http://arnumeral.fr/tutoriels/drupal/mettre-a-jour-drupal-simplement) et pa s très fréquent (et si tu as coché la bonne case,
ton site te prévient par mail qu'il faut le faire).

--
Daniel

Écrivez dans l'ivresse, mais relisez-vous à jeun.
André Gide

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme