dvb: firmware upload

Le
Nicolas Folin
Je cherche à installer une carte dvb hauppage wintv HVR 1110, le
chipset tnt est à base de saa7133 ou 34.

Je peux charger correctement les modules saa7134 et saa7134_dvb.
dmesg donne après le chargement de saa7134:
=
saa7130/34: v4l2 driver version 0.2.14 loaded
saa7133[0]: found at 0000:01:0a.0, rev: 209, irq: 21, latency: 32, mmio:
0xeb004000
saa7133[0]: subsystem: 0070:6701, board: Hauppauge WinTV-HVR1110
DVB-T/Hybrid [card4,autodetected]
saa7133[0]: board init: gpio is 6400000
input: HVR 1110 as /class/input/input6
ir-kbd-i2c: HVR 1110 detected at i2c-3/3-0071/ir0 [saa7133[0]]
tuner 3-004b: chip found @ 0x96 (saa7133[0])
tuner 3-004b: setting tuner address to 61
tuner 3-004b: type set to tda8290+75a
tuner 3-004b: setting tuner address to 61
tuner 3-004b: type set to tda8290+75a
saa7133[0]: i2c eeprom 00: 70 00 01 67 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7133[0]: i2c eeprom 10: ff ff ff 0e ff 20 ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 20: 01 40 01 32 32 01 01 33 88 ff 00 aa ff ff ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 40: ff 21 00 c2 96 10 03 32 15 60 ff ff ff ff ff ff
saa7133[0]: i2c eeprom 50: ff 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
saa7133[0]: i2c eeprom 60: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
saa7133[0]: i2c eeprom 70: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
saa7133[0]: registered device video1 [v4l2]
saa7133[0]: registered device vbi1
saa7133[0]: registered device radio0
=

j'attend un peu et je charge saa7134-dvb:

=
DVB: registering new adapter (saa7133[0]).
DVB: registering frontend 1 (Philips TDA10046H DVB-T)
=

Et dès que j'essaye d'utiliser la carte (un dvbscan fr-Paris par
exemple), il donne:
=
tda1004x: setting up plls for 48MHz sampling clock
tda1004x: timeout waiting for DSP ready
tda1004x: found firmware revision 0 -- invalid
tda1004x: waiting for firmware upload
tda1004x: no firmware upload (timeout or file not found?)
tda1004x: firmware upload failed
=


J'ai vu sur certains site pour ubuntu qu'il fallait récupérer les
firmwares, chose que j'ai faite,
et les placer dans /lib/firmware/[numéro de noyau].

Ce dernier répertoire n'existant pas, je l'ai créer et j'ai essayé, mais
rien n'y fait.

Que dois-je faire pour pouvoir uploader ce firmware ?
Y a-t-il un répertoire spécifique où le mettre ?
Dois-je recompiler le module saa7134-dvb en plaçant ce fichier quelque
part ?
Je dois avouer que c'est bien la première fois que je me heurte à un
problème de
"matériel sans firmware", comme je l'ai (maintenant) lu sur le net


En vous remerciant par avance
Nicolas Folin


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas Folin
Le #9526731
Je me réponds, juste au cas où:

apparemment, je n'avais pas récupéré le bon firmware.

J'ai recopié les fichiers nommés "dvb-fe-tda10045.fw" et
"dvb-fe-tda10046.fw"
récupéré à l'aide du script perl trouvé dans
"/usr/src/linux/Documentation/dvb/get_dvb_firmware"
et je les ai placés dans /usr/lib/hotplug/firmware

Lorsque le 10045.fw était seul, j'avais l'erreur ci dessous.

Lorsque j'ai rajouté le 10046.fw, dmesg m'a indiqué:
======================================= tda1004x: setting up plls for 48MHz sampling clock
tda1004x: timeout waiting for DSP ready
tda1004x: found firmware revision 0 -- invalid
tda1004x: waiting for firmware upload...
tda1004x: found firmware revision 29 -- ok
=======================================
Maintenant, je me heurte à un autre problème:
j'ai deux cartes dvb, et l'une prend les fréquences finissant par
000000, l'autre
les fréquences finissant par 167000...

Mais je divague vers un autre sujet, il me semble...

Merci de m'avoir écouté :o)
Nicolas Folin wrote:
Je cherche à installer une carte dvb hauppage wintv HVR 1110, le
chipset tnt est à base de saa7133 ou 34.

Je peux charger correctement les modules saa7134 et saa7134_dvb.
dmesg donne après le chargement de saa7134:
============================================================ > saa7130/34: v4l2 driver version 0.2.14 loaded
saa7133[0]: found at 0000:01:0a.0, rev: 209, irq: 21, latency: 32,
mmio: 0xeb004000
saa7133[0]: subsystem: 0070:6701, board: Hauppauge WinTV-HVR1110
DVB-T/Hybrid [card4,autodetected]
saa7133[0]: board init: gpio is 6400000
input: HVR 1110 as /class/input/input6
ir-kbd-i2c: HVR 1110 detected at i2c-3/3-0071/ir0 [saa7133[0]]
tuner 3-004b: chip found @ 0x96 (saa7133[0])
tuner 3-004b: setting tuner address to 61
tuner 3-004b: type set to tda8290+75a
tuner 3-004b: setting tuner address to 61
tuner 3-004b: type set to tda8290+75a
saa7133[0]: i2c eeprom 00: 70 00 01 67 54 20 1c 00 43 43 a9 1c 55 d2
b2 92
saa7133[0]: i2c eeprom 10: ff ff ff 0e ff 20 ff ff ff ff ff ff ff ff
ff ff
saa7133[0]: i2c eeprom 20: 01 40 01 32 32 01 01 33 88 ff 00 aa ff ff
ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff
ff ff
saa7133[0]: i2c eeprom 40: ff 21 00 c2 96 10 03 32 15 60 ff ff ff ff
ff ff
saa7133[0]: i2c eeprom 50: ff 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00
saa7133[0]: i2c eeprom 60: 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00
saa7133[0]: i2c eeprom 70: 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00
saa7133[0]: registered device video1 [v4l2]
saa7133[0]: registered device vbi1
saa7133[0]: registered device radio0
============================================================ >
j'attend un peu et je charge saa7134-dvb:

============================================================ > DVB: registering new adapter (saa7133[0]).
DVB: registering frontend 1 (Philips TDA10046H DVB-T)...
============================================================ >
Et dès que j'essaye d'utiliser la carte (un dvbscan fr-Paris par
exemple), il donne:
============================================================ > tda1004x: setting up plls for 48MHz sampling clock
tda1004x: timeout waiting for DSP ready
tda1004x: found firmware revision 0 -- invalid
tda1004x: waiting for firmware upload...
tda1004x: no firmware upload (timeout or file not found?)
tda1004x: firmware upload failed
============================================================ >

J'ai vu sur certains site pour ubuntu qu'il fallait récupérer les
firmwares, chose que j'ai faite,
et les placer dans /lib/firmware/[numéro de noyau].

Ce dernier répertoire n'existant pas, je l'ai créer et j'ai essayé,
mais rien n'y fait.

Que dois-je faire pour pouvoir uploader ce firmware ?
Y a-t-il un répertoire spécifique où le mettre ?
Dois-je recompiler le module saa7134-dvb en plaçant ce fichier quelque
part ?
Je dois avouer que c'est bien la première fois que je me heurte à un
problème de
"matériel sans firmware", comme je l'ai (maintenant) lu sur le net...


En vous remerciant par avance
Nicolas Folin






--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme