Echec d'Installation Dual boot Squeeze et MSWIN

Le
Bernard
Ayant voulu installer Linux en dual boot sur trois ordis de mon
association, j'ai obtenu un succès sur les deux premiers, mais c'est une
espèce de cata sur le troisième. Dans chaque cas, j'ai fait usage de
GParted pour repartitionner en conservant les données, puis j'ai
installé, Lenny sur l'un, et Squeeze sur l'autre. Sur le troisième, j'ai
procédé de même, avec Squeeze, et c'est au moment de choisir les options
de GRUB que je me suis planté, voulant, sans doute à tort, adopter les
mêmes choix que pour les deux installations précédentes.

Lorsque la question m'a été posée de savoir si je souhaitais installer
GRUB sur le MBR (Master Boot Record (secteurs d'amorçage)), j'ai répondu
par l'affirmative, comme j'avais toujours fait jusqu'ici. En fait, je
crois me souvenir que la question était la suivante: "Si la liste des
systèmes ci-affichés est exhaustive, vous pouvez sans crainte installer
GRUB sur le mbr". Quels systèmes étaient donc affichés ? Un, voire deux
systèmes Windows ; je me souviens d'avoir vu, pour sûr, "Windows
Recovery", mais je ne sais plus s'il y en avait ou non un second, le
seul souvenir précis que j'aie, c'est que Linux n'apparaissait pas, ce
que j'avais interprété comme normal, vu que son installation n'était pas
encore tout à fait finalisée. J'ai donc cliqué sur OK pour
l'installation de GRUB sur le MBR, et l'installation s'est achevée sans
problème.

Au Reboot, GRUB n'affichait que trois options: Debian Squeeze, Debian
Squeeze recovery mode, et Windows Recovery Environment (loader sda1)

Par défaut, le boot est sur Squeeze et çà démarre parfaitement, tout
se comporte normalement.

Par contre, si j'essaye de booter sur la seule possibilité offerte pour
Windows (Windows Recovery), cela aboutit rapidement

Windows is loading files
microsoft corporation

puis un

écran ressemblant à une aurore bauréale, puis un nouvel écran:

Can not open file C:RECOVERY.DAT

et, en énormes caractères : ERROR

et là, tout est bloqué et je ne peux sortir qu'en débranchant l'alim. et
la batterie !

Pourtant, le fichier RECOVERY.DAT existe bien. MSWIN habite deux partitions:

/dev/sda1 et /dev/sda2 (Linux étant installé sur une seule partition:
/dev/sda3)

si je fais, depuis Linux:

#mount /dev/sda1 /mnt/fat/

j'accède à un certain nombre de fichiers et répertoires (total environ
7.6 Gb), mais il n'y a pas RECOVERY.DAT

Si c'est /dev/sda2 que je monte d'abord (pour cette fois ci, pas pour
la précédente), j'ai le msg suivant:

The disk contains an unclean file system (0, 0).
The file system wasn't safely closed on Windows. Fixing.
#

/dev/sda2 contient (d'après un 'du -m') près de 30 Gb. J'y trouve un
fichier intitulé RECOVERY.DAT, qui ne fait que 12 octets, 2 lignes de
texte, comme suit:

X71A (puis CTRL-M, soit "caret" précédent le char "M")
X71Q (puis même caractère que dessus)

Alors je ne sais quoi faire. Suffirait il que je copie RECOVERY.DAT
depuis /dev/sda2 vers /dev/sda1 ? Ou bien devrais-je tenter, avec la
config de GRUB, de modifier le boot de MSWIN en précisant /dev/sda2 au
lieu de /dev/sda1 ?

Merci d'avance de me faire part de vos expériences et recommandations.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/4D764B7F.5050409@teaser.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
nono
Le #23188701
--=-ORXrKmfXc9JDKxDARkN7
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

Le mardi 08 mars 2011 à 16:30 +0100, Bernard a écrit :
Ayant voulu installer Linux en dual boot sur trois ordis de mon
association, j'ai obtenu un succès sur les deux premiers, mais c'est une
espèce de cata sur le troisième. Dans chaque cas, j'ai fait usa ge de
GParted pour repartitionner en conservant les données, puis j'ai
installé, Lenny sur l'un, et Squeeze sur l'autre. Sur le troisià ¨me, j'ai
procédé de même, avec Squeeze, et c'est au moment de chois ir les options
de GRUB que je me suis planté, voulant, sans doute à tort, adop ter les
mêmes choix que pour les deux installations précédentes.

Lorsque la question m'a été posée de savoir si je souhaita is installer
GRUB sur le MBR (Master Boot Record (secteurs d'amorçage)), j'ai r épondu
par l'affirmative, comme j'avais toujours fait jusqu'ici. En fait, je
crois me souvenir que la question était la suivante: "Si la liste de s
systèmes ci-affichés est exhaustive, vous pouvez sans crainte i nstaller
GRUB sur le mbr". Quels systèmes étaient donc affichés ? Un, voire deux
systèmes Windows ; je me souviens d'avoir vu, pour sûr, "Window s
Recovery", mais je ne sais plus s'il y en avait ou non un second, le
seul souvenir précis que j'aie, c'est que Linux n'apparaissait pas, ce
que j'avais interprété comme normal, vu que son installation n' était pas
encore tout à fait finalisée. J'ai donc cliqué sur OK pour
l'installation de GRUB sur le MBR, et l'installation s'est achevée s ans
problème.

Au Reboot, GRUB n'affichait que trois options: Debian Squeeze, Debian
Squeeze recovery mode, et Windows Recovery Environment (loader sda1)



Peut-être une piste :

J'ai eu également hier des déboires avec l'installeur debian sur un PC
portable. Mon objectif était d'installer debian squeeze en dual-boot.
- l'installation a été réalisée sans l'accès Inter net mais avec les 2
premiers DVD de la distribution.
- l'installation classique (distrib avec gnome) s'est déroulée
correctement (sda3 pour le / et sda4 pour swap).
- puis installation de grub sur le mbr

Au reboot, seule debian était proposée avec deux choix (le normal et le
rescue).

En cherchant sur le net, il semble que debian n'installe pas le paquet
os-prober.

Voir ceci :
http://debian-facile.org/forum/viewtopic.php?pid530

Je n'ai pas eu le temps de réessayer. Il semble qu'après l'instal lation
de ce paquet, il faille lancer la commande « update-grub2 ».

Je n'ai malheureusement pas eu le temps d'essayer, je n'avais pas
l'accès au net ni aux forums pour trouver des solutions au moment de
l'installation.

a+
nono




Par défaut, le boot est sur Squeeze... et çà démarre parfaitement, tout
se comporte normalement.

Par contre, si j'essaye de booter sur la seule possibilité offerte p our
Windows (Windows Recovery), cela aboutit rapidement

Windows is loading files...
microsoft corporation...

puis un

écran ressemblant à une aurore bauréale, puis un nouvel écran:

Can not open file C:RECOVERY.DAT

et, en énormes caractères : ERROR

et là, tout est bloqué et je ne peux sortir qu'en débranch ant l'alim. et
la batterie !

Pourtant, le fichier RECOVERY.DAT existe bien. MSWIN habite deux partitio ns:

/dev/sda1 et /dev/sda2 (Linux étant installé sur une seule part ition:
/dev/sda3)

si je fais, depuis Linux:

#mount /dev/sda1 /mnt/fat/

j'accède à un certain nombre de fichiers et répertoires (t otal environ
7.6 Gb), mais il n'y a pas RECOVERY.DAT

Si c'est /dev/sda2 que je monte... d'abord (pour cette fois ci, pas pour
la précédente), j'ai le msg suivant:

The disk contains an unclean file system (0, 0).
The file system wasn't safely closed on Windows. Fixing.
#

/dev/sda2 contient (d'après un 'du -m') près de 30 Gb. J'y tro uve un
fichier intitulé RECOVERY.DAT, qui ne fait que 12 octets, 2 lignes d e
texte, comme suit:

X71A (puis CTRL-M, soit "caret" précédent le char "M")
X71Q (puis même caractère que dessus)

Alors je ne sais quoi faire. Suffirait il que je copie RECOVERY.DAT
depuis /dev/sda2 vers /dev/sda1 ? Ou bien devrais-je tenter, avec la
config de GRUB, de modifier le boot de MSWIN en précisant /dev/sda2 au
lieu de /dev/sda1 ?

Merci d'avance de me faire part de vos expériences et recommandation s.






--=-ORXrKmfXc9JDKxDARkN7
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEABECAAYFAk13AOUACgkQsuWx6lZRvlu42wCfaCYJVD5T2Jx3V5DvC9iFUP5K
B9gAniaDNpTb/biWoXz4eIni18ks/JUr
|mw
-----END PGP SIGNATURE-----

--=-ORXrKmfXc9JDKxDARkN7--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Pierre Meurisse
Le #23188981
On Tue, Mar 08, 2011 at 04:30:07PM +0100, Bernard wrote:



..
Par contre, si j'essaye de booter sur la seule possibilité offerte
pour Windows (Windows Recovery), cela aboutit rapidement

Windows is loading files...
microsoft corporation...

puis un

écran ressemblant à une aurore bauréale, puis un nouvel écran:

Can not open file C:RECOVERY.DAT

et, en énormes caractères : ERROR

et là, tout est bloqué et je ne peux sortir qu'en débranchant
l'alim. et la batterie !

Pourtant, le fichier RECOVERY.DAT existe bien. MSWIN habite deux partitions:

/dev/sda1 et /dev/sda2 (Linux étant installé sur une seule
partition: /dev/sda3)

si je fais, depuis Linux:

#mount /dev/sda1 /mnt/fat/

j'accède à un certain nombre de fichiers et répertoires (total
environ 7.6 Gb), mais il n'y a pas RECOVERY.DAT

Si c'est /dev/sda2 que je monte... d'abord (pour cette fois ci, pas
pour la précédente), j'ai le msg suivant:

The disk contains an unclean file system (0, 0).
The file system wasn't safely closed on Windows. Fixing.
#

Merci d'avance de me faire part de vos expériences et recommandations.



Apparemment ton W$ est sur /dev/sda2.
Tu peux éditer le fichier /boot/grub/grub.cfg, sans t'inquiéter de la
mention
#
# DO NOT EDIT THIS FILE
#
qui figure au début.

Tu vas sans doute trouver un truc du genre :

menuentry "windows " {
set root=(hd0,1)
chainloader +1
boot
}

Il suffit de remplacer (hd0,1) par (hd0,2) et de forcer l'écriture du fichier.

Si tout marche comme prévu, tu peux éditer

/etc/grub.d/40_custom

et y placer les 5 lignes qui marchent bien, puis

# update-grub

qui réécrira proprement le fichier prédédent.

J'ai l'habitude de supprimer les droits d'exécution de 30_os-prober pour
éviter les entrées fantaisistes.


Pas de partition de swap ?

Bon courage.

--
Pierre Meurisse

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernard
Le #23190541
Pierre Meurisse wrote:
On Tue, Mar 08, 2011 at 04:30:07PM +0100, Bernard wrote:

..




Pas de partition de swap ?



Mais si. J'en ai défini une de 6 Gb lors de l'installation, je ne me
souviens plus si c'était sda3 ou sda6 ou ? Mais j'aimerais bien la
retrouver, pour vérifier qu'elle n'a pas été virée accidentellement. Je
doute que ce soit le cas, sinon mon système déconnerait sans doute, ou
fonctionnerait très lentement. Cette partition swap n'apparaît pas dans
GRUB, ce qui me paraît normal, car l'on ne peut booter dessus (et je
n'ai jamais vu un lilo ou un grub afficher le swap). On ne peut la
'monter' (unknown filesystem), et donc elle n'apparaît pas avec un 'df'

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
jerome moliere
Le #23190531
--bcaec51b1f13c94e5c049e0e48c9
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Le 9 mars 2011 16:14, Bernard
Pierre Meurisse wrote:

On Tue, Mar 08, 2011 at 04:30:07PM +0100, Bernard wrote:
..



Pas de partition de swap ?




Mais si. J'en ai défini une de 6 Gb lors de l'installation, je ne me
souviens plus si c'était sda3 ou sda6 ou ? Mais j'aimerais bien la
retrouver, pour vérifier qu'elle n'a pas été virée ac cidentellement. Je
doute que ce soit le cas, sinon mon système déconnerait sans do ute, ou
fonctionnerait très lentement. Cette partition swap n'apparaît pas dans
GRUB, ce qui me paraît normal, car l'on ne peut booter dessus (et je n'ai
jamais vu un lilo ou un grub afficher le swap). On ne peut la 'monter'
(unknown filesystem), et donc elle n'apparaît pas avec un 'df'




fdisk sur /dev/sda doit la montrer je pense ?

Jerome

--
J.MOLIERE - Mentor/J
auteur Eyrolles

--bcaec51b1f13c94e5c049e0e48c9
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable


Pierre Meurisse wrote:<br>
On Tue, Mar 08, 2011 at 04:30:07PM +0100, Bernard wrote:<br>
 ..<br>
 <br>
<br>
<br>
Pas de partition de swap ?<br>
 <br>
</blockquote>
Mais si. J&#39;en ai défini une de 6 Gb lors de l&#39;installation, je ne me souviens plus si c&#39;était sda3 ou sda6 ou ?   Mais j&#3 9;aimerais bien la retrouver, pour vérifier qu&#39;elle n&#39;a pas été virée accidentellement. Je doute que ce soit le cas, sin on mon système déconnerait sans doute, ou fonctionnerait trè s lentement. Cette partition swap n&#39;apparaît pas dans GRUB, ce qui me paraît normal, car l&#39;on ne peut booter dessus (et je n&#39;ai jamais vu un lilo ou un grub afficher le swap). On ne peut la &#39;monter&# 39; (unknown filesystem), et donc elle n&#39;apparaît pas avec un &#39 ;df&#39;<font color="#888888"></font><br>


<div><br></div></div><br>

--bcaec51b1f13c94e5c049e0e48c9--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/AANLkTi¼
Yves Rutschle
Le #23190581
On Wed, Mar 09, 2011 at 04:14:22PM +0100, Bernard wrote:
Mais si. J'en ai défini une de 6 Gb lors de l'installation, je ne me
souviens plus si c'était sda3 ou sda6 ou ? Mais j'aimerais bien la
retrouver, pour vérifier qu'elle n'a pas été virée accidentellement.



sfdisk -l /dev/sda

t'affichera la liste des partitions avec leur type. Il se
peut que ta partition de swap n'ai pas le bon type, mais au
moins tu pourras retrouver les partitions exitantes non
montées.

Y.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernard
Le #23191251
Yves Rutschle wrote:
On Wed, Mar 09, 2011 at 04:14:22PM +0100, Bernard wrote:

Mais si. J'en ai défini une de 6 Gb lors de l'installation, je ne me
souviens plus si c'était sda3 ou sda6 ou ? Mais j'aimerais bien la
retrouver, pour vérifier qu'elle n'a pas été virée accidentellement.




sfdisk -l /dev/sda

t'affichera la liste des partitions avec leur type. Il se
peut que ta partition de swap n'ai pas le bon type, mais au
moins tu pourras retrouver les partitions exitantes non
montées.

Y.




Bien trouvé en effet. Mon swap est sur /dev/sda6, il fait 5,858,304
blocks, et le système s'intitule: "Linux swap / Solaris". Je pense que
çà fait près de 6 Gb pour le swap.

Tout baigne !

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme