Echec d'installation de grub sur un Samsung RC730

Le
denis.paris
Mon fils fait actuellement de la production audio sur un portable
Samsung en utilisant des logiciels sous Windows 7, et étant tenté par
l'utilisation de certains logiciels libres m'a demandé une assistance
pour installer une version de linux "ubuntu studio 13-10".

Ce portable ayant second emplacement de disque dur un disque neuf a donc
été installé (Sata II) afin de limiter les risques de l'opération. Ainsi
le premier disque dédié à Windows ne serait pas touché, sauf bien sûr
pour le boot loader. Je lui ai assuré que l'opération était donc sans
risque

Et bien sûr, alors que j'ai installé des dizaines de fois des linux sur
des machines très différentes, cette fois ce fut une catastrophe: au
moment de l'installation du grub le programme me propose le premier
secteur de sda (comme d'habitude), ce que j'accepte, pas de message
d'erreur, demande de reboot et là l'horreur, la machine démarre
directement dans le grub en mode "rescue".

Réinstallions en choisissant d'autre options pour le grub, rien à faire.
Donc impossible de démarrer un OS, ni linux ni surtout Windows. Bien sûr
impossible de mettre la main sur le CD W7 livré avec la machine, lje
retrouve une image ISO d'un Windows que je grave sur une autre machine,
je tente la réparation proposée (qui détecte bien un pb de config) sans
succès, perspective d'avoir à tout réinstaller, cris, hurlements car
bien sûr il y avait un projet urgent Finalement en bidouillant en
mode ligne de commande je parviens à réparer le bouzin. Ouf.

N'ayant jamais été confronté à un tel comportement ("j'ai déjà entendu
ça", m'a-t-on dit) j'ai cherché d'où pouvait venir l'erreur et j'ai
remarqué que le second disque n'est pas vu dans le bios. Il y a 3 ports
SATA, avec un seul disque dans la machine on voit port 1 pour un disque,
port 2 pour le DVD et port 3 de libre, si on rajoute un disque dur on
s'attend à ce que le 3ème port soit alors occupé mais ce n'est pas le
cas. Pourtant le second disque est vu quand on lance un OS, que ce soit
Windows ou une version "Live" d'ubuntu qui le voit bien en /dev/sdb

Je m'excuse d'avoir été un peu long. Mon hypothèse pour le moment est
que le programme d'installation de grub a été trompé à un moment donné
par une remontée d'information du bios non conforme. Il est très
inhabituel qu'au niveau d'un OS on voit des éléments que le bios "ne
voit pas". Mes questions sont donc:

- avez-vous déjà été confronté à ce type d'incohérence entre le bios et
ce que voit l'OS?

- se pourrait-il qu'il y ait une sorte de "mutualisation" au niveau
hardware, par exemple les deux disques partageant le même port logique
dans la machine?

- je compte refaire un essai en utilisant le programme spécifique
"boot-repair", est-ce une bonne stratégie?

- ai-je loupé quelque chose?
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JKB
Le #25957262
Le Mon, 27 Jan 2014 10:55:16 +0100,
denis.paris
Mon fils fait actuellement de la production audio sur un portable
Samsung en utilisant des logiciels sous Windows 7, et étant tenté par
l'utilisation de certains logiciels libres m'a demandé une assistance
pour installer une version de linux "ubuntu studio 13-10".

Ce portable ayant second emplacement de disque dur un disque neuf a donc
été installé (Sata II) afin de limiter les risques de l'opération. Ainsi
le premier disque dédié à Windows ne serait pas touché, sauf bien sûr
pour le boot loader. Je lui ai assuré que l'opération était donc sans
risque...

Et bien sûr, alors que j'ai installé des dizaines de fois des linux sur
des machines très différentes, cette fois ce fut une catastrophe: au
moment de l'installation du grub le programme me propose le premier
secteur de sda (comme d'habitude), ce que j'accepte, pas de message
d'erreur, demande de reboot... et là l'horreur, la machine démarre
directement dans le grub en mode "rescue".

Réinstallions en choisissant d'autre options pour le grub, rien à faire.
Donc impossible de démarrer un OS, ni linux ni surtout Windows. Bien sûr
impossible de mettre la main sur le CD W7 livré avec la machine, lje
retrouve une image ISO d'un Windows que je grave sur une autre machine,
je tente la réparation proposée (qui détecte bien un pb de config) sans
succès, perspective d'avoir à tout réinstaller, cris, hurlements car
bien sûr il y avait un projet urgent... Finalement en bidouillant en
mode ligne de commande je parviens à réparer le bouzin. Ouf.

N'ayant jamais été confronté à un tel comportement ("j'ai déjà entendu
ça", m'a-t-on dit) j'ai cherché d'où pouvait venir l'erreur et j'ai
remarqué que le second disque n'est pas vu dans le bios. Il y a 3 ports
SATA, avec un seul disque dans la machine on voit port 1 pour un disque,
port 2 pour le DVD et port 3 de libre, si on rajoute un disque dur on
s'attend à ce que le 3ème port soit alors occupé mais ce n'est pas le
cas. Pourtant le second disque est vu quand on lance un OS, que ce soit
Windows ou une version "Live" d'ubuntu qui le voit bien en /dev/sdb

Je m'excuse d'avoir été un peu long. Mon hypothèse pour le moment est
que le programme d'installation de grub a été trompé à un moment donné
par une remontée d'information du bios non conforme. Il est très
inhabituel qu'au niveau d'un OS on voit des éléments que le bios "ne
voit pas". Mes questions sont donc:

- avez-vous déjà été confronté à ce type d'incohérence entre le bios et
ce que voit l'OS?



Oui, sur un Lenovo Ideapad. Même motif, même punition. Je ne sais
plus comment je m'en suis sorti. Je me souviens juste qu'à partir de
Windows, je n'ai jamais vu le disque physique Linux, mais à partir
de Linux, je voyais bien le disque Windows.

- se pourrait-il qu'il y ait une sorte de "mutualisation" au niveau
hardware, par exemple les deux disques partageant le même port logique
dans la machine?



Je ne suis pas sûr. Je pense surtout à un bug du bios, voire à une
limitation volontaire.

- je compte refaire un essai en utilisant le programme spécifique
"boot-repair", est-ce une bonne stratégie?



Aucune idée.

- ai-je loupé quelque chose?



Cordialement,

JKB

--
Si votre demande me parvient sur carte perforée, je titiouaillerai très
volontiers une réponse...
=> http://grincheux.de-charybde-en-scylla.fr
=> http://loubardes.de-charybde-en-scylla.fr
jp willm
Le #25957772
Le 27/01/2014 10:55, denis.paris a écrit :

- ai-je loupé quelque chose?





As-tu désactivé "boot secure" dans le bios ?


--
jp willm
http://perso.orange.fr/willms/index.html
denis.paris
Le #25958412
Le 27/01/2014 16:47, jp willm a écrit :
Le 27/01/2014 10:55, denis.paris a écrit :

- ai-je loupé quelque chose?





As-tu désactivé "boot secure" dans le bios ?




Je n'ai pas vu cette option, mais je m'étais assuré que UEFI était
désactivé dans le bios. Est-ce une option différente?

En tout cas je vais m'en assurer (je n'ai pas le PC sous la main), merci
pour cette piste. Pour info le PC est sous W7, il me semble que cette
option "secure boot" est plutôt liée à W8.
jp willm
Le #25958582
Le 27/01/2014 22:42, denis.paris a écrit :
il me semble que cette
option "secure boot" est plutôt liée à W8.



En effet, je me suis sans doute précipité : cette option "boot-secure",
je ne l'ai vue que sur des poste "pré-équipés" W8...


--
http://perso.orange.fr/willms/index.html
jp willm
Le #25958572
Le 28/01/2014 06:13, jp willm a écrit :

En effet, je me suis sans doute précipité : cette option "boot-secure",
je ne l'ai vue que sur des poste "pré-équipés" W8...



Mais qui sait...


--
http://perso.orange.fr/willms/index.html
Sergio
Le #25958622
Le 28/01/2014 06:13, jp willm a écrit :
Le 27/01/2014 22:42, denis.paris a écrit :
il me semble que cette
option "secure boot" est plutôt liée à W8.



En effet, je me suis sans doute précipité : cette option "boot-secure",
je ne l'ai vue que sur des poste "pré-équipés" W8...



Détrompe-toi :
Sur ma carte mère (Asus F2A55), cette option existe. PC "monté à la main, roulé sous les aisselles".

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Eric Masson
Le #25958652
Sergio
'Lut,

Sur ma carte mère (Asus F2A55), cette option existe. PC "monté à la
main, roulé sous les aisselles".



C'est lié à la spec uefi :
http://fr.wikipedia.org/wiki/Unified_Extensible_Firmware_Interface#Lancement_s.C3.A9curis.C3.A9_.28secure_boot.29

--
Newsgroups: fr.comp.mail
je suis à la recherche d'un shema électronique d'un émetteur G.P.S
(Global position system) ou à defaut une adrs Email
-+- N in Guide du Neuneu Usenet - Sans son GNU, on est perdu -+-
Electron
Le #25959512
Le 27/01/2014 22:42, denis.paris a écrit :
Le 27/01/2014 16:47, jp willm a écrit :
Le 27/01/2014 10:55, denis.paris a écrit :

- ai-je loupé quelque chose?





As-tu désactivé "boot secure" dans le bios ?




Je n'ai pas vu cette option, mais je m'étais assuré que UEFI étai t
désactivé dans le bios. Est-ce une option différente?

En tout cas je vais m'en assurer (je n'ai pas le PC sous la main), merc i
pour cette piste. Pour info le PC est sous W7, il me semble que cette
option "secure boot" est plutôt liée à W8.





Bonjour,

J'ai un peu cherché à me documenter sur l'UEFI pour pouvoir faire une
sauvegarde d'un portable Asus Win8 par image disque. j'ai laissé de cot é
pour le moment, ce n'est pas ma machine. Ceci pour dire que je n'ai pas
approfondi...mais...

Tu peux aussi regarder à activer CSM "Compatibility Support Module"
(probablement dans la section boot). Cela passerait le PC en mode BIOS
pour la gestion du boot (lecture du secteur boot du disque au lieu de la
MBR)

Bien à vous,
Electron.
Dominique MICOLLET
Le #25960272
Bonjour,

Electron wrote:
lecture du secteur boot du disque au lieu de la
MBR)



Ah. J'ai toujours cru que le MBR était le secteur boot du disque.
Qu'est ce qui m'échappe ?


Cordialement

Dominique
Electron
Le #25961832
Le 29/01/2014 08:20, Dominique MICOLLET a écrit :
Ah. J'ai toujours cru que le MBR était le secteur boot du disque.
Qu'est ce qui m'échappe ?


Cordialement

Dominique



Exact Oui...^^
Le MBR contenant le bootstrap et la table des partitions (primaires).

Bien à vous,
Electron.
Publicité
Poster une réponse
Anonyme