Et encore les dates

Le
milloche
Bonjour tous
J'y vais direct car ce n'est pas évident à expliquer.
http://www.cijoint.fr/cjlink.php?file=cj200912/cij3NBcQ26.xls
Bon courage
JMM
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
FS
Le #20746221
FS
--
Frédéric SIGONNEAU
Modules et modèles pour Excel :
http://frederic.sigonneau.free.fr/

milloche a écrit :
Bonjour tous
J'y vais direct car ce n'est pas évident à expliquer.
http://www.cijoint.fr/cjlink.php?file=cj200912/cij3NBcQ26.xls
Bon courage
JMM




FS
Le #20746211
Bonjour,

=SI(estdate(B2);SI(JOUR(A2)<>JOUR(B2);PLAFOND(B2-A2;1);B2-A2);MAINTENANT()-A2)

FS
--
Frédéric SIGONNEAU
Modules et modèles pour Excel :
http://frederic.sigonneau.free.fr/

milloche a écrit :
Bonjour tous
J'y vais direct car ce n'est pas évident à expliquer.
http://www.cijoint.fr/cjlink.php?file=cj200912/cij3NBcQ26.xls
Bon courage
JMM




FS
Le #20746201
Re,

Peut-être que tu pourrais même te passer d'une fonction perso (toujours
plus lente que les fonctions intégrées) si le critère discriminant en Bx
est toujours une annotation comme 'en cours' :

=SI(NON(ESTTEXTE(B2));SI(JOUR(A2)<>JOUR(B2);PLAFOND(B2-A2;1);B2-A2);MAINTENANT()-A2)

FS
--
Frédéric SIGONNEAU
Modules et modèles pour Excel :
http://frederic.sigonneau.free.fr/

milloche a écrit :
Bonjour tous
J'y vais direct car ce n'est pas évident à expliquer.
http://www.cijoint.fr/cjlink.php?file=cj200912/cij3NBcQ26.xls
Bon courage
JMM




Jacquouille
Le #20746191
Bonjour Milloche
Je ne comprends pas ta manière d'aborder le problème car, en regardant la
colE, on a l'impression que l'on travaille plus en ligne 3 que en ligne 4.
Perso, je fais =mod(B2-A2;1), formaté en [h]:mm
Pour répondre (essayer) à ta question, tu peux mettre une condition en plus
=si(jour(b2)-jour(a2)=0;ta formule;jour(b2--jour(a2)) --->
=SI(JOUR(B2)-JOUR(A2)=0;SI(estdate(B2);(B2-A2);(MAINTENANT()-A2));JOUR(B2-JOUR(A2)))

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"milloche"
Bonjour tous
J'y vais direct car ce n'est pas évident à expliquer.
http://www.cijoint.fr/cjlink.php?file=cj200912/cij3NBcQ26.xls
Bon courage
JMM



Daniel.C
Le #20746321
Bonjour.
=SI(estdate(B7);SI(ENT(B7)>ENT(A7)>0;ENT(B7)-ENT(A7);B7-A7);MAINTENANT()-A7)
Daniel

Bonjour tous
J'y vais direct car ce n'est pas évident à expliquer.
http://www.cijoint.fr/cjlink.php?file=cj200912/cij3NBcQ26.xls
Bon courage
JMM


milloche
Le #20746731
Impeccable
Merci à tous les trois.
Pour la question de Jacquouille, ce fichier est en réalité un fichier
bourse et des achats et reventes effectués dans la même journée sont
exonérées de frais de SRD. C'est pour cela que je voulais que ça apparaisse
quelque part. Me reste juste à trouver la formule pour le calcul de ces
frais quand la colonne F est égale à 1 ou plus.
JMM
"Daniel.C" %
Bonjour.
=SI(estdate(B7);SI(ENT(B7)>ENT(A7)>0;ENT(B7)-ENT(A7);B7-A7);MAINTENANT()-A7)
Daniel

Bonjour tous
J'y vais direct car ce n'est pas évident à expliquer.
http://www.cijoint.fr/cjlink.php?file=cj200912/cij3NBcQ26.xls
Bon courage
JMM






milloche
Le #20747681
Je suis long (ou lent) à la détente, mais pourquoi employer MOD(B2-A2;1)
alors que B2-A2 donne le même résultat. Depuis des temps immémoriaux, le
modulo était pour moi le reste d'une division, et ici c'est effectivement
le reste d'une division par 1.
Tu as certainement une bonne raison que, curieux étant, j'aimerais
connaître.
<}:o)) JMM

"Jacquouille" news: 4b225086$0$2870$
Bonjour Milloche
Je ne comprends pas ta manière d'aborder le problème car, en regardant la
colE, on a l'impression que l'on travaille plus en ligne 3 que en ligne
4.
Perso, je fais =mod(B2-A2;1), formaté en [h]:mm
Pour répondre (essayer) à ta question, tu peux mettre une condition en
plus
=si(jour(b2)-jour(a2)=0;ta formule;jour(b2--jour(a2)) --->
=SI(JOUR(B2)-JOUR(A2)=0;SI(estdate(B2);(B2-A2);(MAINTENANT()-A2));JOUR(B2-JOUR(A2)))

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"milloche"
Bonjour tous
J'y vais direct car ce n'est pas évident à expliquer.
http://www.cijoint.fr/cjlink.php?file=cj200912/cij3NBcQ26.xls
Bon courage
JMM







Jacquouille
Le #20748761
Bonsoir
Le traitement des dates et des heures est assez complexe dans Excel.
Ainsi, si en A1 tu entres 22:00 Hr comme heure de début de prestation, et en
B1, tu entres 06:00 Hr comme fin de prestation le lendemain, tu auras assez
difficile de faire 06:00-22:00 pour connaître le nombre d'heures
travaillées.....ce que te permet MOD(B1-A1;1)
De mémoire, c'est LL, le chef à 4 plumes et père fondateur de ce forum qui
nous avait appris ce truc.
Bonne soirée

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"milloche" O%
Je suis long (ou lent) à la détente, mais pourquoi employer MOD(B2-A2;1)
alors que B2-A2 donne le même résultat. Depuis des temps immémoriaux, le
modulo était pour moi le reste d'une division, et ici c'est effectivement
le reste d'une division par 1.
Tu as certainement une bonne raison que, curieux étant, j'aimerais
connaître.
<}:o)) JMM

"Jacquouille" news: 4b225086$0$2870$
Bonjour Milloche
Je ne comprends pas ta manière d'aborder le problème car, en regardant la
colE, on a l'impression que l'on travaille plus en ligne 3 que en ligne
4.
Perso, je fais =mod(B2-A2;1), formaté en [h]:mm
Pour répondre (essayer) à ta question, tu peux mettre une condition en
plus
=si(jour(b2)-jour(a2)=0;ta formule;jour(b2--jour(a2)) --->
=SI(JOUR(B2)-JOUR(A2)=0;SI(estdate(B2);(B2-A2);(MAINTENANT()-A2));JOUR(B2-JOUR(A2)))

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"milloche"
Bonjour tous
J'y vais direct car ce n'est pas évident à expliquer.
http://www.cijoint.fr/cjlink.php?file=cj200912/cij3NBcQ26.xls
Bon courage
JMM












Publicité
Poster une réponse
Anonyme