Encore la fonction Sous.Total avec condition

Le
EB
Bonjour,
Merci à Daniel C et Jb pour leurs réponses mais ma question concerne non pas
le filtre (je sais faire) mais la possibilité de mettre une condition à la
fonction sous.total.
Il s'agit d'une liste déjà filtrée sur d'autres critères dans laquelle je
voudrais obtenir automatiquement dans une cellule le soustotal des cellules
répondant par exemple au critère "f"
J'ai essayé la formule matricielle suivante :
{=SI(G2:G300="f";SOUS.TOTAL(3;G2:G300))}
qui me renvoie FAUX
Voyez vous une solution ?
Merci d'avance
EB
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #7085971
Bonjour.
Une fonction perso :

Function NbSiFiltre(Plage As Range, Sel As String)
Dim c As Range
For Each c In Plage
If c = Sel And c.EntireRow.Hidden = False Then
NbSiFiltre = NbSiFiltre + 1
End If
Next c
End Function

Cordialement.
Daniel
"EB"
Bonjour,
Merci à Daniel C et Jb pour leurs réponses mais ma question concerne non
pas le filtre (je sais faire) mais la possibilité de mettre une condition
à la fonction sous.total.
Il s'agit d'une liste déjà filtrée sur d'autres critères dans laquelle je
voudrais obtenir automatiquement dans une cellule le soustotal des
cellules répondant par exemple au critère "f"
J'ai essayé la formule matricielle suivante :
{=SI(G2:G300="f";SOUS.TOTAL(3;G2:G300))}
qui me renvoie FAUX
Voyez vous une solution ?
Merci d'avance
EB


Modeste
Le #7086781
Bonsour® MichDenis avec ferveur ;o))) vous nous disiez :

Un petit coup de chapeau pour AV


oui mais pas de sombrero, ce serait alors un coup de grand chapeau !!!

...son retour est éminent


;o))) serais-tu dans le secret des dieux ???
serait-ce également le retour de la famille V ...

les formules... c'est son job !!!


;-))))
j'savos pas qu'il étot chimiste !!!

--
@+
;o)))
Misange
Le #7087061
T'as raison Denis, peut être que si on crie tous en coeur
"AV reviens parmi les tiens"
il va nous entendre, et ChrisV avec :-)

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

MichDenis a écrit :
Validation matricielle : Ctrl + Maj + Enter
=SOMME(N(SI(SOUS.TOTAL(3;DECALER(G2;LIGNE(G2:G300)-LIGNE(G2);));G2:G300="f")))

Un petit coup de chapeau pour AV...son retour est éminent
les formules... c'est son job !!! ;-))))


"EB" Bonjour,
Merci à Daniel C et Jb pour leurs réponses mais ma question concerne non pas
le filtre (je sais faire) mais la possibilité de mettre une condition à la
fonction sous.total.
Il s'agit d'une liste déjà filtrée sur d'autres critères dans laquelle je
voudrais obtenir automatiquement dans une cellule le soustotal des cellules
répondant par exemple au critère "f"
J'ai essayé la formule matricielle suivante :
{=SI(G2:G300="f";SOUS.TOTAL(3;G2:G300))}
qui me renvoie FAUX
Voyez vous une solution ?
Merci d'avance
EB


MichDenis
Le #7087201
;-))

| Un petit coup de chapeau pour AV
| oui mais pas de sombrero, ce serait alors un coup de grand chapeau !!!

À Seattle, il n'y a pas beaucoup de sombrero !

| serais-tu dans le secret des dieux ???
| serait-ce également le retour de la famille V ...

2 pour le prix d'un -> c'est un bon "deal"

| les formules... c'est son job !!!
| j'savos pas qu'il étot chimiste !!!

C'est un bon catalyseur pour FOR MULE

'-------------------
D'après Wikipédia :
En chimie, un catalyseur est une substance qui augmente la vitesse d'une réaction
MichDenis
Le #7087371
| T'as raison Denis, peut être que si on crie tous en coeur

Je dirais plutôt qu'AV a besoin de "tranquillité" pour la "ponte"
de ces formules !

;-))
EB
Le #7094551
Merci Daniel C pour cette fonction qui fonctionne parfaitement
Merci aussi MichDenis pour ta formule matricielle, malheureusement elle me
renvoie le message FAUX ???
Cordialement
EB

"Daniel.C" news:
Bonjour.
Une fonction perso :

Function NbSiFiltre(Plage As Range, Sel As String)
Dim c As Range
For Each c In Plage
If c = Sel And c.EntireRow.Hidden = False Then
NbSiFiltre = NbSiFiltre + 1
End If
Next c
End Function

Cordialement.
Daniel
"EB"
Bonjour,
Merci à Daniel C et Jb pour leurs réponses mais ma question concerne non
pas le filtre (je sais faire) mais la possibilité de mettre une condition
à la fonction sous.total.
Il s'agit d'une liste déjà filtrée sur d'autres critères dans laquelle je
voudrais obtenir automatiquement dans une cellule le soustotal des
cellules répondant par exemple au critère "f"
J'ai essayé la formule matricielle suivante :
{=SI(G2:G300="f";SOUS.TOTAL(3;G2:G300))}
qui me renvoie FAUX
Voyez vous une solution ?
Merci d'avance
EB






MichDenis
Le #7094791
| Merci aussi MichDenis pour ta formule matricielle, malheureusement elle me
| renvoie le message FAUX ???

comme disait le maître, tu dois être victime d'un micro climat !
Publicité
Poster une réponse
Anonyme