Enlever le #N/A d'une cellule

Le
Marc
Bonjour à tous

Je suis à la recherche d'une aide : j'ai la formule suivante =(((E27-
F27)*(I27))-(G27-H27)) et je voudrais enlever le fameux #N/A qui
apparait dans la cellule lorsqu'il manque un de ces paramétres.

Merci de votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Marc
Le #21681051
On 4 mai, 17:26, Marc
Bonjour à tous

Je suis à la recherche d'une aide : j'ai la formule suivante =(((E27-
F27)*(I27))-(G27-H27)) et je voudrais enlever le fameux #N/A qui
apparait dans la cellule lorsqu'il manque un de ces paramétres.

Merci de votre aide



Désolé , débutant , je patauge un peu . Finalement , c'est la cellule
I27 qui me pose probléme car j'ai la formule RECHERCHEV(C27;W$17:Y
$26;3;FAUX) et lorsque la cel C27 est vide, le #N/A apparait. Je
pense que la formule n'est pas tout à fait bonne mais je n'arrive pas
à trouver où ?

Merci de m'aider

Marc
michdenis
Le #21681151
Bonjour,

=SI(ESTNA(RECHERCHEV(C27;W$17:Y$26;3;FAUX));"";RECHERCHEV(C27;W$17:Y$26;3;FAUX))




"Marc"
Bonjour à tous

Je suis à la recherche d'une aide : j'ai la formule suivante =(((E27-
F27)*(I27))-(G27-H27)) et je voudrais enlever le fameux #N/A qui
apparait dans la cellule lorsqu'il manque un de ces paramétres.

Merci de votre aide
Jacky
Le #21681211
Bonjour,

Essaie
0 ou 1 en i27 si on ne trouve pas la correspondance dans le tableau ou si e27 n'est pas saisie.
En i27 selon le resultat que tu dois obtenir

=SI(ESTNA(RECHERCHEV(C27;W$17:Y$26;3;0));0;RECHERCHEV(C27;W$17:Y$26;3;0))
ou
=SI(ESTNA(RECHERCHEV(C27;W$17:Y$26;3;0));1;RECHERCHEV(C27;W$17:Y$26;3;0))

et
=(E27-F27)*I27-(G27-H27)
est suffisant

--
Salutations
JJ


"Marc"
Bonjour à tous

Je suis à la recherche d'une aide : j'ai la formule suivante =(((E27-
F27)*(I27))-(G27-H27)) et je voudrais enlever le fameux #N/A qui
apparait dans la cellule lorsqu'il manque un de ces paramétres.

Merci de votre aide
Jacky
Le #21681371
Il faut lire
...si c27 n'est pas saisie.
non pas e27


--
Salutations
JJ


"Jacky"
Bonjour,

Essaie
0 ou 1 en i27 si on ne trouve pas la correspondance dans le tableau ou si e27 n'est pas saisie.
En i27 selon le resultat que tu dois obtenir

=SI(ESTNA(RECHERCHEV(C27;W$17:Y$26;3;0));0;RECHERCHEV(C27;W$17:Y$26;3;0))
ou
=SI(ESTNA(RECHERCHEV(C27;W$17:Y$26;3;0));1;RECHERCHEV(C27;W$17:Y$26;3;0))

et
=(E27-F27)*I27-(G27-H27)
est suffisant

--
Salutations
JJ


"Marc"
Bonjour à tous

Je suis à la recherche d'une aide : j'ai la formule suivante =(((E27-
F27)*(I27))-(G27-H27)) et je voudrais enlever le fameux #N/A qui
apparait dans la cellule lorsqu'il manque un de ces paramétres.

Merci de votre aide

Marc
Le #21684081
On 4 mai, 18:58, "Jacky"
Il faut lire
...si c27 n'est pas saisie.
non pas e27

--
Salutations
JJ

"Jacky"


> Bonjour,

> Essaie
> 0 ou 1 en i27 si on ne trouve pas la correspondance dans le tableau ou si e27 n'est pas saisie.
> En i27 selon le resultat que tu dois obtenir

> =SI(ESTNA(RECHERCHEV(C27;W$17:Y$26;3;0));0;RECHERCHEV(C27;W$17:Y$26;3 ;0))
> ou
> =SI(ESTNA(RECHERCHEV(C27;W$17:Y$26;3;0));1;RECHERCHEV(C27;W$17:Y$26;3 ;0))

> et
> =(E27-F27)*I27-(G27-H27)
> est suffisant

> --
> Salutations
> JJ

> "Marc" >
> Bonjour à tous

> Je suis à la recherche d'une aide : j'ai la formule suivante =(((E2 7-
> F27)*(I27))-(G27-H27)) et je voudrais enlever le fameux #N/A qui
> apparait dans la cellule lorsqu'il manque un de ces paramétres.

> Merci de votre aide- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -



Bonjour et merci de vos réponses . En cherchant, avant que vous me
répondiez, j'ai mis la formule de cette façon :
SI(I13="";"";((E13-F13)*(I13))-(G13-H13)) et cela à l'air de
fonctionner . Par rapport à vos réponses, peut il y avoir une
différence ? ...ma solution est moins orthodoxe ???
Merci encore
Publicité
Poster une réponse
Anonyme